Vraag & Antwoord

Servers

2003 server als gatway

Anoniem
fabstar81
17 antwoorden
  • ik heb een 2003 server bak met SP1 erop.
    de bak is een p4 2ghz op 768mb mem

    ik wil deze gaan inrichten als,,oa,, internet gateway

    Er zitten 2 rtl8139 nic's in.

    De pc die eraan gehangen wordt als client is een xp-pro sp2 -bak.

    Wie kan mij enigszins uitleggen hoe ik mijn nic's configureer?

    ik beschik alhier over de nodige kabels.
    Op dit moment zijn beide pc's aan een livebox gekoppeld middels
    een LAN-kabel.

    Dank
  • In Windows Server 2003 zit standaard de functie "routing and remote access". Hiermee zou je in principe je server als router kunnen gebruiken. Het is echter niet makkelijk om een en ander lekker in te stellen. Bovendien heb je dan nog niet echt een goede firewall.

    Als je hem wil gebruiken als firewall aan je internetverbinding, kun je er ook Microsoft ISA server op installeren. Dit is een proxyserver / firewall, die ook wel wat instelwerk vereist, maar je hebt wel een goede firewall draaien.
  • Leo S,

    Heb inmiddels de ISA server 2006.
    Al vlak na installeren moet ik een objectname invullen.

    Ik heb geen bal verstand van de isa server.

    Wat moet ik nu doen.
  • isa server staat erop.

    Als ik de firewall wil starten gaat dat niet.

    Waarom niet?
  • gelukt

    schone install 2003-server

    daarna sp1 erop

    daarna isa-server erop

    :D :D
  • ik heb ook een vraagje over de gateway functie van win2003. mn laptop is toegevoegd in de domein controller van de server, en ook als ik inlog op de laptop in het domein gaat alles goed. het enige is dat mn nic van de laptop geen standaard gateway doorkrijgt van de dhcp server van de 2003 server. met gevolg -> geen internet op de laptop. mis ik een instelling of zo? het netwerk werkt verder perfect!
  • Heb je ook in je DHCP server de optie ingeschakeld om het IP-adres van je gateway door te geven?
  • ik heb alle opties doorgelopen in de dhcp server, maar kan gewoon niet de gateway optie vinden. dus nee, heb dat niet ingesteld nee. ik heb wel 2 keer de scope opnieuw geinstalleerd.

    ik krijg nu dus zowiezo geen ip adres van de win2003 serve,r maar continue van de router. ik heb mn laptop ff afgemeld uit het domein, en kom er nu dus ook niet meer op omdat ik geen ip krijg van de server, maar van de router.

    het gezeik is volgens mij begonnen toen ik de router als geauthorizeerde dhcp server heb ingesteld. die is nu weer unauthorized, maar ik krijg toch elke keer weer een ip adres van de router. :cry:

    even voor de duidelijkheid, ik ben op dit moment dus niet aangemeld in het domein, maar in de werkgroep weer. de server is daar niet in aangemeld (is immers de domeincontroller) en zodoende doet het dns gebeuren het niet (kom niet met de dns naam bij de server -> SERVEME), maar de webpagina's die erop draaien kom ik wel op. al het andere kwa IPadressen van de server doet het ook niet. remote desktop SERVEME instellen doet nix. remote desktop instellen op IP adres wel.
  • Je moet om te beginnen de DHCP functie in je router uitschakelen. 2 DHCP servers op je netwerk is vragen om problemen. Bovendien schakelt Windows zijn DHCP server uit als hij een andere DHCP server ontdekt op het netwerk.

    Als je weer de DHCP server van Windows gebruikt, moet je de volgende opties instellen:
    - Router (dit is je default gateway)
    - DNS servers (spreekt voor zich, dit moet het IP-adres van je domain controller zijn)
    - DNS domain name (dit is de volwaardige domeinnaam van je Active Directory omgeving)

    Eventueel kun je ook nog WINS installeren, maar dat is eigenlijk alleen echt interessant als je nog Windows 9x/me, of Windows NT gebruikt in je netwerk.
  • ik ben er vanmorgen achtergekomen dat de scope wel actief was, maar de dhcp server ineens uit was van windows. die staat nu weer op running, maar de router staat ook nog steeds aan. toen ik nl testte door de dhcp uit te zetten van de router, kreeeg ik nl ook geen ip.

    hmm…nu ik daar weer over nadenk, misschien stond toen ook de dhcp al uit van windows. hmm…vanavond maar weer ff server2003 opstarten (heb vandaag gedraaid op xp, tis nl dual boot)
  • goed, de dhcp staat nu op running
    de router staat met dhcp op disabled
    heb de laptop een reboot gegeven

    maar ik krijg geen ip van de windows server.

    mn opstelling is trouwens dit:

    [code:1:83efd329d0]
    internet router
    |
    dmz linksys wireless router
    | |
    dmz server laptop[/code:1:83efd329d0]

    is het m,et deze opstelling nog steeds mogelijk om de router als dhcp uit te zetten?!
  • Ik snap je opstelling niet helemaal. Als je laptop en je server allebei achter je router hangen en in hetzelfde subnet zitten, moet je gewoon een IP-adres krijgen van je server.
  • beide computers zijn dus aangesloten op de router ja. misschien komt het omdat de laptop wireless is aangesloten? ik heb ook een lease ingesteld van de wireless mac adres in de server, zodat ie een vast IP krijgt. het heeft gewerkt…maar nu krijg ik geen ip meer.

    wanneer ik de laptop aansluit via de NIC, krijg ik wel een IP adres. het zit hem denk ik dus in het wireless gebeuren. ik krijg van de dhcp server een hele rits gateways ook ineens, dus dat zit ook goed. enige is dat ik zonder proxy niet op het internet kom. stel ik de proxy van mn server in op de laptop, heb ik wel internet.

    met of zonder proxy overigens kan ik de laptop niet meer toevoeggen in het domein. volgende melding komt:

    [quote:ce9311167e]Let op: deze gegevens zijn bedoeld voor een netwerkbeheerder. Neem contact met de netwerkbeheerder op als u geen netwerkbeheerder bent. Meld bij uw netwerkbeheerder dat u deze gegevens hebt ontvangen en dat deze gegevens zijn opgeslagen in het bestand C:\WINDOWS\debug\dcdiag.txt.

    De volgende fout is opgetreden tijdens het opvragen van de Service Location (SRV)-bronrecord in DNS dat wordt gebruikt om een domeincontroller te vinden in het domein myhood.fabstar81.com:

    De fout is: Deze bewerking is geretourneerd omdat de time-outperiode verlopen is.
    (foutcode 0x000005B4 ERROR_TIMEOUT)

    De query was voor de SRV-record van _ldap._tcp.dc._msdcs.myhood.fabstar81.com.

    De DNS-server die door deze computer wordt gebruikt voor naamomzetting geft geen antwoord. Deze computer is geconfigureerd om de DNS-servers met de volgende IP-adressen te gebruiken:

    192.168.0.81

    Controleer of deze computer met het netwerk verbonden is, of deze de juiste IP-adressen van DNS-servers in het netwerk zijn en dat tenminste één van de DNS-servers werkt.

    Klik op Help voor meer informatie over hoe u dit probleem kunt oplossen.[/quote:ce9311167e]

    ik krijg niet eens het inlogscherm om het wachtwoord in te vullen van de domeinbeheerder.

    wanneer ik in het log ga kijken van de DNS kom ik volgende fout tegen:

    [quote:ce9311167e]DNS server has updated its own host (A) records. In order to ensure that its DS-integrated peer DNS servers are able to replicate with this server, an attempt was made to update them with the new records through dynamic update. An error was encountered during this update, the record data is the error code.

    If this DNS server does not have any DS-integrated peers, then this error
    should be ignored.

    If this DNS server's Active Directory replication partners do not have the correct IP address(es) for this server, they will be unable to replicate with it.

    To ensure proper replication:
    1) Find this server's Active Directory replication partners that run the DNS server.
    2) Open DnsManager and connect in turn to each of the replication partners.
    3) On each server, check the host (A record) registration for THIS server.
    4) Delete any A records that do NOT correspond to IP addresses of this server.
    5) If there are no A records for this server, add at least one A record corresponding to an address on this server, that the replication partner can contact. (In other words, if there multiple IP addresses for this DNS server, add at least one that is on the same network as the Active Directory DNS server you are updating.)
    6) Note, that is not necessary to update EVERY replication partner. It is only necessary that the records are fixed up on enough replication partners so that every server that replicates with this server will receive (through replication) the new data.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.[/quote:ce9311167e]

    en dan nog iets. dit is een melding die ik krijg elke keer als ik de server een reboot geef:

    [img:ce9311167e]http://fabstar81.com/images/win2003fout.JPG[/img:ce9311167e]

    das ook niet goed geloof ik… zucht…gekke is, dat het allemaal wel half gewerkt heb al. maar nu ineens vollledig niet meer zeg maar.
  • Tja, dit zijn allemaal algemene foutmeldingen die ik vaker zie, maar niet eens een reden hoeven te zijn dat het niet werkt.

    Heeft je laptop wel een verbinding als je een vast IP-adres instelt op je draadloze verbinding? Zo niet, dan kun je even proberen om je laptop opnieuw aan te melden op je draadloos netwerk. Misschien is er iets mis met de encryptie.

    Voor de rest is het moeilijk om op deze manier te bepalen wat er aan de hand kan zijn. Je laat niet zien welke service niet start bij een reboot van je server… Verder moet je server de enige dhcp server zijn, de juiste opties moeten ingesteld zijn (in ieder geval default gateway, dns servers en dns domeinnaam), dns moet draaien (benodigd voor active directory) en je fysieke netwerkverbinding moet in orde zijn…
  • als ik met mn vaste verbinding verbonden ben krigj ik wel een ip adres. dan werkt wel alles. daarom denk ik dat er iets met het draadloze gebeuren is. stel ik echter zelf een ip adres in op mn draadloze netwerkkaart, heb ik wel gewoon internet. dus de encryptie zit wel goed.


    de service die niet start kom ik ook niet achter, want alles lijkt te werken. alleen vage meldingen (wel een hoop) in het logboek die niets met het probleem te maken hebben. de quote;s die ik heb gemaakt zijn wel de meldingen. dus ik neem aan dat er toch iets niet goed zit met die dns service. of kan je dat niet herleiden uit die meldingen die gepost zijn?
  • Nee, ik kan dat niet herleiden uit de plaatjes. Je moet even zoeken in je log, op de tijd dat je server opnieuw opgestart is, naar meldingen die afkomstig zijn van "service control manager". Deze meldingen vertellen je welke service niet gestart kan worden en waaron…
  • Nee, ik kan dat niet herleiden uit de plaatjes. Je moet even zoeken in je log, op de tijd dat je server opnieuw opgestart is, naar meldingen die afkomstig zijn van "service control manager". Deze meldingen vertellen je welke service niet gestart kan worden en waaron…

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.