Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Servers

Geen DNS registratie na XP SP3

None
5 antwoorden
  • Wij hebben het volgende netwerk draaien:

    2 DC's met Windows 2003 SP2 met AD.
    Op 1 DC draait een DHCP server die zo staat ingesteld dat ie de clients moet registreren in de DNS.
    Met Windows clients met XP SP2 gaat dit proces prima, maar zodra we SP3 installeren worden de clients niet meer in de DNS geregistreerd.
    Wij hebben nog niet kunnen ontdekken wat de oplossing is, maar ik vraag me af of meer mensen hier last van hebben.
    We hebben deze hotfix (http://support.microsoft.com/kb/953761) al getest, maar dit verhelpt ons probleem niet.
  • Vreemd, de registratie die de dhcp server doet in AD/DNS zou los moeten staan van de client-OS…Heb je al geprobeerd om de authorisatie van de DHCP server in AD te verwijderen en opnieuw te authoriseren?
  • Precies, maar het vreemde is dat met een XP client met SP2 alles wel goed gaat.
    Het kan dus ook niks met de authorisatie te maken hebben, want anders zou het volgens mij met SP2 ook niet moeten werken.
  • Als je op de client met SP3 het commando 'ipconfig
    egisterdns' draait, verschijnt de hostnaam dan wel in de DNS, of misschien een foutmelding in een eventlog? Heb je voor de PC's ook wel het IP-adres van je domain controllers als DNS servers? Is je DNS zone Active Directory integrated met secure dynamic updates?
  • Nee, die verschijnt niet in de DNS omdat wij ingesteld hebben dat alleen de DHCP server clients mag registreren in de DNS.
    Een foutmelding verschijnt ook niet.
    Met de IP's zit het ook goed en ja, de DNS zone is ook in orde.
    We hebben net dnsapi dll's van een pc met SP2 geplukt en deze op de pc met SP3 geinstalleerd en dan werkt alles perfect.
    Niet echt een definitieve oplossing, maar we weten nu echt zeker dat we niet aan de serverkant moeten gaan zoeken.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.