Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Servers

Hulp nodig bij configuratie apache (virtual host)

sdk
3 antwoorden
  • Ok ik heb WAMP van mijn server pc afgegooid en heb XAMPP geinstalleerd. Na wat moeite (mysql als service aanvinken en dan op admin drukken–>acces violation) werkt het nu.

    Zit echter even met de apache configuratie.

    Ik heb in htdocs 3 mappen aangemaakt:
    website1
    website2
    website3

    Website1 was een test. Dmv localhost/website1 kwam ik tot een succesvolle Joombla installatie

    Nu kom ik bij website 2. De bedoeling is dat www.domein.nl meteen daarheen verwijst. Dit doe je normaal met virtual host (ik iig wel).

    Ik heb het volgende toegevoegd:


    [code:1:f766528379]<VirtualHost *:80>
    ServerName www.domein.nl
    ServerAlias www.domein.nl domain
    DocumentRoot C:/xampp/htdocs/website2
    ErrorLog C:/xampp/htdocs/website2/logs/error.log
    CustomLog C:/xampp/htdocs/website2/logs/access.log common
    </VirtualHost>

    <VirtualHost *:80>
    ServerName localhost
    DocumentRoot C:/xampp/htdocs/xampp
    #ErrorLog C:/xampp/htdocs/xampp/logs/error.log
    #CustomLog C:/xampp/htdocs/xampp/access.log common
    </VirtualHost> [/code:1:f766528379]

    -localhost werkt gewoon nog dan kom op op de xampp introductie.
    -localhost/phpmyadmin werkt gek genoeg ook nog prima

    Maar hierna loop ik tegen 2 problemen aan

    1) localhost/website1/ of via de andere pc 192.168.1.x/website1/ werkte eerst maar nu dus niet meer; 404. Waarom niet? Hoe moet ik deze dan toevoegen als welke "naam"? er is immers geen domein.

    2) domein.nl werkt niet, ik kom dan bij de router uit. Moest dit niet bij hosts in system32/drivers/etc worden opgelost? Heb dit nu gedaan maar krijg het nog steeds. wellicht lost een reboot het op.
  • Je moet je hosts file nog aanpassen. De sitenaam moet gekoppeld worden aan 127.0.0.1. Apache zorgt dan zelf wel, dat je de juiste site te zien krijgt.
  • Dat lost probleem 2 op maar helaas probleem 1 nog niet.

    localhost/website1 krijgt 404 met de bovenstaande settings.

    wellicht kan ik localhost aan c:/xampp/htdocs ipv c:/xampp/htdocs/xampp alleen dan zie ik bij localhost waarschijnlijk xampp niet meer.


    edit: dan werkt het helemaal niet meer

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.