Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Servers

troubles met router / server combinatie

None
24 antwoorden
  • hallo medeforummers,

    ik heb sinds een paar weken problemen met mijn domein. de opstelling is als volgt:

    modem -> router (DMZ) -> server (192.168.0.88 ) en clients

    toen alles werkte werd de DHCP en DNS door de server (win3k) geregeld. DHCP stond dan ook uit op de router en ik heb een range inclusief reservations etc. ingesteld op de server.

    echter op een dag klapte ineens alles eruit. het domein (filesharing en shared folders, folder redirection, etc.) werkte niet goed, internet werkte niet meer en exchange werkte soms wel op de clients, soms niet. de server was niet meer van buitenaf te bereiken (web, mail, ftp, etc.). eigenlijk werkte niets meer.

    ik dacht eerst aan de router, deed ie het nog wel? ik heb 3 verschillende routers geprobeerd én alle routers gereset maar het probleem bleef. resette ik de oude router dan deed internet het weer niet, maar netwerk etc weer wel. soms ook andersom. internet wel, domein verder niet. Loadde ik de oude configuratie van de router dan deed helemaal niets het meer.

    router als oorzaak is daarmee uitgesloten dacht ik. dan DHCP maar kijken, zodra ik nl de routers inschakelde (al dan niet gereset) kreeg ik zodra ik DHCP dan uitzette geen ip adres meer van de server. een nieuwe range ingesteld, DHCP opnieuw geconfigd op de server bood ook geen soelaas.

    toen de router (WRT54G linksys) maar een firmware upgrade laten doen (kon ie sowieso wel gebruiken) en nu doet warempel internet het op alle clients (maar dan is wel DHCP ingeschakeld op de router) en op een enkele client ook de link naar exchange. echter, domein doet het weer niet. de shares zijn neit beschikbaar en de redirected folders ook niet. nu heb ik zojuist geprobeerd de router's dhcp uit te schakelen zodat de server het over zou nemen, maar dat is geen succes. ik kan geen nieuwe ipadressen verkrijgen van de server. zelfs als ik de router op ROUTER zet ipv gateway krijg ik geen eens internet op alle clients (toen alles het deed stond de router op ROUTER, wat betekent dat er een andere modem
    outer in het netwerk aanwezig is die het internet regelt, GATEWAY is als het dus ook een modemfunctie heeft, in mijn situatie dus niet van toepassing, maar internet werkt nu alleen maar als ie op ROUTER staat)

    dan ga je al gauw denken aan DNS problemen. echter, in de DNS logs van de server kom ik alleen volgende log tegen:

    [code:1:3580e14d00]The DNS server has encountered numerous run-time events. To determine the initial cause of these run-time events, examine the DNS server event log entries that precede this event. To prevent the DNS server from filling the event log too quickly, subsequent events with Event IDs higher than 3000 will be suppressed until events are no longer being generated at a high rate.
    [/code:1:3580e14d00]

    verder komen er GEEN foutmeldingen voor, noch in de DNS logs, noch in de Directory service logs, noch in de file replication logs, noch in de system logs. In de DNS logs komen echter wel veel van dit soort meldingen voor:
    [code:1:3580e14d00]The DNS server wrote version 485 of zone myhood.fabstar81.com to file myhood.fabstar81.com.dns.
    [/code:1:3580e14d00]

    elke tien minuten/kwartier wordt er wel zo een item weggeschreven.

    de DNS heb ik overigens een keer opnieuw geconfigt ook, maar helaas, biedt geen soelaas.

    ik heb trouwens het idee dat het internet het nu op de clients alleen maar doet omdat de router de ip's uitdeelt en natuurlijk de DNS van het modem gebruikt.

    iemand? help?!
    ik ben net na een jaar rommelen (diverse crashes van meerdere servers) in het domein af van dat vervuilde domein (zie overige topics) en ik had nu eindelijk een schoon (nog steeds) en werkend (niet nog steeds) domein. nu met dit euvel krijg ik er een beetje de pest in.

    graag wat hulp.
  • kleine toevoeging: op de clients is er wel internet, maar ik kan niet op https:// websites komen.

    op de server is er een melding over KDC:

    [code:1:39298b12d4]The currently selected KDC certificate was once valid, but now is invalid and no suitable replacement was found. Smartcard logon may not function correctly if this problem is not remedied. Have the system administrator check on the state of the domain's public key infrastructure. The chain status is in the error data.[/code:1:39298b12d4]

    heeft dat er iets mee te maken?
  • ik heb net wat meer tests gedaan:

    vanuit de server kan ik wel op alle share komen van de clients. van de clients kom ik niet op alle shares van de server.

    naar de server toe kan ik wel vanuit de clients remote desktop doen, van de server naar de clients toe niet.

    wat duidt hierop?
  • Hoe heb je de dhcp en dns geconfigureerd?

    Normaal moet het zo wel werken:
    DHCP
    -range instellen
    -gateway ip adres van je router
    -dns ipadres van de server. (zonder Microsoft DNS werkt domein aanmelding niet!)

    DNS
    -je geeft je domein naam op
    - als forwarder adres gebruik je het ipadres van je router / of meteen de de dns adressen van de provider.

    Draait er ook iets van ISA, routing en remote access, andere firewall? Wanneer je met www.grc.com kijkt, zie je dan wel dat de poorten openstaan welke je hebt geforward in je router naar de server?
  • de normale firewalls staan op de modem en router. de router staat in een DMZ van de modem en in de router regel ik mn poortforwarding. poortforwarding gaat goed.

    DHCP heb ik precies zo ingesteld als je zegt. DNS volgens mij ook. ik heb DNS een paar keer opnieuw ingesteld omdat ik dacht dat het niet werkte.

    ik ben er overigens achter dat nu de clients ook naar de shares van de server kunnen kijken, maar aanmelden gaat niet. ook doen de domein-shares het niet. de server shares dus wel, maar de rootshare in het domein niet. ik heb alle folder redirects geregeld via rootshares in het domein. het is dan wellicht AD dat niet goed werkt.
  • Kan je de ip configuratie is posten? En post ook is een uitdraai van ipconfig. Zowel van de server als van een werkplek. Als de werkplekken zich niet kunnen aanmelden bij het domein dan zal er toch iets niet goed zitten.
  • op dit moment kan ik niet op werkplekken komen. maar dit zijn de dhcp, en ip configs van de server (megatron). ik kan wel op de shares komen van de werkplekken (via DNS namen) maar ik kan geen remote desktop opstarten op DNS naam (ik weet de IP adressen niet)

    hier iig de prt screeens van de server:

    [img:41d79a2c06]http://82.173.173.242/fabstar/images/ip_megatron.JPG[/img:41d79a2c06]

    [img:41d79a2c06]http://82.173.173.242/fabstar/images/ipconfig_all.JPG[/img:41d79a2c06]

    [img:41d79a2c06]http://82.173.173.242/fabstar/images/scope.JPG[/img:41d79a2c06]

    waarbij 192.168.0.10 mn router is, 192.168.1.1 mn modem.
  • Waarvoor gebruik je al die extra opties in je scoop? In het algemeen is 003, 006 en 015 genoeg.

    Hoe heb je dns geconfigureerd?
  • weet ik eigenlijk niet. kan ze er voor de test wel even uithalen. moet je trouwens bij 015 je gehele domeinnaam neerzetten of zoals mij nu alleen MYHOOD (volledig FGDN is myhood.fabstar81.com)

    DNS heb ik geconfigd volgens mij net als jouw voorbeeld. een forward scope. ik weet alleen niet of ik mijn router of mijn modem als forwarder heb gezet…of dat ik mijn ISP's DNSen heb gebruikt.

    [img:c6c30a3163]http://82.173.173.242/fabstar/images/dns_megatron.JPG[/img:c6c30a3163]

    dit is trouwens de dhcp config van mn router:

    [img:c6c30a3163]http://82.173.173.242/fabstar/images/dhcp_router.JPG[/img:c6c30a3163]

    als ik dus de DHCP uitzet op deze router zou de server de DHCP het over moeten nemen. dit doet hij niet. nu de dns op de router niet is ingevuld lukt daarom waarschijnlijk de aanmelding niet en wellicht ook de domeinshares?
  • Verwijder je dns configuratie is, en maak het eens opnieuw aan via dit kb artikel: http://support.microsoft.com/kb/323380/nl
  • zal ik een primaire of secundaire doen en zal ik hem integreren in AD?
    altijd een probleem voor me om te kiezen.
  • Primaire en integreren in AD.
  • ok, gedaan. alleen dit stuk snap ik niet:

    [quote:8b4623860e]De DNS-hoofdzone verwijderen
    Een DNS-server waarop Windows Server 2003 wordt uitgevoerd, volgt specifieke stappen bij de naamomzetting. Een DNS-server voert eerst een query uit op de eigen cache, controleert vervolgens de eigen zonerecords, verzendt aanvragen naar doorstuurservers en probeert vervolgens de namen om te zetten via basisservers.

    Standaard maakt een Microsoft DNS-server verbinding met internet om DNS-aanvragen te verwerken met basisservers. Als u het programma Dcpromo gebruikt om een server te promoveren tot een domeincontroller, heeft de domeincontroller DNS nodig. Als u DNS installeert tijdens het promotieproces, wordt een hoofdzone gemaakt. Deze hoofdzone maakt uw DNS-server duidelijk dat het een hoofdinternetserver betreft. Daarom gebruikt uw DNS-server geen doorstuur- of basisservers bij de naamomzetting.


    Klik op Start, wijs Systeembeheer aan en klik op DNS.
    Vouw Servernaam uit, waarbij Servernaam de naam is van de server. Klik op Eigenschappen en vouw Zone voor forward lookup uit.
    Klik met de rechtermuisknop op de zone "." en klik op Verwijderen.[/quote:8b4623860e]

    heb de engelse en zie die niet in de eigenschappen terugkomen of iets wat daar op lijkt.

    krijg nu ik DNS opnieuw heb ingesteld gelijk deze melding in de logs:

    [quote:8b4623860e]The DNS server encountered error 32 attempting to load zone myhood.fabstar81.com from Active Directory. The DNS server will attempt to load this zone again on the next timeout cycle. This can be caused by high Active Directory load and may be a transient condition.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.[/quote:8b4623860e]
  • Hier http://www.petri.co.il/how_to_install_active_directory_on_windows_2003.htm staat een complete handleiding in het Engels.
  • mjah…alles heb ik nu doorlopen. de nieuwe config verschilt niet veel van mijn eigen config. snap dus niet waarom het niet werkt. ik kan nu niet op afstand de router's DHCP uitzetten anders werkt helemaal nix meer ben ik bang. dus dat ga ik morgen op locatie doen.

    DNS lijkt wel te werken, de tests krijg ik een PASS voor iig. alleen meldingen in de DNS log blijven hetzelfde. altijd maar die melding over de AD. :(
  • Je router doet DHCP? Dan heb ik daar denk ik overheen gelezen. Heb je dan in je router DHCP opties wel gezegd dat die de server als DNS moet gebruiken? Als alle pc's nu de router als dns hebben dan is dat het probleem waarom ze zich niet kunnen aanmelden op het domein.
  • ik heb de router nu dhcp laten regelen omdat als ik die uitzet, de server de dhcp niet overneemt. dit was eerst wel het geval. dat hele gedeelte snap ik niet waarom de server dat niet doet.

    ik heb nu de DNS van de server wel in de router gezet als DNS. dit was gister nog niet het geval.

    ff testen of ik nu wel in de clients kan komen.
  • nou, het werkt weer :). ik kan inloggen op de server, de domein shares werken weer. en ik kan waarempel ook op beveiligde sites komen.

    blijven 2 dingen over:

    [list:9caf8f293c]
      die meldingen over de AD in de DNS, maar die stonden er ook al in toen alles nog werkte. dit terwijl AD gewoon goed draait. DHCP wordt niet overgenomen door de server (dit ga ik vanavond op locatie nog eens testen) [/list:u:9caf8f293c] maar thanks alvast voor het meedenken!
  • Mooi dat dat weer werkt. Als je dhcp op de server configureert moet je eerst de dhcp op de router uitzetten. Zodra windows merkt dat er een 2e dhcp server is schakelt hij de windows dhcp uit.
  • ok, dat zal ik vanavond op locatie dan uitproberen. is het voldoende als ik de DHCP even uitschakel op de server waarna ik de router's dhcp uitzet, of moet ik hem echt helemaal opnieuw instellen?

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.