Vraag & Antwoord

Servers

Netwerk op Laptop

Anoniem
Velletje
17 antwoorden
  • Na reeds vele Linux distributies op al even vele desktop PC'c te hebben geinstalleerd heb ik het nu voor het eerst op een Compaq Armada V300 Laptop geinstalleerd.
    Op zich eigenlijk probleemloos echter heb ik iets vreemd met de netwerkkaart.
    In de laptop zit een Xircom 10/100 PCMCIA netwerkkaart.
    Als ik de laptop voorzie van een vast IP-adres (dus geen DHCP) dan kan ik de ene keer wel mijn lokale netwerk bereiken en de andere keer niet. De kaart wordt goed geinitialiseerd door de pcmcia carddriver en de xircom module, ik hoor tijdens booten twee piepjes.
    Als ik kijk met ifconfig zie ik dat het IP-adres is toegekend, met route zie ik dat de routeringstabel goed is (op mijn desktop PC's staat exact hetzelfde in de route tabel)en toch krijg ik soms de foutmelding dat er geen route naar buiten is naar mijn LAN.
    Als ik dan met ifconfig mijn IP-adrs verander dan MOET ik rebooten om dit te activeren terwijl normaal gesproken alleen een netwerk restart (/etc/rc3.d/S10network reload) voldoende moet zijn, tenminste bij al mijn desktop PC's werkte dat altijd goed.
    Als ik gebruik maak van DHCP heb ik deze problemen niet maar ik gebruik liever vaste IP-adressen.
    Heeft iemand enig idee hoe dit kan?
    Heeft het misschien iets te maken met de volgorde waarin de pcmcia drivers worden geladen? Want de eth0 interface wordt pas opgebracht nadat de pcmcia carddriver en xircom module zijn geladen en dit gebeurt pas aan het einde van het boot proces dus vlak voor je kunt inloggen
    Ik heb op de site van Xircom gekeken voor eventuele drivers maar helaas zeggen daar Linux NIET te ondersteunen!!!
    Onder Windows 2000 werkt de kaart prima zowel met vast IP-adres als met DHCP
    ALvast bedankt
  • Kheb zo vlug geen idee. Maat ut lijkt me wel handig als je zegt welke Linux je gebruikt.

    Nou ja een ideetje dan… je kunt eens proberen het netwerkgebeuren volledig vanuit een script te starten; heb je meer grip. Beginnen met de kaartmodules te laden en daarna de ifconfigcommando's.

  • MrLeeJohn,

    Ik gebruik momenteel RedHat 7.2 maar ik heb exact hetzelfde probleem bij gebruik van mandrake 8.0 op deze laptop

  • Ik denk dat jou probleem erin zit dat je in de verkeerde directory zit. Besturing voor PCMCIA gebeurd door het programma PCMCIA-cs. Instellingen voor de programma staan in een andere directory (bij mij /etc/pcmcia/ eigen installatie debian en pcmcia los erbij geinstalleerd). In deze directory staat ook het netwerk script en de instellingen in deze bestanden betreffen netwerk instellingen voor pcmcia netwerk kaarten. Onder /etc/rc3.d start je een normaal netwerk script voor een vaste kaart. Pcmcia instellingen werken dus onafhankelijk van je standaard scripts. Het enige wat standaard opstart is je pcmcia kaart detecteer service. De rest wordt verder door scripts in de pcmcia directory afgehandeld.

    (je zei twee piepjes, dit moeten wel twee gelijke piepjes zijn. Hoog/laag of anders geeft nl een foutmelding)

    tip: zet in je syslogd.conf bestand een extra regel: *.* /dev/tty12
    hiermee redirect je alle messages naar je alt+f12 console en zie je meteen wat er allemaal gebeurd. Hiermee heb ik ook een unsupported pcmcia card aan de gang gekregen.

    [This message has been edited by [DarthV] (edited 14-12-2001).]

  • DarthV,

    bedankt voor je reactie.
    Uiteraard ben ik verder gaan onderzoeken en ik heb ontdekt dat als ik mijn netwerk vier keer herstart met /etc/rc3.d/S10network restart dat het plotseling dan WEL werkt.
    Wat ik dus niet begrijp is WAAROM het dan WEL werkt.
    Kun je trouwens aangeven welk bestand in /etc/pcmcia gebruikt moet worden en hoe ik er voor zorg dat dit tijdens het booten ook gebruikt wordt want in alle network scripts staan zoveel verwijzingen naar andere scripts dat ik door de bomen het bos niet meer zie.
    Ik gebruik momenteel RedHat 7.2

  • Vreemd dat het dan wel werkt, maarja het kan andere oorzaken hebben. In ieder geval werkt pcmcia op de volgende manier (beknopt:

    Wanneer je een netwerk pcmcia kaart in de socket doet gaat ie kijken in het bestand /etc/pcmcia/config of ie de kaart hierin kan vinden. Zo ja gaat ie kijken in welke sectie de kaart zit. In dit geval dus network. Het script /etc/pcmcia/network wordt gedraaid dat op zijn beurt weer het bestand /etc/pcmcia/network.opts oproept. In het bestand /etc/pcmcia/network.opts staan alle netwerk instellingen voor de pcmcia kaart. Je kunt dit bestand handmatig editten of je kunt het programma pcnetconfig draaien. Hiermee krijg je vragen over de instellingen. Maaarr het kan zijn dat die xircom kaart gebruik maakt van een standaard kernel driver dat weet ik ff niet.

    Heb je nog iets gezien met die /dev/tty12 verwijzing ?

    Ennuh nog wat sites die makkelijk zijn:
    http://mobilix.org/pcmcia_linux.html http://www.linux-laptop.net/

  • DartV,

    Bedankt voor je uitleg.
    Ik ben tussen kerst en nieuw vrij geweest en heb dus zitten graven in mijn configuratie.
    Het door jouw genoemd bestand (/etc/pcmcia/network.opts) is NIET op mijn laptop aanwezig.
    Kennelijk heeft Redhat Linux een andere manier om het netwerk te configureren.
    Ik ben er nog steeds niet achter hoe dit bij Redhat geregeld wordt.
    Als ik mijn laptop opstart worden de pcmcia services geactiveerd (ik hoor twee dezelfde hoge piepjes).
    Mijn Xircom kaart wordt herkend, ik kan mijn IP-adres van de kaart pingen, echter een andere machine op mijn LAN niet.
    Dit werkt pas na vier of vijf keer herstarten met /etc/rc.d/init.d/network restart.
    Kortom ik ben er nog steeds niet achter.
    heb je nog suggesties?
    P.S.Ik zag in een Linux forum op internet dat er nog iemand is met exact hetzelfde probleem maar met een andere PCMCIA kaart. Ook hier was er nog geen oplossing

  • Ik las ook een paar keer dat iemand er lst van had. Zet dan 5 keer network-restart in rc.local. Duurt het starten wat langer maar dan werkt het wel… toch?
  • Even nog wat rond gekeken in mijn redhat doc hoekje en volgens mij vind je zowiezo de pcmcia dir in /etc/sysconfig/ daarin staan ook de netwerk scripts.

    Dat je netwerk pas na 5 keer script restarten werkt is ook geen doen. Het werkt wel of het werkt niet. Ik heb een paar keer gezien dat de editor van RedHat niet goed werkt. Met name de automatische configuratie scripts van bijvoorbeeld X geven weleens configuratie fouten (line breaks ed die niet goed gaan). Een beetje rondneuzen op google gaf me ook een aantal foutmeldingen van RH 7.2 en pcmcia. De enige manier om te zien wat er gebeurd is de syslog naar tty12 te zetten. Of op een ander terminal venster het commando: tail -f /var/log/messages geven.
    Als je twee (gelijke) piepjes hoort betekent dat de pcmcia kaart gedetecteerd is. Daarna pas ziet het pcmcia programma (aan de pcmcia conf files) dat het een netwerk kaart is. Daarna worden de netwerk scripts geladen en hierin gaat het fout. De enige manier om hier achter te komen is door stap voor stap te doorlopen wat er in de scripts gebeurd en eventueel foutmeldingen detecteren.

    [This message has been edited by [DarthV] (edited 02-01-2002).]

  • DartV,

    Het heeft enige tijd geduurd maar nog steeds moet ik 4 a5 keer /etc/rc.d/init.d/network restart doen om naar buiten te komen.
    Ik heb in /etc/syslogd.conf de regel *.* /dev/tty12 gezet om de messages op console 12 te zien.
    het enige verschil wat ik zie tussen dat het netwerk NIET werkt en wanneer het WEL werkt zijn de volgende twee regels:
    eth0 MII link partner 0021
    eth0 MII selected

    Zodra ik deze regels zie dan werkt anders niet

    Misschien heb je nu een suggestie want ik heb alle scripts doorgespit maar kan niets vinden waarom het niet direct in een keer werkt

    Velletje
  • DartV,

    Het heeft enige tijd geduurd maar nog steeds moet ik 4 a5 keer /etc/rc.d/init.d/network restart doen om naar buiten te komen.
    Ik heb in /etc/syslogd.conf de regel *.* /dev/tty12 gezet om de messages op console 12 te zien.
    het enige verschil wat ik zie tussen dat het netwerk NIET werkt en wanneer het WEL werkt zijn de volgende twee regels:
    eth0 MII link partner 0021
    eth0 MII selected

    Zodra ik deze regels zie dan werkt anders niet

    Misschien heb je nu een suggestie want ik heb alle scripts doorgespit maar kan niets vinden waarom het niet direct in een keer werkt

    Velletje
  • DartV,

    Het heeft enige tijd geduurd maar nog steeds moet ik 4 a5 keer /etc/rc.d/init.d/network restart doen om naar buiten te komen.
    Ik heb in /etc/syslogd.conf de regel *.* /dev/tty12 gezet om de messages op console 12 te zien.
    het enige verschil wat ik zie tussen dat het netwerk NIET werkt en wanneer het WEL werkt zijn de volgende twee regels:
    eth0 MII link partner 0021
    eth0 MII selected

    Zodra ik deze regels zie dan werkt anders niet

    Misschien heb je nu een suggestie want ik heb alle scripts doorgespit maar kan niets vinden waarom het niet direct in een keer werkt

    Velletje
  • DartV,

    Het heeft enige tijd geduurd maar nog steeds moet ik 4 a5 keer /etc/rc.d/init.d/network restart doen om naar buiten te komen.
    Ik heb in /etc/syslogd.conf de regel *.* /dev/tty12 gezet om de messages op console 12 te zien.
    het enige verschil wat ik zie tussen dat het netwerk NIET werkt en wanneer het WEL werkt zijn de volgende twee regels:
    eth0 MII link partner 0021
    eth0 MII selected

    Zodra ik deze regels zie dan werkt anders niet

    Misschien heb je nu een suggestie want ik heb alle scripts doorgespit maar kan niets vinden waarom het niet direct in een keer werkt

    Velletje
  • DartV,

    Het heeft enige tijd geduurd maar nog steeds moet ik 4 a5 keer /etc/rc.d/init.d/network restart doen om naar buiten te komen.
    Ik heb in /etc/syslogd.conf de regel *.* /dev/tty12 gezet om de messages op console 12 te zien.
    het enige verschil wat ik zie tussen dat het netwerk NIET werkt en wanneer het WEL werkt zijn de volgende twee regels:
    eth0 MII link partner 0021
    eth0 MII selected

    Zodra ik deze regels zie dan werkt anders niet

    Misschien heb je nu een suggestie want ik heb alle scripts doorgespit maar kan niets vinden waarom het niet direct in een keer werkt

    Velletje
  • emn dan nog beweren dat linux makkelijk is……. ga nou toch gauw !!
  • [quote:613f1c241e]
    Op 18-03-2002 22:18, schreef Froggy:
    emn dan nog beweren dat linux makkelijk is……. ga nou toch gauw !!

    [/quote:613f1c241e]

    Je hoort maar weinig mensen zeggen dat linux makkelijk is. De meeste zeggen dat het niet moeilijk is :grin:

    Ga jij es ff gauw naar het netwerkforum om te kijken hoeveel mensen hun nic onder windows niet aan de praat krijgen…
    Mag er a.u.b ook een met linux tussen zitten?
  • Ja Sjoerd, tuurlijk mag dat, maar mag ik effe kotsen as er op zoveel topics een fanaat reageert dat linux et makkelijkst is?

    Ik snap echt wel dat linux de zinnen prikkelt bij de mensen, dat deed het bij mij ook… maar die freaks hier hebben me er echt kompleet afgeholpen…

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.