Vraag & Antwoord

Servers

CGi script werkt op andere server niet meer

Ik had een werkend cgu script op de protland server. Deze had echter wat nadelen. Het grootste dat ik 3/7 dagen niet bij de ftp server kon. Nu heb ik dus het script gewoon geupload in de cgi-bin van de neiuwe server, helaas werkt hij nu niet. Dit kan 2 oorzaken hebben en ik krijg ze allebei neit opgelost 1 het pad is niet juist naar perl. Dit staat op #!usr/local/bin/perl (bovenaan het cgi script dus host = www.xszone.nl maar zie nergens faq) 2 De mailverwijzingen kloppen niet Op de vorige server was het programma sendmail gedisabled om spammers te voorkomen. Hierdoor heb ik de sendmail mogelijk niet juist ofgesteld. Zou iemand hierna willen kijken? [code:1:c3c19e24d6] $mailprog = "/usr/lib/sendmail" $cfg_email_onform = "1"; $sendto = "the.dark.prince\@hccnet.nl"; $cc_to = ""; [/code:1:c3c19e24d6] In de html staat oa dit: [code:1:c3c19e24d6]<form action="/cgi-bin/bizmail.cgi" method="POST" name="Subscribe"> <input type="hidden" name="sendreply" value="1"> <input type="hidden" name="reply_subject" value="{sof2name} This is the reply subject"> <input type="hidden" name="subject" value="Lead from BizMailForm"> <input type="hidden" name="success_page" value="http://dutchchillclan.dev-c.nl/success.html"> <input type="hidden" name="send_to" value="s.dekooter@hccnet.nl"> <input type="hidden" name="required" value="sof2name,email"> <input type="hidden" name="outputfile" value="sof2name,name,city,microphone,email,ipaddress,feedback,date"> <input type="hidden" name="datafile" value="bizmail.dat"> <input type="hidden" name="data_format" value=","> <input type="hidden" name="text_qualifier" value="1"> <input type="hidden" name="message_format" value="html"> [/code:1:c3c19e24d6] Ik geloof dat dit de defoults van het cgi overwriten, moet hier dan ook een \ voor de @ van het mail adres??? Please help mij, ik ben hier echt al uren aan bezich geweest. (het orginele script komt van www.bizmailform.com/ )

Anoniem
sdk