Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Videobewerking

VirtualDub (her)kent geen audiocodecs (meer)

Anoniem
rwilligen
7 antwoorden
  • Voor de bewerking van mijn (analoge) video-8 filmpjes gebruik ik op mijn PC (PentiumIII, 800MHz - Windows ME) de capturekaart Studio PCTV Pro van Pinnacle en de capture AVI modus van VirtualDub versie 1.4.13 (VDub). Daarbij gebruik ik als Format 384x288 YUY2 met videocodec DivX 4.12 in de modus "1 pass, quality-based" met een keyframe interval 1, opdat ik later op één beeldje nauwkeurig kan snijden bij de latere videobewerking; deze instelling geeft een videocompressie van ca 6:1.

    Voor het audiogedeelte zet ik de VDub capture op PCM (= Uncompressed) 44.100 Hz; 16 bit; Mono - 86 kB/s. Het liefst zou ik ook hier direct comprimeren door MPEG Layer-3 als audiocodec te gebruiken op 64 kBit/s, 44.100 Hz, Mono - 8 KB/s. Maar als ik dat doe, krijg ik na het starten van de capture een foutmelding in Kernel32.dll en een berucht blauw scherm: systeem herstarten dus.

    Als het filmpje eenmaal is gecaptured, open ik het in VDub en dan wordt keurig via File > File Information … > Audio stream vermeld:
    Sampling rate: 44100 Hz
    Channels: 1 (Mono)
    Sample precision: 16-bit
    Compression:PCM (Uncompressed).

    Tot zover gaat alles goed. Maar dan! VirtualDub is onnavolgbaar in de eenvoud waarmee te gebruiken stukjes videomateriaal in één arbeidsgang kunnen worden gemarkeerd en als afzonderlijke videoclips weggeschreven. Omdat ik soms met ruimte moet woekeren, comprimeer ik het geluid tegelijkertijd van PCM naar MP3. Dat gaat op zichzelf wel vlekkeloos, maar daarna ontstaan er problemen bij de verdere videobewerking.

    Als een aldus opgeslagen clip later in VDUB wordt geopend, weigert VDub deze clip af te spelen en komt er de foutboodschap:
    "The requested audio compression is not compatible with the input format. Check that the sampling rate and channel count of the input match those of the requested format."

    En via File > File Information … > Audio stream staat nu vermeld:
    Sampling rate: 44100 Hz
    Channels: 1 (Mono)
    Sample precision: 0-bit
    Compression: Unknown (tag 0055).

    Het gekke is dat als je met de linkermuisknop het schuifje op de voortgangsbalk van VDub een beetje heen en weer beweegt en daarna weer klikt op de [Input playback] knop de clip (soms) weer normaal afspeelt, maar lang niet altijd.

    Dan ook wordt afgebeeld via File > File Information … > Audio stream:
    Sampling rate: 44100 Hz
    Channels: 1 (Mono)
    Sample precision: 0-bit
    Compression:Fraunhofer IIS MPEG Layer-3 Codec
    (Merk op dat de Sample precision WEL op 0-bit blijft staan.)

    Dit is een heel vervelend verschijnsel, vooral als meerdere clips tot een geheel moeten worden samengevoegd bij gelijktijdige videocompressie via de 2-pass Variable Bit Rate modus van DivX 4.12. Normaal gaat dat flitsend via de Job control optie VDub, maar nu de audiocodec niet meer direct wordt herkend, draait de hele Job control list in de gort. Echt niet leuk meer!

    Ik heb allerlei verschillende (?) audiocodecs uitgeprobeerd (Radius MP3, Lame MP3 en de Fraunhofer IIS v1.2 Build 63i die met DivX3.11 alpha is meeverpakt), maar niets wil lukken: telkens krijg ik de eerder vermelde foutboodschap en wordt als compressor op gegegeven 'Unknown (tag 0055)'.

    Ik heb ook DivX 5.02 geprobeerd in plaats van versie 4.12, maar het mocht allemaal niet baten. (Lijkt ook logisch, omdat het 'ergens' in de audio-instellingen zit?) Toen heb ik de prioriteit van de MPEG Layer-3 codec van 6 op 3 gezet in Start > Instellingen > Configuratiescherm > Geluiden en media > Apparaten > Audiocompressiecodecs etc., maar ook dat hielp niet.

    Heeft iemand dit verschijnsel ook ooit ervaren of beter nog: weet iemand wat ik moet doen om van dit vervelende fenomeen verlost te worden? Ik ben zeer benieuwd naar eventuele reacties …

    :o
    Detko
  • Ik ben ff vluchtig door je (hele) verhaal gefietst: Ik denk dat de mono(ipv stereo) je probleem is.

    Allereerst zijn er in de verschillende vdub versies dilema's geweest met mono audio en dan kan het ook nog een probleem van je mp3 audio codec zijn alhoewel je er meerdere hebt getest dus dat valt eigenlijk af.

    Maak maar eens een stukje in stereo als test, of : gebruik eens een andere versie vdub.

    De oplossing indien je persee versie 13 wilt gebruiken is om alles in stereo te doen en pas als laatste handeling de boel om te zetten naar mp3 mono
  • Bedankt voor je reactie, maar helaas: daarin blijkt het niet te zitten?

    Ik heb nu namelijk videoclips gecaptured in PCM 44100/16bit/Stereo/172KBps met VirtualDub-versies 1.4.07, 1.4.09 en 1.4.13. Deze clips spelen feilloos af als ze in hun VDub worden geopend en het PCM-formaat wordt exact herkend.

    Als je de audio van deze clips daarna comprimeert met MP3 128 kBitps/44100/Stereo/16KBps en vervolgens in VDub opent, krijg je de beschreven foutboodschap en geeft 'File information' Compression: Unknown (tag 0055). Om moedeloos van te worden…

    Maar daarna ontdekte ik iets vreemds. Met VDub 09 converteerde ik bij wijze van alternatief het bronbestand met PCM-audio naar Microsoft ADPCM 4-bit Stereo 44 KBps. Toen ik dit bestand daarna in VDub wilde openen verscheen deze andere foutboodschap:

    "VBR audio stream detected
    VirtualDub has detected an improper VBR audio encoding in the source AVI file and will rewrite the audio header with standard CBR values during processing for better compatibility. This may introduce up to 415 ms of skew from the video stream. If this …"

    Als je dan op [OK] klikt, gebeurt er verder niks en afspelen lukt ook niet door die 'unknown compression tag'. Zoals je zult hebben gemerkt, heb ik van de achterliggende techniek niet bar veel verstand, maar ik krijg nu de indruk dat die PCM encoder/decoder misschien corrupt is geraakt.

    Zou dit kunnen en hoe installeer ik dan een nieuwe PCM-codec?
    Heb je andere suggesties?
  • Ik ben bang dat je een beetje een codec rotzooitje hebt en dat nu (kennelijk) 1 van de mp3 codec's in vbr staat.

    MP3 codec's kan je altijd maar 1 voor 1 gebruiken, je kunt er dus nooit meer dan 1 tegelijk geinstalleerd hebben, doe je dit wel dan kan het zo zijn dat degene die daadwerkelijk gebruikt wordt bij het coderen een andere is dan degene die je insteld en ik ben zo maar bang dat dit jouw probleem is.

    De reden is dat mp3 codec's niet van elkaar verschillen, althans wat betreft een compressie programma zoals vdub, deze kan dus niet het verschil zien tussen lame en fraunhoffer, de fourcc code is van bijde hezelfde.
    Een soortgelijke situatie bestaat bij mjpeg video codec's, als je er daar meer dan 1 van installeerd is het net russisch roulette als je gaat comprimeren/capturen want je weet nooit welke gebruikt wordt.


    Ik stel voor dat je de hele bubs de-installeerd, evt nog een register clean doet en ff je windows dir doorzoekt op dll en ax files en evt nog achtergeleven codec resten zelf verwijdert en vervolgens wer opnieuw begint met 1 codec…..
  • Bedankt voor je suggesties. Ik heb ze alle opgevolgd, maar het wordt steeds gekker!

    Dit is wat ik heb gedaan: Systeemherstelpunt (WinME) gemaakt. Wissen van de mappen VDub, DivX3.11alpha. Installaties ongedaan gemaakt van DivX4.12, IIS WinPlay3 (map bevatte l3aud32.dll), DVDx 2.0 (map bevatte nLame.dll). Ook via Start > ..>Apparaten verwijderd de codecs Fraunhofer IIS MPEG Layer-3 (professional) en DivX;-) Audio Compression. PC (koud) herstart. Norton WinDoctor gedraaid (32 problemen in 2 categorieën; gerepareerd) en daarna RegCleaner van jv16 PowerTools gedraaid: nog 36 ongeldige elementen aangetroffen en verwijderd. Tenslotte 'met de hand' nog verwijderd uit C:\Windows|System: DivXa32.acm, l3codeca.acm, DivX_c32.ax, L3CODECX.AX, DivXc32.dll, DivXc32f.dll, lame_enc.dll en VorbisEncX.dll. Meer 'verdachte' bestanden kon ik niet vinden. PC (koud) herstart.

    Daarna in deze volgorde geïnstalleerd: DivX3.11 alpha (om weer aan die l3codeca.acm te komen), DivX4.12 codec en VirtualDub 4.1.13. PC (koud) herstart. Daarna stukje video gecaptured met PCM 44100 Hz; 16 bit; Stereo; 172 kB/s. Dit clipje geopend in VDub, video op DirectStreamCopy en audiocompressie op MP3 44100 Hz Stereo bij verscheidene waarden tussen 96 en 320 kbps via Job Control.

    VDub afgesloten, weer geopend en clips met MP3 audio geladen en geprobeerd af te spelen. De eerste keer komt TOCH weer die vermaledijde foutboodschap "The requested audio compression is not compatible with the input format. Check that the sampling rate and channel count of the input match those of the requested format." Als ik dan wat vogel met het schuifje op de voortgangsbalk en/of de knop voor [Output playback] vindt VDub de codec en verandert de 'Unknown tag' in de MP3-codec. Alle andere clips kunnen dan probleemloos geladen en afgespeeld worden. Tot op het moment dat VDub wordt afgesloten: bij de eerste clip moet-ie toch eerst weer een zetje hebben… (Toch enige verbetering!)

    Maar nu het gekke. Als ik in Verkenner op een videoclip met MP3 audio dubbelklik, start de Windows MediaPlayer (6.4) op, maar die probeert onmiddellijk verbinding te maken met Internet met de vermelding 'Poging codec te downloaden.' Laat ik hem z'n gang gaan dan krijg ik de boodschap 'Kan geen juiste decompressor downloaden.' en WMP6.4 speelt vervolgens de video af, maar zonder geluid. Via Bestand > Eigenschappen is dan ook alleen een 'Video Renderer' actief, maar wordt geen DirectShow filter of audio codec afgebeeld. WMP7.01 gedraagt zich analoog, maar ik heb deze layer de toegang tot Internet ontzegd. In plaats daarvan wordt in de help-functie vermeld 'Dit bestandstype wordt niet ondersteund - Meer informatie is niet beschikbaar - Raadpleeg (Engelse tekst) Web Help".

    Ook de MicroDVD-speler probeert Internet op te komen; de BSPlayer v.0.85 doet dat niet maar vertikt het geluid hoorbaar te maken, en met Radlight 3.03R5.2 wordt zowel video als geluid geproduceerd.

    Heb je enig idee hoe ik de WMPs weer in het gareel kan krijgen?

    (Sorry; weer een lang verhaal geworden, maar ik vind het allemaal bar ingewikkeld…)
  • Het is (denk ik) duidelijk: er is een audio codec maar vermoedelijk eerder een directshow filter op de achtergrond aanwezig die alle mpeg (en/of ook andere) audio naar zich toetrekt bij het afspelen.

    Directshow filters zijn ,indien de maker geen un-install toevoegd, nogal moeilijk op te sporen aangezien ze totaal transparant te werk kunnen gaan.

    Het laatste stukje horror-ware welke ik zelf gehad heb en die me bijna tot waanzin had gedreven voordat ik 'm vond was de Moonlight Odiodecoda.
    Een bijzonder rot stukkie stickyware waar ik nogal wat voor aan de hand moest halen voordat ik eraf was.
    Het filter trok alle mpeg1/level1,2 en 3 audio naar zich toe als afspeelfilter en deed daarbij een bijzonder slecht kunstje: hij vrat al mijn cpu-bronnen en speelde stotterig met blauwe schermen en nog veel meer moois.

    Ik heb hem ff opgezocht: het is de mlcom.ax
    Dit filtertje heeft mij toen ook heel wat hoofdpijn bezorgt met soortgelijke problemen als jij nu hebt….

    Wellicht heb jij hem ook? , ff zoeken op je sys naar mlcom.ax

    Andere optie: met een herinstall van mediaplayer wil je ook wel eens van dit soort probs afkomen….

    Overigens: het opnieuw installeren van "legacy" codec's zoals pcm kan in theorie volgens mij niet, ze zijn los niet te krijgen, ze zitten bij een windows installatie standaart m=ingebakken en als je er 1 kwijtraakt/beschadigt ben je simpel gezegd de lul….

    De enigste oplossing die ik er voor ken is door bewust zo'n beetje alles wat met audio en video te maken heeft te un-installen/verwijderen en dan een reparatie-herinstallatie te doen.
    Of dit lukt is maar de vraag, ik heb het ooit eens gedaan en de puinhoop die daar op volgde heeft mij doen besluiten een format c: te doen….
  • Die waanzin waarover je het had, spreekt me wel aan: ik word zelf ook behoorlijk ibbel van al dat vruchteloos geploeter… Troostrijke gedachte dat ook jij als 'oude rot' ooit tegen deze ervaring bent opgelopen. :(

    Neen, [i:75c70eb1de]mlcom.ax [/i:75c70eb1de]is (helaas) niet in aanwezig op mijn PC. Wel een hele zwik andere, maar ik durf ze niet te hernoemen of anderszins aan te pakken omdat ik vrees dat dan de puinhoop helemaal niet meer is te overzien.

    Het is me overigens gelukt het systeem naar een eerder punt te herstellen. Die WMPs spelen nu weer normaal een videoclip af zonder eerst verbinding te zoeken met Internet. (Blijft toch een raadsel…)

    Wel geeft WMP6.4 een system freeze als ik bij een videoclip (zowel een AVI-bestand met PCM- als een met MP3-audio) geef "Bestand > Eigenschappen". Ctrl+Alt+Del is dan de enige uitweg. Dat gebeurt ook als ik een MPG-bestand afspeel; dit zou dus stroken met jouw vermoeden dat een bepaald onduidelijk DirectShow filter alles afroomt?

    WMP7.01 bevriest niks en speelt gewoon af, maar geeft bij "Eigenschappen" voor AVI-clips respectievelijk 'Audiocodec: onbekend' en 'Audiocodec: MPEG Layer-3 Decoder'. Bij afspelen van MPG wordt aangegeven dat zowel een MPEG Audio- als Video-decoder actief zijn, maar welke blijft onduidelijk.

    Op Internet kwam ik nog tegen de FFDshow 11-13-2002 alpha (GPLsw ex www.afterdawn.com), maar die doet helaas alleen (goeie) dingen met de video-instellingen, maar niks met audio.

    VirtualDub blijft narrig bij het openen van DivX-clips met MP3-audio. Ik berust er maar in en zal moeten accepteren dat ik alleen met succes clips in PCM-formaat kan bewerken totdat de hele zaak aan elkaar is geplakt om daarna een finale MP3-compressie te doen.

    Je laatste aanbeveling - format C: - zou wel eens de enig juiste kunnen zijn, maar dat stel ik nog maar even uit totdat ook andere vitale progs op mijn PC zijn flauw gevallen? Mocht ik nog tegen een andere oplossing aan blunderen, dan zal ik dat hier natuurlijk nog melden.

    Voor het overige: nogmaal bedankt
    en: Over en sluiten maar? :(

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.