Vraag & Antwoord

Multimedia, dvd, thuisbioscoop

Elektrische storingen in beeld bij capturen, niet bij TV-kij

6 antwoorden
  • Ik heb een heel vervelend probleem. Ik heb een Pinnacle PCTV Pro TV-kaart, waar je ook mee kan capturen. Lange tijd voldeed deze kaart perfect, ik kon er in PAL resolutie prachtig TV op kijken en opnemen in dezelfde resolutie. MAAR. Sinds een paar dagen is er ineens het volgende probleem: Als ik een video capture, en ik bekijk het resultaat daarna, blijken er elektrische storingen in het beeld te zijn. Flikkerende strepen en knipperende ruis. Heel gek, want het lijkt wel structureel, zelfs periodiek te verschijnen, ongeveer om de halve seconde. Met het TV kijken zie ik dat niet, en het komt ook alleen voor in de PAL resolutue. Met 640*480 en lager is het beeld strak. Ik heb windows al overnieuw geinstalleerd, en het is nog steeds hetzelfde liedje. Zou de TV kaart aan het overlijden izjn? Dat vind ik dan gek, omdat voor het TV kijken en het capturen dezelfde hardwarde gebruikt wordt. Slechte ontvangst /. storin kan het niet zijn want het was eerst niet zo en bovendien gaat het TV kijken nog wel goed. Ik ben ten einde raad, weet iemand een oplossing ???
  • Tja.... Een zoekplaatje..... Ik neem aan dat met herinstallatie je echt geheel terug naar de bron bent gegaan: de laatste configuratie kwa drivers(voor het HELE systeem!) waarvan je zeker weet dat ie goed zou moeten werken? Je update nl nogal eens wat zonder er eigenlijk bij stil te staan(tenminste, ik wel :oops: ) Zo kan een update van office of zelfs alleen word er voor zorgen dat je een nieuwere versie mediaplayer krijgt met allen ellende van dien. Wat dat betreft is sowiezo alle software verdacht want het zal me nix verbazen als kladblok nog eens met een autoupdate functie verschijnt... :wink: Vooral auto-update van msoft is wat dat betreft een hufter: zonder dat je er erg in hebt zit je in 1 keer met nieuwere drivers,directX,mediaplayers en noem maar op en nieuwer wil niet altijd beter zijn. Het zou een hele hoop kunnen zijn maar omdat het alleen met volle pal res is kun je ook denken aan ram/geheugen, bij een hogere resolutie worden er meer bits gebufferd en dus ook hogere geheugen adressen aangesproken die anders (bij <pal) niet worden gebruikt.(dat denk ik tenminste, weet niet zeker) Heb je al geprobeert te wisselen tussen overlay en primary?(heet dacht ik bij pinnacle anders maar komt op hetzelfde neer) De buffering in geheugen is anders tussen deze twee methodes. Er zou dan dus ook nog wel een ander brokkie hardware/software waarvan je het totaal niet verwacht dwars kunnen zitten..... Zakt je voeding niet door zijn hoeven? wordt er niet iets te heet?: stof? En als laatste kan dan natuurlijk ook nog je tv kaart kaduuk zijn maar dat is wat ik altijd pas als allllllleeeeeeer laatste overweeg, en meestal is dat het niet. Apparaten zonder bewegende delen die goed werken gaan slechts zelden "zomaar" in 1 keer stuk. je zou mogelijk eens de boel goed kunnen gaan testen,ik weet dat Madonion/futuremark een video benchmark heeft, videomark2000 oid. [edit] schiet er me er nog wel 1 te binnen: hogere resolutie: hogere datarate: wellicht raakt de data corrupt op 1 van de idekabels/bussen als gevolg van een te hoge snelheid, IDE heeft per slot van rekening geen paritybits zoals scsi, dat een bitje goed uit het mobo komt wil dus niet persee zeggen dat ie ook goed op de hd aankomt/weggeschreven wordt.... Ik heb al rare dingen gezien met ide 66-100-133 door slechte verbindingen/kabels enz enz. Onderschat wat dat betreft windows mediaplayer niet, de hoeveelheid foutcorrectie die daar in zit gebouwd is enorm en ook nog eens eens erg goed. De gecapturede avi zou dus best wel eens corrupt kunnen zijn, Vdub heeft daarvoor in de laatste versies een checker ingebouwd video/scan videostream for errors. Kan je me niet een paar slechte sec. mailen? kan ik eens in hex kijken wat er aan mankeerd,als er tenminste wat te zien is. zo ja: ruwe capture zoals jij hem ook hebt.(vdub/directstreamcopy)
  • Er is iets met de interlace aan de hand.... Kennelijk(?) cap je in divx en je voert de encoder interlaced materiaal. (Virtualdub 1.4.13) Als ik de-interlace door veld1 te verdubbelen(#2 wordt dan dus verwijdert) dan zijn de flikkeringen verdwenen. Ook "discard field 2" levert hetzelfde resultaat. Voor de meelezers: Dit is het probleem. [img:01f346cae9]http://home.hccnet.nl/r.vanwilligen/Slecht1.jpg[/img:01f346cae9] [img:01f346cae9]http://home.hccnet.nl/r.vanwilligen/Slecht2.jpg[/img:01f346cae9] Als ik het hele filmpje bekijk dan lijkt het wel alsof je het slachtoffer bent van een "broken capture driver" die een field-swap doet. dus in plaats van ab-ab-ab-ab-ab-ab-ab capture jij ba-ba-ba-ba-ba-ba-ba Het probleem is dat divx de hele boel nogal filtert en een field-swap filter bij afspelen (kennelijk) geen effect heeft, alleen een field weghalen of verdubbelen werkt. Ik weet hoe een verkeerde fieldorder bij mjpeg eruit ziet maar aangezien divx de hele boel quantisized (blokjes) is alleen in de hele kleine blokjes nog iets te zien wat mij sterk doet denken aan een field-swap. Die fieldswap in 1 quantisized blokje is denk ik wat jij ziet als "ruis" Zet je mon zo groot dat je 1 viewpane(input) vol in beeld hebt en dan met de cursor naar bv frame 7,21(heeft ook de flikker),30 enz Als je de-interlace filter op duplicate field 1 zet zul je ook zien dat in de output de flikker is verdwenen. De ruis blijft maar dat kan aan het onvermogen van het divx afspeelfilter divx liggen om complexe interlace bewerkingen te doen. Hoe verder? Testen: virtualdub tijdens capture een fieldswap laten doen(video/swap fields). of: capture in mjpeg en laat virtualdub op de capture file naderhand een fieldswap doen, mogelijk is het probleem met mjpeg al zelfs zonder fieldswap opgelost. En als je inderdaad last van fieldswap hebt: verklaart waarom alleen op full pal het probleem daar is, op alle lagere resoluties wordt kennelijk door de pinnacle driver progressive gecaptured, bij de PIC video mjpeg codec kan je overigens de driver forceren om op lagere resoluties toch interlaced te capturen(dit staat standaart "aan"!!), "2 fields if more then 240 lines", alles boven de 240 lijnen verticaal wordt interlaced gecaptured. Er af komen? , erg lastig... Ik heb een tijdje , ook "zomaar ineens", min of meer hetzelfde probleem gehad maar andersom: mijn gewone TV weergave was field-swapped maar alles wat ik capturede was ok maar het gecapturede filmpje werd door mediaplayer weer swapped weergegeven, virtualdub gaf hem wel goed weer. Volgens Hauppauge,Microsoft,Avery Lee en Donald Graft(vdub filters) is er geen register switch die dit probleem kan oplossen, bij mij is het ook weer "zomaar" verdwenen..... Ik verdenk nog steeds een mediaplayer update van de narigheid..... Wel OS werk je? (service pack?) Ik zou overigens ook een nieuwere vdub gebruiken,versie 1.4.10 die jij gebruikt heeft (zoals een hoop recente releases) een mooie hoop bugs waaronder een erg vervelende audio de-sync bug die in 1.4.13 eindelijk is opgelost....
  • Bedankt voor je lange antwoord rwilligen, ik zal het als ik thuis ben meteen uittesten. Maar: Ik heb dit probleem niet alleen met divx hoor, ook met MJPEG en uncompressed. Dus ik denk dat het iets anders is. Maar wellicht helpt dat field 1-verdubbelen en field-2 weghalen wel. Ik gebruik overigens win98SE zonder verdere servicepacks. Ik gebruik Windows Media Encoder 8.
  • Bedankt voor je lange antwoord rwilligen, ik zal het als ik thuis ben meteen uittesten. Maar: Ik heb dit probleem niet alleen met divx hoor, ook met MJPEG en uncompressed. Dus ik denk dat het iets anders is. Maar wellicht helpt dat field 1-verdubbelen en field-2 weghalen wel. Ik gebruik overigens win98SE zonder verdere servicepacks. Ik gebruik Windows Media Encoder 8. Volgens mij alleen de mediaspeler die standaard in win98se zit. En, met Virtualdub geeft hij ook het geflikker weer.
  • Nou, ik heb het geprobeerd. Met fieldswap tijdens capture wordt het deinterlace zodanig dat het niet meer terug te deinterlacen is met het filter Smart Deinterlace, en als ik in MJPeg capture en later SD doe is het wel wat minder, maar nog steeds aanwezig. Zit ik er nu aan vast totdat hij 'opeens' weer normaal gaat doen ? :(

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.