Vraag & Antwoord

Anders (hardware)

RAID Drivers wisselen?

8 antwoorden
  • Ik heb hier een ASUS A7V333 Moederbord met 2x 40Gig Maxtor harde schijven welke als RAID 0 opgestelt zijn. Er staat ook netjes RAID 0 als ik opstart en het systeem ziet de schijf ook als 80Gig. Nu is het geval dat de driver die hierop staat de Promise MBFastTrak133 Lite is. Nu las ik laatst een artikel waarin stond dat de MB driver voor mirror is (dus RAID 1) en de SBFastTrak voor striping (dus RAID 0 wat ik hier heb en ook wil!). Naar alle waarschijnlijkheid gebruik ik dus de verkeerde driver, terwijl ik niet echt de indicaties heb dat striping niet zou werken, zou ook geen idee hebben hoe ik dat verder kan controleren overigens. Maar indien ik toch van driver moet/wil wisselen is dat dan uberhaupt mogelijk zonder dataverlies? Kan ik mijn huidige MBFastTrak driver vervangen door de SBFastTrak zonder dat ik een complete format hoef te doen? Normaal gesproken zou het lastig zijn om van Mirror naar Striping te gaan zonder opnieuw te formatten, maar omdat het systeem nu wel staat als zijnde striping wil ik alleen de driver wisselen. Ik ben wat voorzichtig om zomaar RAID drivers te deleten. Iemand hier een idee over en uiteraard het liefst een oplossing! Bedankt alvast.
  • Nou, het idee is simpel en de oplossing dus ook. Als de driver die je nu gebruikt geen striping zou ondersteunen dan kreeg je die keus "Striping/Mirroring" helemaal niet lijkt mij. Dus als jij die keus wel krijgt en je hebt voor "Striping" gekozen en alles werkt naar behoren (en dat doet het, want je ziet in Windows één schijf van 80 Gig) dan is er volgens mij maar één oplossing: [b:d744a9b058]Overal afblijven[/b:d744a9b058] en het lekker zo laten!!! Een oud Chinees spreekwoord zegt "When it's not broken, don't fix it!!!" Waar las je dat artikel trouwens? Ik ben wel nieuwsgierig naar de argumentatie eigenlijk. Gr. Jim
  • Raid 0 heeft toch geen invloed op snelheid (lezen/schrijven)? Met raid 0 heb je alleen een 1 groot disk.[list=][/list]
  • Jim, Bedankt voor je reactie. http://hardwareanalysis.com/content/topic/4170/?o=0 , is één van de velen forums over het raid probleem. Daar is ook te lezen dat de array juist kan worden weergegeven wanneer je de "verkeerde" driver gebruikt, terwijl het toch niet optimaal werkt. Diverse benchmark tests tonen dat blijkbaar aan. Ik krijg verder ook geen gekke meldingen en inderdaad lang dacht ik ook van als het werkt laat dan maar, maar nu wordt ik toch nieuwsgierig en wil ik beide drivers gaan proberen. Nu kan ik wel twee keer een complete herinstallatie van winxp gaan zitten doen om die drivers erop te krijgen, maar dat lijkt me wat omslachtig. Er zal toch wel een andere manier zijn om op een simpelere manier die drivers te wisselen?
  • Ik weet niet of je aan een format ontkomt. Ik zou iig wel proberen ergens een 80GB schijf te lenen voordat je aan de slag gaat. Dan al je partities backuppen en vervolgens pas gaan knoeien. Mocht je dan toch eerst moeten formatteren om de nieuwe driver aan de praat te krijgen, dan kun je binnen een relatief korte tijd je backup terugpompen en evt. dmv de rescue mode van de windows setup CD het MBR redden/opnieuw aanmaken.
  • Eerst even Mehmet: Nou en of dat scheelt, bij striping worden de gegevens over twee schijven verdeeld en theoretisch ligt de schrijf- zowel als leessnelheid dus dubbel zo hoog. In de praktijk gaat er wat verloren aan overhead maar een verhoging van de transfersnelheid van zo'n 50-70% is heel gebruikelijk. =========================================================== Nu terug naar ike: Ik heb dat verhaal op Hardware Analysis gelezen en met alle respect, daar staat heel iets anders dan wat jij in je eerste bericht vermeldt. Ik pik de twee belangrijkste items eruit: "[i:4665e15e08]The bios of the controler makes the strip ok and everytime the system starts up the bios of the raid controler recognizes the strip ok .. 160Gb.[/i:4665e15e08]" en dat is bij jouw ook zo, maar: "[i:4665e15e08]But unfortunately Windows xp recognize the 2 80gb Hd apart. Not as a strip.....[/i:4665e15e08]" en dat is bij jouw heel zeker niet het geval, je schrijft zelf: "en het systeem ziet de schijf ook als 80Gig". Kortom, dat forumtopic gaat over een probleem wat jij helemaal niet hebt en dus blijf ik bij mijn oorspronkelijke advies. En verder sluit ik mij aan bij het advies van Captain_Kansloos, sterker nog: knutselen aan een bestaande RAID-configuratie blijkt in de praktijk telkens weer een bijna zekere weg naar compleet gegevensverlies dus die backup heb je bijna zeker nodig. Maar hoe je die backup dan terug zou moeten zetten op een "kale" RAID-Array zou ik niet weten, maar mischien heeft Captain_Kansloos daar meer ervaring mee. Ge zijt dus gewaarschuwd! :wink: Gr. Jim
  • [quote:f4e99e33ba="Jim van Zweeden"]Maar hoe je die backup dan terug zou moeten zetten op een "kale" RAID-Array zou ik niet weten, maar mischien heeft Captain_Kansloos daar meer ervaring mee.[/quote:f4e99e33ba]Nou, ervaring niet eigenlijk. Maar mijn boerenkool verstand zegt (of denkt) dat een array (transparant) als 1 logische partitie door het OS gezien wordt. Ik ga er dan ook vanuit dat je in 1 klap alle data vanuit bv. een image terug kunt zetten.
  • [b:8e34bbd706]Captain_Kansloos schreef:[/b:8e34bbd706] [quote:8e34bbd706]Maar mijn boerenkool verstand zegt (of denkt) dat een array (transparant) als 1 logische partitie door het OS gezien wordt.[/quote:8e34bbd706] Jawel, door Windows (het OS) wel, maar als je door omstandigheden nou tegen een "kale" RAID-Array zit aan te kijken en je wilt een backup terugzetten, dus noodgedwongen onder DOS of zo, gaat het dan ook goed? Jim

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.