Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Anders (hardware)

OS install herkent harde schijf niet

Toet1
10 antwoorden
  • Dag allemaal,

    Ik hoop dat ik dit in het goede forum neerzet.. Excuses als het niet zo is.
    Het onderstaande probleem lijkt me voornamelijk een hardware probleem:

    Ik heb zo'n 3 maanden terug een laptop gekocht bij een build-to-order bedrijf.
    Bij het installeren van Windows 7 kwam het eerste probleem al om de hoek zetten: De installatie zag geen harde schijf op de computer staan.
    Toen ik vervolgens in de BIOS keek stond er weldegelijk een harde schijf.

    Ik heb toen de laptop terug naar het bedrijf gestuurd die me deze geleverd had en kreeg enkele dagen later een telefoontje dat zij bovenstaand probleem niet tegenkwamen en windows er voor mij opgezet hadden (met door mij aangeleverde serial code).

    Afijn, er staat dus Windows 7 Professional op op dit moment, deze ziet ook de harde schijf, BIOS ziet de harde schijf, niets aan de hand.

    Tot het moment dat ik probeer een dual boot met Linux (Ubuntu, Fedora) er op probeerde te zetten. Wederom hetzelfde probleem. Als er wordt gevraagd op welke harde schijf/welke partitie ik het systeem in wens te zetten, krijg ik een leeg lijstje te zien, terwijl ik van te voren al een partitie had aangemaakt voor de installatie.

    Wederom hetzelfde probleem dus.
    Wederom het bedrijf gebeld, maar zij konden me niet verder helpen. Ze kenden het probleem niet, en, zoals eerder gezegd, kwamen zij het niet tegen toen ik mijn laptop op had gestuurd.
    Op hun advies daarom nu een bericht op een computerforum.

    Informatie over de harde schijf:
    1 harde schijf (intern)
    Hitachi HTS723232L9A360 ATA Device
    Stuurprogramma's volledig bijgewerkt

    Ik hoop dat iemand hier een idee heeft hoe dit probleem te verhelpen is..
    Ik heb de dual boot namelijk ook nodig voor het onderzoek bij mijn studie:(
    Groetjes,
    Siebe
  • Zet in de bios eens de SATA mode van de Drive op IDE
    eens kijken wat er dan gebeurt
  • Wat krijg je te zien als je de aangemaakte partitie verwijdert en nog eens probeert om Linux te installeren? Zie je dan de niet-gepartitionneerde ruimte wel? Mogelijk dat je een partitie had aangemaakt in een format dat niet door Linux ondersteund wordt.
  • Bedankt voor jullie snelle antwoorden!

    @ Anjo:
    Als ik dat wil doen staat er een waarschuwing dat er data verloren kan gaan. Kan dit gebeuren en moet ik de data dan even op een externe hd zetten?
    Daarnaast staat er dat ik dan het bestaande OS (windows 7) opnieuw zou moeten installeren.. Als dat niet nodig is riskeer ik dit liever niet, natuurlijk :-)
    De mode staat inderdaad wel op dit moment op AHCI

    @ Hans60:
    Dit zal ik morgen even proberen, maar heeft dit echt nut? Hij ziet namelijk ook niet de partitie van Windows waar genoeg ruimte opstaat..Hier zou dan weinig aan veranderen mijns inziens..
    Welke format ondersteunt Linux dan wel en niet? Hier had ik nog niets van gelezen?
  • Ubuntu moet op ext3 partitie en ik weet niet of er al SATA drivers in de distributie zitten die jij gebruikt, vandaar mijn suggestie om de schijf in IDE-mode te zetten.
    Bij mijn weten zal er geen data verloren gaan ALS jij maar van die partitie met win 7 afblijft.
    Als je t niet vertrouwd ga eerst eens met een LiveCD van Ubuntuu aan de gang en kijk of je dat bevalt.
    Heb hier zo'n DVD liggen en die gaf ook een mogelijkheid om na een testsessie evt Ubuntu te instaleren.
    Als je na t "spelen' de ACHI weer aanzet moet je weer gewoon met Win7 pro aan de gang kunnen maar een backup is alyijd zinnig
    suc6 Anjo
  • Wellicht zou de TS nog kunnen melden, om welk merk/type laptop het gaat. Meestal is Windows toch al voor-geïnstalleerd. Verder kan de TS ook nog melden waarmee de laptop harddisk, van te voren is gepartitioneerd.

    Mijn Lenovo R61i laptop, die ik september 2008 kocht, staat net zoals de laptop van de TS in het BIOS als AHCI. Ik kon de originele Windows 7 Home Premium upgrade DVD gewoon installeren. Dus zonder extra drivers toe te voegen, tijdens de installatie. Op diezelfde laptop staat ook Ubuntu Linux 9.10 en Ubuntu 10.04 Alpha 3. Deze staan beide op een eigen EXT4 partitie.

    Dat advies over die IDE compatible mode, lijkt me meer iets voor die stokoude Windows XP.
  • Ik heb even gekeken op het internet, omdat ik toch niet helemaal gerust was gesteld op die waarschuwing bij het veranderen van SATA mode..

    Verschillende sites vertellen dat Linux AHCI gewoon zou moeten herkennen, dus dat lijkt me dan niet het probleem?

    Verdere informatie over de laptop:
    Gekocht bij BTO, volledige naam is X-BOOK 17F31A NVIDIA GT130M.
    Omdat ik via een website waar je als student goedkoop software kan kopen, goedkoper windows kon kopen dan via hen, was windows dus niet voorgeinstalleerd.

    Wat bedoel je precies met 'van te voren gepartitioneerd'?
    Het is een 320 GB HD, met momenteel 1 partitie ter grootte van 270 GB met Windows 7 Professional erop geinstalleerd, en 1 lege partitie van 30GB gereserveerd voor Linux, beide NTFS geformatteerd.
  • [quote:7bdf222a94="Toet1"]Wat bedoel je precies met 'van te voren gepartitioneerd'? [/quote:7bdf222a94] Zoiets zei je toch in je startpost [quote:7bdf222a94="Toet1"]Als er wordt gevraagd op welke harde schijf/welke partitie ik het systeem in wens te zetten, krijg ik een leeg lijstje te zien, terwijl ik van te voren al een partitie had aangemaakt voor de installatie[/quote:7bdf222a94]
    [quote:7bdf222a94="Toet1"]Het is een 320 GB HD, met momenteel 1 partitie ter grootte van 270 GB met Windows 7 Professional erop geinstalleerd, en 1 lege partitie van 30GB gereserveerd voor Linux, beide NTFS geformatteerd.[/quote:7bdf222a94] Dat is geen ideale partitie indeling. Gebruikelijk is het om voor de primaire Windows 7 partitie 60 GB te reserveren. De rest wordt dan Extended partitie, met daarin een ongeveer 200 GB logische partitie. En de rest voor Linux.

    Linux kan wel NTFS partities zien. En kan er tegenwoordig ook op schrijven. Maar kan er in principe niet op geïnstalleerd worden. Je zou die laatste 30 GB ongepartitioneerd kunnen laten. Dan maakt de Linux distributie de vereiste Linux partities zelf aan. Let wel goed op het partitie-voorstel van de Linux distributie. Want vaak is dat anders, dan je zelf zou willen.

    [Edit]
    [quote:7bdf222a94="Toet1"]Gekocht bij BTO, volledige naam is X-BOOK 17F31A NVIDIA GT130M. [/quote:7bdf222a94] Als ik zo de specificaties op de site van hardware.info bekijk, zou je daarop Ubuntu 9.10 wel op moeten kunnen installeren. [/Edit]
  • Ik heb met hulp van een vriend die er wat meer verstand van heeft dan ik via de installatie cdrom de partitie verwijderd en er vervolgens een linux partitie van gemaakt. Geen effect echter, nog steeds geen enkele partitie zichtbaar in stap 4 van de installatie.

    Duidelijk werd wel dat linux de harde schijf en partities zeker ziet, gezien ze onder /dev/ zichtbaar waren, alleen tijdens de installatie weigert ie ze te zien..
  • Bedoel je dat hij Ubuntu 9.10 heeft opgestart als Live CD. Bijvoorbeeld: PC opstarten vanaf de Ubuntu 9.10 Desktop CD. Dan English > Try Ubuntu without installing. Zodra de Gnome Desktop is geladen. System > Administration > GParted. Daar zou je dezelfde partities behoren te zien als: Applications > Accessories > Terminal. Daarin typ of plak je [code:1:4d457118e8] sudo fdisk -l [/code:1:4d457118e8][Enter] Zie je dan wel schijnen via Places > Computer? Post screenshot(s) indien je iets tegenstrijdigs ziet. Of iets ziet waarvan je denkt, dat dit niet klopt.

    Had je dat installeren gedaan direct nadat je PC ermee had opgestart: English > Installation? Of nadat deze was opgestart als Live CD en gedubbeld-klikt op het icoontje "Ubuntu installation 9.10." Het zou beide behoren te werken.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.