Vraag & Antwoord

Programmeren

RECODE zoals in SPSS maar nu in Excel??

1 antwoord
  • In Excel maak ik een rapportage op basis van een stapel gegevens die uit een externe tool komen. In deze rapportage worden gemiddelde's berekend. Nou is het geen probleem als deze gemiddelde's standaard zouden zijn want dan zegt Excel gewoon =GEMIDDELDE(data!A2:A24) maar nu moet het in dit rapport beetje anders. Soms moet het gewicht op een andere plaats gelegd worden. Standaard is 12345 (dan is het midden de 3) maar ik soms moet een vraag met de gewichten 54321 (dan maakt het voor het midden niet uit maar links en rechts wel) en soms is het gewicht 210-1-2 het midden is dan 0. In SPSS kan je zeggen RECODE en verander de waarden maar, ik ben bezig geweest met iets in VB: [code:1:d5abdd0943] ... Select Case intWeging Case "54321": If (intAnswer = 1) Then strTemp = strTemp & "5" ElseIf (intAnswer = 2) Then strTemp = strTemp & ";4" ElseIf (intAnswer = 3) Then strTemp = strTemp & ";3" ElseIf (intAnswer = 4) Then strTemp = strTemp & ";2" ElseIf (intAnswer = 5) Then strTemp = strTemp & ";1" End If Case "210-1-2": If (intAnswer = 1) Then strTemp = strTemp & ";2" ElseIf (intAnswer = 2) Then strTemp = strTemp & ";1" ElseIf (intAnswer = 3) Then strTemp = strTemp & ";0" ElseIf (intAnswer = 4) Then strTemp = strTemp & ";-1" ElseIf (intAnswer = 5) Then strTemp = strTemp & ";-2" End If End Select ... [/code:1:d5abdd0943] Maar het lukt me niet. Wie heeft een geniaal idee?

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.