Vraag & Antwoord

Programmeren

[excel] uren optellen met IFELSE erbij?

4 antwoorden
  • Ja mensen ik kom er niet uit, ik wil heel simpel voor mezelf mijn uren bijhouden die ik gewerkt heb en dan wat ik heb verdiend. Excel heeft daar echter geen zin in. Hier is hoe ik het ff snel heb opgezet: [URL=http://img371.imageshack.us/my.php?image=screenshot658dh7.jpg][img:46b6ebc733]http://img371.imageshack.us/img371/9366/screenshot658dh7.th.jpg[/img:46b6ebc733][/URL] Het gaat bij mijn vraag dus om de rode cellen. In K3 staat dit: =ALS (G3>"12:30"[color=red:46b6ebc733][b:46b6ebc733];[/b:46b6ebc733][/color:46b6ebc733] I3-G3[color=red:46b6ebc733][b:46b6ebc733];[/b:46b6ebc733][/color:46b6ebc733] ALS(G3 > "09:30"[color=red:46b6ebc733][b:46b6ebc733];[/b:46b6ebc733][/color:46b6ebc733] I3-G3-"0:30"[color=red:46b6ebc733][b:46b6ebc733];[/b:46b6ebc733][/color:46b6ebc733] I3-G3-"0:45")) Ik heb 12:30 - 13:00 pauze dus dat halfuurtje moet niet in UREN komen, en 09:30 - 09:45 ook niet. Met deze formule haalt excel er echter altijd OF niets vanaf, OF 45min??
  • Hallo Lodyx, Wanneer de starttijd in één van de pauzes is, dan wordt de starttijd de eindtijd van de betreffende pauze. In H3 komt dan de volgende formule te staan: =ALS(EN(G3>=TIJD(9;30;0);G3<=TIJD(9;45;0));TIJD(9;45;0);ALS(EN(G3>=TIJD(12;30;0);G3<=TIJD(13;0;0));TIJD(13;0;0);G3)) Wanneer de eindtijd in één van de pauzes is, dan wordt de eindtijd de starttijd van de betreffende pauze. In J3 komt dan de volgende formule te staan: =ALS(EN(I3>=TIJD(9;30;0);I3<=TIJD(9;45;0));TIJD(9;30;0);ALS(EN(I3>=TIJD(12;30;0);I3<=TIJD(13;0;0));TIJD(12;30;0);I3)) In K3 komt dan de volgende formule te staan: =ALS(OF(H3="";J3="");"";ALS(EN(H3<=TIJD(9;30;0);J3>=TIJD(9;45;0);J3<=TIJD(12;30;0));J3-H3-TIJD(0;15;0);ALS(EN(H3>=TIJD(9;45;0);H3<=TIJD(12;30;0);J3>=TIJD(13;0;0));J3-H3-TIJD(0;30;0);ALS(EN(H3<=TIJD(9;30;0);J3>=TIJD(13;0;0));J3-H3-TIJD(0;45;0);J3-H3)))) Succes!!!
  • [quote:2cbd480bc4="Lodyx"]Ja mensen ik kom er niet uit, ik wil heel simpel voor mezelf mijn uren bijhouden die ik gewerkt heb en dan wat ik heb verdiend.[/quote:2cbd480bc4] Kijk ook [url=http://office.microsoft.com/nl-nl/templates/results.aspx?qu=urenstaten&av=TPL000]hier[/url] eens voor meer inspiratie
  • heej, dit hele verhaal snap ik! de formules kloppen ook:) maar ik heb het probleem dat ik nog een pauze heb in de middag. kan deze ook in de formule toegepast worden? ikzelf kan het niet voor elkaar krijgen. dus er komt iets bij, namelijk de pauze in de middag van 14:45 tot 15:00 kan iemand mij daar mee helpen? hetzelfde voorbeeld als hierboven graag gebruiken!

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.