Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Programmeren

som.als() opdracht in excel voldoet niet

Aimable
5 antwoorden
  • Ik heb van de mutates van mijn prive rekening een overzicht gemaakt in excel.

    Daarna heb ik per soort mutatie een optelling laten maken vai de formule som.als()

    Maar als je nu bv de kabel betaalt, dan wordt dat Kabel juli 2002 en Kabel augustus 2002 etc.

    mijn formule =SOM.ALS($C$2:$C$1002;"Kabel";$D$2:$D$1002) voldoet dan niet omdat de omschrijving dan alleen kabel moet zijn wil hij het kunnen optellen.

    Is de formule zo aan te passen dat het bv alleen kijkt of het aangegeven woord vermeld staat?
  • Probeer eens met DBsom(…)
    Als je dan de criteria laat verwijzen naar een kollom met zoekwoorden zoals bv kabel, worden alle regels welke met kabel beginnen opgeteld.
    Persoonlijk zou ik kiezen voor een nieuwe kolom in de database waarin je een unieke kode zet per mutatie.
  • Als ik het goed heb begrepen moet ik met DBsom ook een extra kolom maken met de trefwoorden erin?

    En anders zeg maar via getallen rubriceren.

    Is het niet te veel gevraagd als je die DBsom formule wilt opschrijven?
    Ik kom er niet helemaal uit via de help van excel.
  • http://home.hccnet.nl/w.bauhaus/forum/som_als.xls
    Ik heb een klein voorbeeldje op mijn homepage gezet.

    Succes

    wim
  • Bedankt voor je voorbeeld, ik heb het bekeken, ik denk toch dat ik het ga rubriceren, ook al omdat ik de optelkolom alfabetisch wil kunnen houden.

    Dat schijnt niet te lukken als ik dat probeer in het gekregen voorbeeld.

    iig bedankt voor de genomen moeite.


    greetz

    Evert

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.