Vraag & Antwoord

Programmeren

Hoe werkt if in macro's van excel

Anoniem
trudge
3 antwoorden
  • Graag wou ik excel een bepaalde aktie laten uitvoeren (lijkt me niet zo van belang) als de waarde in vakje A1 (van blad 1) ongelijk is aan 0.
    Dit had ik zo in gedachten:

    [code:1:6f16872245]
    If A1<>0 Then
    *aktie*
    End if
    [/code:1:6f16872245]

    Dit werkt echter niet. Zou aub iemand mij hiermee kunnen helpen?
  • Een voorbeeldje uit de nederlandse versie:
    [code:1:a7c88c8730]=ALS(F188>0;C188/(S188-78);O187)[/code:1:a7c88c8730]
    De eerste waarde-toekenning C188/(S188-78) vindt plaats als de bewering waar is, de tweede O187 vindt plaats als de bewering onwaar is.
  • [quote:deab1e24aa]
    Hoe werkt if in macro's van excel
    [/quote:deab1e24aa]

    Ik had het dus over het gebruik in de macro.
    Toch bedankt voor je reactie. Ik heb (gelukkig) zelf al een oplossing gevonden

    [code:1:deab1e24aa]
    If Range("A1") <> 0 Then
    *aktie*
    End if
    [/code:1:deab1e24aa]

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.