Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Programmeren

Rondschrijven in excel ?

None
9 antwoorden
  • Het volgende probleem;

    Ik heb een adressen bestand met zo'n 180 adressen.

    Nu wil ik de naam rondschrijven.

    Dus ipv J. van de Berg Berg, J. van de

    ipv Mevr. J. ter Haar - Groot Koerkamp Haar - Groot Koerkamp, J. ter

    Kan dit in excel evt via macro?
  • Probeer eens met tekst naar kolomen
    Menu: Data => tekst naar kolomen…

    Kies in het scherm voor scheidingsteken ,

    Werkt alleen als je achter elke achternaam een , hebt staan
    (eventueel eerst invoegen met een formule.)

    daarna de twee cellen weer samenvoegen in een nieuwe kolom.
    bv =B1 & " " & A1
    daarna kolom kopieren en klakken speciaal als waarde in een nieuwe kolom.
  • Dta is nu juist het probleem

    het staat niet rondgeschreven en het moet niet naar gewoon leesbaar dat was het idd op die manier.

    maar het is niet rondgeschreven en het moet ropndgeschreven worden, dus de andere kant op dat is voor mij een probleem.
  • Lijkt me in VBA ook wel moeilijk.
    Hoe moet je weten dat iemand een dubbele achternaam heeft?

    Dus toch maar tekst naar kolommen en dan weer samenvoegen in
    de gewenste volgorde (spatie als scheidingsteken). Die paar die dan nog fout gaan even handmatig goed zetten.
  • Dat gaat gewoon niet goed.

    Je hebt J. Jansen en J. ter Haar en J. van den Berg om maar iets te noemen, je kunt het dan nog niet goed weer samenvoegen. Probeer het zelf maar eens.


    In dBase kan het nl wel.

    Ik kan laten zoeken naar de 3e posite waar niets staat en in positie 4 die >='A' en positie 5 die #. en #' '
    Als het waar is gaat vanaf de vierde positie tot eind getrimd met komma en spatie en vanaf begin veld tot 3e positie erachter naar een nieuw veld

    dan schuift het op met 4e 5e en 6e positie waarbij de extra voorwaarde is dat dit nieuwe veld leeg moet zijn voordat er iets geplaatst mag worden.

    Ik zet het hier neer, misschien brengt dat iemand op een idee hoe het dan in excel zou kunnen.

    Desgewenst wil ik dat programmatje in dBase hier wel plaatsen.
  • [code:1:4daac731c0]=ALS(D1="";ALS(C1="";B1& " " & A1;C1&" "&A1&" "&B1);D1 &" "&A1 &" "&B1&" "&C1)[/code:1:4daac731c0]

    Ik heb het geprobeerd.
    Met jou voorbeeldnamen gaat het wel goed zo.
    Eerst tekst naar kolomen gedaan. (spatie als scheidingsteken)
    daarna in kolom E de bovenstaande formule ingevoerd.Dit werkt alleen als er niet meer dan 3 spatie's in de naam staat.

    J.Jansen < wordt > Jansen J.
    J.ter Haar < wordt > Haar J. ter
    J.van den Berg < wordt > Berg J. van den

    Wim
  • Dat ziet er goed uit, alleen mis ik de komma achter de achternaam.

    De vraag rijst ook of dit uit te breiden valt naar meer dan 3 spaties in de naam of dat dit het maximum is.
  • [code:1:15b59e49e5]=ALS(E1="";ALS(D1="";ALS(C1="";B1 &", "&A1;C1& ", " & A1 &" "&B1);D1&", "&A1&" "&B1&" "&C1);E1 &", "&A1 &" "&B1&" "&C1&" "&D1)[/code:1:15b59e49e5]
    Toegift, :)
    Max 4 spaties en de gevraagde comma

    Mischien moet je je adressenbestand anders indelen,
    b.v. aparte velden voor:
    Titel, voorletters, voornaam, tussenvoegsel, achternaam
    Heb je in de toekomst dit probleem niet meer.
  • je hebt eigenlijk wel gelijk dat het anders moet worden ingedeeld maar zover was het nog niet. Met deze formule kom ik iig een heel eind
    bedankt voor de gedane moeite.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.