Vraag & Antwoord

OS Windows

Multiboot WinXP & MCE2005

32 antwoorden
  • Na het lang zelf geprobeerd te hebben zonder resultaat, gooi ik 't in de groep: Ik wil een multiboot maken met Windows XP Pro en Windows XP Media Center Edition 2005. WinXP heb ik geinstalleerd op partitie 1 van HD1 (WD160GB SATA). Dat is mijn standaard OS en draait zonder problemen. Op HD2 (WD80GB) heb ik MCE2005 geinstalleerd. Ik heb beide partities waar Windows op geinstalleerd is Primary en Active gemaakt. Voor de duidelijkheid heb ik hier 'n screenshot uit PartitionMagic geupload: http://members.chello.nl/j.swinkels4/C!T.JPG Het probleem is dat ik alleen in MCE2005 kom door de HD met MCE2005 bovenaan te zetten bij boot sequence in de bios. Dit is natuurlijk niet handig, ik wil gewoon zo'n keuze menu bij het starten van de PC. Ik ben al bezig geweest om boot.ini handmatig aan te passen, maar tot nu toe zonder resultaat. Boot.ini ziet er nu zo uit: [i:a3251d4d97][Boot Loader] Timeout=5 Default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS [Operating Systems] multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect[/i:a3251d4d97] Kan iemand me helpen het voor elkaar te krijgen een multiboot met keuze menu te maken? Alvast erg bedankt!
  • check dit: vergeet deze! deze: http://forum.computertotaal.nl/phpBB2/viewtopic.php?t=131263&highlight=multiboot+mce2005
  • [quote:2fa3c2fe2c="tdw"]check dit: vergeet deze! deze: http://forum.computertotaal.nl/phpBB2/viewtopic.php?t=131263&highlight=multiboot+mce2005[/quote:2fa3c2fe2c] Die is al oud en erg off-topic en er wordt niet meer op gereageerd. Ik hoop dat er inmiddels mensen zijn die me kunnen helpen.
  • dat had je dus al gezien...
  • Ik ben bang dat je weer opnieuw zult moeten installeren. Het probleem zit em in die twee primaire partities waarvan er altijd maar één actief kan zijn en dat moet je dus inderdaad steeds in het BIOS veranderen want de machine kan alleen maar van een actieve partitie opstarten. De oplossing: haal die tweede primaire partitie met WinMCE weer weg en maak in plaats daarvan een uitgebreide partitie aan, maak hierin vervolgens een logisch station. Kies tijdens het opnieuw installeren van WinMCE voor "Zelf de partitie aangeven waar Windows geïnstalleerd moet worden" (kijk uit, deze optie zit verstopt onder "Geavanceerde instellingen"en kies dan die nieuw aangemaakte logische partitie. Vervolgens installeert Windows zoals gebruikelijk en maakt automatisch een nieuwe boot.ini aan waarin beide Windowsversies worden opgenomen. Voortaan kun je dan tijdens het booten wel kiezen. Succes, Jim
  • Naar ik begrijp heb je Partition magic. Daarbij zit ook Bootmagic en kun je ook op een van je systemen deze bootloader installeren en daarin de opstartbare systemen aangeven. Dat werkte bij mij met DOS en WIN 2000 op een schijf en Linux als eerste partitie op een tweede schijf.
  • [quote:bec316c364="Jim van Zweeden"]Ik ben bang dat je weer opnieuw zult moeten installeren. Het probleem zit em in die twee primaire partities waarvan er altijd maar één actief kan zijn en dat moet je dus inderdaad steeds in het BIOS veranderen want de machine kan alleen maar van een actieve partitie opstarten. De oplossing: haal die tweede primaire partitie met WinMCE weer weg en maak in plaats daarvan een uitgebreide partitie aan, maak hierin vervolgens een logisch station. Kies tijdens het opnieuw installeren van WinMCE voor "Zelf de partitie aangeven waar Windows geïnstalleerd moet worden" (kijk uit, deze optie zit verstopt onder "Geavanceerde instellingen"en kies dan die nieuw aangemaakte logische partitie. Vervolgens installeert Windows zoals gebruikelijk en maakt automatisch een nieuwe boot.ini aan waarin beide Windowsversies worden opgenomen. Voortaan kun je dan tijdens het booten wel kiezen. Succes, Jim[/quote:bec316c364] Dus het volgende moet ik doen: Via PartitionMagic de partitie van MCE verwijderen en een nieuw logisch station aanmaken. Moet die dan nog active gemaakt worden? Dan installeer ik vanuit WinXP MCE2005 via geavanceerd op het zojuist aangemaakte logische station?
  • Ik heb ditzelfde probleem opgelost door XOSL als bootmanager te installeren. Hiermee kun je de ID van de harde schijven omwisselen, zodat de 2e HDD als eerste wordt gezien door de BIOS en deze dus gewoon opstart. Ook is het niet echt nodig om de partitie op schijf 2 weg te gooien. Je kunt WinXP uitstekend als 2e OS installeren in een primaire partitie, zelfs als deze actief staat. De bootbestanden worden dan op de 1e HDD geplaatst (First Active Primary) en de BOOT.INI op je C: partitie zal dan 2 regels bevatten waardoor je op zou moeten kunnen starten. Het hangt er maar vanaf hoe je installeert. Als de 1e HDD aanwezig is terwijl je installeert, dan wordt [i:4acf69d1d7]dat[/i:4acf69d1d7] de bootschijf en zou je zonder probleem moeten kunnen starten naar de 2e Windows. Als je de 1e HDD uitschakelt, dan lukt dat niet. Zodra de 1e HDD weer wordt geactiveerd kun je de 2e HDD niet meer opstarten, behalve door de BIOS hiervoor in te stellen. En zoals eerder gezegd, ook met XOSL.
  • [quote:4b0bd8b75d="Binary"]Ik heb ditzelfde probleem opgelost door XOSL als bootmanager te installeren. Hiermee kun je de ID van de harde schijven omwisselen, zodat de 2e HDD als eerste wordt gezien door de BIOS en deze dus gewoon opstart. Ook is het niet echt nodig om de partitie op schijf 2 weg te gooien. Je kunt WinXP uitstekend als 2e OS installeren in een primaire partitie, zelfs als deze actief staat. De bootbestanden worden dan op de 1e HDD geplaatst en de BOOT.INI op je C: partitie zal dan 2 regels bevatten waardoor je op zou moeten kunnen starten. Het hangt er maar vanaf hoe je installeert. Als de 1e HDD aanwezig is terwijl je installeert, dan wordt [i:4b0bd8b75d]dat[/i:4b0bd8b75d] de bootschijf en zou je zonder probleem moeten kunnen starten naar de 2e Windows. Als je de 1e HDD uitschakelt, dan lukt dat niet.[/quote:4b0bd8b75d] Ik heb MCE2005 geinstalleerd op HD2, maar het probleem is dat ik geen automatisch aangepaste Boot.ini krijg.
  • [quote:a8e3b0e6f4="Binary"]Als de 1e HDD aanwezig is terwijl je installeert, dan wordt [i:a8e3b0e6f4]dat[/i:a8e3b0e6f4] de bootschijf en zou je zonder probleem moeten kunnen starten naar de 2e Windows. Als je de 1e HDD uitschakelt, dan lukt dat niet.[/quote:a8e3b0e6f4] Misschien komt het omdat HD1 een SATA schijf is en dat setup van MCE2005 op HD2 die zonder SATA drivers tijdens installatie van MCE2005 niet ziet. Zou dat het probleem kunnen veroorzaken?
  • Je zou kunnen proberen om de boot.ini aan te passen door de volgende regel toe te voegen: [code:1:5b43fb606b] multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows MCE" /fastdetect [/code:1:5b43fb606b] Hierdoor zou je in principe de 2e HDD moeten kunnen starten. Lukt dat niet, dan kun je alsnog XOSL proberen. Of WinMCE opnieuw installeren natuurlijk, want dat zou gewoon moeten kunnen. Heb je de 1e HDD uitgeschakeld tijden de installatie van WinMCE 2005?
  • [quote:0c0b12ca78="Binary"]Je zou kunnen proberen om de boot.ini aan te passen door de volgende regel toe te voegen: [code:1:0c0b12ca78] multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows MCE" /fastdetect [/code:1:0c0b12ca78] Hierdoor zou je in principe de 2e HDD moeten kunnen starten. Lukt dat niet, dan kun je alsnog XOSL proberen. Of WinMCE opnieuw installeren natuurlijk, want dat zou gewoon moeten kunnen. Heb je de 1e HDD uitgeschakeld tijden de installatie van WinMCE 2005?[/quote:0c0b12ca78] Die regel had ik al geprobeerd, maar helaas zonder resultaat. Nee, ik heb HD1 niet uitgeschakeld tijdens setup van MCE2005. Zie post hierboven over SATA.
  • [quote:6e0ab36495="JBS"]Misschien komt het omdat HD1 een SATA schijf is en dat setup van MCE2005 op HD2 die zonder SATA drivers tijdens installatie van MCE2005 niet ziet. Zou dat het probleem kunnen veroorzaken?[/quote:6e0ab36495] Ik ging er vanuit dat beide schijven SATA zijn, en zo niet, dan zou dat natuurlijk een verklaring zijn. Maar dat zou tot meer problemen moeten leiden, want de combinatie SATA/IDE is erg lastig in te stellen. Ik hoor graag hoe het in elkaar zit (en ik moet beter leren lezen).
  • [quote:64b9900bf0="Binary"]Ik hoor graag hoe het in elkaar zit (en ik moet beter leren lezen).[/quote:64b9900bf0] Zie openings post. Nog 'n keer dan :P HD1: WD160GB SATA HD2: WD80GB ATA
  • Ik zie in de openingspost niet dat de 2e HDD ATA is. Omdat je dat bij de 1e expliciet aangeeft kreeg ik wel het vermoeden, maar ik wou het toch even zeker weten, vandaar... Ik durf nu niet te zeggen welk effect deze combinatie zal hebben. Een mogelijke (waarschijnlijke) verklaring is het wat mij betreft in elk geval wel. Gewoon maar herinstallatie zal in dit geval heel waarschijnlijk ook niet helpen. Herinstallatie waarbij de SATA drivers vooraf worden geladen mogelijk wel, maar dat durf ik ook niet met zekerheid te stellen. Maar ik zou het in jouw plaats welk graag willen proberen. Of XOSL hiermee problemen zou hebben zou ik zelfs ook niet met zekerheid kunnen zeggen. Kortom: een lastig probleem.
  • [quote:c1b870acf1="Binary"]Ik zie in de openingspost niet dat de 2e HDD ATA is. Omdat je dat bij de 1e expliciet aangeeft kreeg ik wel het vermoeden, maar ik wou het toch even zeker weten, vandaar...[/quote:c1b870acf1] Al moet ik 't 10x vertellen. Ben al lang blij dat iemand met me mee denkt :) Ik ga dat zo snel mogelijk probereren met het laden van de SATA drivers tijdens de setup. Denk dat ik vanmiddag vrij neem :P Wordt vervolgd....
  • Ik heb MCE2005 opnieuw geinstalleerd en tijdens de setup de SATA drivers gevoerd. Helaas heb ik nu nog steeds geen multiboot. Boot.ini ziet er nog steeds zo uit: [i:506a52d7cf][Boot Loader] Timeout=5 Default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS [Operating Systems] multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect[/i:506a52d7cf] Zelf toevoegen van de regel: [i:506a52d7cf]multi(0)disk(1)rdisk(0)partition(1)\WINDOWS="Microsoft Windows MCEl" /noexecute=optin /fastdetect[/i:506a52d7cf] heeft geen zin. Pad kan dan niet gevonden worden etc. Iemand nog ideeen?
  • Ik ben nu in de weer geweest met BootMagic maar daarmee lukt het ook al niet. Als ik [i:43ce63851d]Add OS [/i:43ce63851d]kies ziet ie alleen maar mijn Windows XP op HD1. Ik kan partitie 1 op HD2 dan wel selecteren via Advanced, maar dat is ook zonder resultaat. Ik krijg niet eens een keuze menu bij het rebooten. Dat kreeg ik bij het handmatig aanpassen van boot.ini wel, maar dan was de verwijzing naar MCE2005 weer niet correct. Ik word er onderhand beetje moedeloos van. :cry:
  • Maar zoals ik al eerder schreef, het probleem blijft dat er van twee primaire partities altijd maar één tegelijk actief kan zijn en dan is de andere op dat moment dus niet "bootable" en dus krijg je een foutmelding. Vandaar mijn advies om die tweede Win in een logische partitie te zetten. Die hoeft dan niet bootable te zijn omdat de benodigde opstartbestanden gewoon op de eerste (primair en actieve) partitie komen te staan. En dan werkt ook die toegevoegde regel in het boot.ini bestand weer wel. Alternatief (zoals ook in dit topic al gesuggereerd) is natuurlijk een bootmanager die bij de start van de pc als eerste in beeld komt en waar je de gewilde startpartitie kunt kiezen. De bootmanager handelt dan het op niet-actief zetten van de ene en het op wel-actief zetten van de andere zelf af. Volgens mij heeft het met Serial- dan wel Parallel-ATA niets te maken. Je hebt op beide schijven al een partitie staan en als één van beide schijven niet gezien zou worden bij gebrek aan een S-ATA driver zou dat dus ook nooit gelukt zijn. Jim
  • [quote:8f4f718f88="Jim van Zweeden"]Maar zoals ik al eerder schreef, het probleem blijft dat er van twee primaire partities altijd maar één tegelijk actief kan zijn en dan is de andere op dat moment dus niet "bootable" en dus krijg je een foutmelding. Vandaar mijn advies om die tweede Win in een logische partitie te zetten. Die hoeft dan niet bootable te zijn omdat de benodigde opstartbestanden gewoon op de eerste (primair en actieve) partitie komen te staan. En dan werkt ook die toegevoegde regel in het boot.ini bestand weer wel. Alternatief (zoals ook in dit topic al gesuggereerd) is natuurlijk een bootmanager die bij de start van de pc als eerste in beeld komt en waar je de gewilde startpartitie kunt kiezen. De bootmanager handelt dan het op niet-actief zetten van de ene en het op wel-actief zetten van de andere zelf af. Volgens mij heeft het met Serial- dan wel Parallel-ATA niets te maken. Je hebt op beide schijven al een partitie staan en als één van beide schijven niet gezien zou worden bij gebrek aan een S-ATA driver zou dat dus ook nooit gelukt zijn.[/quote:8f4f718f88] Ik heb MCE2005 inmiddels al op een logische partitie geinstalleerd. Deze is niet active. De regel in boot.ini werkt nog steeds niet, helaas. Ik heb ook al een boot manager geprobeerd (BootMagic) maar die ziet MCE2005 helemaal niet, alleen WinXP op HD1.

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.