Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Windows

map niet bereikbaar voor browser

None
11 antwoorden
  • Mijne Dames en Heeren,

    het volgende gebeurt mij:

    Ik poog iets van een website te maken waarin een image.gif geplaatst moet worden.
    Als ik in de url balk de volledige url van de gif ingeef (via apache, loclhost) krijg ik een foutmelding. http://localhost/osc/catalog/blaat/Image1.bmp

    Als ik de gif enkele mappen hoger zet doet ie het wel …http://localhost/osc/catalog/Image1.bmp

    Het gaat hier om de map blaat,die eerst images heette, hoe ik hem ook noem; geen verschil.
    Als ik de gif in de map catalog plaats kan ik hem via de browser benaderen ….

    ik snap er niets meer van, wie heeft een idee?

    vr.gr.

    Aernout
  • Kijk is of de map blaat niet met hoofdletters is geschreven
  • nope, is het niet!
    ik heb het idee dat het te maken heeft met oscommerce (die de mao aanmaakt ……)

    heb net het hele handeltje op een andere schijf geinstalleerd, en het werkt nog steeds niet!

    dank voor het meedenken!

    groet,

    Aernout
  • Kun je er gifjes van maken ipv bmp's? bmp's laat ie in mijn browser niet zien….(zelfde voor localhost natuurlijk).

    Heb je het lokaal staan allemaal?
    Als je in je code kijkt, heb je dan het plaatje inclusief volledig pad staan? En als je het plaatje in het andere pad zet.. laat ie dat niet zien, of zit je dan ook al op een andere pagina te kijken? (kan namelijk ook te maken hebben met security, waarbij je plaatje in een httpsdocs folder moet staan ipv httpdocs, dwz als je hosting zo is opgezet dat je een folder hebt voor "public" bestanden en voor beveiligde bestanden, als je een SSL security voor je oscommerce hebt.)….
    (Ik hoop dat ik toch een klein beetje duidelijk ben en je niet overrompel met zaken waar je misschien niet eens last van hebt!)
  • jeetje…..

    de plaatjes zijn gif, ze staan local.
    in de code van de index staat een volledig pad, vanaf de directory waar de index staat, dus dat moet kloppen!

    het plaatje kan ik ook niet direct als gif bestand in een brwser openen.

    in een andere directory word ie zichtbaar. (zie original topic!)

    ik hoop dat ik enigzins duidelijk antwoord geef op een reply waar ik met moeite uitkom :-? :oops: :D
  • ja, sorry…. :)

    ok.. heb je oscommerce online staan? Als je je plaatje ziet, zit je dan al in oscommerce? En zo ja, zie je dan http:// staan voor je url of https://?
    Staat er wat in de handleiding voor oscommerce waar alles geinstalleerd staat enzo?

    Hoe zet je je bestandjes online? Via ftp? Als je via ftp je gifjes op je website zet, heb je dan dezelfde folder/map/directorystructuur als wat je in je adresbalk ziet in je browser? Of staat het in een bepaalde map?
  • oscommerce draait alleen lokaal.

    het gaat om de standaard plaatjes van oscommerce (alleen de knoppen) die het niet doen …) maar als ik er een willekeurig plaatje neerzet in dezelfde map, kan ik die ook niet openen)

    dit alles gebeurd direct na het installeren op de server. zoals aangegeven in de handeiding van oscommerce geinstalleerd.

    de plaatjes staan in :
    /osc/catalog/includes/languages/dutch/buttons/quick_find.gif

    alle plaatjes die in de map includes of lager staan zijn niet vindbaar in de browser. als ik dezelfde plaatjes dan in de map catalog kopieer, en die url ingeef in mijn browser, dan zie ik hem wel …..

    maaruh;

    even simpel gezegd: de plaatjes opzich, buiten het hele oscommerce verhaal om, doen het niet in mijn browser. dat is het hele probleem.

    ik moet toch als ik in mijn browser een url opgeef die ergens in mijn http dir staat deze kunnen openen??? ongeacht het aantal submappen wat er tussen zit??? zou dit een apache probleem zijn? of een rechten probleem van de plaatjes en hun mappen?

    greetz
  • Laat ik het zo even uitleggen….
    Stel nou dat je naar de site gaat en je wilt wat kopen.. meestal zit je dan in een http:// address. Plaatjes zijn dan ook gewoon aanspreekbaar.
    Als je gaat afrekenen, ga je -als het goed is- een beveiligd deel van de site in. Dan zie je https:// en zieje rechtsonderin ook een slotje. De plaatjes die HIERIN staan, staan voor zover ik heb gezien NIET op dezelfde plaats als op de gewone site. Dit heeft te maken met beveiliging.

    Maar als je in je FTP geen verschil ziet in de mappen en op beide plekken staan de plaatjes.. en je kunt het pad van het plaatje in je browser gooien en het komt niet tevoorschijn.. ja, dan is er inderdaad wat loos.
    Kun je een folder aanmaken die NIET oscommerce/includes heet en verder dezelfde structuur aanmaken en dan kijken of ie het doet?
  • IK HEB HEM!

    in een van de submappen (boven de map met gif's)
    stond een .htaccess bestand, dit gooide de hele handel op slot (dat dot dat nou eenmaal …)

    Nu ik die heb weggehaald, werkt het in ieder geval…

    nu eens kijken waar dat htaccess bestand voor bedoeld is em waarom ie het niet doet!

    Allen hartelijk dank tot zover!
  • eh.. dat is niet zo slim. :cry:
    een .htaccess bestand wordt door apache gebruikt, zodat ie je mappen kan benaderen zoals jij dat wil. Je hebt nu kans dat je oscommerce het niet meer doet. (voorbeeld: het zet in je .htaccess bestand waar ie je cgi-bin kan vinden….).
    Maar het is wel vreemd als dat in een submap staat, want het zou in je root moeten staan….
    Dus als alles het gewoon doet….. en ook je oscommerce (incl. beveiliging enzo), dan is het goed. Overigens is je .htaccess bestand gewoon een tekst bestand, dus je zou het ook gewoon hebben kunnen downloaden en kijken wat er in stond….
  • http://forums.oscommerce.com/index.php?showtopic=185617

    kijk! hier ga ik eens bestuderen wat en hoe of wat met dat htaccess bestand…

    ik weet dat het er niet voor niets staat, maar zonder doet ie het en met niet, dus ……….

    bedankt allemaal! ik ga naar het volgende probleem (https in apache ….)

    greetz

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.