Vraag & Antwoord

OS Windows

[Windows XP] Stop C0000139 tijdens opstarten

4 antwoorden
  • Ik had gisteren een goed werkende Windiows XP met Service Pack 2 Image teruggezet. In veilige modus met Driver Sweeper nvidia drivers schoongepoetst, nieuwe van nvidia website international whql drivers geïnstalleerd. Daarna drivers van Sweex geluidskaart geïnstalleerd. Dat werkte. En van Pinnacle PCTV MediaCenter Software version 4.0 geïnstalleerd, om online te updaten naar 4.1. Nadat dit voltooid was, plugde ik mijn externe PCTV 150e/55e USB TV kaart in. Dat leek redelijk te werken. Maar de volgende morgen toen ik mijn PC wilde opstarten in XP, verscheen foutmelding [code:1:bb07407333] Stop: C0000139 {entrypoint niet gevonden} kan entrypoint van procedure LdrSetMuiType niet vinden in DLL-bestand ntdll.dll [/code:1:bb07407333] om na enkele seconden te rebooten. Ik plugde die USB TV kaart uit. Dat hielp niet. Ook probeerde ik XP veilige modus. Ook dan reboot de PC tijdens het opstarten, maar zonder foutmeldingen te tonen. Ik heb mijn ongeveer 3 jaar oude WDC WD2000JB getest met de diagnostische software van de fabrikant. Zowel de Quick- en Extended Test toonde: No errors detected for this drive. Die uitgebreide test duurde ongeveer 1 uur en 25 minuten. Ik vond via google een [url=http://techrepublic.com.com/5208-6230-0.html?forumID=101&threadID=220459&start=0]vergelijkbaar probleem,[/url] maar dan met Windows NT4. Om te check of die ntdll.dll wellicht corrupt is geworden, heb ik de [url=http://en.wikipedia.org/wiki/Md5sum]md5sum[/url] gecontroleerd vanuit Ubuntu 7.10. [code:1:bb07407333] jolo@athlox-xp-desktop:/media/hda1/WINDOWS/system32$ md5sum ntdll.dll a558be062173291aa6bb94d9fcb8fa7f ntdll.dll jolo@athlox-xp-desktop:/media/hda1/WINDOWS/system32/dllcache$ md5sum ntdll.dll a558be062173291aa6bb94d9fcb8fa7f ntdll.dll [/code:1:bb07407333] de md5sum uit de C:\Windows\system32\ntdll.dll is blijkbaar hetzelfde als die uit de dllcache. Ik heb bij Microsoft support die Stop C0000139 ingetypt. Op Nederland vond deze niets. Op Engels alleen http://support.microsoft.com/kb/134326/en-us Het gaat hier om een oude AthlonXP 1700+ met 2x512 MB + 1x1GB werkgeheugen. Er is niets overklokt. Het is een multiboot PC met XP SP2, Vista Premium en Linux. omdat zowel Vista Premium en Ubuntu 7.10 nog wel goed opstarten, denk ik in eerste instantie niet aan een hardware probleem. Maar voor alle zekerheid heb ik Memtest86+ v1.70 al gestart. Asus A7V266-E moederbord met nieuwste BIOS uit 2002. AGP slot: 7600GS Voeding stekker van videokaart is aangesloten. PCI slot 1: Leeg PCI slot 2: Sitecom usb2.0/firewire combocard PCI slot 3: Leeg PCI slot 4: Sweex soundcard 5.1 Onboard geluidskaart is in het BIOS Disabled. PCI slot 5: 3C905C netwerkkaart Voeding: Een matige Codegen van 350 Watt. Eventueel kan ik die wisselen met een Zalman 400Watt voeding, uit een andere oude PC. Ik kan nu wel wel weer die goed werkende Windiows XP met Service Pack 2 Image terugzetten. Maar wacht daar nog even mee, om te checken welke ervaring men hiermee heeft. Met de zoekmachine van dit forum vond ik niets. Zoekwoord: [b:bb07407333] C0000139 [/b:bb07407333] en ik probeerde ook [b:bb07407333] C*139 [/b:bb07407333]
  • [quote:e4db7b9e79="jolo"]Maar voor alle zekerheid heb ik Memtest86+ v1.70 al vast gestart. [/quote:e4db7b9e79] Na een memtest van 44 uur met 22 pass zonder fouten, vond ik dit wel voldoende om aan te nemen dat mijn werkgeheugen nog in orde is. Dus heb ik het recovery console advies opgevolgd in deze topic, met een zojuist nieuw geslipstreamde XP SP2 CD. http://www.hardwareanalysis.com/content/topic/19187/ [quote:e4db7b9e79="Charles McKinney"] cd system32 ren RPCRT4.dll RPCRT4.old CD-ROM_or_DVD-ROM_Drive_Letter: cd \i386 expand RPCRT4.dl_ BootDriveLetter:\windows\system32 exit [/quote:e4db7b9e79] Maar nu onstond tijdens het opstarten in XP, deze foutmelding [code:1:e4db7b9e79] Stop: C000021a {onherstelbare systeemfout} Het systeemproces windows logon Process is onverwacht afgebroken met de status 0xc0000139 {0x00000000 0x00000000}. Het systeem is afgesloten. [/code:1:e4db7b9e79] en uiteraard de gebruikelijke reboot. Met deze zoekwoorden in google xp stop C000021a status 0xc0000139 vond ik deze topic, die een een reparatie installatie aanraad http://gathering.tweakers.net/forum/list_messages/1038195 Net als in deze topic http://www.computing.net/windowsxp/wwwboard/forum/141918.html Dus heb ik dat geprobeerd. De reparatie installatie vanaf de XP SP2 CD ging goed tot en met stap 6 van deze [url=http://www.michaelstevenstech.com/XPrepairinstall.htm]How to Perform a Windows XP Repair Install.[/url] Echter na de reboot verscheen de volgende foutmelding [code:1:e4db7b9e79] Schijfleesfout Druk op CTRL+ALT+Del om opnieuw op te starten [/code:1:e4db7b9e79] Via de zoekmachine van dit forum met zoekwoord [b:e4db7b9e79] Schijfleesfout [/b:e4db7b9e79] vond ik deze topic http://forum.computertotaal.nl/phpBB2/viewtopic.php?t=98860&highlight=schijfleesfout Het door Ben Jonson geadviseerde CHKDSK c: /r in de Recovery Console, gaf de volgende output [code:1:e4db7b9e79] chkdsk is bezig met het controleren van het volume... chkdsk is bezig met het voorbereiden van extra controle of herstel... chkdsk heeft een of meer fouten op het volume gevonden. [/code:1:e4db7b9e79] Toen typte ik exit, om de PC opnieuw op te leten starten. De reparatie installatie werd hervat. Nadat de reparatie installatie was voltooid, startte de PC weer goed op in XP. Het probleem lijkt hiermee opgelost. Al weet ik hiermee niet hoe het was ontstaan. Of de software van Pinnacle PCTV MediaCenter ermee te maken zou kunnen hebben. De tijd zal dat moeten leren.
  • Harddisk al eens getest? http://www.tacktech.com/display.cfm?ttid=287
  • Die harddisk had ik al getest. Zie startpost [quote:9f2d11b1cc="jolo"]Ik heb mijn ongeveer 3 jaar oude WDC WD2000JB getest met de diagnostische software van de fabrikant. Zowel de Quick- en Extended Test toonde: No errors detected for this drive. Die uitgebreide test duurde ongeveer 1 uur en 25 minuten. [/quote:9f2d11b1cc] Maar omdat dit inmiddels al 5 dagen geleden was, doe ik dit voor alle zekerheid nu nogmaals. //Edit 13:30 18-12-2007 De DLDiag 4.12 Quick en Extended tests zijn weer voltooid. Ook deze keer: No errors detected for this drive. //Edit2 15:30 18-12-2007 Inmiddels heb ik de harddisk ook getest met HDTune. In de benchmark die ik 5x heb gedaan, zitten wel wat dipjes. In de eerste test Minimum 1.6 MB/sec Maximum 60.6 MB/sec Average 50.3 MB/sec Access Time 13.9 ms Burst Rate 72.4 MB/sec CPU Usage 7.7% HDTune Error Scan die ongeveer 71 minuten duurde, vond geen fouten.

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.