Vraag & Antwoord

OS Windows

Windows XP kan partities harddisk niet vinden

8 antwoorden
  • [b:41e58f9bf7]Windows XP Proff. kan de partities op de harddisk niet vinden.[/b:41e58f9bf7] Mijn desktop heeft het MSI K7T 266 PRO-2 RU moederbord, met RAID, voorzien van de meest recente BIOS-versie, incl. de RAID-drivers (via MSI). Verder werk ik met Windows XP Proff. Ik werk op mijn desktop met twee harde schrijven, resp. 60 en 80 Gb. Van deze oude drives heb ik destijds –toen ze nog prima werkten- via Ghost image-files gemaakt. Ook van de bestanden heb ik goede backups. Omdat de oude harddisks het een week na elkaar hebben begeven enkele weken geleden twee nieuwe harddisks gekocht. Beiden een IDE-drive van Seagate, n.l. de Barracuda 7200.10, ST3160215 A van 160 Gb. De harddisks op de gebruikelijke wijze via FDISK (DOS) gepartitioneerd en geformatteerd. Vervolgens de imagefiles van de oude schijven teruggezet. “Harddisk 1” aangesloten op IDE-0 en “harddisk 2” op IDE-3 (RAID). Tijdens deze procedure steeds opgestart vanuit de floppydrive of vanuit IDE-0. Alles leek in eerste instantie goed te verlopen. Wanneer ik tot slot echter het programma Norton Disk Doctor draai krijg ik de volgende foutmelding voor de “harddisk 2” op de Raidcontroller: Error on hard disk- An extended partition is invalid. An extended partition has invalid parameters and is probably inaccessible. Correct this situation if you are unable to access partitions on hard disk 2. Do you wish to correct this problem? Probleem zelf eerst trachten op te lossen door te controleren met Partition Magic 8.0. Deze constateert echter geen fouten. Vervolgens probleem proberen op te lossen via Norton Disk Doctor met als resultaat dat een extra partitie werd aangemaakt van 29 Gb, die ook volledig in gebruik was. Ook constateerde ik daarna, dat bij opstarten via “disk 1” Windows niet de partities laat zien van “disk 2”.(RAID). Windows booten vanaf “disk 2” (RAID) lukt evenmin. Even wordt het Windows-beeldzichtbaar en daarna start computer opnieuw. Om het probleem op te lossen van alles geprobeerd. Totale nieuwe schijfpartitionering / formattering met zowel FDISK, Partition Magic als Windows XP Proff. Lost het probleem niet op. Ook een heropbouw van de Master Boot Record met FDISK bood geen soelaas. Windows XP opnieuw installeren vanaf CD-ROM evenmin. Vervolgens “disk 1”aangesloten op IDE-3 (Raid) en “disk 2” op IDE-0. En ziedaar.. alles werkt naar behoren, ongeacht of ik opstart via disk 1(nu RAID dus) of disk 2. Wel blijft de hiervoor genoemde foutmelding “Error on harddisk enz.” komen voor die disks, welke is aangesloten op IDE-3 (RAID).Deze foutmelding komt alleen voor de disks aangesloten op de RAID-connector, ongeacht welke disk dit is. De foutmelding komt niet door bij aansluiting van de disks op IDE-0. Samenvattend heb ik nu het volgende probleem: Disk 1 op IDE-0 en disk 2 op IDE-3(RAID): Via disk 2 systeem niet op te starten (Windows XP scherm verschijnt even later gevolgd door een reset). Via disk 1 systeem normaal op te starten. Alleen herkent Windows XP de partities van disk 2 nu niet en geeft Disk Doctor de eerdergenoemde foutmelding externe partitie, alleen voor disk 2 (RAID). Disk 1 op IDE-3(RAID) en disk 2 op IDE-0: Zowel via disk1 als disk 2 Windows XP normaal op te starten en in beide gevallen worden alle partities van de beide harddisks herkent. Wel geeft Disk Doctor de eerdergenoemde foutmelding externe partitie voor disk 1 (RAID). Aansluiting van een disk op connector IDE-4 (ook RAID) in plaats van op IDE-3 geeft in alle gevallen dezelfde problemen. DOS en Partition Magic. Ongeacht op welke connector de disks worden aangesloten, alle partities worden altijd herkent en zijn in alle gevallen normaal benaderbaar. Wie kan mij helpen aan een oplossing voor dit probleem? Dit temeer omdat ik beide harddisks eigenlijk zou willen aansluiten op een RAID-connector om zodoende altijd een “duplicaat” van de harddisk ter beschikking te hebben bij calamiteiten.
  • Indien je echt een raid wilt, in dit geval raid 1, dan dienen de schijven aan ide 2 en 3 gehangen te worden, dan zal de promise controller in de bios op enabled en op de raid functie gezet dienen te worden, dan komt er bij het opstarten voorbij welke toets of toetsen er gebruikt moeten worden om in de raid bios te komen om een array aan te maken, dan pas heb je een raid, dan worden de schijven gezien als 1 schijf. Ook moet in windows de promise driver te zijn geladen, wat denkelijk niet het geval is met de image die wordt teruggezet, je had immers de oude schijven niet in raid staan. Wil je toch maar geen raid en geen gebruik maken van die controller, hang beide schijven aan ide 1 en ide 2, beide als master en hang de cd/dvd devices als slave erachter, of als je er welo gebruik ervan wil maken, hang die aan ide 2 en 3, dan moet de promise controller als gewone controller werken, dus niets doen in de raidbios, maar dan worden die devices alleen herkent als de drivers geladen zijn, of via een flop of als windows is geladen met die drivers ervoor.
  • Bedankt voor je reactie. Ook voor het aansluiten van één disk op de RAID-connector moet in de BIOS de RAID op "enabled" worden gezet en moeten Raid-drivers zijn geinstalleerd. Dit heb ik dan ook allemaal gedaan. In mijn oude situatie werkte een en ander prima. De "oude" imagefiles zijn slechts een maand oud, omdat ik regelmatig imagefiles aanmaak. Omdat ik in de "oude situatie" slechts één disk op RAID had aangesloten heb ik eerst deze situatie weer OK willen hebben. Daarna pas zou ik willen overgaan om beide schijven paralel naast elkaar te laten lopen op de beide RAID-connectoren (IDE-3 en IDE-4. Jouw toelichting geeft mij dus nog niet de gewenste oplossing. Nogmaals bedankt.
  • Ik denk dat je de topicstart zelf nog eens door moet lezen, ik kon er al geen broodje van bakken en heb een standaard verhaal gegeven. Overigens kan die promise controller geen atapi devices aansturen anders dan ik had voorgesteld. Je hebt het over een extendet partitie, zit daar wel een logisch station in?, bij mijn weten dient een OS vanaf een primaire aktief gemaakte partitie te starten. Ook heb je het over wel of niet starten vanaf een bepaalde schijf, staan op beide schijven een windows XP versie en alle opstartbestanden? of is gewoon dezelfde image gebruikt. En via welk keuzemenu laat je die schijf als eerste opstarten? Ook snap ik niet wat het probleem is, je wilt een RAID 1 maken, dan worden alle partities toch weer verwijderd als er een array wordt aangemaakt en dien je de schijf weer opnieuw in te delen. Dat kan via de XP cd en de raid driver disk of via een cd met Gparted.
  • Ik zal het nog een keer proberen uit te leggen. Op mijn computer heb ik 4 IDE-connectoren, IDE 1 en 2 (normaal) en IDE 3 en 4 voor RAID. Ik werk als volgt: Op IDE-1 heb ik als "master" een harddisk, disk 1, aangesloten. Mijn tweede harddisk, disk2, heb ik aangesloten op IDE 3(RAID). Op mijn beide disks heb ik een primaire active partitie en een extended partitie met enkele logische stations. Beide harddisks worden vervolgens onafhankelijk van elkaar gebruikt als zelfstandige schijven met op elke schijf Windows XP en andere programma's, alsook de Raid-drivers. Nu kan ik, ongeacht hoe ik opstart, beide schijven altijd benaderen vanuit Windows. Zo kopieer ik op vaste tijdstippen mijn documenten van disk 1 naar disk 2. en omgekeerd. Via het Bootmenu van mijn Award BIOS (tijdens opstarten F11 indrukken) krijg ik een keuze scherm voor het opstarten. Dit kan dan vanaf de A-drive, de CDROM, een USB-stick, Disk 1(IDE-1) of disk 2(IDE-3 en dus RAID). Beide nieuwe disks heb ik in eerste instantie op dezelfde wijze voorbereid (partitioneren en formatteren en imagefiles mei eigen inhoud voor disk 1 en disk 2 terugzetten). Doe ik nu disk 1 op de RAID-connector, dan werkt het opstarten via disk 1 prima en is disk 2 op gewone connector ook benaderbaar. Ook kan ik opstarten via disk 2 (andere connector) is is disk 1 ook normaal benaderbaar. Doe ik echter disk 2 op de RAID connector, dan wordt de Array normaal herkent, maar werkt opstarten via disk 2 NIET. Wel kan ik opstarten via disk1 op de gewone connector, maar dan is disk 2 op de RAID niet benaderbaar binnen Windows. Binnenkort wil ik beide disks paralel aansluiten op de RAID (Striping, RAID 0 dus). Dan moeten beide disks wel vanaf de RAID connector kunnen opstarten, (in het geval de ene disk defect is moet de andere het overnemn).
  • De vraag was dan ook of dezelfde image is gebruikt voor schijf 1 en 2, zo te zien staan er geen promise drivers in windows op schijf 2, dat is de enige conclusie die ik kan trekken. Overigens is het een AMI bios, ook kan een raid niet met 1 schijf zoals je nu weeggeeft, maar dat terzijde. Ook heb je het nu over een RAID 0, striping, dan heb je geen mirror, neem aan dat je raid 1 bedoeld. Maar nogmaals, wat is het probleem als je toch van plan bent om een raid 1 aan te maken?
  • Sorry, inderdaad heb ik de begrippen striping en mirror verwisseld. Het is mijn bedoeling de schijven als "mirror" (Raid 1) te plaatsen. Als echter de ene schijf stuk loopt en de andere wil niet via de RAID-connector opstarten dan heb ik een probleem. Overigens zijn de Raid-drivers wel op beide disks aanwezig. Ik heb zelfs een imagefile van de goedwerkende schijf gemaakt en deze overgezet naar de andere drive. Ook nu blijf ik dezelfde problemen houden. Dus m.i. kan het niet aan de drivers liggen. Ik denk dat ik toch dieper moet zoeken. Zo kreeg ik via het systeemlogboek de melding: De masterbrowser heeft een servermelding ontvangen van computer nr. ...., die meent de masterbrowser voor het domein te zijn op transport NetBT_Tcpip. Zou deze melding te maken kunnen hebben met mijn probleem ?
  • Dat gaat over het netwerk. Maar waarom bouw je niet eerst een raid 1, maak een array en zet die image daarop, werkt dat hoef je er verder toch geen zorgen te maken. Je hebt tenslotte er een IMAGE van. Het is mij een raadsel waarom sommige configuraties met die schijven niet wil werken, het zijn tenslotte gewoon clonen van elkaar. Ook nog alleen 1 schijf aan die IDE 3 of 4 geprobeerd?

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.