Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Windows

Iconen bij Favorieten worden vervangen door verkeerd icoon.

Rosturp
22 antwoorden
  • Beste PC liefhebers,

    Het volgende probleem doet zich bij mij voor:

    Na bezoek aan een webpagina met [b:b91fc77191]een eigen icoon/favicon[/b:b91fc77191] (bv Computer Totaal), wordt na het afsluiten van deze pagina, een verkeerd icoon toegevoegd aan de snelkoppeling naar deze pagina. De standaard "E" icoon van Explorer blijkt vervangen te zijn door het 1e icoon uit het bestand shell32.dll. Dit icoon is "leeg". (Voor de duidelijkheid: je ziet dit lege icoon ook wanneer een bestand nog niet gekoppeld is aan een programma). [b:b91fc77191]Let aub op: de bedoeling is dus NIET dat ik de favicon wil behouden, ik wil de E van Explorer gewoon terug zien![/b:b91fc77191] Het probleem doet zich overigens niet voor bij pagina's (de meeste) die geen eigen favicon hebben. In dit geval blijft het E icoon keurig gehandhaafd.

    De volgende acties zijn reeds door mij uitgevoerd, zonder resultaat:

    1. Dit forum raadplegen.

    2. Het lege pictogram vervangen door het pictogram van Explorer (E) uit het bestand C:\WINDOWS\system32\url.dll

    3. Het bestand "IconCache" verwijderen en daarna opnieuw opstarten.

    4. Opstarten in veilige modus en daarna weer normaal opstarten.

    5. De kleurdiepte van het scherm wijzigen in 16 bit en daarna weer in 32 bit.

    6. Max Cached Icons sleutel toevoegen aan het register met waarde 2000.

    (zie voor punt 5 en 6 http://support.microsoft.com/kb/132668/nl

    Geen van bovenstaande punten heeft het probleem kunnen verhelpen. Heeft iemand enig idee op welke wijze ik dit euvel wel kan oplossen? Ik heb zelf het idee dat het om een registerinstelling gaat.

    Alvast hartelijk dank voor eventuele reacties.

    mvg
    Toni
  • Nog niet geprobeerd: Tweakui http://www.microsoft.com/windowsxp/downloads/powertoys/xppowertoys.mspx
    Kies Repair -Rebuild Icons
  • [quote:6c40cae1fb="Jan bakker"]Nog niet geprobeerd: Tweakui http://www.microsoft.com/windowsxp/downloads/powertoys/xppowertoys.mspx
    Kies Repair -Rebuild Icons[/quote:6c40cae1fb]

    Jan dank je voor je reactie. Het powertoyspack bestaat uit diverse onderdelen. Enig idee welk onderdeel ik nodig heb? (Tweak UI?)

    Verder kom ik deze melding tegen op de site: [b:6c40cae1fb]PowerToys only work with U.S. English regional settings[/b:6c40cae1fb]. Dat roept bij mij twijfels op of het proggie wel werkt. Ik hoor graag van je.

    Mvg,
    Toni
  • Hoi Jan,

    Mijn vermoeden was juist, het ging idd om de file Tweak UI. Leuk proggie.
    Ik heb inmiddels de functie "Rebuild Icons"uitgevoerd, maar helaas…..
    het probleempje is niet opgelost. Wat zou ik nog meer kunnen proberen?

    mvg,
    Toni
  • Inderdaad, je moet Tweakui hebben. Sommige andere Toys zijn overigens ook handig. Zelf gebruik ik bv. de Open Command Window Here vaak.

    Tweakui is inderdaad Engelstalig. Ik draai het op een Engelse XP, maar met de Regional Settings op Nederlands en dat werkt gewoon. Volgens mij moet het ook op een Nederlandse Windows gewoon draaien, zij het dat de tekst Engels is. Ik weet in elk geval zeker dat dat onder Windows 98 zo was.
  • Leg je probleem nu eens nogmaals uit, want als ik het nu goed begrijp maak je snelkoppelingen van diverse site's en daar krijg ja dan ook de goede pictogram voor, alleen je wilt de IE pictogram?

    Over welke pictogrammen heb je het hier, die op het bureaublad of van de favorieten?

    Of heb ik het fout en ga je nu het voor mij, met mijn mierenhersenen, het nogmaals uitleggen. :wink:

    http://pcmagazine.zdnet.nl/print.cfm?id=36741
  • Ik doe mijn best. Het gaat alleen om het icoon naast de snelkoppelingen van mijn internet favorieten. Normaliter is dat de standaard E van Explorer. Echter sommige websites (zoals Computer Totaal) hebben een eigen icoon, ook wel favicon genoemd. Bezoek ik dus de website van Computer Totaal, dan krijg ik netjes het favicon icoontje te zien. Tot zover gaat alles goed. Maar nu komt het:

    Als ik de map tijdelijke internetbestanden opschoon (mbv CCleaner) dan worden vanzelfsprekend ook alle favicons gewist. Als ik Windows dan opnieuw opstart dan moet ik normaal gesproken weer het standaard E-icoon (van Explorer) voor de snelkoppeling van de Computer Totaal website zien staan. En dat gebeurt niet. Deze blijkt ineens vervangen te zijn door een "leeg" icoon. (Hiermee bedoel ik het 1e icoon uit het bestand shell32.dll). Om een ander visueel te maken heb ik een screenshot toegevoegd. Ook voor deze twee websites geldt, dat het E icoon ineens is verdwenen.

    [img:b3160dcbd7]http://pic50.picturetrail.com/VOL414/10019627/18062189/303974880.jpg[/img:b3160dcbd7]

    Ik hoop dat ik het zo wat beter omschreven heb. Het kan niet anders of er staat een registerwaarde niet juist. Maar welke? Heb je raad voor me?
    Alvast bedankt.

    groetjes,
    Toni
  • Op die fiets.

    Maar, als je de cookies van die websites uitsluit van cleaning, bij instellingen in Ccleaner, worden de favicons gelijk weer opgenomen.

    Dat je geen IE pictogram krijgt bij een volledige verwijdereing van de temporary internet file, handmatig of met Ccleaner, krijg je vanzelf na verloop van tijd weer de juiste, vaak krijg je eerst hele vreemde, in jouw geval blanco.


    Misschien dat deze ook werkt.
    http://www.softpedia.com/get/Internet/Bookmark-Managers/favorg.shtml

    Of je zet die je wilt houden op alleen lezen, weet niet of het werkt maar dat valt te proberen.
  • Hoi Lange Pier,

    Bedankt voor je reactie. Ik stel het erg op prijs dat je meedenkt over een eventuele oplossing. Een optie is idd de favicons bewaren in een andere map, of uitsluiten van opschonen. Echter hier gaat vooralsnog niet mijn voorkeur naar uit. Liever zie ik gewoon de E van Explorer weer terugkomen, dan een bonte verzameling aan iconen voor alle snelkoppelingen. Op die site trof ik wel een interessant stukje tekst aan:

    So, why do we need a utility to manage these favicons? Because Internet Explorer doesn’t do its job very well. The downloaded icon file is stored as a temporary file. Which means that after a while, the favicon will disappear and [b:af4658f814]your shortcut will be associated again with the standard Internet Explorer icon[/b:af4658f814].

    Het gedeelte dat VET staat, dat gebeurt bij mij dus niet. Ik stoei nog even verder met je andere optie (allleen lezen) Uiteraard laat ik je de afloop hiervan weten.

    groetjes,
    Toni
  • Had ik het toch niet goed begrepen, je wilt alleen de IE pictogram zien helaas kun je de de favicons niet uitschakelen in Internet Explorer, wel in FireFox en zijn familie.

    Over het herstellen in de default IE favicon ben ik nog niets tegengekomen.

    http://tweakers.net/meuktracker/14033/maxthon-201-build-460-preview.html
    Schilletje?
  • Je schrijft aan het begin van deze discussie dat je het lege pictogram hebt vervangen door het pictogram van Explorer (E) uit het bestand C:\WINDOWS\system32\url.dll. Heb je dat voor een specifiek bestand gedaan of in Folder Options (Mapopties? Ik heb een Engelse Windows) voor alle Internet Shortcuts?

    Je kunt even kijken welk pictogram standaard gebruikt wordt onder het tabblad File Types (bestandstypen, bestandssoorten?)

    Overigens blijven bij mij de favicons gewoon staan nadat ik mijn Internet Cache inclusief cookies geleegd heb. Ik vraag me af waar die gegevens dan staan opgeslagen.
  • Ik ook niet, maar bedankt voor je reactie. Wellicht was je onbewust toch dichtbij met je oplossing…

    Als ik nl alle snelkoppelingen het kenmerk "Alleen Lezen" meegeef, zou het icoon niet vervangen mogen worden. Dit ga ik even in de gaten houden.
  • [quote:cca2c2d91b="Jan bakker"]
    Overigens blijven bij mij de favicons gewoon staan nadat ik mijn Internet Cache inclusief cookies geleegd heb. Ik vraag me af waar die gegevens dan staan opgeslagen.[/quote:cca2c2d91b]

    Gooi via Ccleaner die index.dat file maar eens weg, wat overigens bij mij niet werkt op deze comp, dan zijn die ook verdwenen.
  • [quote:9a6166d161="Jan bakker"]Je schrijft aan het begin van deze discussie dat je het lege pictogram hebt vervangen door het pictogram van Explorer (E) uit het bestand C:\WINDOWS\system32\url.dll. Heb je dat voor een specifiek bestand gedaan of in Folder Options (Mapopties? Ik heb een Engelse Windows) voor alle Internet Shortcuts? Je kunt even kijken welk pictogram standaard gebruikt wordt onder het tabblad File Types (bestandstypen, bestandssoorten?) [/quote:9a6166d161]

    Hoi Jan, dit heb ik op snelkoppeling niveau gedaan. Dus op de snelkoppeling gaan staan en dan via de andere muisknop kiezen voor eigenschappen, etc. Via Extra'-Mapopties-Bestandstypen het pictogram wijzigen voor "snelkoppelingen" heeft bij mij helaas geen effect.

    Echter het probleem blijkt op te lossen door de snelkoppelingen van websites die een eigen favicon gebruiken, het kenmerk alleen lezen mee te geven. Ik zie nu dat bij de snelkoppeling van www.computertotaal.nl het pictogram "E" van Explorer weer terug is gekomen en dat was nu juist de bedoeling! Ik vertrouw er op dat dit ook voor de andere websites gaat lukken. Hartelijk dank voor jullie reacties.

    mvg,
    Toni
  • My penny.
    [b:3da89da20c]regsvr32 url.dll[/b:3da89da20c]

    Anders even Googlen op:
    [b:3da89da20c]HKEY_CLASSES_ROOT\InternetShortcut\DefaultIcon "url.dll,0"[/b:3da89da20c]
    Interessant draadje bij Tech Support Guy
  • Interessant! Uit posts op andere forums, blijkt dat het dus idd om een bug in IE7 gaat. Zal er later vandaag nog eens kritisch naar kijken.
    Bedankt voor je tip!
  • We zijn er uit. Rosturp bracht me verder op weg en ik weet nu exact wat de oorzaak van het probleem is. Het gaat om een bug in IE7 en MS heeft hiervoor nog geen goede fix uitgebracht. Wat gebeurt er nu eigenlijk.

    Standaard behoort XP het pictogram voor een snelkoppeling naar een webpagina uit het volgende bestand te halen:
    [b:28f251a931]C:\Windows\System32\url.dll[/b:28f251a931]
    Dit bestandje bevat 4 pictogrammen, waarvan de 1e het bekende E icoon is. Zie hieronder, rechterzijde. Let met name even op de padverwijzing.
    (Als voorbeeld heb ik de site van PC Active genomen, aangezien deze geen favicon gebruikt).

    [img:28f251a931]http://pic50.picturetrail.com/VOL414/10019627/18062189/304099464.jpg[/img:28f251a931]

    Maar nu komt het….

    Wanneer een website met een eigen favicon wordt bezocht (bv Computer Totaal), dan wordt het pad dat naar het pictogram voor de snelkoppeling verwijst onterecht gewijzigd in: [b:28f251a931]C:\Windows\System32\shell32.dll[/b:28f251a931]
    Het 1e pictogram uit dit shell32.dll bestand is dat lege pictogram, ook wel Default Icon genoemd. Daar zit m dus de kneep. (zie hieronder)


    [img:28f251a931]http://pic50.picturetrail.com/VOL414/10019627/18062189/304099430.jpg[/img:28f251a931]

    De enige oplossing is alle aangetaste snelkoppelingen, opnieuw voorzien van het gewenste pictogram en deze snelkoppelingen daarna het kenmerk "alleen lezen" meegeven. De verwijzing is nog steeds onjuist (!), maar het E pictogram wordt nu wel vastgehouden. Tis ff wachten op de fix dus. Als die er komt….want het probleem is bekend bij MS, maar de voorgestelde oplossing werkt bij mij niet. Zie hiervoor: http://support.microsoft.com/kb/930426/en-us

    Mannen bedankt voor de reacties, zonder jullie hulp was ik hier niet achter gekomen.

    Mvg,
    Toni

    (ps: Rosturp, wat bedoel je eigenlijk met "My Penny"?)
  • Mischien dat je hier nog wat aan hebt? http://www.aignes.com/deadlink.htm
    Programmatje heet AM-Deadlink en zorgt voor controle op weblinks en ook de Favorites.
  • Tom dank je, maar ik ben niet zo'n voorstander van het programmeren van allerlei progjes, tenzij ze werken zonder installer. Ik ken het progje wat je noemt, maar dit herstelt niet het bovengenoemde probleem. Het is gewoon een bug waar nog steeds een goede MSpatch voor moet komen.

    Mvg,
    Toni
  • Ik dacht niet dat ik me schuldig maak aan "inbreken" als ik m.b.t. deze aangelegenheid ook nog even op deze ervaring wijs…….?
    Hierbij merk ik op dat die "favico's" (bij een schoonmaakbeurt) onder IE6 wel worden verwijderd en vervangen door default ico's, maar onder IE7 dus niet.
    Merkwaardig dat niemand daar iets mee kan.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.