Vraag & Antwoord

OS Windows

WINDOWS XP --> MsConfig / Opstart programma probleempje ?

13 antwoorden
  • Hallo, Ik heb een raar probleempje dat ik nog nooit eerder heb gehad, en ik heb geen idee wat ik eraan kan doen. Als je in de programmamap in de map opstarten een programmatje plaatst, dan wordt deze automatisch gestart bij het opstarten van windows xp. Dit is ook terug te zien als je het programmatje msConfig opent en bij opstarten kijkt. Het rare nu is dat ik één programmaatje JetmailMonitor in het opstarten mapje heb gestopt, en dat er bij het opstarten van windows steeds twee keer het programmaatje wordt opgestart, en deze verschijnt dus ook twee keer met zijn icoontje rechtsonder in het scherm In het programma MsConfig bij Opstarten zie je dan ook twee keer het programma staan aangevinkt, 1x op de locatie COMMON STARTUP, en 1x op de locatie STARTUP ? Terwijl hij echt maar één keer in het mapje opstarten staat, en ook niet bij andere gebruikers in de opstarten map. Als ik één vinkje weghaal en de andere laat staan in msconfig (ongeacht welke ik weghaal en welke ik laat staan), dan wordt automatisch de andere ook verwijderd en start het programma dus helemaal niet meer op ? Ik heb nu dus kennelijk alleen nog maar de keus uit het programma dubbel op te starten, of helemaal niet, maar hij moet natuurlijk gewoon 1 keer opstarten. Wie kan mij helpen ?
  • Misschien komt het doordat het programma wat je gebruikt zelf ook al de mogelijkheid bied om automatisch op te starten met Windows. Dan is het niet nodig om deze in het mapje opstarten te plaatsen. Misschien dat dat dit conflict oplevert? Wat betreft programma's automatisch opstarten met Windows: het aanmaken van een sleutel in het register is een stuk eenvoudiger en werkt waarschijnlijk beter. Maar laten we eerst kijken of het misschien aan de programma-instellingen ligt, anders geef ik de instructies voor het register wel. Grt,
  • De "locatie" Startup is te vinden in:C:\Documents and Settings\<je naam>\Start Menu\ Programs\Startup en de "locatie" Common Startup in: C:\Documents and Settings\All Users\Start Menu\ Programs\Startup Het verschil is dat bij Startup programma's alleen mee opstarten als jij inlogt en bij Common Startup bij iedere willekeurige gebruiker. In sommige programma's kun je aangeven dat het programma moet starten als Windows start. Dat wordt dan soms bewerkstelligd door een shortcut in één van deze mappen te plaatsen. Bij jou staan er kennelijk shortcuts in beide mappen. Haal er één weg (naar behoefte die van jou of die van iedereen) en alles is weer in orde. Dit weghalen doe je dus in de verkenner en niet in msconfig.
  • Dit heb ik al geprobeerd, en er staat slechts in één van de mapjes een snelkoppeling, maar in het msconfig staat hij wel twee keer (startup & common startup) ??? Ook is er in het programmatje zelf niet de mogelijkheid om ervoor te kiezen dat het automatisch opstart. Ik heb dit ook nog nooit eerder gehad en ik snap er dan ook niets van.
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\run Zet hem daar eens in, misschien dat hij vanaf die positie wil werken. Overigens heb je ook nog "default user", staat hij daar miscchien ook in.
  • Nee, ook in default user staat hij niet. Dat met die register aanpassing werkt wel denk ik, maar ik wil eigenlijk liever weten wat er nu mis is, dus hoe dit ontstaan is en waar de fout zit.
  • waarschijnlijk weer zo´n progje dat zich graag in de voorste startrij nestelt. en dan zelf ook nog eens in de map opstarten zetten, da´s wat veel van het goede. in het menu start/alle programma´s kan je in de map opstarten weghalen wat je niet bevalt via rechtsklikken/verwijderen. in msconfig ontvink je een van beide vermeldingen, en dan heb je weer wat je wilt, lijkt me.
  • Zo simpel werkt het dus niet helaas. Als ik één van de drie (opstartmap, of 1 van de twee in msconfig) weghaal, dan worden de overige ook verwijderd (alsof ze alle drie aan elkaar gekoppeld zitten). Het lijkt dus alles of niets.
  • http://technet.microsoft.com/en-us/sysinternals/bb963902.aspx
  • Ik heb Jetmailmonitor maar even gedownload. Ook om te kijken of het beter is dan Poptray ( www.poptray.org ), wat ik zelf gebruik. (Is het niet. ik blijf Poptray gebruiken.) Ik kan het probleem niet reproduceren. Als ik een link naar Jetmailmonitor in de startup van All Users zet zie ik het in Msconfig bij Common Startup terug, zet ik de link in de Startup van <mijn naam> dan geeft Msconfig hem als Startup. Alleen als ik een link in beiden zet krijg ik twee vermeldingen in Msconfig. Ik snap het dus ook niet. Je kunt misschien nog het volgende proberen: Haal in de verkenner alle links naar JetmailMonitor weg. Controleer of ze nu ook in Msconfig verdwenen zijn. Start een Repair Install via Control Panel - Add or Remove Programs (Het installatieprogramma biedt deze mogelijkheid zelf aan) en laat, als het installatieprogramma daarom vraagt, de link door het programma aan de startupfolder toevoegen. Mogelijk is het dan in orde. Zo niet, zoek dan eens in Documents and Settings naar JetmailMonitor.lnk. Vink bij de zoekactie More Advanced options en daarbinnen System Folders, Hidden Folders en Subfolders aan. Wie weet blijken er toch meer shortcuts verstopt te zitten. Misschien zit er elders in Windows iets verkeerd. Als je een andere shortcut (bv. naar notepad) in een Startupfolder plaatst, verschijnt die dan ook twee keer in Msconfig? Zo ja, dan kunnen we vandaaruit verder zoeken. Ik zie dat er, terwijl ik dit schrijf, een verwijzing naar Autoruns is bijgekomen. Inderdaad een prima programma.
  • [quote:b31c83b840]Misschien zit er elders in Windows iets verkeerd. Als je een andere shortcut (bv. naar notepad) in een Startupfolder plaatst, verschijnt die dan ook twee keer in Msconfig? Zo ja, dan kunnen we vandaaruit verder zoeken.[/quote:b31c83b840] Dit is inderdaad het geval en tot nu toe kan ik nergens een fout of oplossing vinden. Ook in het programmatje autoruns verschijnt hij dubbel en kan ik ze ook alleen samen verwijderen. :?
  • OK, dan verder zoeken. De grootste kans lijkt me het volgende: Open het register (Start-run, type regedit, klik op OK) Doe de volgende twee dingen: Ga naar de sleutel HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders. In het rechter gedeelte zie je een Key staan met de naam Startup. Die moet als waarde hebben: C:\Documents and Settings\<je naam>\Start Menu\Programs\Startup. (Als dit tenminste het pad is naar je Startupfolder.) Ga naar de sleutel HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders. OOk hier moet in het rechtervenster een Key met de naam Startup staan. Deze is van het type REG_EXPAND_SZ en moet de waarde hebben %USERPROFILE%\Start Menu\Programs\Startup. Ik vermoed haast dat deze sleutel de waarde %ALLUSERSPROFILE%\Start Menu\Programs\Startup heeft. De waarde van (bijna) alle sleutels hier moet trouwens met %USERPROFILE% beginnen. In elk geval moet geen enkele met %ALLUSERSPROFILE% beginnen. Als een van deze sleutels niet klopt, verander de waarde dan. (dubbelklikken op de sleutel en de juiste waarde typen.) Let er bij het wijzigen van %ALLUSERSPROFILE% op dat je niet alleen ALL maar ook de S weghaalt. Herstart en kijk of het is opgelost. Als dit niet helpt zal ik kijken waar nog meer register-entries zijn die nagekeken kunnen worden, maar dat kost even tijd.
  • :D :D :D Nou, echt reuze bedankt !!! Dat was kennelijk het probleem. Ik heb de sleutels in het register aangepast (ze klopte beide niet). En nu is het probleem opgelost. Alles werkt weer zoals het hoort. Enorm bedankt voor dit supper goede advies. :P :P :P

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.