Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Windows

Iconen geheugenkaartlezer in Vista

Anoniem
None
6 antwoorden
  • k gebruik Vista home premium SP1
    Sinds enige tijd zijn de driver iconen van mijn ingebouwde geheugenkaartlezer uit het scherm "Deze computer" verdwenen.
    Als ik een geheugenkaart in 1 van de sleuven steek verschijnt er direkt weer een icoontje in dit scherm dat weer verdwijnt als ik de kaart verwijder.
    Voorheen stonden deze iconen standaard naast mijn harde schijf en cd/dvd iconen. Hoe krijg ik deze iconen weer terug??

    Mvgr.

    Gerard Jansen
  • Hallo Gerard,

    Probeer eens in het register te kijken. Ik neem aan dat de schijfletters altijd hetzelfde zijn.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\DriveIcons

    Hier maak je een nieuwe sleutel aan met de schijfletter; bijvoorbeeld T (dat is bij mij de SD-kaartlezer)
    Weer een sleutel in T aanmaken met de naam DefaultIcon. Als je ergens een icoon-bestandje van een SD kaart hebt kun je die gebruiken. In DefaultIcon staat een REG_SZ met de naam (Standaard). Als waarde vul je hier het pad in naar dat icoontje. Bijvoorbeeld D:\Documenten\Afbeeldingen\sdkaartje.ico. Explorer.exe ff herstarten en geniet van je nieuwe icoontje.

    Ik werk zelf onder XP, dus het zou kunnen dat in Vista het register iets anders in elkaar zit, maar je vindt het wel.

    Succes!
  • Hoi Koen,
    Bedankt voor je antwoord, maar het lukt me niet.
    Ik deed als volgt: In DriveIcons maak ik een sleutel J (mijn SDHC kaartlezer). In sleutel J maak ik een sleutel DefaultIcon Maar daarna ga ik denk ik de mist in, want ik moet in Standaard (van DefaultIcon) een pad maken naar "Deze computer" op mijn bureaublad. In Vista heet dit overigens alleen Computer.
    Als pad geef ik dus op Computer/SDkaartje.ico.Explorer.exe Maar na herstarten is er niets gewijzigd. Kun je me vertellen wat ik fout doe?

    Groet,

    Gerard
  • Hoi Gerard,

    Het gaat inderdaad vanaf daar fout. Volgens mij heb jij "Computer/SDkaartje.ico.Explorer.exe" ingevuld.
    Je moet in "Standaard" de locatie van het icoon-bestandje ingeven, en die staat sowiezo niet in Deze computer. Dus je moet invullen waar SDkaartje.ico zich bevindt. Dus als jij SDkaartje.ico op je bureaublad hebt staan moet je verwijzen (in XP) naar "C:\Documents and Settings\<gebruikersnaam>\Bureaublad\SDkaartje.ico" (zonder aanhalingtekens). En met Explorer.exe bedoel ik het proces explorer.exe herstarten. Dit proces bevat namelijk je bureaublad, je taakbalk en dus ook de cache van je icoontjes.

    Dus je verwijst naar "SDkaartje.ico" en je herstart explorer.exe (of gewoon je pc ff herstarten als je niet weet hoe je explorer.exe moet herstarten).

    Snap je het? Veel succes!

    Groeten,
    Koen
  • Hallo Koen,
    Het wil me niet lukken omdat er volgens mij nog iets anders aan de hand is.

    Zoals ik reeds meldde verschijnen de juiste iconen in Deze computer als ik geheugenkaarten in de CartReader doe en als ik de kaart(en) weer verwijder verdwijnen de iconen ook weer. Als ik met ingestoken kaarten (SD en CF) het register open dan zie ik ook in het register onder DriveIcons 2 mappen nl. H en J in beide zitten de submappen DefaultIcon en Defaultlabel In DefaultIcon staat in REG-SZ standaard keurig netjes het pad naar de icon ingevuld bijv: %SystemRoot%\system\DriveIcon.dll,14.
    Ik dacht handig te zijn door dit pad uit te breiden met .Explorer.exe maar als ik Regedit afsluit en opnieuw opstart zonder kaart in de CartReader zijn de iconen weer verdwenen en staan alleen de driveletters H en J nog onder DriveIcons vermeld. De submappen zijn uit het register verdwenen.
    In de tweede submap DefaultLabel staat alleen de naam van de icon vermeld maar ook die is dus verdwenen.

    nogmaals hartelijk voor de moeite die je hebt gedaan maar ik stop

    Groet,

    Gerard
  • Hm, dat is vreemd. Dat betekent dat er iets is wat het register verandert wanneer je een CF of SD kaartje inplugt. Misschien zit er een autorun op die kaartjes die het een en ander verandert wat icoontjes betreft?

    Wat ik niet helemaal begrijp is waarom je dat pad uitbreidt met ".Explorer.exe", want je pc zal bij een pad dat er uitziet als "D:\Documenten\Sd.ico.Explorer.exe" denken dat hij moet gaan zoeken naar het bestand "SD.ico.Explorer.exe" in de map "Documenten" op schijf "D". Of heb jij een andere gedachte daarbij?

    Check die autoruns eens, misschien zit daar iets tussen wat het kan zijn. Anders rest er voor zo ver mijn kennis reikt nog één oplossing: ff windows opnieuw installeren, heb je weer een schone en snelle installatie en ben je van alle mankementjes van je huidige Vista af ;-)

    Succes!

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.