Vraag & Antwoord

OS Windows

Dropdown menu in Excel

4 antwoorden
  • Hallo Allemaal. Ik heb de volgende vraag: Ik heb een factuur in Excel gemaakt. De hele worksheet bestaat uit 3 werkbladen. Blad 1 is de factuu, in blad 2 worden verschillende berekeningen gedaan en in blad 3 heb ik een soort klanten database. Nu wil ik op Blad 1 een dropdown menu maken welken de gegevens bevatten van de klantnamen van Blad 3. Wanneer er een Naam in de dropdown menu geselecteerd wordt, moeten direct de bijbehorende NAW gegevens (uit Blad 3) ingevuld worden op Blad 1, in de een bepaalde cel (D18=Naam. D19=Adres. D20=Postcode/Plaats). Weet iemand of dit mogelijk is? Zo ja, hoe moet ik dit doen? Alvast hartelijk dank. Groetjes Eric.
  • Kun je niet beter met Access gaan werken?
  • [quote:51ad55d796="InZane"]Kun je niet beter met Access gaan werken?[/quote:51ad55d796] Je bedoelt Excel samen met Access. Ik zou niet weten hoe ik dan vanuit excel die klantendatabase zou moeten benaderen. Ik weet dat het ook binnen Excel moet kunnen. Ik heb nu al zoiets als hieronder staat, maar dat is niet omdat dit met nummers in een tekstbox werkt. Is dus niet handig om een bepaalde klant op deze manier te selecteren. ============================================= Private Sub volgende_Click() TextBox.Text = TextBox.Text + 1 End Sub Private Sub invoegen_Click() X = 1 X = X + Val(TextBox.Text) ' Naam Range("D18").Select ActiveCell = "=(KlantenDB!A" & X & ")" 'Adres Range("D19").Select ActiveCell = "=(KlantenDB!B" & X & ")" 'Postcode en Plaats Range("D20").Select ActiveCell = "=(KlantenDB!C" & X & ")" End Sub Private Sub TextBox_Change() End Sub Private Sub vorige_Click() TextBox.Text = TextBox.Text - 1 End Sub =============================================== Ik dit dus met een dropdown menu. De klantgegevens mogen uit een access database komen hoor, als ik maar weet hoe?? Groetjes, Eric
  • Dropdown menu: Data > Valideren Aanvullen bijbehorende gegevens: =VERT.ZOEKEN(zoekwaarde;tabelmatrix;kolomindex_getal)

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.