Vraag & Antwoord

OS Linux

Windows XP toevoegen aan lilo

4 antwoorden
  • Beste Mensen, Ik heb een probleem met mijn lilo configuratie op mijn mandake systeem. Ik wil mijn Windows XP toevoegen aan lilo, nou heb ik wat internet sites gevonden hoe dat moet, en dat heb ik ook geprobeert, maar het lijkt allemaal niet te werken. Dit is mijn lilo.conf [code:1:31d80c55e7] boot=/dev/hdc map=/boot/map default="linux" keytable=/boot/us.klt prompt nowarn timeout=100 message=/boot/message menu-scheme=wb:bw:wb:bw disk=/dev/hdc bios=0x80 image="/boot/vmlinuz" label="linux" root="/dev/hdc5" initrd="/boot/initrd.img" append="devfs=mount hdb=ide-scsi acpi=off quiet" vga=788 read-only image=/boot/vmlinuz label="linux-nonfb" root=/dev/hdc5 initrd=/boot/initrd.img append="devfs=mount hdb=ide-scsi acpi=off" read-only image=/boot/vmlinuz label="failsafe" root=/dev/hdc5 initrd=/boot/initrd.img append="devfs=nomount hdb=ide-scsi acpi=off failsafe" read-only other=/dev/fd0 label="floppy" unsafe other=/dev/hdd1 label="Windows_XP" [/code:1:31d80c55e7] Dit is mijn hd configuratie [code:1:31d80c55e7] Disk /dev/ide/host0/bus1/target0/lun0/disc: 20.4 GB, 20496236544 bytes 16 heads, 63 sectors/track, 39714 cylinders Units = cylinders of 1008 * 512 = 516096 bytes Device Boot Start End Blocks Id System /dev/ide/host0/bus1/target0/lun0/part1 * 1 2407 1213096+ 82 Linux swap /dev/ide/host0/bus1/target0/lun0/part2 2408 39714 18802728 5 Extended /dev/ide/host0/bus1/target0/lun0/part5 2408 14597 6143728+ 83 Linux /dev/ide/host0/bus1/target0/lun0/part6 14598 39714 12658936+ 83 Linux Disk /dev/ide/host0/bus1/target1/lun0/disc: 60.0 GB, 60040544256 bytes 255 heads, 63 sectors/track, 7299 cylinders Units = cylinders of 16065 * 512 = 8225280 bytes Device Boot Start End Blocks Id System /dev/ide/host0/bus1/target1/lun0/part1 * 1 7299 58629186 7 HPFS/NTFS [/code:1:31d80c55e7] Als ik nu lilo krijg werkt linux gewoon, alleen als ik windows xp kies, krijg ik een zwart scherm met bovenaan windows xp daaronder een knipperend streepje. Maar hij gaat niet verder. Als ik in KDE configuration LILO aanpas en dan op check configuration druk, krijg ik de volgende melding; [code:1:31d80c55e7] Configuration ok. LILO said: LILO version 22.4.1 (test mode), Copyright (C) 1992-1998 Werner Almesberger Development beyond version 21 Copyright (C) 1999-2002 John Coffman Released 27-Jan-2003 and compiled at 11:11:26 on Feb 5 2003. Reading boot sector from /dev/hdc Using GRAPHIC secondary loader Calling map_insert_data Mapping message file /boot/message -> message-graphic Calling map_insert_file Boot image: /boot/vmlinuz -> vmlinuz-2.4.21-0.13mdk Mapping RAM disk /boot/initrd.img -> initrd-2.4.21-0.13mdk.img Added linux * Boot image: /boot/vmlinuz -> vmlinuz-2.4.21-0.13mdk Mapping RAM disk /boot/initrd.img -> initrd-2.4.21-0.13mdk.img Added linux-nonfb Boot image: /boot/vmlinuz -> vmlinuz-2.4.21-0.13mdk Mapping RAM disk /boot/initrd.img -> initrd-2.4.21-0.13mdk.img Added failsafe Boot other: /dev/fd0, loader CHAIN Pseudo partition start: 0 Added floppy Boot other: /dev/hdd1, on /dev/hdd, loader CHAIN Added Windows_XP The boot sector and the map file have *NOT* been altered. [/code:1:31d80c55e7] Ik heb geen idee meer hoe ik het nu op moet lossen, heeft iemand misschien een idee, Alvast bedankt, c0mKi
  • [quote:59416f2366="c0mKi"] Als ik nu lilo krijg werkt linux gewoon, alleen als ik windows xp kies, krijg ik een zwart scherm met bovenaan windows xp daaronder een knipperend streepje. Maar hij gaat niet verder.[/quote:59416f2366] Is dit het vervolg van [url=http://forum.computertotaal.nl/phpBB2/viewtopic.php?t=99843]dit topic.[/url] Zo ja, heb je de boot.ini van WinXP wel aangepast? Je [b:59416f2366] /etc/lilo.conf [/b:59416f2366] lijkt me namelijk in orde.
  • wat moet er aangepast worden aan die boot.ini dan? want het windows xp wat er komt te staan is het label van lilo.
  • [quote:0f2051a9cb="c0mKi"] wat moet er aangepast worden aan die boot.ini dan?[/quote:0f2051a9cb] Ik weet het niet zeker, want dit is meer een vraag voor OS Windows Maar als dit je boot.ini is [code:1:0f2051a9cb] [boot loader] timeout=30 default=multi(0)disk(0)rdisk(3)partition(1)\WINDOWS [operating systems] multi(0)disk(0)rdisk(3)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect [/code:1:0f2051a9cb] Dan wordt het dit [code:1:0f2051a9cb] [boot loader] timeout=30 default=multi(0)disk(0)rdisk(4)partition(1)\WINDOWS [operating systems] multi(0)disk(0)rdisk(4)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect [/code:1:0f2051a9cb]

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.