Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Debian unstable en KDE3

robian
7 antwoorden
  • Onlangs heb ik geupgrade naar debian unstable, dit ging allemaal goed, ook met een nieuwe Gnome versie en KDE. KDE werkt nu nog niet, als ik het start bij het inloggen in X wordt in m'n .xsession-errors file iets gezegd over WM=KDE2 en wordt het bestand .kde2-errors in m'n home dir gezet.
    Schijnbaar is de kde 2 versie niet goed vervangen door drie. Want apt-cache showpkg kdebase geeft wel een versie 3 weer.

    Wat is hier de oplossing? Ik zou ook niet weten hoe ik alles van kde helemaal verwijder en dan het opnieuw doe…
  • Heb je hetzelfde probleem als je KDE probeert te starten met een nieuwe test-user? Hiermee kun je vaststellen of het een systemwide probleem is, of dat er sprake is van een configuratie-probleem in jouw gebruikersprofiel.
  • Met een nieuwe user (net getest) heb ik hetzelfde probleem. Dus zou ik eigenlijk een her installatie ofzo moeten doen, maar dit gaat lastig via apt-get install kdebase bv. omdat je dan zelf veel dependencies moet oplossen.
  • Je hebt niet het goede commando gebruikt om te kijken welke versie is geinstalleerd.

    apt-cache policy package_naam kun je gebruiken om te kijken welke versie is geinstalleerd.

    of dpkg -l

    of het programma apt-show-versions (deze util moet je wel eerst installeren).
  • Ok, apt-cache showpkg kde geeft ook kde 3 aan, ik ben er nog niet achter
    hoe ik het nu oplos. apt-get -f install lost ook geen dependency problemen op, iemand een idee hoe gewoon de installatie opnieuw uit te voeren?
  • Ik kan niet gokken welke packages geinstalleerd zijn. Ik begrijp ook niet goed wat je bedoelt met het oplossen van dependencies.

    Als de default-release stable is en je probeert een unstable package te installeren, loop je de kans dat de dependencies niet in stable aanwezig zijn. Je kunt dit oplossen door de default-release aan te passen (/etc/apt/apt.conf) of door de -t switch voor apt-get te gebruiken.
  • Ik heb geupgrade van stable naar unstable en daarbij werd automatisch kde 3.1 geinstalleerd. Dus het hoort bij de unstable versie. Dus opzich zouden er geen stable/unstable conflicten moeten zijn.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.