Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

[Slackware 9.1] kernel upgrade Test 2.6.0-test6 & test11

jolo
6 antwoorden
  • Omdat mijn externe via firewire aangesloten harddisk, niet goed werkte met de Slackware 9.1 voor gecompileerde 2.4.22 kernel
    [code:1:76ce88c0b9]
    scsi0 : SCSI host adapter emulation for IDE ATAPI devices
    Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
    sr0: scsi3-mmc drive: 24x/24x writer cd
    w xa/form2 cdda tray
    scsi1 : SCSI emulation for IEEE-1394 SBP-2 Devices
    scsi2 : SCSI emulation for USB Mass Storage devices
    Attached scsi removable disk sda at scsi2, channel 0, id 0, lun 0
    [/code:1:76ce88c0b9] maar wel werkte in Slackware 9.0 met kernel 2.4.20
    [code:1:76ce88c0b9]
    scsi0 : SCSI host adapter emulation for IDE ATAPI devices
    Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
    sr0: scsi3-mmc drive: 24x/24x writer cd
    w xa/form2 cdda tray
    scsi1 : IEEE-1394 SBP-2 protocol driver (host: ohci1394)
    Attached scsi disk sda at scsi1, channel 0, id 0, lun 0
    scsi2 : SCSI emulation for USB Mass Storage devices
    Attached scsi removable disk sdb at scsi2, channel 0, id 0, lun 0
    [/code:1:76ce88c0b9] deze test met kernel 2.6.0-test6
    [code:1:76ce88c0b9]
    uname -a
    Linux linux 2.6.0-test6 #1 Sun Sep 28 22:01:56 CEST 2003 i686 unknown unknown GNU/Linux [/code:1:76ce88c0b9]
    [code:1:76ce88c0b9]
    ohci1394: $Rev: 1045 $ Ben Collins <bcollins@debian.org>
    ohci1394_0: OHCI-1394 1.1 (PCI): IRQ=[5] MMIO=[dd000000-dd0007ff] Max Packet=[2048]
    ieee1394: Node added: ID:BUS[0-00:1023] GUID[0090a950000b4397]
    ieee1394: Host added: ID:BUS[0-01:1023] GUID[00023c0021020f9e]
    sbp2: $Rev: 1034 $ Ben Collins <bcollins@debian.org>
    scsi1 : SCSI emulation for IEEE-1394 SBP-2 Devices
    ieee1394: sbp2: Logged into SBP-2 device
    ieee1394: sbp2: Node 0-00:1023: Max speed [S400] - Max payload [2048]
    Vendor: WDC Model: FireWire/USB2.0 Rev: 4.17
    Type: Direct-Access ANSI SCSI revision: 06
    SCSI device sdb: 234441648 512-byte hdwr sectors (120034 MB)
    sdb: asking for cache data failed
    sdb: assuming drive cache: write through
    sdb: sdb1 sdb2 < sdb5 sdb6 >
    Attached scsi disk sdb at scsi1, channel 0, id 0, lun 0
    [/code:1:76ce88c0b9]
    Met de kernel 2.6.0-test6 werkt deze externe via firewire aangesloten harddisk dus wel.

    Uiteraard test ik nog meer hardware met deze 2.6.0-test6 kernel, maar daar ga ik morgen mee verder.
  • Dan hier het vervolg van de kernel 2.6.0-test6

    De volgende modules laad ik via /etc
    c.d
    c.modules
    [code:1:9edbe6f3d7]
    /sbin/modprobe ne2k-pci
    /sbin/modprobe ide-scsi
    /sbin/modprobe sg
    /sbin/modprobe ohci1394
    /sbin/modprobe snd-emu10k1
    /sbin/modprobe snd-mixer-oss
    /sbin/modprobe usblp
    /sbin/modprobe scanner
    [/code:1:9edbe6f3d7]
    Dit is mijn /sbin/lsmod output
    [code:1:9edbe6f3d7]
    Module Size Used by
    snd_pcm_oss 49156 0
    uhci_hcd 30696 0
    scanner 21376 0
    usblp 12128 0
    snd_mixer_oss 17664 3 snd_pcm_oss
    snd_emu10k1 92132 2
    snd_rawmidi 20608 1 snd_emu10k1
    snd_pcm 89664 2 snd_pcm_oss,snd_emu10k1
    snd_timer 22720 1 snd_pcm
    snd_seq_device 7140 2 snd_emu10k1,snd_rawmidi
    snd_ac97_codec 52740 1 snd_emu10k1
    snd_page_alloc 9572 2 snd_emu10k1,snd_pcm
    snd_util_mem 3648 1 snd_emu10k1
    snd_hwdep 7808 1 snd_emu10k1
    snd 45892 10 snd_pcm_oss,snd_mixer_oss,snd_emu10k1,snd_rawmidi,snd_pcm,snd_timer,snd_seq_device,snd_ac97_codec,snd_util_mem,snd_hwdep
    soundcore 7008 3 snd
    ohci1394 32416 0
    ieee1394 71628 1 ohci1394
    sg 30348 0
    ide_scsi 12544 0
    ne2k_pci 7904 0
    [/code:1:9edbe6f3d7]
    Ik heb mijn usb printer/scanner psc750 geinstalleerd via kde configuratie centrum. De test pagina werd goed afgedrukt. Om te kunnen scannen heb ik ook nog de hpoj 0.9 software geinstalleerd. Terwijl de hpoj 0.9 software de smp kernel 2.4.x liet crashen, werkt deze wel met de smp kernel 2.6.0-test6.
    [code:1:9edbe6f3d7]
    CPU0 CPU1
    0: 214868 89 IO-APIC-edge timer
    1: 187 0 IO-APIC-edge i8042
    2: 0 0 XT-PIC cascade
    9: 0 0 IO-APIC-level acpi
    12: 61 0 IO-APIC-edge i8042
    14: 7653 0 IO-APIC-edge ide0
    15: 6 0 IO-APIC-edge ide1
    17: 0 0 IO-APIC-level EMU10K1
    18: 13 1 IO-APIC-level ohci1394, eth0
    21: 1 1 IO-APIC-level uhci-hcd, uhci-hcd
    NMI: 0 0
    LOC: 214905 232097
    ERR: 0
    MIS: 0
    [/code:1:9edbe6f3d7] apic werkt dus ook. Of acpi werkt ben ik wat minder zeker over. De ene keer schakelt in tekst mode, via [b:9edbe6f3d7] halt -p [/b:9edbe6f3d7] de pc wel goed uit. De andere keer schakelt de pc niet goed uit via [b:9edbe6f3d7] halt -p [/b:9edbe6f3d7]
    [code:1:9edbe6f3d7]
    <knip>
    Turning off swap
    Unmounting local file systems
    Remounting root filesystem read-only
    Powerdown
    acpi_power_off called
    hwsleep_OL57 [13] acpi_enter_sleep_date: Entering sleep state [S5]
    [/code:1:9edbe6f3d7] De ventilatoren blijven dan gewoon draaien.
    Dit is mijn dmesg | grep ACPI output
    [code:1:9edbe6f3d7]
    BIOS-e820: 000000001fffc000 - 000000001ffff000 (ACPI data)
    BIOS-e820: 000000001ffff000 - 0000000020000000 (ACPI NVS)
    ACPI: RSDP (v000 ASUS ) @ 0x000f6910
    ACPI: RSDT (v001 ASUS CUV4X-D 0x30303031 MSFT 0x31313031) @ 0x1fffc000
    ACPI: FADT (v001 ASUS CUV4X-D 0x30303031 MSFT 0x31313031) @ 0x1fffc100
    ACPI: BOOT (v001 ASUS CUV4X-D 0x30303031 MSFT 0x31313031) @ 0x1fffc040
    ACPI: MADT (v001 ASUS CUV4X-D 0x30303031 MSFT 0x31313031) @ 0x1fffc080
    ACPI: DSDT (v001 ASUS CUV4X-D 0x00001000 MSFT 0x0100000b) @ 0x00000000
    ACPI: Local APIC address 0xfee00000
    ACPI: LAPIC (acpi_id[0x00] lapic_id[0x03] enabled)
    ACPI: LAPIC (acpi_id[0x01] lapic_id[0x00] enabled)
    ACPI: IOAPIC (id[0x02] address[0xfec00000] global_irq_base[0x0])
    ACPI: INT_SRC_OVR (bus[0] irq[0x0] global_irq[0x2] polarity[0x0] trigger[0x1])
    ACPI: INT_SRC_OVR (bus[0] irq[0x9] global_irq[0x9] polarity[0x3] trigger[0x3])
    Using ACPI (MADT) for SMP configuration information
    ACPI: Subsystem revision 20030813
    tbxface-0117 [03] acpi_load_tables : ACPI Tables successfully acquired
    ACPI Namespace successfully loaded at root c04ff3dc
    evxfevnt-0093 [04] acpi_enable : Transition to ACPI mode successful
    ACPI: Interpreter enabled
    ACPI: Using IOAPIC for interrupt routing
    ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 9 10 *11 12 14 15)
    ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 9 *10 11 12 14 15)
    ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 *5 6 7 9 10 11 12 14 15)
    ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 *9 10 11 12 14 15)
    ACPI: PCI Root Bridge [PCI0] (00:00)
    ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
    ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.PCI1._PRT]
    ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 9
    ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 11
    ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 10
    ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 5
    PCI: Using ACPI for IRQ routing
    ACPI: Power Button (FF) [PWRF]
    ACPI: Processor [CPU] (supports C1)
    ACPI: Processor [CPU1] (supports C1)
    ACPI: (supports S0 S1 S4 S5)
    [/code:1:9edbe6f3d7]
    Het geluid van mijn Audigy1 via ALSA in de kernel 2.6.0-test6 werkt ook. Maar dan alleen de voor speakers. De mixers hebben geen OGain. En daarmee ook geen geluid uit de achter speakers.
    [code:1:9edbe6f3d7]

    rexima

    min . . . . : . . . . max
    -> Vol <- [|————————————————–] 0% [ ]
    Bass [=========================|————————-] 50%
    Trebl [=========================|————————-] 50%
    Pcm [|————————————————–] 0%
    Spkr [|————————————————–] 0%
    Line [|————————————————–] 0% [ ]
    Mic [|————————————————–] 0% [R]
    CD [|————————————————–] 0% [ ]
    IGain [|————————————————–] 0%
    Line1 [|————————————————–] 0% [ ]
    PhoneIn [|————————————————–] 0% [ ]
    Video [|————————————————–] 0% [ ]
    [/code:1:9edbe6f3d7]

    De nvidia drivers heb ik nog niet kunnen testen. Er is een patch te doenloaden voor 2.6.0-test5, maar nog niet voor kernel 2.6.0-test6. De tvkaart heb ik ook nog niet getest.
  • De tvkaart icm kernel 2.6.0-test6 heb ik inmiddels getest.
    Na [code:1:b1995d5b4d]
    root@linux:/usr/src/linux-2.6.0-test6/Documentation/video4linux/bttv# sh MAKEDEV
    *** new device names ***
    /dev/video0: char 81 0
    /dev/video1: char 81 1
    /dev/video2: char 81 2
    /dev/video3: char 81 3
    /dev
    adio0: char 81 64
    /dev
    adio1: char 81 65
    /dev
    adio2: char 81 66
    /dev
    adio3: char 81 67
    /dev/vtx0: char 81 192
    /dev/vtx1: char 81 193
    /dev/vtx2: char 81 194
    /dev/vtx3: char 81 195
    /dev/vbi0: char 81 224
    /dev/vbi1: char 81 225
    /dev/vbi2: char 81 226
    /dev/vbi3: char 81 227
    root@linux:/usr/src/linux-2.6.0-test6/Documentation/video4linux/bttv#
    [/code:1:b1995d5b4d]
    en het toevoegen in /etc
    c.d
    c.modules
    [code:1:b1995d5b4d]
    modprobe videodev
    modprobe bttv
    [/code:1:b1995d5b4d] bleek deze te werken. Hetzelfde geldt ook voor de in xawtv bijgeleverde programma, console radio.

    De nvidia driver heb ik ook getest met zowel kernel 2.6 test5 en - test6, maar deze test is nog niet gelukt. Ik gebruikte daarvoor de patch van http://www.minion.de/ volgens de instrukties op http://www.minion.de/files/NVIDIA_kernel-1.0-4496.README
    Dit is de patch output met kernel 2.6 test6
    [code:1:b1995d5b4d]
    root@linux:/usr/src/NVIDIA-Linux-x86-1.0-4496-pkg2/usr/src/nv# patch -p1 < NVIDIA_kernel-1.0-4496-2.6.diff
    patching file Makefile
    patching file Makefile.kbuild
    patching file Makefile.nvidia
    patching file conftest.sh
    patching file makedevices.sh
    patching file nv-linux.h
    patching file nv.c
    patching file os-agp.c
    patching file os-interface.c
    patching file os-registry.c
    root@linux:/usr/src/NVIDIA-Linux-x86-1.0-4496-pkg2/usr/src/nv# [/code:1:b1995d5b4d]
    ln -s Makefile.kbuild Makefile
    [code:1:b1995d5b4d]
    root@linux:/usr/src/NVIDIA-Linux-x86-1.0-4496-pkg2/usr/src/nv# make install
    make[1]: Entering directory `/usr/src/linux-2.6.0-test6'
    *** Warning: Overriding SUBDIRS on the command line can cause
    *** inconsistencies
    make[2]: `arch/i386/kernel/asm-offsets.s' is up to date.
    echo \#define NV_COMPILER \"`gcc -v 2>&1 | tail -n 1`\" > /usr/src/NVIDIA-Linux-x86-1.0-4496-pkg2/usr/src/nv/nv_compiler.h
    CC [M] /usr/src/NVIDIA-Linux-x86-1.0-4496-pkg2/usr/src/nv/nv.o
    CC [M] /usr/src/NVIDIA-Linux-x86-1.0-4496-pkg2/usr/src/nv/os-agp.o
    CC [M] /usr/src/NVIDIA-Linux-x86-1.0-4496-pkg2/usr/src/nv/os-interface.o
    CC [M] /usr/src/NVIDIA-Linux-x86-1.0-4496-pkg2/usr/src/nv/os-registry.o
    LD [M] /usr/src/NVIDIA-Linux-x86-1.0-4496-pkg2/usr/src/nv/nvidia.o
    Building modules, stage 2.
    MODPOST
    CC /usr/src/NVIDIA-Linux-x86-1.0-4496-pkg2/usr/src/nv/nvidia.mod.o
    LD [M] /usr/src/NVIDIA-Linux-x86-1.0-4496-pkg2/usr/src/nv/nvidia.ko
    make[1]: Leaving directory `/usr/src/linux-2.6.0-test6'
    nvidia.ko installed successfully.
    [/code:1:b1995d5b4d] Na de reboot is in de lsmod output
    [code:1:b1995d5b4d]
    nvidia 1702796 0
    [/code:1:b1995d5b4d]
    In dmesg over de nvidia driver
    [code:1:b1995d5b4d]
    nvidia: module license 'NVIDIA' taints kernel.
    1: nvidia: loading NVIDIA Linux x86 nvidia.o Kernel Module 1.0-4496 Wed Jul 16 19:03:09 PDT 2003
    [/code:1:b1995d5b4d] Maar als ik in /etc/X11/XF86Config de driver vesa verander in nvidia, dan crashed X. In /log/var/XFree86.0.log
    [code:1:b1995d5b4d]
    <knip>
    (II) Loading extension GLX
    (II) LoadModule: "nvidia"
    (WW) Warning, couldn't open module nvidia
    (II) UnloadModule: "nvidia"
    (EE) Failed to load module "nvidia" (module does not exist, 0)
    (II) LoadModule: "mouse"
    (II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
    (II) Module mouse: vendor="The XFree86 Project"
    compiled for 4.3.0, module version = 1.0.0
    Module class: XFree86 XInput Driver
    ABI class: XFree86 XInput driver, version 0.4
    (EE) No drivers available.

    Fatal server error:
    no screens found

    When reporting a problem related to a server crash, please send
    the full server output, not just the last messages.
    This can be found in the log file "/var/log/XFree86.0.log".
    Please report problems to xfree86@xfree86.org.
    [/code:1:b1995d5b4d] :roll:
  • Ik kreeg een tip, ook nog in de hoofd map van de nvidia driver, [b:91f841fea3] /usr/src/NVIDIA-Linux-x86-1.0-4496-pkg2/ [/b:91f841fea3] nogmaals te typen [b:91f841fea3] make install [/b:91f841fea3]
    [code:1:91f841fea3]
    <knip>
    rm -f /usr/lib/tls/libGLcore.*
    rm -f /usr/lib/tls/libGLwrapper.*
    rm -f /usr/X11R6/lib/libGL.*
    rm -f /usr/X11R6/lib/libGLcore.*
    rm -f /usr/X11R6/lib/libGLwrapper.*
    rm -f /usr/X11R6/lib/modules/extensions/libGLcore.*
    rm -f /usr/X11R6/lib/modules/extensions/libglx.*
    Installing new drivers
    install usr/lib/libGL.so.1.0.4496 /usr/lib
    install usr/lib/libGLcore.so.1.0.4496 /usr/lib
    install usr/X11R6/lib/modules/drivers/nvidia_drv.o
    /usr/X11R6/lib/modules/drivers
    install usr/X11R6/lib/modules/extensions/libglx.so.1.0.4496
    /usr/X11R6/lib/modules/extensions
    install usr/X11R6/lib/libXvMCNVIDIA.a /usr/X11R6/lib/libXvMCNVIDIA.a
    install usr/X11R6/lib/libXvMCNVIDIA.so.1.0.4496
    /usr/X11R6/lib/libXvMCNVIDIA.so.1.0.4496
    cd /usr/lib/; ln -fs libGL.so.1.0.4496 libGL.so
    cd /usr/X11R6/lib/modules/extensions; ln -fs libglx.so.1.0.4496
    libglx.so
    Installing documentation in /usr/share/doc/NVIDIA_GLX-1.0
    mkdir -p /usr/share/doc/NVIDIA_GLX-1.0/include
    cp -r usr/include/* /usr/share/doc/NVIDIA_GLX-1.0/include
    cp -r usr/share/doc/* /usr/share/doc/NVIDIA_GLX-1.0
    /sbin/ldconfig
    root@linux:/usr/src/NVIDIA-Linux-x86-1.0-4496-pkg2#
    [/code:1:91f841fea3]
    Daarna bleek X wel op te starten. Het nvidia logo flitse voorbij. Het installeren van de nvidia driver met behulp van de patch, met kernel 2.6.0-test6 is dan toch nog gelukt. :)
    Wel ontstond er nog even een ander probleempje. Xawtv die wel startte met de vesa driver, wilde niet meer starten met de nvidia driver.
    [code:1:91f841fea3]
    jolo@linux:/var/log$ xawtv
    This is xawtv-3.88, running on Linux/i686 (2.6.0-test6)
    Warning: Cannot convert string "-*-ledfixed-medium-r-*–39-*-*-*-c-*-*-*" to type FontStruct
    Segmentation fault
    jolo@linux:/var/log$
    [/code:1:91f841fea3]
    Ik vond echter een oplossing. http://www.linuxquestions.org/questions/showthread.php?threadid=77751

    the -noxv-video option.
    [code:1:91f841fea3]
    xawtv -noxv-video
    [/code:1:91f841fea3] xawtv werkte weer.

    Ik heb ook nog een andere PC met een Radeon 9000. Daar ga ik ook nog op testen met de driver van de ati website, met kernel 2.6.0-test6 in Slackware 9.1. Echter niet meer vandaag, maar voor later in deze week. :roll:
  • [quote:f75d37dc77="jolo"]Ik heb ook nog een andere PC met een Radeon 9000. Daar ga ik ook nog op testen met de driver van de ati website, met kernel 2.6.0-test6 in Slackware 9.1. Echter niet meer vandaag, maar voor later in deze week. [/quote:f75d37dc77] Het heeft wat langer geduurd voor ik hier aan toe kwam. Inmiddels ben ik al bij Test 2.6.0-test11.

    Ik heb gedownloads van de ati website fglrx-glc22-4.3.0-3.2.8.i586.rpm Ik heb deze geconverteerd naar een tgz bestand
    [code:1:f75d37dc77]
    rpm2tgz fglrx-glc22-4.3.0-3.2.8.i586.rpm fglrx-glc22-4.3.0-3.2.8.i586.tgz
    [/code:1:f75d37dc77] [Enter]
    Dan
    [code:1:f75d37dc77]
    tar -xzvf fglrx-glc22-4.3.0-3.2.8.i586.tgz
    [/code:1:f75d37dc77] [Enter]
    Ik heb de uitgepakte mappen naar de juiste locaties gekopieerd. Dus in /lib/modules/ de map fglrx een sub map daarvan is build_mod

    Omdat er in kernel 2.6.0-test11 na de gebruikelijke
    [code:1:f75d37dc77]
    ./make
    [/code:1:f75d37dc77] [Enter]
    en vanuit fglrx
    [code:1:f75d37dc77]
    ./make_install.sh
    [/code:1:f75d37dc77] [Enter]
    een VMALLOC_VMADDR foutmelding ontstond heb de twee volgende patches gedownload
    Deze
    [code:1:f75d37dc77]
    diff -ruN build_mod.orig/firegl_public.c build_mod/firegl_public.c
    — build_mod.orig/firegl_public.c 2003-09-05 00:45:33.539384168 +0200
    +++ build_mod/firegl_public.c 2003-09-05 00:47:13.193234480 +0200
    @@ -129,7 +129,9 @@
    #define pte_offset pte_offset_map
    #endif
    #endif
    -
    +#ifndef VMALLOC_VMADDR
    +#define VMALLOC_VMADDR(x) ((unsigned long)(x))
    +#endif
    // ============================================================
    #ifndef TRUE
    #define TRUE 1Naamloos 1
    [/code:1:f75d37dc77]
    en deze
    [code:1:f75d37dc77]
    — firegl_public.c.orig 2003-09-22 04:43:30.000000000 +0200
    +++ firegl_public.c 2003-10-09 00:14:41.337778176 +0200
    @@ -3106,7 +3108,7 @@

    int __ke_amd_adv_spec_cache_feature(void)
    {
    -#if ( (PAGE_ATTR_FIX == 1) || (LINUX_VERSION_CODE == KERNEL_VERSION(2,4,19)) )
    +#if ( (PAGE_ATTR_FIX == 1) || (LINUX_VERSION_CODE >= KERNEL_VERSION(2,4,19)) )
    /* the kernel already does provide a fix for the AMD Athlon
    big page attribute / cache flush data consistency system bug on its own.
    (AMD claimed that CPU cache behaviour for such pages is not specified.)
    [/code:1:f75d37dc77]
    Dat ging ongeveer zo
    [code:1:f75d37dc77]
    patch -p1 fglrx_patch
    [/code:1:f75d37dc77]
    en
    [code:1:f75d37dc77]
    patch -p1 amd_patch
    [/code:1:f75d37dc77]
    Daarna weer in de sub map build_mod ./make en in de sub map fglrx ./make_install.sh

    Nadat ik eerst nog een foutmelding zoals: Operation not permitted kreeg, lukte me het na wat her compileren de kernel, de fglrx module te laden
    [code:1:f75d37dc77]
    fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
    [fglrx] Maximum main memory to use for locked dma buffers: 430 MBytes.
    [fglrx] module loaded - fglrx 3.2.8 [Sep 21 2003] on minor 0
    [/code:1:f75d37dc77]
    Vervolgens /etc/X11/XF86Config aangepast. Ofwel driver vesa gewijzigd in fglrx
    Maar X crashde
    [code:1:f75d37dc77]
    (II) LoadModule: "fglrx"
    (WW) Warning, couldn't open module fglrx
    (II) UnloadModule: "fglrx"
    (EE) Failed to load module "fglrx" (module does not exist, 0)
    (II) LoadModule: "mouse"
    (II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
    (II) Module mouse: vendor="The XFree86 Project"
    compiled for 4.3.0, module version = 1.0.0
    Module class: XFree86 XInput Driver
    ABI class: XFree86 XInput driver, version 0.4
    (EE) No drivers available.

    Fatal server error:
    no screens found

    When reporting a problem related to a server crash, please send
    the full server output, not just the last messages.
    This can be found in the log file "/var/log/XFree86.0.log".
    Please report problems to xfree86@xfree86.org.
    [/code:1:f75d37dc77]
  • [quote:0d29008d2d="jolo"]Ik heb de uitgepakte mappen naar de juiste locaties gekopieerd.[/quote:0d29008d2d] Ik heb bij dat handmatige kopiëren toch nog wat vergeten. Onder andere /usr/X11R6/lib/modules/drivers/fglrx_drv.o en usr/X11R6/lib/modules/linux/libfglrxdrm. Deze staan nu in de juiste sub mappen.

    Toen ik daarna X probeerde te starten met startx
    [code:1:0d29008d2d]
    startkde: Could not start kdeinit. Check your installation.
    Warning connect failed: No such file or directory
    ksmserver: error while loading shared libraries: LibGL.so1: cannot open shared object file: No such file or directory
    [/code:1:0d29008d2d]

    Maar na het systeem te hebben gereboot startte X wel op. Alleen volgens /var/log/XFree86.0.log werkt 3D nog niet.
    [code:1:0d29008d2d]
    (EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENODEV"
    (EE) fglrx(0): cannot init AGP
    (II) fglrx(0): [drm] removed 1 reserved context for kernel
    (II) fglrx(0): [drm] unmapping 8192 bytes of SAREA 0xe081b000 at 0x40228000
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed! *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO) *
    (WW) fglrx(0): * no 3D acceleration available *
    (WW) fglrx(0): ********************************************* *
    (II) fglrx(0): FBADPhys: 0xe0000000 FBMappedSize: 0x08000000
    (==) fglrx(0): Write-combining range (0xe0000000,0x8000000)
    (II) fglrx(0): FBMM initialized for area (0,0)-(1024,8191)
    (II) fglrx(0): FBMM auto alloc for area (0,0)-(1024,768) (front color buffer - $
    (==) fglrx(0): Backing store disabled
    (==) fglrx(0): Silken mouse enabled
    (II) fglrx(0): Using hardware cursor (scanline 768)
    (II) fglrx(0): Largest offscreen area available: 1024 x 7419
    (**) Option "dpms"
    (**) fglrx(0): DPMS enabled
    (II) fglrx(0): Using XFree86 Acceleration Architecture (XAA)
    Screen to screen bit blits
    Solid filled rectangles
    Solid Horizontal and Vertical Lines
    Offscreen Pixmaps
    Setting up tile and stipple cache:
    32 128x128 slots
    32 256x256 slots
    16 512x512 slots
    (II) fglrx(0): Acceleration enabled
    (II)fglrx(0): Direct rendering disabled
    [/code:1:0d29008d2d]
    [update: 9:23]

    Ik was het agp gedeelte in de bovengenoemde foutmelding even vergeten, en heb ik zojuist toegevoegd.

    Ik heb nu via fgrlrxconfig het dialoog Do you want to use the external AGP GART module (y/n)? beantwoord met y. Voor de foutmelding maakt dat geen verschil.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.