Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Linux start niet meer op!!

wstolk
15 antwoorden
  • Gister Linux Mandrake 9.1 geinstaleerd. Na meerdere mislukte pogingen is het eindelijk gelukt.

    Aan het begin van de installatie werd een stuurprog. geinst. voor een SCSI HD / RAID contr.

    In mijn systeem zit inderdaad een SCSI kaart, deze is echter voor mijn scanner. Nadat deze kaart (tijdelijk) was verwijderd kon ik zonder problemen Linux instaleren.

    Na de instalatie de kaart terug geplaats en …. Linux loopt vast tijdens het opstarten.

    Fouch Mol
  • Blijkbaar is er een ernstig conflict.
    Ten eerste: heb je plug&play; OS uit gezet in het BIOS?
    Ten tweede: zoek in de GNU/Linux hardware database eens op of de kaart überhaupt werkt onder GNU/Linux

    Ik heb het overigens eens gehad met een netwerkkaart, maar dat bleek achteraf toch aan de kaart zelf te liggen die brak was, want een andere kaart met exact dezelfde chip werkte prima.
  • Linux & scsi = 4 handen op 1 buik

    oftewel er zijn weinig kaarten die echt niet onder linux werken.

    dus …
    wat voor kaart heb je
    staat zoals marcel zei pnp OS uit in je bios (probeer het anders eens door hm aan te zetten)
    staat in je bios het cachen van div. onderdelen uit. want dat wil ook weleens lastig doen.
  • Liever nog: wat voor melding krijg je in je boot/opstart log ?

    M.
  • De SCSI kaart is, Adaptec AIC-7850 PCI SCSI-controller.

    Als ik Linux probeer op te starten loopt de computer gewoon vast.
    Na rebooten en opnieuw opstarten krijg ik een melding dat HDA4 verkeerd is ge-unmount de HD wordt daarna gecontroleerd en er worden dusdanige fouten gevonden dat het niet mogelijk is te "Booten".

    Gister met behulp van de inst. CD is het nog wel gelukt Linux op te starten.
    De instal. begon met het instaleren van een SCSI HD/RAID Adapter (maar die heb ik niet :x ).

    Deze keer liep er niets vast na een herstart, toen ik later echter wou uitloggen hing hij weer.

    Vandaag dus weer geen Linux. Ook niet via de Instl. CD.

    Fouch Mol
  • Hmm, volgens de Hardware-HOWTO wordt deze scsi-kaart gewoon ondersteund: http://www.tldp.org/HOWTO/Hardware-HOWTO/scsi.html, dus daar zal het niet aan liggen.

    Ik zou het eens met bijvoorbeeld KNOPPIX of een andere distro proberen. Je kunt ook het Mandrake forum eens opzoeken, wellicht zijn er meer mensen die dit hebben. Ga er nooit vanuit dat je de enige bent die een bepaald probleempje tegenkomt.

    Heb je Mandrake gekocht? Dan zijn er misschien ook mogelijkheden om daar installatie support te krijgen?
  • o ja, probeer ook eens erin te komen en kijk wat er dan allemaal in /var/log/messages staat en andere bestanden in /var/log/.

    Je kunt ook met het commando dmesg (als je ingelogd bent) een lijst zien van de meldingen van de Linux kernel.
  • Heb Linus van een collega gekregen (gedownload, 3 CD, Mandarke 9.1 Bamboo)

    Het probleem is dat ik er nu helemaal niet meer in kom.
    Opstarten, vastlopen opnieuw opstarten HD controle, onherstelbare fouten en daarna een knipperende cursor en ik weet het niet meer….

    Mijn eerste ervaring met Linux


    Fouchienus
  • >onherstelbare fouten

    Een kapotte hd… en dan Linux de schuld geven…. en dat op een Linux-forum posten :lol: ja… dolle pret :o
  • Geen kapotte HD. Ik heb op twee andere partities Windows draaien, zonder problemen.

    De foutmelding hebben betrekking op het bestandssysteem van Linux!!
  • wat er dus waarschijnlijk gebeurd is dat je controller een conflict heeft/krijgt met eoa. Linux instelling.

    Dit zou je kunnen voorkomen door in lilo of grup de juiste parameters mee te geven voor je controller of deze expliciet niet te laden en dat pas na volledig booten "handmatig" te doen.

    Wat hangt er ana je controller btw. ? Alleen je scanner ??

    Dat linux een raidcontroller ziet is overigens niet zo vreemd want dat is een scsi kaart ook min of meer.

    Probeer anders eens met een knoppix cd of een resque system te booten en post eens de uitkomsten van :

    lspci
    lsmod
    cat /proc/interupts
    cat /proc/iomem
    cat /proc/ioports

    TIP.
    In Linux kun je auto-aanvullen door op TAB te kloppen na enkele letters getypt te hebben.
  • [quote:9746ffe870="wstolk"]Dat linux een raidcontroller ziet is overigens niet zo vreemd want dat is een scsi kaart ook min of meer.[/quote:9746ffe870]Ja maar Linux zou op zo'n setup gewoon moeten opstarten. Dit is heel vreemd![quote:9746ffe870]Probeer anders eens met een knoppix cd of een resque system te booten en post eens de uitkomsten van :

    lspci
    lsmod
    cat /proc/interupts
    cat /proc/iomem
    cat /proc/ioports[/quote:9746ffe870]Ja daar ben ik ook benieuwd naar. Maar zelfs gedeelde interrupts zouden geen probleem moeten zijn. Misschien probeert de Mandrake Linux kernel de hd's wel als scsi te benaderen(?)

    Nog een vraagje: Op welke HD of partitie staat Linux en op welke Windows? Windows wil namelijk ook nog wel eens voor problemen zorgen (partities verwisselen etc. Ik heb geen ervaring met Windows en Linux op 1 machine, maar wat ik weet is dat meestal Windows de lastigste klant is :-) (wil niet op tweede partitie of schijf, verandert partitietabel, etc.)
    Staat Windows vooraan? Ziet Windows de Linux partities?
  • [quote:13f5386704="wbsoft"]Ja daar ben ik ook benieuwd naar. Maar zelfs gedeelde interrupts zouden geen probleem moeten zijn. Misschien probeert de Mandrake Linux kernel de hd's wel als scsi te benaderen(?)

    [/quote:13f5386704]

    Dat vrees ik nml. ook een kelin beetje en dan moet je wel maatregelen nemen

    Overigens kan dit hooguit als jde ide-scsi laadt volgens mij
  • Aan de scsi kaart hangt inderdaad alleen een scanner.

    Hoe en waar kan ik in Lilo parameters invoeren? (geen enkele ervaring met Linux, behalve deze).

    Gedeelde interrupts, dit lijkt meer een Windows probleem.

    Zowel de beide Windows versies als de Linux partitie staan op een eigen primaire partitie.
    De versch. besturingsystemen kunnen elkaars partitie niet zien.

    Als bootmanager gebruik ik bootmagic 8.0.
    Na het opstarten van de Linux partitie verschijnt de Linux bootmanager met daarin verschilende opstartmogelijkheden en Windows1 en windows2.

    Het instaleren van de scsi stuurprogramma is een van de eerste dingen die geinstalleerd wordt, waaruit ik min of meer concludeer dat Linux "denkt"dat er een scsi HD in de computer zit.

    Fouchienus
  • Als inderdaad blijkt dat je parameters zou moeten meegeven dan kun je dat op de Boot: prompt doen, die je even ziet bij het opstarten. Als je daar begint te typen start hij niet verder op totdat je Enter indrukt.

    Ik weet niet wat je zou moeten intypen om te zorgen dat Linux de HD's hoe dan ook als IDE ziet; ik blijf het een vreemd probleem vinden.

    Er is een lilo howto: http://tldp.org/HOWTO/LILO.html
    Er is ook een overzicht van mogelijke kernel parameters, als je de kernel sources installeert in /usr/src/linux/Documentation/kernel-parameters.txt

    Je zou het ook op het forum van tweakers.net kunnen vragen, op gathering.tweakers.net, onder Non-windows Operating Systems (NOS), daar zitten misschien meer techneuten.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.