Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Geluidskaart

Grezly
5 antwoorden
  • Ik heb hier een Acer pc met PII.
    Ik heb hier slackware op geinstalleerd.
    Alleen nu doet mijn geluidskaart het niet.
    Het probleem is dat hij geintegreerd is op het mobo.
    Ik heb al het commando lspci -vv gedaan, voor de output ervan.
    Ik denk dat de volgende de geluidskaart is:

    [quote:4b5d76578f]00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
    Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Step
    ping- SERR- FastB2B-
    Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort
    - <MAbort- >SERR- <PERR-
    Interrupt: pin ? routed to IRQ 9
    [/quote:4b5d76578f]
    Heb ik het goed?
    En zo ja, hoe kan ik nu aan de drivers van die geluidskaart komen?
  • Nope, lijkt meer op je ACPI interface…
  • [code:1:818413b8d7]root@blaat:~# lspci -vv
    00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
    Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ >SERR- <PERR-
    Latency: 32
    Region 0: Memory at e0000000 (32-bit, prefetchable) [size=64M]
    Capabilities: [a0] AGP version 1.0
    Status: RQ=32 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64- HTrans- 64bit- FW- AGP3- Rate=x1,x2
    Command: RQ=1 ArqSz=0 Cal=0 SBA+ AGP+ GART64- 64bit- FW- Rate=x2

    00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03) (prog-if 00 [Normal decode])
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
    Status: Cap- 66Mhz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
    Latency: 64
    Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
    I/O behind bridge: 00008000-00008fff
    Memory behind bridge: 80200000-820fffff
    BridgeCtl: Parity- SERR- NoISA- VGA+ MAbort- >Reset- FastB2B+

    00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
    Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
    Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
    Latency: 0

    00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01) (prog-if 80 [Master])
    Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
    Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
    Latency: 32
    Region 4: I/O ports at 9080 [size=16]

    00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01) (prog-if 00 [UHCI])
    Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
    Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
    Latency: 32
    Interrupt: pin D routed to IRQ 11
    Region 4: I/O ports at 9040 [size=32]

    00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
    Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
    Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
    Interrupt: pin ? routed to IRQ 9

    00:10.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 05)
    Subsystem: Intel Corp. 82558 10/100 with Wake on LAN
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
    Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
    Latency: 32 (2000ns min, 14000ns max), cache line size 08
    Interrupt: pin A routed to IRQ 11
    Region 0: Memory at 82400000 (32-bit, prefetchable) [size=4K]
    Region 1: I/O ports at 9000 [size=32]
    Region 2: Memory at 82200000 (32-bit, non-prefetchable) [size=1M]
    Capabilities: [dc] Power Management version 1
    Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA PME(D0+,D1+,D2+,D3hot+,D3cold-)
    Status: D0 PME-Enable- DSel=0 DScale=0 PME-

    01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage LT Pro AGP-133 (rev dc) (prog-if 00 [VGA])
    Subsystem: ATI Technologies Inc Rage LT Pro AGP 2X
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping+ SERR- FastB2B-
    Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
    Latency: 32 (2000ns min), cache line size 08
    Region 0: Memory at 81000000 (32-bit, non-prefetchable) [size=16M]
    Region 1: I/O ports at 8000 [size=256]
    Region 2: Memory at 80200000 (32-bit, non-prefetchable) [size=4K]
    Expansion ROM at 80220000 [disabled] [size=128K]
    Capabilities: [50] AGP version 1.0
    Status: RQ=256 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64- HTrans- 64bit- FW- AGP3- Rate=x1,x2
    Command: RQ=1 ArqSz=0 Cal=0 SBA- AGP- GART64- 64bit- FW- Rate=<none>
    Capabilities: [5c] Power Management version 1
    Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
    Status: D0 PME-Enable- DSel=0 DScale=0 PME-

    root@blaat:~#[/code:1:818413b8d7]
    Dit is de uitkomst van lspci -vv.
    Nu hebben wij hier meerdere dezelfde pc's staan, met windows erop, en ik heb daar de volgende informatie uit kunnen halen.

    [quote:818413b8d7]Crystal WDM
    Intel 82371AB/EB
    PCI to ISA bridge (ISA mode)

    Crystal Semiconductor
    [/quote:818413b8d7]

    Dan lijkt t mij toch wel die enige uit de vorige post.
    Maar ik hoop dat jullie mij verder kunnen helpen..
  • hmm. ik heb je uitkomst van lspci ff vluchtig doorgekeken maar zie daar geen geluidskaart bij staan, misschien is dat 't probleem!
    Wat denk ik het makkelijkste is:
    kijk eens in je boekje of op de website van je moederbord en kijke welke geluidskaart je hebt. Compileer vervolgens de alsa drivers voor je kaart (alsa vind je wel met google).
    Met mijn pc krijg ik in ieder geval ook een betere kwaliteit geluid met alsa.
  • Op http://wiki.nedlinux.nl vind je mijn ALSA howto voor Slackware met daarbij een link naar alle supported geluidskaarten. Daar staat vaak gewoon bij een onboard kaart de naam van de Southbridge en deze staat in de manual vermeld, succes.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.