Vraag & Antwoord

OS Linux

XP installeren met Linux en Win98

10 antwoorden
  • Hallo medeforummers, Ik heb 2 schijven in de computer. Op de eerste heb ik Windows98 draaien, en op de tweede zit SuSE 8.2 Pro en op een andere partitie (van de 2e schijf) zitten bestanden die ik niet kwijt wil raken. Nu heb ik op de 1e schijf een partitie bijgemaakt en daar wil ik XP op installeren. Alleen ben ik nu bang dat XP mijn MBR zal overschrijven en ik niet meer in Linux kom. Bestaat de mogelijkheid om na de installatie weer het bootmenu van Linux (Grub) te gebruiken? En als ik toch moet aanpassen, dat eerst Windows opgestart wordt? Ik ben geen kei in Linux, dus graag een beetje voorgekauwd a.u.b. Alvast bedankt, en een prettige dag verder.
  • Ja dat kan. Maar zorg er eerst voor dat je een opstartschijfje voor linux maakt Dan kun je daarna Grub weer installeren in je MBR. Zowel je opstartschijfje en de installatrie van Grub op je MBR gaat het gemakkelijkst via Yast.
  • Dat kan prima, wat je kunt doen is gewoon van bijvoorbeeld de SuSE installcd booten, je SuSE partitie mounten, chrooten en grub terug zetten in het MBR met: grub: root (hd1,0) setup (hd0)
  • Hoi allemaal, Bedankt voor de reacties, maar ik heb zo te zien alles verprutst. Ik heb met de Install-cd van SuSE opgestart en voor starten geinstalleerd systeem gekozen. Nou, hij startte mooi in Linux op en toen ben ik in YAST2 gaan vingeren. Bij 'Systeem' heb ik bij 'Boot' en bij het knopje 'reset' gekozen voor 'Configuratie opnieuw inlezen' en daarna op 'OK' geklikt. Nu start Linux wel weer mooi op . . . . . . alleen mijn beide Windows-versies ben ik kwijt. Sorry, maar ik weet echt niet wat ik verkeerd gedaan heb, dus vraag ik weer om jullie hulp. Hoe krijg ik Windows weer in het opstartmenu? Alvast dank.
  • Welke opstartmenu heb je nu? Ik heb hetzelfde gehad, door jouw procedure schreef YaSt lilo naar het mbr, terwijl ik daarvoor grub gebruikte Als dat het geval is, kijk even in de faq bij grub met welk commando je grub weer terug kunt zetten in je mbr. max
  • [quote:f8c1a3937f="jhde"]Bij 'Systeem' heb ik bij 'Boot' en bij het knopje 'reset' gekozen voor 'Configuratie opnieuw inlezen' en daarna op 'OK' geklikt. Nu start Linux wel weer mooi op . . . . . . alleen mijn beide Windows-versies ben ik kwijt. [/quote:f8c1a3937f] Wat bedoel je met:"alleen mijn beide Windows-versies ben ik kwijt."? Staan deze twee Windows niet in de SuSE bootmenu, of toont (als superuser) [code:1:f8c1a3937f] fdisl -l [/code:1:f8c1a3937f] geen Windows partities? Als de Windows partities er nog wel zijn, dan zou je /boot/grub/menu.lst er zo uit kunnen zien. [code:1:f8c1a3937f] # Modified by YaST2. Last modification on Sun Sep 7 21:38:00 2003 color white/blue black/light-gray default 0 gfxmenu (hd0,4)/boot/message timeout 8 title SuSE 8.2 kernel (hd0,4)/boot/vmlinuz root=/dev/hda5 splash=silent showopts initrd (hd0,4)/boot/initrd title windows root (hd0,0) chainloader +1 [/code:1:f8c1a3937f] Dat wil zeggen als je 1 Windows op een primaire partitie C: hebt en de andere op een logische partitie D: Als je daarentegen zowel Windows XP en Windows 98 op een primaire partitie hebt staan, dan zou je /boot/grub/menu.lst er zo uit kunnen zien. [code:1:f8c1a3937f] # Modified by YaST2. Last modification on Sun Sep 7 21:38:00 2003 color white/blue black/light-gray default 0 gfxmenu (hd0,4)/boot/message timeout 8 title SuSE 8.2 kernel (hd0,4)/boot/vmlinuz root=/dev/hda5 splash=silent showopts initrd (hd0,4)/boot/initrd title Windows XP unhide (hd0,0) hide (hd0,1) root (hd0,0) makeactive chainloader +1 title windows 98 Se unhide (hd0,1) hide (hd0,0) root (hd0,1) makeactive chainloader +1 [/code:1:f8c1a3937f] Dit is alleen maar een voorbeeld, dus je moet er dan wel voor zorgen dat de info over de partities kloppen voor jouw PC. [quote:f8c1a3937f="maximilaan"]Ik heb hetzelfde gehad, door jouw procedure schreef YaSt lilo naar het mbr, terwijl ik daarvoor grub gebruikte [/quote:f8c1a3937f] Ik heb hier nog even gecontroleerd op een PC waar nog SuSe 8.2 op geinstalleerd is. In Yast2, Systeem, Bootloader configuration, wijzigen. Als die op GRUB staat is het in orde. Om GRUB te installeren vanaf de command line als superuser [code:1:f8c1a3937f] grub-install /dev/hda [/code:1:f8c1a3937f]
  • Hoi Jolo en Max, Bedankt voor de antwoorden. Jolo, aan jouw antwoord heb ik veel gehad. Het was inderdaad zo, dat Windows niet meer getoond werd in het bootmenu. Bij de configuratie stond ie er ook niet; dus heb ik in YAST2 de Bootconfiguratie weer aangesproken en de veranderingen aangebracht zoals het in jouw voorbeeld stond. En ja, ik had Windows weer. Alleen ben ik nu het mooie opstartscherm van Grub kwijt. Bij het opstarten van de computer verschijnt deze melding: "[b:febd30404a]Graphics file "(hd0,1,2) /boot/message" missing, press a key to continue[/b:febd30404a]". Druk ik dan op Enter, krijg ik een "lelijk" blauw dos-achtige menu met daarin de keuze-opties: SuSE 8.2 (voorheen gewoon linux), Windows, floppy en failsafe. Als ik hier met mijn pijltjestoets kies voor Windows, krijg ik dan vervolgens het bootmenu van XP. Toch bedankt, maar als je me verder kunt helpen . . . heel graag.
  • [quote:9563854570="jhde"]"Graphics file "(hd0,1,2) /boot/message" missing, press a key to continue". [/quote:9563854570]Weet je zeker dat die foutmelding letterlijk zo werd getoond? Wat belangrijk is, dat in de regel die naar dat SuSE opstartscherm verwijst [code:1:9563854570] gfxmenu (hd0,4)/boot/message [/code:1:9563854570] dat de partitie daarin (hd0,4) overeenkomt met die van SuSE [code:1:9563854570] kernel (hd0,4)/boot/vmlinuz root=/dev/hda5 splash=silent showopts initrd (hd0,4)/boot/initrd [/code:1:9563854570] Dus als bijvoorbeeld in de kernel en de initrd regels staat (hd0,4) dan behoort deze ook te staan in de gfxmenu regel.
  • Hoi Jolo, Ik moet je helaas nogmaals lastigvallen met het probleem. Het verhaal in mijn vorige reactie verschijnt inderdaad letterlijk in beeld. Verder klopt het ook dat ik Windows nu krijg, maar juichen had ik te vroeg gedaan want Linux start niet op. Als ik Linux wil booten komt het volgende in beeld: [b:b13fc095e3]kernel (hd0,1,2) /boot/vmlinuz root=/dev/hdc3 vga=0x314 hdd=ide-scsi hddlun=0 splash=silent splash=silent splash=silent showopts Error 11: Unrecognized device string Press any key to continue . . .[/b:b13fc095e3] Jammer genoeg weet ik te weinig van Linux af om dit allemaal te begrijpen. Misschien dat het bovenstaande jou wat meer zegt. In ieder geval bedankt voor je tijd en antwoorden. Grtz.
  • [quote:9ab4ef3f4a="jhde"]kernel (hd0,1,2) /boot/vmlinuz root=/dev/hdc3 vga=0x314 hdd=ide-scsi hddlun=0 splash=silent splash=silent splash=silent showopts [/quote:9ab4ef3f4a] Dus de tweede harddisk waarop SuSE is geinstalleerd, op de derde primaire partitie, is Secondary Master? Die [code:1:9ab4ef3f4a] kernel (hd0,1,2) [/code:1:9ab4ef3f4a] is fout. Als die [code:1:9ab4ef3f4a] root=/dev/hdc3 [/code:1:9ab4ef3f4a] juist is, dan [code:1:9ab4ef3f4a] kernel (hd2,2) [/code:1:9ab4ef3f4a] Kun je SuSE Linux nog wel opstarten, met een SuSE Linux opstart diskette? Als je die niet hebt, druk dan na de PC te hebben opgestart, bij dat blauw dos-achtige menu, als SuSE is geselecteerd, druk dan op de e. De kernel regel is dan geselecteerd, druk dan nogmaals op de e. Ga dan met de pijltjes toets naar links, en wijzig die (hd0,1,2) in (hd2,2) en druk op [Enter] Selecteer dan de initrd regel, en doe daarmee hetzelfde. Selecteer dan weer de kernel regel, en druk op b. Als SuSE dan wel goed opstart, breng je deze wijziging ook aan in je /boot/grub/menu.lst

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.