Vraag & Antwoord

OS Linux

Inloggen kan niet meer

Anoniem
gleep
15 antwoorden
  • Vandaag heb ik het op een of andere manier voor elkaar gekregen om niet meer in te kunnen loggen (zowel grafisch, als via textmodus), voor alle accounts tegelijk.
    Eerst werkte in het terminal venster de opdracht SU niet meer, het wachtwoord was telkens fout (meerdere keren geprobeerd).
    Als ik in het menu een optie aanklikte waar root voor nodig was, en daar het wachtwoord invulde, lukte het wel meteen.
    De standaard Windows Optie gaf helaas meer problemen, na opnieuw opstaren lukte het inloggen helemaal niet meer.
    Dit gold voor Alle accounts (root, dagelijkse account, test), zowel grafisch als tekst.
    Bij het invullen van een fout wachtwoord kwam de gewone melding dat het wachtwoord niet klopte, terwijl bij het juiste wachtwoord een pop-up verscheen met "inloggen mislukt".
    Bij tekst inloggen kwam bij een fout wachtwoord de regel 'login incorrect' te voorschijn, terwijl bij het juiste wachtwoord het scherm werd gewist, en 'login' weer verscheen.

    Via runlevel 1 heb ik met 'passwd' het root wachtwoord opnieuw in gesteld, maar dat hielp niet.
    Het wissen van het wachtwoord (geprobeerd met 'test') in /etc/shadow werkte ook niet.

    Hoe kan ik ervoor zorgen dat normaal inloggen weer mogelijk is?


    Indien van belang: De volgende dingen heb ik gedaan voor het probleem ontstond (of mogelijk, waardoor het probleem ontstond)

    - GIMP opstarten, was eerste keer, dus moesten enkele bestanden worden aangemaakt, en instellingen voor het programma worden opgegeven

    - SAMBA instellingen aangepast (nog niet eerder gebruikt) om op het lokale netwerk bestanden te kunnen wisselen.

    - Java runtime environment (plugin voor mozilla) geprobeerd de installeren. (mislukte, foutmelding dat de verkeerde plugin was gedownload)

    Ik hoop dat ik het probleem duidelijk heb omschreven, en dat iemand een oplossing weet.

    E.G.
  • Check eens even in init 1 of je /etc/passwd en je /etc/shadow niet perongelijk readonly staan.
    Kijk ook of je niet perabuis je / readonly gemount hebt.
    boot eens met een knoppix cd en check of je config bestanden wel goed staan en metname dan de "rechten"

    Kijk ook of je lampje van je capslock echt uit is en of het wel werkt :oops:
  • [quote:9de317f021="wstolk"]Check eens even in init 1 of je /etc/passwd en je /etc/shadow niet perongelijk readonly staan.
    Kijk ook of je niet perabuis je / readonly gemount hebt.
    boot eens met een knoppix cd en check of je config bestanden wel goed staan en metname dan de "rechten"

    Kijk ook of je lampje van je capslock echt uit is en of het wel werkt :oops:[/quote:9de317f021]
    Capslock kan het probleem niet zijn (en stond ook echt uit), want bij dat menu werd het wachtwoord wel geaccepteerd.
    Verder kwam er een andere foutmelding, namelijk "inloggen mislukt" in plaats van "verkeerde gebruiker of wachtwoord".

    Volgens mij staan passwd en shadow wel op readonly (in ieder geval shadow) welke rechten moet ik dan gevan aan die bestanden?
    (chmod 777?)
  • /etc/passwd heeft 644 en /etc/shadow heeft 640 als toegangsrechten.
    777 lijkt me geen strak plan omdat iedereen dan alle wachtwoorden mag wijzigen ;)

    Max
  • Zo te zien gebruik je RedHat. Stop je cdrom in de drive, reboot en kies voor upgrade. Dikke kans dat ie het dan weer doet…
  • /etc/shadow / etc/group en etc/passwd mogen gerust read only zijn.
    het liefst staan deze ook op "chatr +i". Dat mag het probleem ook niet zijn. 644 moet voldoende zijn om in te laten loggen. Root mag read/write rechten hebben, de rest enkel leesrechten.

    Wat het dan wel is..
    is /bin/login brak ?
    of stond deze ergens anders ?
  • Ik heb gekeken naar de rechten van /etc/passwd en /etc/shadow, die van passwd stond op 644, en shadow stond op 400, maar het veranderen daarvan in 640 heeft niet geholpen.
    Ik ga nu de upgrade optie proberen.
  • [quote:1489c6ba56="MrLeeJohn"]Zo te zien gebruik je RedHat. Stop je cdrom in de drive, reboot en kies voor upgrade. Dikke kans dat ie het dan weer doet…[/quote:1489c6ba56]
    Geprobeerd, maar helaas heeft het niet geholpen :(

    Ik heb ook geprobeerd om een nieuwe gebruiker aan te maken via runlevel1, maar die kan ook meteen niet inloggen.

    Bij het inloggen in tekstmodus heb ik nu een foutmelding voorbij zien flitsen, die helaas te snel weg is om helemaal te lezen.

    De melding had in ieder geval de woorden 'authentication failed', en ik krijg deze melding niet als ik een verkeerd wachtwoord opgeef.
    (dan staat er alleen 'login incorrect')

    [quote:1489c6ba56="KayJay"]/etc/shadow / etc/group en etc/passwd mogen gerust read only zijn.
    het liefst staan deze ook op "chatr +i". Dat mag het probleem ook niet zijn. 644 moet voldoende zijn om in te laten loggen. Root mag read/write rechten hebben, de rest enkel leesrechten.

    Wat het dan wel is..
    is /bin/login brak ?
    of stond deze ergens anders ?[/quote:1489c6ba56]
    shadow ook op 644? misschien dat dat het is, ga dat nog proberen.
    /bin/login bestaat, maar ik heb geen idee hoe ik kan zien of daar het probleem ligt.
  • Ik heb nu een duidelijkere foutmelding gekregen:
    Authentication failed, couldn't contact ldap server
    Blijkbaar heb ik de verplichting ingesteld om ldap te gebruiken.
    Hoe ik dat precies voor elkaar gekregen heb weet ik niet (vermoed met de samba config), maar zo'n service draait in ieder geval niet op mijn computer.
  • de samba config staat los van het niet in kunnen loggen op je OS.

    Je kunt bij een install van het OS kiezen voor ldap authorisatie .. wellicht dat je het uitgezet hebt? want dan ben je zuur ;)
    Misschien zelf de authorizatie omgezet naar ldap ?
  • [quote:2403843b59="KayJay"]de samba config staat los van het niet in kunnen loggen op je OS.

    Je kunt bij een install van het OS kiezen voor ldap authorisatie .. wellicht dat je het uitgezet hebt? want dan ben je zuur ;)
    Misschien zelf de authorizatie omgezet naar ldap ?[/quote:2403843b59]
    Ik vermoed eigenlijk dat ik het juist per ongelijk heb aangezet, terwijl de service ervoor niet draaid, en daardoor geen authorisatie mogelijk is.
    Ik ben nu bezig www.ldap.org te doorzoeken, misschien staat daar nog een oplossing/suggestie.
  • >Misschien zelf de authorizatie omgezet naar ldap ?

    Heb je een pam-module geinstalleerd? Een ldap-plugin?
  • Ik ben ook ooit eens aan het stoeien geweest met een ldap- server. Heb toen o.a. een aanpassing in /etc/nsswitch.conf gedaan:
    [code:1:ade5ffc241]
    Passwd: ldap
    group: ldap
    shadow: ldap
    [/code:1:ade5ffc241]

    Normaal is dit:
    [code:1:ade5ffc241]
    passwd: files nisplus
    shadow: files nisplus
    group: files nisplus
    [/code:1:ade5ffc241]

    Ik weet het niet zeker, maar misschien helpt het je op weg.
  • Ik zal het morgen. (of eigenlijk al vandaag) proberen.
  • Check is op irc weet niet waar maar daar zijn genoeg ppl die je willen helpen.

    ik kon niet veder dan de GRUB en kon me kernel ook niet laden, nu bleek door te checken in MS-dos dat het formateren niet ging door een fout melding sector 0 has a defect of zo iets.. balle maar wel lang gezocht :>

    succes man over 2 maanden kan ik ook mensen helpen ben nu nog beginner

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.