Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

VPN server

MVE
6 antwoorden
  • Ey,

    Kan iemand mij op weg helpen waar ik naar moet zoeken als ik een VPN server wil opzetten. Dit wil ik, zodat ik bij anderen thuis op mij eigen netwerk kan komen. Ik heb echter geen id hoe deze servers heten en zoeken op google levert ook niet echt duidelijke resultaten op.

    Iedere hulp is welkom.

    MVGR,

    René
  • freeswan - www.freeswan.org
    Linux FreeS/WAN is an implementation of IPSEC & IKE for Linux

    poptop - www.poptop.org
    Poptop is the PPTP server solution for Linux. Ports also exist for Solaris 2.6, OpenBSD, FreeBSD and others

    tinc - http://tinc.nl.linux.org/
    tinc is a Virtual Private Network (VPN) daemon that uses tunnelling and encryption to create a secure private network between hosts on the Internet.

    En welke wordt het? Freeswan is m.i. de meest uitgebreide, en dus ook de moeilijkste om te configureren. Er zijn inmiddels ook hardwarematige vpn-gateways op de markt die gebruik maken van freeswan.

    Met poptop kun je vrij eenvoudig een vpn op basis van pptp opzetten. Niet de veiligste, maar wel makkelijk en snel.

    Met tinc heb ik geen ervaring. Heb er ooit eens iets over gelezen in Linuxmagazine. Vandaar.
  • ..ik ben zelf voorstander voor Poptop..:
    -rpm's downloaden en isntalleren en reboot voor nieuwe kernel.
    -dan pptp server configureren en klaar is kees!

    Als je Suse gebruikt (vnaaf versie 8.2) kan je poptop mee compilen in je kernel (pptp server support) en kan je makkelijk alles up2date houden met Yast2.
    Je hebt zelfs een fancy webmin module voor poptop/pptp vpn server!

    Freeswan is helemaal cool maar wil je een beetje VPN, zet dan een pptp met mschap v 2.0 encryptie en 128 bits encryptie op..

    M.
  • In eerste lijkt mijn keuze te vallen op Poptop. Misschien niet de veiligste maar er valt toch niet erg veel interessants bij mij te halen (misschien van naief) dus ik hoef geen extreem veilige verbinding. Het gemak spreekt me wel aan.
    Ga me er na de kerst eens in verdiepen.

    Bedankt voor de suggesties.
  • Ey,

    Heb poptop geinstaleerd. Als ik nu met een Win2k(SP3) een VPN verbinding op wil starten krijg ik op de Win2k client fount 619 (De opgegeven poort is nier verbonden). Op de server krijg ik de volgende error:
    /usr/sbin/pppd: The remote system is required to authenticate itself
    /usr/sbin/pppd: but I couldn't find any suitable secret (password) for it to use to do so.

    Lijkt me iets in /etc/ppp/chap-secrets. Maar kan het fout hebben. Ik heb in chap-secrets ingevuld wat ze op http://poptop.sourceforge.net/dox/chap-secrets.txt zeggen.
    Wat kan het zijn dat 't niet werkt?

    MVGR,

    René

    [edit]
    insmod ppp_mppe levert het volgende op:
    Using /lib/modules/2.4.18-mppe/kernel/drivers/net/ppp_mppe.o
    /lib/modules/2.4.18-mppe/kernel/drivers/net/ppp_mppe.o: unresolved symbol ppp_register_compressor_R9682e733
    /lib/modules/2.4.18-mppe/kernel/drivers/net/ppp_mppe.o: unresolved symbol ppp_unregister_compressor_Ra1b928df
    /lib/modules/2.4.18-mppe/kernel/drivers/net/ppp_mppe.o:
    Hint: You are trying to load a module without a GPL compatible license
    and it has unresolved symbols. Contact the module supplier for
    assistance, only they can help you.

    Ik heb Kernel 2.4.18-mppe (gepatched dus),
    pppd v. 2.4.1 (ook gepatched),
    PoPToP v. 1.1.2,
    en dat allemaal op Debian 3.0
    [/edit]
  • ik heb met webmin nu een ppp account aangemaakt. Probleem was waarschijnlijk dat er een tab te veel instond ofzo. Nu gaat de client wel aanmelden maar krijg ik de volgende error (op de Win2k client):

    Fout 742: De externe computer ondersteunt het vereiste type gegevens codering niet.

    [edit]
    Na een beetje zoeken, proberen is het me gelukt. Ik krijg nu een verbinding :D
    [/edit]

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.