Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Installatie Suse 8.2 Pro(bleem)

Marcel de Reus
4 antwoorden
  • Zie http://nl.linux.org/forum/show.php?fid=417&table=start om een heel verhaal niet te hoeven hertypen ;)

    Links:
    FN 41 moederbord manual: http://www.shuttle.com/hq/support/download/dwn2.asp?model=SN41G2#
    Nvidia nForce 2 drivers: http://www.nvidia.com/object/linux_nforce_1.0-0261.html

    Op dat andere forum kreeg ik, zoals te zien is, geen reacties (geen idee waarom?), ik hoop hier meer respons te vinden. Kennis is er genoeg, gelezen dit Forum ;) Overigens draai ik op dezelfde PC nu met Win98SE en RH 9 probleemloos (na ja, op de gebruikelijke crashes van Zinloos na dan :cry:), maar ik wil volledig over naar Linux (omdat Suse in de 8.2 Pro versie Cinerella heeft meegeleverd). Alvast BVD! :)

    Groet, M.V. Wesstein

    PS: de huidige HDD van deze PC wordt tzt hergebruikt in een thuisserver (nog te bouwen) en lijkt me dus verder niet relevant voor dit verhaal.
  • Ik zie dat je hem wel handmatig geinstalleerd krijgt, maar dat hij daarna enkel blijft hangen wederom bij USB als je wilt booten?
    Dat is niet zo'n probleem, dan schakel je gewoon de USB detectie even uit. Zoiezo zou ik eens kijken of je in de bootregel van de installatiecd, dat is dus het eerste scherm wat je krijgt als je van cd1 boot' de optie nousb niet kunt invoeren. Als ik me niet vergis geeft F2 een lijstje van de mogelijke opties, kijk maar eens of daar iets over USB uitschakelen staat.

    Verder kun je anders dus handmatig installeren. Daarna moet je nogmaals booten van cd en dan voor resque kiezen. Je komt dan op een gegeven moment op de cli terrecht en dan doen je:

    mkdir /mnt/suse
    mount /dev/hdx /mnt/suse
    chroot /mnt/suse

    hdx vervang je natuurlijk door de goede partitie (de root-partitie van suse dus). Vervolgens zit je min of meer gewoon al in je SuSE systeem en moet je er enkel nog voor zorgen dat de USB detectie niet plaatstvind tijdens het booten.
    Hoe SuSE dit precies regelt weet ik niet, maar probeer eens aan /etc/hotplug/blacklist toe te voegen (met vim /etc/hotplug/blacklist, dan naar de laatste regel wandelen en op 'i' drukken, als je klaar bent met invoeren op esc drukken en daarna op ':' je krijgt onderin een lijntje en daar tik je dan wq)
    usb-uhci
    uhci
    usbcore
    ohci

    Dat zijn de belangrijkste usb modules. Als SuSE idd zo werkt dan zal hij die dus niet meer proberen te laden en zou het allemaal moeten werken.
  • Heb de betreffende HDD maar in de PC gehangen (internet nu van oude AMD K6 @500MHz :P) en heb via de 'safe settings' optie in GRUB, na root+ww opgeven en X-server starten, de USB controller uit de bootsequentie weten te halen. Echter, nu loopt'ie vast op de soundcard. Die is er niet, slechts de ingebouwde AC97 decoder: 'Starting sound driver: intel8x0' en dan doet'ie niks meer. Alleen een harde reset is dan nog mogelijk. Ik heb de Nvidia drivers weten te installeren (er is een RPM voor Suse 8.2 beschikbaar) maar op vage wijze weigert Suse de sounddecoder te herkennen. Ga nog ff proberen met andere settings (weet inmiddels waar ik die kan vinden en hoe er te komen, grafisch dan ;)). Thx zover!

    Groet, M.V. Wesstein
  • De wonderen zijn de wereld nog niet uit. Op dit moment staat de Suse bak Mozilla 1.5 te downen onder het 'gewone' gebruikersaccount :D Hoe ik de zaak aan de praat heb gekregen weet ik niet meer, maar ik heb iig het hele 'USB hotplug' gebeuren uitgezet (HOTPLUG_USB: off of zoiets…) Daarnaast een systeemcheck gerund (van DVD) wat wss ook geholpen heeft. Heb ook nog wat services aangezet, vnl netwerkgerelateerd. Anyway, op dit moment draait de boel, later eens gaan tweaken en proberen de USB-tree aan de praat te krijgen. Ik vrees dat ik daar jullie expertise bij nodig zal hebben ;) Dank voor de hulp zover :)

    Groet, M.V. Wesstein

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.