Vraag & Antwoord

OS Linux

Alsa fouten

Anoniem
Marcel de Reus
32 antwoorden
  • Ik denk dat het probleem is dat amixer enkel op Alsa devices werkt? Waarom test je dat niet even door gewoon een andere mixer als rexima te gebruiken?
  • Wat ik merkte met alsa icm. kmix is dat kmix bij lange na niet al je intellingen weergeeft.
    KAmix echter wel en daar kon ik dus bas ed. activeren zodat die in kmix nu ook werken maar verdere instellingen zijn via kmix dus niet te bereiken (ik heb een emu10k met 4.1 speakerset) zoals de instellingen voor mijn "achter" boxen en daar kon ik mbv. KAmix dus weer wel bij.

    Verder gebruik ik gewooneen standaard kerenl met alsa modules en heb alleen alsaconf gebruikt om de boel te configgen.
    (zonder alsa conf ook geen geluid ;( )
  • Kernel 2.6.1 is al te downloaden. Ik heb 'm zojuist gedownload en gecompileerd. Maar ook nu heb ik hier nog steeds dat verschil. Met ALSA in rexima geen OGain, en met OSS in rexima wel OGain.
  • Is het nog gelukt Grezly? Ik kwam er namelijk achter toen ik 2.6.1 installeerde onder Slack 9.0 dat bij mij idd het geluid ook hartstikke zacht is op mijn onboard via82xx chip.
  • Na een reboot deed het geluid het helemaal niet meer bij mij

    Ik krijg bij alsamixer de volgende fout als ik het wil opstarten:

    [code:1:8a5b32ffe3]
    deev@slackware:~$ alsamixer
    ALSA lib control.c:612:(snd_ctl_open_noupdate) Invalid CTL default

    alsamixer: function snd_ctl_open failed for default: No such file or directory
    deev@slackware:~$[/code:1:8a5b32ffe3]
  • [quote:9225d91a7a="Grezly"] Na een reboot deed het geluid het helemaal niet meer bij mij [/quote:9225d91a7a] Maar wat is er gebeurt nadat je vandaag om 4:42 pm een lsmod output postte, en meldde dat alsa nog niet werkte met kernel 2.6.1? En daarna je bericht compleet wijzigde dat het wel werkt. Worden na die reboot nog wel al die modules geladen, die je postte in die verwijderde lsmod output? Had je iets gewijzigd in Slackware, waardoor die reboot vereist was?

    Ik heb nu zelf zojuist de nieuwe kernel 2.6.2 gedownload, en gecompileerd.
  • Ja. alle modules worden nog wel geladen….

    De reboot was nodig omdat ik wegging (dus zette de pc uit).
    Toen ik hem weer aanzette gebeurde dit…
  • [quote:ba63a9878a="Grezly"] Ja. alle modules worden nog wel geladen…. [/quote:ba63a9878a] Tja, die laatst geposte lsmod lijkt me wel in orde. Maar wat heb je in /etc/rc.d/rc.modules toegevoegd, en welke hekje(s) heb je verwijderd? En heb je hetzelfde probleem met de 2.6.2 kernel?
  • Ja, bij de 2.6.2 kernel krijg ik precies dezelfde foutmelding..

    Ik ga morgen vroeg maar eens _opnieuw_ een schone slack installeren.

    Ik heb ook helemaal niets gewijzigd…vind het een heel raar probleem maar ja….
    Als er nog opties zijn hoor ik het graag…
  • Na een nieuwe slack installatie te hebben gedaan, en de 2.6.2 kernel er in heb gezet, krijg ik de volgende fout:

    [code:1:c8c20e2748]deev@slackware:~$ alsamixer

    alsamixer: function snd_ctl_open failed for default: No such device
    [/code:1:c8c20e2748]

    Ik vraag me toch af hoe dit ineens allemaal zo kan zijn…

    /edit

    Ik had een module niet mee gecompiled…mijn fout :D.

    Nu doet het geluid het dus weer wel, maar de vervorming is er nog steeds…en dat irritant geluid…

    //edit 2

    Ik heb bij Geluids I/O de geluidskwaliteit op 8 bits gezet, nu krijg ik al minder dat 'gekraak'.

    Maar zou ik eventueel die geluiden van KDE disablen of iets dergelijks?

    ondersteunt alsa deze driver nog niet goed ofzo?
  • [quote:9d8a53901b="Grezly"] Nu doet het geluid het dus weer wel, maar de vervorming is er nog steeds…en dat irritant geluid… [/quote:9d8a53901b] Ik heb zelf een test gedaan met een OGG muziek bestand. Hier vind ik dat met mijn Audigy wel redelijk klinken, in Slackware 9.1 met kernel 2.6.2 en kde 3.2. Zelfs de hoge en lage tonen regelaars werken nu. In Kmix gebruik ik nu Master, PCM, Wave en emu10k1 PCM.

    [quote:9d8a53901b="Grezly"] Maar zou ik eventueel die geluiden van KDE disablen of iets dergelijks? [/quote:9d8a53901b] Als je in een konsole typt
    [code:1:9d8a53901b]
    kcontrol
    [/code:1:9d8a53901b][Enter] Geluid en multimedia > Geluidssyteem, kun je het geluid testen, en eventueel het Geluidssysteem activeren uitvinken.
  • Ik heb inmiddels ALSA drivers 1.0.2c gedownload.
    [quote:c1efb4a69e="ALSA website"]
    2004-02-04 1.0.2c driver package release | More fixes for compilation problems
    2004-02-03 1.0.2b driver package release | It fixes next 2.6 kernel compilation problems.
    2004-01-30 1.0.2a driver package release | It should fix most of 2.6 kernel compilation problems and adds RME HDSP MADI (hdspm) driver[/quote:c1efb4a69e]

    Ik heb de 2.6.2 kernel bij mij opnieuw gecompileerd in Slackware 9.1. Ditmaal voor de geluidskaart alleen als kernel opties bij Sound
    [code:1:c1efb4a69e]
    <M>Sound card support [/code:1:c1efb4a69e]

    En de zojuist gedownloade ALSA drivers gecompileerd en geïnstalleerd. En deze keer getest met een onboard geluidskaart, een Asustek CMI8738. Het geluid klinkt bij mij met een OGG muziek bestand acceptabel.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.