Vraag & Antwoord

OS Linux

[Kmail SuSE 9.0] Kan geen e-mail meer verzenden via Chello

Anoniem
None
34 antwoorden
  • Mogen en doen is iets anders he :-P
    Ik rot er gewoon een server neer, pas als hij niet werkt omdat zij poorten oid zitten te blokken wordt ik boos ;-)
    Ik had verder nog niet naar Direct ADSL gekeken, maar datalimiet komt niet in mijn woordenboek voor. GNU/Linux en IPv6 wel, maw Xs4all zou het dan woorden.
  • [quote:7198b3d714="rudiZ"]heb je de username wel juist ingevuld? Dus niet het email-adres maar je login naam? [/quote:7198b3d714] Ja, die heb ik juist ingevuld. Ik gebruik in GNU/Linux dezelfde SMPT usernaam als in Windows XP.

    [quote:7198b3d714="jolo"] Zonder de hardware router DrayTek Vigor 2200E, bleek ik wel e-mail te kunnen verzenden met Kmail. Ofschoon ik niks heb veranderd aan de configuratie van de hardware router, sinds dat traag surf probleem met SuSE 8.2, ziet het ernaar uit dat ik de hardware router configuratie nog maar eens moet controleren. [/quote:7198b3d714] Ik heb de hardware router configuratie nagelopen, maar ik kan niets bijzonders vinden. De Advanced Setup > IP Filter / Firewall Setup, lijkt nog ongewijzigd. Default Call Filter en Default Data Filter.

    Dus samenvattend e-mail verzenden in GNU/Linux met de hardware router heeft gewerkt, maar nu niet meer. E-mail verzenden in GNU/Linux lukt nu alleen nog zonder de hardware router. Verzenden van e-mail in Windows XP met de hardware router werkt nog wel.
  • tja en dan is het verrekte vervelden dat je niet goed kunt nagaan hoe/wat windows doet :(

    Maar als je router neit veranderd is en kmail ook niet dan zou het moeten werken. Internet werkt verder wel gewoon goed ?
    Dan kan het zijn dat nat in je router toch niet helemaal goed is waardoor je header van kmail niet een is welke door chello geaccepteerd wordt.
    check toch kmail nogeens op alle instellingen.
    probeer het eens mbv. fetchmail om je post op te halen.
  • [quote:4f99d47293="wstolk"]tja en dan is het verrekte vervelden dat je niet goed kunt nagaan hoe/wat windows doet[/quote:4f99d47293] Dat weet ik inderdaad niet. Maar dit geldt ook voor GNU/Linux. Ik startte net IPTraf, zodat ik het verzenden van een e-mail met en zonder hardware router kon vergelijken. Dat verzenden van e-mail zonder hardware router, gaat echter zo snel dat het me niet lukt de gegeven van IPTraf te kopieren.

    [quote:4f99d47293="wstolk"]Maar als je router neit veranderd is en kmail ook niet dan zou het moeten werken. Internet werkt verder wel gewoon goed ? [/quote:4f99d47293] Kmail zou inderdaad hebben moeten werken. Internet zelf werkt in GNU/Linux, met de hardware router, nog wel goed.
    [quote:4f99d47293="wstolk"]
    Dan kan het zijn dat nat in je router toch niet helemaal goed is waardoor je header van kmail niet een is welke door chello geaccepteerd wordt.
    [/quote:4f99d47293] Ik weet ook niet zeker of de e-mail vanuit GNU/Linux met de hardware router chello wel bereikt. Bovenaan de foutmelding van Kmail staat namelijk: Fout - Kmail
    [quote:4f99d47293="wstolk"] check toch kmail nogeens op alle instellingen. [/quote:4f99d47293] Het enige wat ik in Kmail heb ingevult voor het verzenden van e-mail, is mijn naam (username) en Host mail.chello.nl
    De smpt poort was al ingevuld op 25. De Hostnaam is niet ingevuld.
    [quote:4f99d47293="wstolk"] probeer het eens mbv. fetchmail om je post op te halen.[/quote:4f99d47293] Waarom fetchmail? Het ontvangen van e-mail in GNU/Linux met de hardware router werkt tenslotte nog wel goed. De hardware router lijkt alleen het verzenden van e-mail, vanuit GNU/Linux te blokkeren.
  • fetchmail…. :( sorry zat ff verkeerdom te denken.

    /var/log/messages laat ook niks zien?

    ff gekeken bij mijzelf (hccnet)
    en ik kan ook niet direct verzenden (doe dat normaal via mijn eigen mailserver
    Toch eens kijken of postix wel geconfigureerd is :( zodat hij ook direct verzend :-?

    [edit]
    bleek een foutje van mezelf te zijn en had niets met postfix te maken maar ik had wel een verzend-naam gemaakt maar geen identitiet :( daarna deed hij het wel gewoon
    [edit]

    bekijk je volledige headers eens als je en mailtje naar jezelf stuur
  • Bekijk de data die over het netwerk gaat eens met ettercap. Die logt alles als je wilt dus dan kun je er wel rustig naar kijken.
  • [quote:88f0a1af12="wstolk"]/var/log/messages laat ook niks zien? [/quote:88f0a1af12] Wat voor een info? Zoiets als dit?
    [code:1:88f0a1af12]
    Jan 23 20:47:30 linux SuSEfirewall2: Firewall rules successfully set from /etc/sysconfig/SuSEfirewall2
    Jan 23 20:47:31 linux SuSEfirewall2: Firewall rules successfully set from /etc/sysconfig/SuSEfirewall2
    <knip>
    Jan 23 21:07:04 linux kernel: ip6_tables: (C) 2000-2002 Netfilter core team
    Jan 23 21:07:04 linux kernel: ip_tables: (C) 2000-2002 Netfilter core team
    Jan 23 21:07:04 linux kernel: ip_conntrack version 2.1 (4095 buckets, 32760 max) - 304 bytes per conntrac
    <knip>
    Jan 23 21:07:04 linux kernel: ne2k-pci.c:v1.02 10/19/2000 D. Becker/P. Gortmaker
    Jan 23 21:07:04 linux kernel: http://www.scyld.com/network/ne2k-pci.html
    <knip>
    [/code:1:88f0a1af12]
    [quote:88f0a1af12="wstolk"]bekijk je volledige headers eens als je en mailtje naar jezelf stuur[/quote:88f0a1af12]
    Daar heb ik geen fouten in kunnen vinden.
    [code:1:88f0a1af12]
    Onderwerp
    Datum:
    Van: <mijn voor en achternaam> en <mijn e-mail adres>
    Aan: <mijn e-mail adres>
    [/code:1:88f0a1af12]

    [quote:88f0a1af12="Marcel de Reus"] Bekijk de data die over het netwerk gaat eens met ettercap. [/quote:88f0a1af12] ettercap kende ik nog niet. De log van ettercap in SuSE 9.0 met de hardware router
    [code:1:88f0a1af12]
    213.46.243.2:25
    501 Syntax error in parameters or arguments.
    221 amsfep15-int.chello.nl ESMTP server closing connection.
    [/code:1:88f0a1af12]

    [Edit]

    Ik heb ook de Windows versie van ettercap gedownload. De log daarvan ziet er toch wel anders uit
    [code:1:88f0a1af12]
    213.46.243.2:25
    250 Message received <knip>
    221 amsfep15-int.chello.nl ESMTP server closing connection.
    [/code:1:88f0a1af12] [/Edit]
  • Ik heb nog het volgende geprobeerd. In de configuratie van het hardware router. In Advanced Setup > IP Filter / Firewall Setup > General Setup heb ik zowel Call Filter en Data Filter geselecteerd op Disable. De hardware router firewall zou dan uit moeten staan. Maar ook dan kan ik nog steeds geen e-mail verzenden met Kmail. De foutmelding blijft hetzelfde. Volgens www.grc.com staan dan nog steeds de geteste 1055 poorten op Stealth. En dit laatste heb ik getest in Slacware 9.1, waarin zonder de harware router zelfs meerdere poorten open staan.
  • Stealth kan afair geen kwaad. Dat betekent alleen dat de portscanner niet kan zien of ze dicht of open zitten. Slackware draait standaard geen firewall, dus het is logisch dat die poorten open staan.
    Bij mij zijn al mijn poorten gestealth door mijn hardware router en ook in gebruik Chello en toch kan er hier gewoon via KMail gemailed worden. Ik zal dadelijk als mijn moeder of zusje weer wil mailen ettercap wel even laten draaien, kijken wat deze zegt. Mooi programma he overigens, op wiki.nedlinux.nl heeft Maikel er een stukje over geschreven.
  • [quote:2e1237aa30="Marcel de Reus"]Stealth kan afair geen kwaad. [/quote:2e1237aa30] Maar als ik de firewall in de hardware router disable, en ook in Slackware geen firewall gebruik, dan mogen de poorten toch niet op stealth staan. Dat zou de indruk kunnen wekken dat er iets niet in orde is met de hardware router (firewall), die daardoor de e-mail vezonden vanuit GNU/Linux zou blokkeren. Alleen vraag ik me dan af, waarom de e-mails verzonden door Outlook Expess in WinXP, dan NIET worden geblokkeerd door de hardware router (firewall).
  • Ja daar heb je een punt. Wat ik je wel kan vertellen is dat ik vanachter mijn hardware router Girotel niet kon bereiken, ook al stond de firewall helemaal uit. Die dingen doen blijkbaar van alles ook als je dat niet instelt. Voor mijn router was er toen een update beschikbaar die dat verhielp. Heb jij al naar de laatste firmware geupdate?
  • [quote:741bd82cf0="Marcel de Reus"]Heb jij al naar de laatste firmware geupdate?[/quote:741bd82cf0]
    Nee, in mijn hardware router zit nog dezelfde firmware als toen ik 'm zo een acht maanden geleden kocht. Ik had een firmware update nog niet overwogen omdat het e-mail verzenden met Kmail, met deze hardware router vorig jaar nog wel werkte. Maar een firmware update is wel een optie. Net als het drukken op de reset knop achter op de hardware router. Alleen dan zal ik de hardware router opnieuw moeten configureren. En wellicht moet ik 'm ook opnieuw configureren na een firmware update.
  • Ik hoefde hem niet opnieuw te configgen iig.
  • [quote:63c5bbd791="Marcel de Reus"]Ik hoefde hem niet opnieuw te configgen iig.[/quote:63c5bbd791] Het ziet ernaar uit dat je gelijk hebt. Terwijl je dit schreef was ik al bezig de firmware update uit te voeren. Helaas wel met behulp van een Windows utility :-? De firmware update van v2.3.1 naar v2.3.8 is gelukt. De hardware router firewall kan nog steeds niet uitgezet worden. Maar ik kan nu weer wel e-mail verzenden via de hardware router, vanuit GNU/Linux. Het was waarschijnlijk toch een bug.

    Marcel en de anderen, in ieder geval bedankt voor het meedenken. :)

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.