Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

alsa-probleem slackware

Knepsel
9 antwoorden
  • Probeer al een tijdje alsa te installeren onder Slackware9.0 maar het wil niet goed lukken:
    Als ik modprobe snd-emu10k1 doe krijg ik dit:
    /lib/modules/2.4.20/kernel/sound/pci/emu10k1/snd-emu10k1.o: init_module: No such device
    /lib/modules/2.4.20/kernel/sound/pci/emu10k1/snd-emu10k1.o: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
    You may find more information in syslog or the output from dmesg
    /lib/modules/2.4.20/kernel/sound/pci/emu10k1/snd-emu10k1.o: insmod /lib/modules/2.4.20/kernel/sound/pci/emu10k1/snd-emu10k1.o failed
    /lib/modules/2.4.20/kernel/sound/pci/emu10k1/snd-emu10k1.o: insmod snd-emu10k1 failed
    root@emile:~#
    En als ik amixer probeer op te starten krijg ik:
    amixer: Mixer attach default error: No such device
    Met dmesg krijg ik wel een irq-fout maar dat lijkt me van een andere orde:
    IRQ routing conflict for 00:11.2, have irq 9, want irq 3
    IRQ routing conflict for 00:11.3, have irq 9, want irq 3
    usb-uhci.c: USB UHCI at I/O 0xa400, IRQ 9
    usb-uhci.c: Detected 2 ports
    usb.c: new USB bus registered, assigned bus number 3
    hub.c: USB hub found
    hub.c: 2 ports detected
    PCI: Found IRQ 3 for device 00:11.3
    IRQ routing conflict for 00:11.2, have irq 9, want irq 3
    IRQ routing conflict for 00:11.3, have irq 9, want irq 3
    usb-uhci.c: USB UHCI at I/O 0xa000, IRQ 9
    Heb al heel wat gegoogled, maar ik kom er niet uit.
    ik draai Slack9.0 met een Audigy2 kaart
  • [quote:034c3103ca="Knepsel"]Probeer al een tijdje alsa te installeren onder Slackware9.0 maar het wil niet goed lukken:
    Als ik modprobe snd-emu10k1 doe krijg ik dit:
    /lib/modules/2.4.20/kernel/sound/pci/emu10k1/snd-emu10k1.o: init_module: No such device [/quote:034c3103ca] Wellicht kunnen de ALSA drivers niet geladen worden omdat de OSS drivers nog geladen worden via hotplug. Als je PC opstart met de boot option
    [code:1:034c3103ca]
    nohotplug
    [/code:1:034c3103ca] kan je dan wel de ALSA drivers laden?

    Een andere mogelijkheid is de OSS module, [b:034c3103ca] emu10k1 [/b:034c3103ca] te plaatsen in [b:034c3103ca] /etc/hotplug/blacklist [/b:034c3103ca]

    Als je daarentegen die module emu10k1 via [b:034c3103ca] /etc
    c.d
    c.modules [/b:034c3103ca] had geladen, zet je er uiteraard een hekje voor.

  • Heb net alsa geupgrade van o.9.6 naar 1.0.2. Nu laat snd-emu10k1 zich wel laden maar emu10k1 niet meer. amixer en aplay(geluidstest) gaven vervolgens geen problemen, maar verder kreeg ik geen geluid. Toen ik soundcore er uit gooide kon ik wel een mp3 van de hd afspelen, maar de hele comp. vertraagde en het geluid was erg krakerig. Toen ik vervolgens rebootte met de optie nohotplug en daarna een mp3 probeerde af te spelen kreeg ik een cpu-overload. Enig idee wat nu te doen? bvd

    Emile
  • Top geeft nu bij het afspelen van een mp3 een cpu-belasting van rond de 90 % aan.
    Als dat geen dijk van een driver-conflict is.. :P
  • [quote:a1d4e6fe93="Knepsel"] Top geeft nu bij het afspelen van een mp3 een cpu-belasting van rond de 90 % aan. [/quote:a1d4e6fe93] Dat is wel erg veel. Zou je die top hier kunnen posten, en ook je /sbin/lsmod output. Met welk programma speelde je die mp3 af? Als ik een OGG muziek bestand afspeel via Kaboodle, dan is de cpu-belasting ongeveer 25 % in Gnome, en ongeveer 35 % in KDE. Daarentegen de cpu-belasting van xmms in Gnome is nihil. Eveneens nihil voor xmms in KDE. Alleen start het afspelen van een OGG muziek bestand, met xmms in KDE nogal moeizaam.
  • De top-output kopieren lukt helaasniet; de cpu-belasting verandert voortdurend.
    Maar het lijkt idd wel een KDE-probleem.Het opstarten gaat haperend en de cpu-belasting blijft ongeveer 1 minuut lang na het opstarten op 90 % hangen.Daarna zakt het tot rond de nul, maar zodra ik met Kaboodle een mp3 opstart loopt het weer op tot zo'n 95 %. Met XMMS is er geen probleem. Met Gnome is er wat dat betr. helemaal geen probleem.
    lsmod ziet er als volgt uit:
    root@emile:~# lsmod
    Module Size Used by Tainted: P
    snd-pcm-oss 37572 0 (autoclean)
    snd-mixer-oss 12624 1 (autoclean) [snd-pcm-oss]
    agpgart 35776 3 (autoclean)
    nvidia 1628288 11 (autoclean)
    cmpci 24976 0 (unused)
    snd-cmipci 18292 0
    snd-opl3-lib 5988 0 [snd-cmipci]
    snd-mpu401-uart 3264 0 [snd-cmipci]
    uhci 24560 0 (unused)
    ehci-hcd 14632 0 (unused)
    usbcore 58144 1 [uhci ehci-hcd]
    tuner 9696 1 (autoclean)
    bttv 67936 0
    i2c-algo-bit 6984 1 [bttv]
    i2c-core 12708 0 [tuner bttv i2c-algo-bit]
    videodev 5632 3 [bttv]
    snd-bt87x 5068 0
    emu10k1-gp 1352 0 (unused)
    gameport 1452 0 [snd-cmipci emu10k1-gp]
    ohci1394 16264 0 (unused)
    ieee1394 30828 0 [ohci1394]
    pcmcia_core 38112 0
    snd-emu10k1 62292 1
    snd-pcm 56512 0 [snd-pcm-oss snd-cmipci snd-bt87x snd-emu10k1]snd-timer 13508 0 [snd-opl3-lib snd-pcm]
    snd-hwdep 4864 0 [snd-opl3-lib snd-emu10k1]
    snd-util-mem 1136 0 [snd-emu10k1]
    snd-page-alloc 6356 0 [snd-bt87x snd-emu10k1 snd-pcm]
    snd-ac97-codec 43532 0 [snd-emu10k1]
    snd-rawmidi 12672 0 [snd-mpu401-uart snd-emu10k1]
    snd-seq-device 3904 0 [snd-opl3-lib snd-emu10k1 snd-rawmidi]
    snd 30148 0 [snd-pcm-oss snd-mixer-oss snd-cmipci snd-opl3-lib snd-mpu401-uart snd-bt87x snd-emu10k1 snd-pcm snd-timer snd-hwdep snd-util-mem snd-ac97-codec snd-rawmidi snd-seq-device]
    soundcore 3332 16 [cmpci bttv snd]
    ide-scsi 8048 0
    tulip 41248 1
    apm 9608 2
  • Volgens je lsmod output, onder andere deze regels
    [code:1:6a7c20b5d6]
    cmpci 24976 0 (unused)
    snd-cmipci 18292 0
    [/code:1:6a7c20b5d6]
    heb je ook nog een onboard geluidskaart. Gebruik je deze en je Audigy2 allebei? Als je alleen de Audigy2 gebruikt, kun je waarschijnlijk beter de onboard geluidskaart in de BIOS disablen.
  • heb het onboard geluid nu disabled. Raar genoeg lukte dat niet via het bios, maar alleen via een jumper op het mb. Maar goed, dat zou geloof ik geen verschil moeten maken.
    lsmod ziet er nu als volgt uit:
    ]root@emile:~# lsmod
    Module Size Used by Tainted: P
    snd-pcm-oss 37572 0 (autoclean)
    snd-mixer-oss 12624 2 (autoclean) [snd-pcm-oss]
    agpgart 35776 3 (autoclean)
    nvidia 1628288 11 (autoclean)
    parport_pc 14724 1 (autoclean)
    lp 6752 0 (autoclean)
    parport 23264 1 (autoclean) [parport_pc lp]
    printer 7040 0
    ohci1394 16264 0 (unused)
    ieee1394 30828 0 [ohci1394]
    uhci 24560 0 (unused)
    ehci-hcd 14632 0 (unused)
    usbcore 58144 1 [printer uhci ehci-hcd]
    tuner 9696 1 (autoclean)
    bttv 67936 0
    i2c-algo-bit 6984 1 [bttv]
    i2c-core 12708 0 [tuner bttv i2c-algo-bit]
    videodev 5632 3 [bttv]
    snd-bt87x 5068 1
    snd-emu10k1 62292 1
    snd-pcm 56512 0 [snd-pcm-oss snd-bt87x snd-emu10k1]
    snd-timer 13508 0 [snd-pcm]
    snd-hwdep 4864 0 [snd-emu10k1]
    snd-util-mem 1136 0 [snd-emu10k1]
    snd-page-alloc 6356 0 [snd-bt87x snd-emu10k1 snd-pcm]
    snd-ac97-codec 43532 0 [snd-emu10k1]
    snd-rawmidi 12672 0 [snd-emu10k1]
    snd-seq-device 3904 0 [snd-emu10k1 snd-rawmidi]
    snd 30148 0 [snd-pcm-oss snd-mixer-oss snd-bt87x snd-emu10k1 snd-pcm snd-timer snd-hwdep snd-util-mem snd-ac97-codec snd-rawmidi snd-seq-device]
    soundcore 3332 10 [bttv snd]
    emu10k1-gp 1352 0 (unused)
    gameport 1452 0 [emu10k1-gp]
    pcmcia_core 38112 0
    ide-scsi 8048 1
    tulip 41248 1
    apm 9608 2
    Maar het probleem blijft: KDE start moeizaam op en een mp3 met Kaboodle afspelen lukt nauwelijks, de cpu-bel. blijft rond de 90% hangen. Die soundcore verwijderen lukt trouwens niet:soundcore: Device or resource busy. met rmmod -e krijg ik die melding weliswaar niet, maar de module wordt niet verwijderd.
    Eerlijk gezegd zie ik door de bomen het bos niet meer.
  • [quote:704f46bd14="Knepsel"]De top-output kopieren lukt helaasniet; de cpu-belasting verandert voortdurend. [/quote:704f46bd14] Als je top start, en dan kaboodle, en als de cpu belasting hoog is op q drukt. Dit is mijn top output, als ik met Kaboodle in kde een OGG muziek bestand afspeel.
    [code:1:704f46bd14]
    56 processes: 54 sleeping, 2 running, 0 zombie, 0 stopped
    CPU states: 12.6% user 22.4% system 0.0% nice 0.0% iowait 64.8% idle
    Mem: 514960k av, 180832k used, 334128k free, 0k shrd, 8172k buff
    94956k active, 69720k inactive
    Swap: 160608k av, 0k used, 160608k free 106644k cached

    PID USER PRI NI SIZE RSS SHARE STAT %CPU %MEM TIME CPU COMMAND
    905 jolo 16 0 15108 8612 11208 R 33.7 1.6 0:37 0 artsd
    833 root 15 0 148M 17M 132M S 0.5 3.5 0:03 0 X
    947 jolo 17 0 1916 1024 1784 R 0.5 0.1 0:00 0 top
    941 jolo 15 0 32388 18M 30840 S 0.1 3.6 0:00 0 kdeinit
    1 root 16 0 488 240 464 S 0.0 0.0 0:04 0 init
    2 root 34 19 0 0 0 SWN 0.0 0.0 0:00 0 ksoftirqd/0
    3 root 5 -10 0 0 0 SW< 0.0 0.0 0:00 0 events/0
    4 root 5 -10 0 0 0 SW< 0.0 0.0 0:00 0 kblockd/0
    5 root 15 0 0 0 0 SW 0.0 0.0 0:00 0 khubd
    6 root 25 0 0 0 0 SW 0.0 0.0 0:00 0 pdflush
    7 root 15 0 0 0 0 SW 0.0 0.0 0:00 0 pdflush
    8 root 25 0 0 0 0 SW 0.0 0.0 0:00 0 kswapd0
    9 root 10 -10 0 0 0 SW< 0.0 0.0 0:00 0 aio/0
    10 root 17 0 0 0 0 SW 0.0 0.0 0:00 0 kseriod
    11 root 15 0 0 0 0 SW 0.0 0.0 0:00 0 kjournald
    43 root 18 0 0 0 0 SW 0.0 0.0 0:00 0 scsi_eh_0
    131 root 10 -10 1404 536 1360 S < 0.0 0.1 0:00 0 dhcpcd
    bash-2.05b$
    [/code:1:704f46bd14]
    [quote:704f46bd14="Knepsel"]Die soundcore verwijderen lukt trouwens niet:Device or resource busy. met rmmod -e krijg ik die melding weliswaar niet, maar de module wordt niet verwijderd. [/quote:704f46bd14]
    Dat je module soundcore niet uit het geheugen kunt verwijderen kan wel kloppen. Deze module is vereist voor de geluidskaart.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.