Vraag & Antwoord

OS Linux

KDE upgraden

Anoniem
None
6 antwoorden
  • ik zit nu op Fedora Core 1.0 met KDE 3.1 en die wou ik gaan upgraden naar 3.2.2, dus ik ga naar kde.org, en download de stable version voor Fedora i386, in een mapje gezet…

    ik start de console , cd naar het mapje, en typ: [code:1:94ba2b8998]rpm -i *.rpm[/code:1:94ba2b8998]

    ik krijg de volgende errors [code:1:94ba2b8998][root@MSHOME kde]# rpm -i *.rpm
    error: Failed dependencies:
    qt >= 1:3.3.1 is needed by kdeartwork-3.2.2-0.1
    qt >= 1:3.3.1 is needed by kdeedu-3.2.2-0.1
    qt >= 1:3.3.1 is needed by kdelibs-3.2.2-0.1
    qt-devel >= 1:3.3.1 is needed by kdelibs-devel-3.2.2-0.1
    qt-designer >= 1:3.3.1 is needed by kdevelop-3.0.3-0.1
    /usr/lib/qt-3.3 is needed by redhat-artwork-0.93-1
    [/code:1:94ba2b8998]
    nou ik denk ik zal wel eerst PyQt moeten installeren die erbij zat,
    ik typ:[code:1:94ba2b8998] [root@MSHOME kde]# rpm -i PyQt-3.10-0.1.i386.rpm
    error: Failed dependencies:
    libsip.so is needed by PyQt-3.10-0.1
    [/code:1:94ba2b8998]

    nou, libsip.so zal dan wel bij sip-3.10-0.1.i386.rpm zitten, dan krijgen ik deze fout:
    [code:1:94ba2b8998] [root@MSHOME kde]# rpm -i sip-3.10-0.1.i386.rpm
    file /usr/bin/sip from install of sip-3.10-0.1 conflicts with file from package sip-3.8-1
    file /usr/lib/python2.2/site-packages/libsip.so from install of sip-3.10-0.1 conflicts with file from package sip-3.8-1
    [/code:1:94ba2b8998]

    Wat moet ik nu doen?
  • Volgens mij heb je geen PyQt nodig, maar de gewone Qt. Verder zal je ook wel een nieuwe versie an Arts moeten hebben.
  • ik heb een gratis QT versie van de trolltech website gedownload en geinstalleerd.. alleen die is versie 3.3.0 en ik heb 3.3.1 nodig..
  • Heb je het al met deze qt-3.3.1-0.5.i386.rpm geprobeerd?
  • [quote:c95bce248c="jolo"]Heb je het al met deze qt-3.3.1-0.5.i386.rpm geprobeerd?[/quote:c95bce248c]

    [code:1:c95bce248c][root@MSHOME downloads]# rpm -i qt-3.3.1-0.5.i386.rpm
    warning: qt-3.3.1-0.5.i386.rpm: V3 DSA signature: NOKEY, key ID 30c9ecf8
    file /usr/bin/qtconfig from install of qt-3.3.1-0.5 conflicts with file from package qt-3.1.2-14
    [root@MSHOME downloads]#[/code:1:c95bce248c]

    ik dacht.. miss werkt –upgrade wel..
    [code:1:c95bce248c][root@MSHOME downloads]# rpm –upgrade qt-3.3.1-0.5.i386.rpm
    warning: qt-3.3.1-0.5.i386.rpm: V3 DSA signature: NOKEY, key ID 30c9ecf8
    error: Failed dependencies:
    qt = 1:3.1.2-14 is needed by (installed) qt-devel-3.1.2-14
    /usr/lib/qt-3.1 is needed by (installed) redhat-artwork-0.88-1
    [/code:1:c95bce248c]

    niet dus… wat moet ik nu proberen? oude qt versie te verwijderen?
  • [quote:552e32f098="Chestah"]niet dus… wat moet ik nu proberen? oude qt versie te verwijderen?[/quote:552e32f098] Dat is waarschijnlijk niet nodig. Je kunt het proberen met de –force optie.
    [code:1:552e32f098]
    rpm -Uvh –force qt-3.3.1-0.5.i386.rpm
    [/code:1:552e32f098][Enter]

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.