Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

auto soft power off

hws
8 antwoorden
  • Inleiding: :D
    "Auto soft power off" is het softwarematig uitschakelen van de computer. Als je onder Windows de computer afsluit, dan wordt niet alleen Windows afgesloten, maar de hele computer.

    Probleem: :-?
    Onder linux heb ik dit niet meer. Ik heb het probleem gehad onder Redhat 9 en Mandrake 9. Wanneer ik aangeef de computer af te willen sluiten, wordt wel de harde schijf uitgeschakeld, maar de voeding blijft actief. Vervolgens moet ik de pc dan alsnog handmatig afsluiten.
    Ik heb alle updates voor redhat geïnstalleerd, maar het probleem is nog niet opgelost. Is het misschien een instelling in redhat die ik moet aanpassen?
  • Waarschijnlijk heb je de apm of acpi module niet draaien. Dan sluit je systeem idd niet af.

    Kijk eens of ie ertussen staat met 'lsmod'.
  • geen van beiden staan ertussen. Ze zijn dus kennelijk niet geactiveerd. Hoe zorg ik ervoor dat ze dit wel doen?

    apmd wordt wel automatisch opgestart.
  • ik heb precies hetzelfde. Hopelijk komt er snel iemand met een antwoordt.
  • [quote:fc8103535e="yolk2003"]"Auto soft power off" is het softwarematig uitschakelen van de computer. Als je onder Windows de computer afsluit, dan wordt niet alleen Windows afgesloten, maar de hele computer. Onder linux heb ik dit niet meer. Ik heb het probleem gehad onder Redhat 9 en Mandrake 9.[/quote:fc8103535e] Om wat voor een (merk) PC gaat het?

    Als ik bij mij op een Athlon XP 1700+ Fedore Core 1 uitzet via Rode Hoed > Afmelden > Uitzetten > OK, dan gaat bij mij de PC helemaal uit. De PC gaat bij mij ook helemaal uit, als ik in tekst mode of in een Terminal typ [code:1:fc8103535e] halt -p [/code:1:fc8103535e][Enter]

    Bij mij zijn de modules acpi en/of apm ook niet geladen. Maar typ ik [b:fc8103535e] dmesg | grep apm [/b:fc8103535e] dan is de output
    [code:1:fc8103535e]
    apm: BIOS version 1.2 Flags 0x0b (Driver version 1.16)
    [/code:1:fc8103535e] Ik heb hier in Fedore Core 1 er niets voor hoeven configureren. De Power Management in de BIOS staat bij mij [Disabled]

    {Edit]

    In Fedora Core 1 is bij mij geïnstalleerd: APMd
    [code:1:fc8103535e]
    rpm -qa | grep apm
    apmd-3.0.2-20
    [/code:1:fc8103535e]

    [/Edit]
  • acpi in Fedora Core 1 zou moeten werken indien geïnstalleerd is
    [code:1:f479d3b27d]
    rpm -qa | grep acpi
    acpid-1.0.2-5
    [/code:1:f479d3b27d]
    En als boot option
    [code:1:f479d3b27d]
    acpi=on
    [/code:1:f479d3b27d]
    Na de reboot
    [code:1:f479d3b27d]
    dmesg | grep acpi
    Kernel command line: ro root=LABEL=/ hdd=ide-scsi rhgb init 3 acpi=on
    PCI: if you experience problems, try using option 'pci=noacpi' or even
    'acpi=off'
    [/code:1:f479d3b27d]
    en
    [code:1:f479d3b27d]
    dmesg | grep apm
    apm: BIOS version 1.2 Flags 0x0b (Driver version 1.16)
    apm: overridden by ACPI.
    [/code:1:f479d3b27d] En bij mij blijkt op mijn Athlon XP 1700+ net zoals apm ook acpi te werken.


    En dan nog een [Edit]

    Als ik met de boot option [code:1:f479d3b27d] acpi=on [/code:1:f479d3b27d] acpi inschakel, dan wordt de volgende module geladen
    [code:1:f479d3b27d]
    /sbin/lsmod | grep acpi
    asus_acpi
    [/code:1:f479d3b27d]
    En inderdaad in die Athlon XP 1700+ zit een Asus moederbord.

    [/Edit]
  • hmmm, op mijn Asus L3800C laptoppie crahst ie. Logisch overigens, want bij de configuratie kreeg ik de opmerking dat de checksum niet klopte.. Blijkbaar komt ie dan toch door de installlatie heen :( ….
    De waarschuwing komt pas bij de configursatie…
    Ik zal eens naar mijn modules kijken, zit nu effe in XP…

    Edit: bij het starten laad ie acpid met OK… verder nog niet gekeken in mijn systeem. Google en groups: FC-2 lijkt nog te nieuw…
  • Ik heb Core 2 en nu gaat mijn systeem wel normaal uit, zoals in Windows.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.