Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

FC1: Kernel 2.6 installeren

nougabolle
3 antwoorden
  • Ik wil kernel2.6 hebben.
    Gebasseerd op de volgende site wil ik dit doen.
    http://www.fedoranews.org/jorge/howto/howto01.shtml

    ik heb de volgende bestanden gedownload:
    kernel-2.6.5-1.339.i686.rpm kernel-source-2.6.5-1.339.i386.rpm
    kernel-doc-2.6.5-1.339.i386.rpm

    1e vraag:
    wat is:
    [code:1:b4e7d8ee7f]kernel-unsupported-modules[/code:1:b4e7d8ee7f]

    gebasseerd op vermelde site doe ik het volgende
    1- Installeren kernel2.6 –> niet upgraden
    2- mkdir /sys
    3- echo "none /sys sysfs defaults 0 0" >> /etc/fstab
    4- mv /boot/initrd-2.6.0-1.1.103.img
    oot
    $ cd /lib/modules
    $ /sbin/mkinitrd /boot/initrd-2.6.0-1.1.103.img 2.6.0-1.1.103/

    waar 2.6.0-1.1.103 dus 2.6.5-1.339 is

    5- mv /etc/sysconfig/hwconf
    oot
    6 - Kudzu uitzetten
    7- scsi weghalen uit GRUB

    3e vraag : hoe haal ik scsi weg uit de grub

    8- Kernel 2.6 now uses the file /etc/modprobe.conf instead of /etc/modules.conf, if you activated the kudzu service and moved/deleted
    enamed your /etc/sysconfig/hwconf it should've been created.
    One issue that you might encounter is that the USB Human Interface module has changed in 2.6, it is called uhci-hcd instead of usb-uhci, so you may need to modify your /etc/modprobe.conf

    alias usb-controller uhci-hcd

    or add the hardcoded entry in your /etc
    c.sysinit for modprobing uhci-hcd (thanks to Frank Merenda for this).
    Other modules that changed: "keybdev" into "usbkbd" and "mousedev" into "usbmouse".

    4e vraag: wat betekendt dit bij punt 8? hoe doe ik dat?
    5e vraag: zie ik iets over het hoofd?
    sorry voor de lange topic, maar ik ben onzeker nu vwb de installatie van kernel2.6
    Allerlei technische dingen die ik niet begrijp. Upgraden naar FC2 wil ik niet.

    Ik ben degene die mij door de installatie van 2.6 loodst zeer erkentelijk en dankbaar.
  • [quote:b1d2eeb6c7="nefertitis"]1e vraag: wat is: kernel-unsupported-modules [/quote:b1d2eeb6c7] Weet ik eigenlijk ook niet. Die drie bestanden die je gedownload hebt voor Fedora Core 1zou voldoende moeten zijn.
    [quote:b1d2eeb6c7="nefertitis"]3e vraag : hoe haal ik scsi weg uit de grub [/quote:b1d2eeb6c7] In /boot/menu.lst staat ergens in de kernel-2.6.5 regel zoiets als [b:b1d2eeb6c7] hdd=ide-scsi [/b:b1d2eeb6c7] dat dan weg kan.

    [quote:b1d2eeb6c7="nefertitis"]4e vraag: wat betekendt dit bij punt 8? hoe doe ik dat? [/quote:b1d2eeb6c7] Precies wat er staat. Je bewerkt [b:b1d2eeb6c7] /etc/modprobe.conf [/b:b1d2eeb6c7] zoals het toevoegen van die: alias usb-controller uhci-hcd

    [quote:b1d2eeb6c7="nefertitis"]5e vraag: zie ik iets over het hoofd? [/quote:b1d2eeb6c7] Dat hangt er vanaf wat voor een hardware je hebt. Het ziet er naar uit dat in die binary 2.6.5 kernel de firewire modules ontbreken.

    Ik heb de kernel rpm's ook geïnstalleerd in FC1 op mijn Athlon XP 1700+. Maar als ik opstart vanaf de kernel 2.6.5
    [code:1:b1d2eeb6c7]
    <knip>
    EXT3-fs: mounted filesystem with ordered data mode
    Freeing unused kernel memory: 148k freed
    [/code:1:b1d2eeb6c7]
    Hier blijft het opstarten hangen.


    Op mijn Dual Pentium III had ik een tijdje geleden in FC1, al de kernel rpm's 2.6.0 en 2.6.3 geïnstalleerd. Die startte wel goed op, al was dat met een aantal foutmeldingen.


    Welke is vraag 2
  • :lol: vraag 2 ben ik vergeten

    hmmm,

    als een linux veteraan als jij met kernel2.6 enige problemen hebt poog ik het niet.
    Dan maar w8ten op Core-2

    bedankt.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.