Vraag & Antwoord

OS Linux

slackware9.1 geluidsprobleem. driver werkt in knoppix wel.

Anoniem
musicom76
5 antwoorden
  • Hallo, ikben een beginnend linux gebruiker, heb een slackware9.1 systeem en alles werkt prima, behalve dan de geluidskaart… Ik heb een Ensonic AudioPCI kaart, met de Creative CT5880-DCQ chip. In Knoppix wordt hij herkend (weetikveel hoe knoppix dat doet) als Ensonic AudioPCI 5880, en de ct1371 driver wordt gebruikt. Dit werkt dan ook.
    Als ik dan deze driver meebak in mijn kernel (geprobeerd met 2.4.22 en 2.6.2), dan word hij echter niet herkend en alsaconf kan ook al geen PNP Pci kaarten vinden.
    Tot dusver heb ik het geluid dus niet kunnen laten werken.

    Wat mij ook opviel was dat bij het configureren van de 2.6.2 kernel de optie Plug 'n Play support 'niet uitvouwde'. met make menuconfig kon je erop drukken maar hij vouwt niet uit. bij 2.4.22 was dat wel zo. Misschien heeft het er iets mee te maken…

    weet iemand een oplossing voor of oorzaak van dit probleem ?
  • [quote:ad48ede4ec="musicom76"]Ik heb een Ensonic AudioPCI kaart, met de Creative CT5880-DCQ chip. In Knoppix wordt hij herkend als Ensonic AudioPCI 5880, en de ct1371 driver wordt gebruikt. Dit werkt dan ook. Als ik dan deze driver meebak in mijn kernel (geprobeerd met 2.4.22 en 2.6.2), dan word hij echter niet herkend en alsaconf kan ook al geen PNP Pci kaarten vinden. [/quote:ad48ede4ec] Hoe heb je dat precies geconfigureerd? Als je naar de kernel-source map van 2.6.2 gaat. Had je daar bij kernel option > Sound > een <M> geselecteerd bij Sound card support? En bij ALSA ook een <M>. En bij PCI devices > een <M> bij (Creative) Ensonic AudioPCI 1371/1373 (NEW).

    Heb je de /sbin/lsmod output van Slackware 9.1 al vergeleken met die van knoppix? En had je wel je gewone users occount lid gemaakt van de groep [b:ad48ede4ec] sys [/b:ad48ede4ec]
  • Ik heb bij sound support en alsa <Y> gekozen, dus meebakken in de kernel zelf. De driver heb ik zowel meegebakken in de kernel geprobeerd, als ook als module.

    wat betreft die group sys, ik heb ook geen geluid als root zelfs. trouwens zijn de users standaard niet lid van sys in slackware? dus als ik als root kde gebruik, geen geluid. ook alsamicer start niet op, (snd_ctl_open failed for default: No such file or directory

    dat /sbin/lsmod zal ik es proberen, nog nooit bekeken. Ik wist dat die es1371 (sorrie, dus geen ct1371) module geladen werd bij knoppix, omdat hij dat aangaf bij het booten.
  • hm. /sbin/lsmod geeft in knoppix dit weer:
    ———————————–
    knoppix@ttyp0[knoppix]$ /sbin/lsmod
    Module Size Used by Not tainted
    efs 7436 0 (autoclean)
    hfs 76864 2 (autoclean)
    minix 19848 0 (autoclean)
    ntfs 51168 0 (autoclean)
    xfs 525120 0 (autoclean)
    sg 25916 1 (autoclean)
    autofs4 8756 1 (autoclean)
    af_packet 13448 0 (autoclean)
    reiserfs 169616 0 (autoclean)
    ext3 64132 0 (autoclean)
    jbd 46292 0 (autoclean) [ext3]
    nls_iso8859-1 2876 3 (autoclean)
    nls_cp437 4380 2 (autoclean)
    agpgart 38296 0 (unused)
    tuner 9408 1
    msp3400 15596 1 (autoclean)
    bttv 95968 0 (unused)
    i2c-algo-bit 6888 1 [bttv]
    i2c-core 12100 0 [tuner msp3400 bttv i2c-algo-bit]
    videodev 5472 2 [bttv]
    gameport 1388 0
    ac97_codec 11916 0
    soundcore 3428 0 [bttv]
    8139too 17096 1
    mii 2256 0 [8139too]
    crc32 2832 0 [8139too]
    serial 52004 0 (autoclean)
    usb-uhci 21868 0 (unused)
    usbcore 57472 1 [usb-uhci]
    apm 9768 2
    rtc 6940 0 (autoclean)
    cloop 9092 2
    ———————————–

    is het niet vreemd dat soundcore used is door bttv (bttv is toch een chip voor tvkaarten ? ik heb wel zo'n kaart erin hangen… maar wat heeft dat met sound te maken..)

    trouwens die es1371 zie ik nergens terug. maar toch heb ik geluid… sndconfig herkende hem automatisch. Maarja sndconfig zit niet bij Slackware, maar met alsaconfig zou het toch ook moeten kunnen zou je zeggen?
  • [quote:108d91a27a="musicom76"]Ik heb bij sound support en alsa <Y> gekozen, dus meebakken in de kernel zelf. De driver heb ik zowel meegebakken in de kernel geprobeerd, als ook als module. [/quote:108d91a27a] Het beste is voor al die sound options, ook bij sound support en alsa de <M> te kiezen.

    [quote:108d91a27a="musicom76"]wat betreft die group sys, ik heb ook geen geluid als root zelfs. trouwens zijn de users standaard niet lid van sys in slackware? [/quote:108d91a27a] Nee, tenzij je dit in adduser hebt geregeld.

    [quote:108d91a27a="musicom76"]is het niet vreemd dat soundcore used is door bttv (bttv is toch een chip voor tvkaarten ? ik heb wel zo'n kaart erin hangen… maar wat heeft dat met sound te maken..) [/quote:108d91a27a] Dat zou wel kunnen. Een tv-kaart heeft ook een audio chip.

    Deze output in knoppix 3.3 zijn bij mij de audio en tv-kaart modules.
    [code:1:108d91a27a]
    emu10k1 61064 0
    sound 55276 0 [emu10k1]
    ac97_codec 11916 0 [emu10k1]
    tuner 9408 1 (autoclean)
    tvaudio 12444 1 (autoclean)
    msp3400 15596 1 (autoclean)
    bttv 95968 0 (unused)
    i2c-algo-bit 6888 1 [bttv]
    i2c-core 12100 0 [tuner tvaudio msp3400 bttv i2c-algo-bit]
    soundcore 3428 7 [emu10k1 sound bttv]
    videodev 5472 3 [bttv]
    [/code:1:108d91a27a]
    [quote:108d91a27a="musicom76"]trouwens die es1371 zie ik nergens terug. maar toch heb ik geluid..[/quote:108d91a27a] Dan kun je ook nog de outputs vergelijken van dmesg.
    [code:1:108d91a27a]
    dmesg | grep es1371
    [/code:1:108d91a27a][Enter]

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.