Vraag & Antwoord

OS Linux

Kan bepaalde webpagina niet laden met Konqueror

Anoniem
jolo
12 antwoorden
  • Nu java en flash bij mij in Konqueror geinstalleerd zijn heb ik tot nu toe iedere willekeurige webpagina naar tevredenheid kunnen laden.
    Echter liep ik vandaag tegen een probleem aan dat mij toch wel zou teleurstellen - Ik gebruik Konqueror namelijk zeer graag - als het niet opgelost zal worden, namelijk, dat de inlogpagina voor internetbankieren van postbank.nl niet laadt. Vanaf de pagina (hoofdpagina) http://www.postbank.nl/ing/pp/page/home/0,,1859_103763,00.html
    kan je in principe inloggen door op [log in] onder "Mijn Postbank.nl" te klikken. Echter als ik dat doe dan verschijnt er welliswaar een nieuwe URL bovenaan en wordt het scherm leeg, maar er wordt vervolgens niets geladen.
    Het scherm blijft leeg en al vrij snel lees ik onderaan "Pagina geladen". Als ik de bron van het lege scherm bekijk staat er ook niets in.

    Ik heb hetzelfde geprobeerd met Mozilla, maar deze kan de pagina [u:728309f99d]wel[/u:728309f99d] laden.

    Zou iemand mij kunnen vertellen wat er precies aan de hand is en of dit probleem te verhelpen is?

    (JavaScript staat overigens aan)
  • Welke versie van Konqueror heb je? Het is namelijk zo dat ouder versies (ik meen 3.1.3 en eerder) inderdaad problemen hebben met de postbank site. Ik heb hier konqueror 3.2.1 en die doet het in ieder geval vlekkeloos met de postbank site, aangezien diverse mensen hier thuis ermee bankieren via MijnPostbank of Girotel.
  • Dien evt een bugrapport in van konqueror waarin je precies uitlegt hoe je bij de 'lege' pagina kunt komen.
  • Dus het komt er dus op neer dat ik moet upgraden.
    Als ik ga upgraden dan wil ik er wel zeker van zijn dat er geen dingen mis gaan die met mijn beperkte linux-kennis niet meer te herstellen zijn.
    Ik ben hiermee onlangs vreselijk mee op m'n bek gegaan, want ik moest alles weer opnieuw gaan installeren. Zelfs mijn backup-drive waar al de belangrijke downloads opstonden was op merkwaardige wijze ineens gewist. :x
    Dit dus nooit meer!

    Ik zal even wat belangrijke gegevens noemen betreft mijn huidige installatie.
    - Mandrake 9.2
    - Kernel 2.4.22-10mdk, kernel-source 2.4.22-10mdk
    - KDE werkomgeving 3.1.3

    Ik meen ergens op internet te hebben gelezen dat het heel goed mogelijk schijnt te zijn slechts Konqueror van een update te voorzien, dus dat je dan niet per defintie tegen afhankelijkheidsproblemen hoeft aan te lopen. Klopt dit?
    Zo ja, dan zou dat natuurlijk wel fijn zijn aangezien ik slechts de update van Konqueror nodig heb.

    Maar als ik wil updaten, hoe moet ik dat dan doen?
    Welke rpm's moet ik vernieuwen en in welke volgorde moet ik die dan installeren? En moet ik misschien eerst bepaalde installaties ongedaan maken alvorens ik de nieuwe installeer?

    Ik hoop dat iemand mij kan vertellen, liefst in stappen, hoe ik het aan moet pakken.
  • Je kunt in ieder geval niet alleen konqueror vervangen, aangezien deze onderdeel is van KDE en je dus KDE zult moeten updaten. Toen ik net echter wilde uitzoeken welke pakketen je nodig had bleken de Mandrake ftp-mirrors grotendeels leeg oid. Ik vermoed dat ze 10.0 aan het uploaden zijn oid.
    Ik denk overigens dat Mandrake zelf een nieuwere KDE wel als update aanbiedt. Ik weet echter niet zo veel van Mandrake, dus voor je weer kunt herinstalleren zou ik toch even wachten tot een van de fanatieke Mandrake freaks langskomt ;)
  • Bij het Googlen kwam ik het script "Konstruct" tegen (http://developer.kde.org/build/konstruct/) welk mij uitlegde dat het mij zal helpen met het installeren van KDE 3.2.2.
    Heeft er hier iemand ervaring met dit script? Werkt het?

    Ik heb zoals in de README geadviseerd werd (maak immers gebruik van de officiele Mandrake 9.2 ditributie) "Detective" (script-onderdeel) gebruikt om te kijken of, wil ik het script succesvol laten verlopen, de benodigde rpm installaties wel aanwezig zijn. Deze geeft deze (als het goed is) weer als dat het geval is.
    Nu is het vreemde alleen dat ik volgens mij al de benodigde onderdelen (maakte gebruik van de Mandrake CDROM-source) heb geinstalleerd, maar dat "Detective" toch zegt dat er pakket-instalaties missen.

    Geef hier even het resultaat zoals in de console weergegeven:

    [quote:cb83f3975c]
    [root@localhost detektive]# make
    [===== NOW BUILDING: detektive-0.1 =====]
    [fetch] complete for detektive.
    [checksum] complete for detektive.
    [extract] complete for detektive.
    [patch] complete for detektive.
    [configure] complete for detektive.
    "Detektive" investigates your system and tries to list missing packages.

    Detected Mandrake 9.2 as distribution.

    Checking for known uninstalled rpm packages which may be missing:
    Package: XFree86-devel (REQUIRED)
    Package: yac (REQUIRED)
    Package: libjpeg-devel (REQUIRED)
    Package: libxpm-devel (REQUIRED)
    Package: libungif-devel (REQUIRED)
    Package: libncurses-devel (REQUIRED)
    Package: libpng-devel (REQUIRED)
    Package: libopenssl (REQUIRED)
    Package: libbzip2-devel (REQUIRED)
    Package: libtiff-devel (REQUIRED)
    Package: libpcre-devel (REQUIRED)

    If you have installed these from source you may ignore this list.
    [build] complete for detektive.
    [all] complete for detektive.

    [/quote:cb83f3975c]


    Zelfs de onderdelen die er qua naam maar een beetje op leken heb ik voor de zekerheid ook maar geinstalleerd, tevergeefs.
    Er staat dat ik de lijst mag negeren als ik de pakketen van de "source" heb geinstalleerd. Valt daar misschien de CDROM-source ook onder? In dat geval is er misschien niets aan de hand.

    Als ik van iemand hier te horen krijg dat "Konstruct" werkt dan denk ik dat ik de upgrade-gok maar waag.
  • Nee daar hoort de cdrom helaas niet toe. From source betekent dat je pakketten zelf compileert. Dat is wat Konstruct dus ook doet, KDE compileren en dat duurt behoorlijk lang. Of het werkt weet ik niet, ik compileer KDE gewoon met de hand, maar het is nog makkelijker om gewoon Mandrake binaries te gebruiken. Op de KDE ftp-mirrors staan echter geen Mandrake binaries en ik kom nog steeds niet op de Mandrake ft–mirrors.
  • Ik vroeg mij af of de Redhat binaries niet in dergelijke mate overeen komen met die van Mandrake dat ik die misschien ook kan gebruiken zonder al te veel conflicten te krijgen. Of gaat dat dan toch fout?
  • Ik bedenk mij net dat ik de rpm's voor kde 3.2.2 heb op CDROM van de Mandrake 10.0 Community-versie. Maar aangezien ik mensen doorgaans positiever hoor praten over de 3.2.1-versie zou ik eigenlijk deze liever willen.
    Dus als ik de Redhat ook kan gebruiken doe ik dat dus liever.
    Anders dan toch maar van de source.
  • in welk opzicht is men positiever over kde 3.2.1 dan over kde 3.2.2?

    Max
  • Ik denk dat hier sprake is van een misverstand. Mandrake 10 Community heeft net zoals Mandrake 10 Official KDE 3.2.0.

    Er zijn ook wel Non-official Mandrake 9.2 KDE 3.2.1 rpm's. Gebruik deze op eigen risico. http://www.heger.ch/linux/sagittarius/non_official_kde3.2_mdk9.2/
  • Ik denk dat ik mij maar ga wagen aan de installatie van KDE 3.2.1 gebruikmakend van http://www.heger.ch/linux/sagittarius/non_official_kde3.2_mdk9.2/.
    (bedankt jolo)
    Bij het uitvoeren van MandrakeUpdate in de console krijg ik onderstaand als output alvorens het Mandrake Vernieuwen-scherm opkomt:

    [quote:1e9ed1a5be]
    [root@localhost harald]# MandrakeUpdate
    bezig met onderzoeken van het synthesis bestand [/var/lib/urpmi/synthesis.hdlist.Installation CD 1 (x86) (cdrom1).cz]
    bezig met onderzoeken van het synthesis bestand [/var/lib/urpmi/synthesis.hdlist.Installation CD 2 (x86) (cdrom2).cz]
    bezig met onderzoeken van het synthesis bestand [/var/lib/urpmi/synthesis.hdlist.International CD (x86) (cdrom3).cz]
    bezig met onderzoeken van het synthesis bestand [/var/lib/urpmi/synthesis.hdlist.main_ftp.cz]
    bezig met onderzoeken van het synthesis bestand [/var/lib/urpmi/synthesis.hdlist.contrib_ftp.cz]
    Zou pakket kernel-linus2.2-2.2.25-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-multimedia-2.4.22.21mm.1mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-tmb-2.4.22.21.tmb.1mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-2.4.22.10mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel22-smp-2.2.20-9mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel2.4-marcelo-2.4.22-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-multimedia-smp-2.4.22.21mm.1mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-smp-2.4.22.10mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-secure-2.4.22.10mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-enterprise-2.4.22.10mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-p3-smp-64GB-2.4.22.10mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-i686-up-4GB-2.4.22.10mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-tmb-enterprise-2.4.22.21.tmb.1mdk-1-1mdk.i586 installeren, niet opwaarderen
    toegevoegd medium update_source
    bezig met onderzoeken van het synthesis bestand [/var/lib/urpmi/synthesis.hdlist.Installation CD 1 (x86) (cdrom1).cz]
    bezig met onderzoeken van het synthesis bestand [/var/lib/urpmi/synthesis.hdlist.Installation CD 2 (x86) (cdrom2).cz]
    bezig met onderzoeken van het synthesis bestand [/var/lib/urpmi/synthesis.hdlist.International CD (x86) (cdrom3).cz]
    bezig met onderzoeken van het synthesis bestand [/var/lib/urpmi/synthesis.hdlist.main_ftp.cz]
    bezig met onderzoeken van het synthesis bestand [/var/lib/urpmi/synthesis.hdlist.contrib_ftp.cz]
    bezig met bron hdlist (of synthesis) van "update_source" te ontvangen…
    …ontvangen is klaar
    bezig met onderzoeken hdlist bestand [/var/cache/urpmi/partial/hdlist.update_source.cz]
    bezig met schrijven van lijstbestand voor medium "update_source"
    onderzoeken van publieke sleutelbestand van "update_source"…
    …sleutel 22458a98 uit publiek sleutelbestand van "update_source" geïmporteerd
    hdlist synthesis bestand opgebouwd voor medium "update_source"
    0 headers in de buffer gevonden
    bezig met het verwijderen van 0 verouderde titels in de cache
    config-bestand [/etc/urpmi/urpmi.cfg] wegschrijven
    config-bestand [/etc/urpmi/urpmi.cfg] wegschrijven
    bezig met onderzoeken van het synthesis bestand [/var/lib/urpmi/synthesis.hdlist.Installation CD 1 (x86) (cdrom1).cz]
    bezig met onderzoeken van het synthesis bestand [/var/lib/urpmi/synthesis.hdlist.Installation CD 2 (x86) (cdrom2).cz]
    bezig met onderzoeken van het synthesis bestand [/var/lib/urpmi/synthesis.hdlist.International CD (x86) (cdrom3).cz]
    bezig met onderzoeken van het synthesis bestand [/var/lib/urpmi/synthesis.hdlist.main_ftp.cz]
    bezig met onderzoeken van het synthesis bestand [/var/lib/urpmi/synthesis.hdlist.contrib_ftp.cz]
    bezig met onderzoeken van het synthesis bestand [/var/lib/urpmi/synthesis.hdlist.update_source.cz]
    Zou pakket kernel-linus2.2-2.2.25-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-2.4.22.30mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-multimedia-2.4.22.21mm.1mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-tmb-2.4.22.21.tmb.1mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-2.4.22.10mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel22-smp-2.2.20-9mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel2.4-marcelo-2.4.22-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-i686-up-4GB-2.4.22.30mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-enterprise-2.4.22.30mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-multimedia-smp-2.4.22.21mm.1mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-smp-2.4.22.10mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-secure-2.4.22.10mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-enterprise-2.4.22.10mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-p3-smp-64GB-2.4.22.10mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-smp-2.4.22.30mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-p3-smp-64GB-2.4.22.30mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-secure-2.4.22.30mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-i686-up-4GB-2.4.22.10mdk-1-1mdk.i586 installeren, niet opwaarderen
    Zou pakket kernel-tmb-enterprise-2.4.22.21.tmb.1mdk-1-1mdk.i586 installeren, niet opwaarderen
    [/quote:1e9ed1a5be]

    Ik vraag mij af in hoeverre ik de adviezen gegeven in de console "Zou het pakket ……installeren, niet opwaarderen" serieus moet nemen om geen risico's te lopen bij het upgraden van KDE. Is het echt nodig om ze te installeren?

    Jolo, bedoel je dat ik de vernieuwingen "Beveiligingsverbeteringen", "Programmafout-reparaties" en "Gewone bijgewerkte pakketten" ook allemaal moet installeren alvorens ik KDE ga vernieuwen?

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.

Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord