Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

gmplayer werkt wel vanuit terminal, niet vanuit wmaker

musicom76
5 antwoorden
  • Ik heb een vaag probleem met MPlayer.

    Ik draai Windowmaker op een archlinux systeem, en heb als root mplayer geinstalleerd met pacman. Als ik (als user) vanuit een terminal '(/usr/bin/)gmplayer' intik, wordt de gui keurig opgestart. Als ik vervolgens ditzelfde intik bij het wmaker-menu
    un…, dan verschijnt de gui, en het controlepaneel is volledig zwart. Ook wordt nu niet het MPlayer-logo getoond in het videowindow. Ditzelfde probleem doet zich voor wanneer ik een dock-button of menu-entry maak met als commando gmplayer.

    Ik heb mplayer al es opnieuw geinstalleerd maar dit maakte niet uit.

    Heeft iemand een vaag (of duidelijk) idee waar dit aan kan liggen ?
  • Nope, maar wellicht kun je erachter te komen door in de runregel 'gmplayer > ~/gmplayer.log' te tikken? Ik weet niet zeker of het directen ook via een wm werkt, maar je kunt het proberen. De eventuele errors zouden dan in ~/gmplayer.log terrecht moeten komen.
  • Hoi,

    Bij mij werkt gmplayer alleen op de voorgrond, dus de opdracht 'gmplayer &' werkt bij mij niet. Alleen 'gmplayer' werkt wel (SuSE 8.2 / 9.0)… De reden daarvan heb ik niet kunnen achterhalen; in situaties waarin dat nodig is gebruik ik dan ook gewoon de command line interface: mplayer.

    Groet,

    Philip
  • Het probleem dat musicom76 schetst kom ik ook wel eens tegen. Een oplossing (die bij mij werkt) is een "batchfile", een bash script met als inhoud (ongeveer)
    [code:1:236b5415b1]
    cd /usr/bin
    ./<programma>
    [/code:1:236b5415b1]
    Om de een of andere reden werkt dit vaak.

    Greetz, dJezzer 8)
  • Bedankt voor de antwoorden. Ik zal eens in die log kijken. De batch oplossing had ik ook al geprobeerd, maar dat werkte niet. Ik zou ook niet weten waarom het zou werken want /usr/bin staat in PATH, maar ik heb het voor de zekerheid toch geprobeerd.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.