Vraag & Antwoord

OS Linux

(SuSE 9.0) Linux Netwerkje

6 antwoorden
  • Gegroet allen, Ik heb thuis een netwerkje gebouwd van 3 computers: - Server (dual pentium pro 200, 256MB EDO ECC, 325GB+ HDDs) - Werkstation (PIII 800, 512MN SD-RAM, 160GB HDD0 - Notebook (PII 366, 64MB EDO(?), 20GB HDD) De server moet alle homedirs van verschillende gebruikers gaan beheren, en deze wilde ik middels NFS koppelen aan het werkstation/het notebook. Ik heb in /etc/exports het volgende aangegeven: /home/multimedia-1/ 10.0.0.* (ro,root_squash,sync,nohide) /home/multimedia-2/ 10.0.0.* (ro,root_squash,sync,nohide) /home/user1 10.0.0.253 (rw,no_root_squash,sync,nohide) Als ik nu /home/user1 van de server op mijn werkstation/notebook wil mounten, gaat er iets mis met de rechten... de gebruikers staan op alle 3 de computers geregistreerd met dezelfde uid, gid, username en password... Enig id wat ik verkeerd doe? BvD,
  • Heb je op de NFS client de map aangegeven in de /etc/fstab en users rechten gegeven deze schijf te mounten? iets als server:/home/user1 /mnt/user1 nfs user 0 0
  • nee, ik heb hem zodanig ingesteld dat de schijf automatisch wordt gemount tijdens het opstarten van het systeem. dit is een fragment van mijn fstab: [code:1:9f551413b4] zeus:/home/multimedia-1 /media/multimedia-1 nfs defaults 0 0 zeus:/home/multimedia-2 /media/multimedia-2 nfs defaults 0 0 zeus:/home/pegasys /home/pegasys nfs defaults 0 0 [/code:1:9f551413b4] de rechten staan op de te exporteren directory goed ingesteld, dus waarom werkt dit dan niet goed?
  • Zijn de nfs en portmap services gestart? bestaat de directory waarop je wilt mounten? Heb je al een met de hand proberen te mounten ( "mount -t nfs zeus:/home/pegasys /home/pegasys" )? krijg je dan misschien een foutmelding? Kijk eventueel nog in /var/log/messages of daar een foutmelding staat.
  • Wellicht een domme opmerking maar in je /etc/exports staat [code:1:27305b705a] /home/user1 10.0.0.253 (rw,no_root_squash,sync,nohide) [/code:1:27305b705a] Nu wil je server:/home/pegasys gaan mounten, maar die heb je niet in exports staan. Tweede punt waar je wel zeker van moet zijn is dat je ook daadwerkelijk 10.0.0.253 als IP hebt.
  • /home/user1 was een voorbeeldje, /home/pegasys is de daadwerkelijke tekst in exports. Ik ben heel erg zeker dat de ip-adressen kloppen, en portmapper en de hele ratteplan draaien ook goed. aangezien de "multimedia" shares goed werken, en het probleem zich alleen voordoet bij de homedirs van gebruikers... Ze worden goed gemount, krijg ook geen foutmeldingen, alleen is 3/4 van de mappen leeg, alsof ik geen leesrechten heb...

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.