Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

kernel geeft DriveStatusError en SeekCompleteError bij afslu

Anoniem
musicom76
16 antwoorden
  • Ik heb de laatste tijd iets heel engs met een van mijn hdd's. Het werkt allemaal prima zowle onder linux als windows, maar bij het afsluiten van linux meldt de kernel allemaal foutmeldingen zoals

    —————————————————————————————————
    Jun 21 13:16:14 Archus kernel: hdb: max request size: 128KiB
    Jun 21 13:16:14 Archus kernel: hdb: 160086528 sectors (81964 MB) w/7936KiB Cache, CHS=65535/16/63, UDMA(33)
    Jun 21 13:16:14 Archus kernel: /dev/ide/host0/bus0/target1/lun0: p1 p2 < p5 p6 p7 p8 >
    Jun 21 13:16:14 Archus kernel: hdb: task_no_data_intr: status=0x51 { DriveReady SeekComplete Error }
    Jun 21 13:16:14 Archus kernel: hdb: task_no_data_intr: error=0x04 { DriveStatusError }
    Jun 21 13:16:14 Archus kernel: hdb: Write Cache FAILED Flushing!
    —————————————————————————————————


    Ook heeft hij moeite om dma aan te hebben staan met die drive.
    Het betreft een Maxtor 80/7200/8MB schijf trouwens. Is het iets om me druk om te maken ?
  • Ik heb de kabel vervangen maar dat helpt ook niet… :cry: dit is niet leuk.
  • Jij draait toch arch linux hé?
    Ik had onlangs ook eens arch geinstalleerd en die gaf dezelfde fouten bij het afsluiten. (ik heb ook een maxtor 80gb schijf)
    Onder andere distributies heb ik er geen last van, ik heb een vemoeden dat het aan de afsluit scripts van arch ligt. (het ligt iig niet aan de kernel want ik gebruik dezelfde kernel als onder slackware en daar gaat het goed)
    Mijn vermoeden is dat het reboot commando te snel wordt gegeven na het unmounten van de partities, zodat de harde schijf te weinig tijd heeft om zijn buffers te flushen. Ik zou /etc
    c.shutdown eens bekijken en onderaan na het read-only remounten het volgende toevoegen:
    [code:1:2fc72df8b5]
    sync
    sleep 1
    [/code:1:2fc72df8b5]
    zodat het er uiteindelijk zo uitziet:
    [code:1:2fc72df8b5]
    stat_busy "Remounting Root Filesystem Read-only"
    /bin/mount -n -o remount,ro /
    stat_done
    sync
    sleep 1
    # Power off or reboot
    if [ "$RUNLEVEL" = "0" ]; then
    [/code:1:2fc72df8b5]
  • Dit wordt veroorzaakt door bepaalde type Maxtors. Schijnt geen kwaad te kunnen en wordt gecorrigeerd in nieuwere kernels.

    Zie ook http://www.redhat.com/archives/fedora-test-list/2004-May/msg02412.html
  • Er is eene kernel optie voor;

    [quote:83d7788085]CONFIG_IDEDISK_MULTI_MODE:
    If you get this error, try to say Y here:

    hda: set_multmode: status=0x51 { DriveReady SeekComplete Error }
    hda: set_multmode: error=0x04 { DriveStatusError }

    If in doubt, say N.[/quote:83d7788085]

    Te vinden onder de driver sectie voor ATA/ATAPI support.
  • Klopt, ik draai Archlinux. Ik zal dat truucje van die afsluitscript eens proberen en anders de kernel hercompilen met die ene optie aan.

    Bedankt mensen !
  • Hm. dat met dat afsluitscript werkte niet. Het probleem bleef.

    Wat betreft die kernel optie… ik checkte het even na maar die stond al als 'Y' aangevinkt toen ik make menuconfig deed. Ik zal nog es overnieuw builden en kijken wat hij dan doet.
  • Hm. Helaas werkt dit ook niet !
    Wat me opvalt is dat in windows(XP) het geluid stottert zodra ik iets anders doe met dezelfde disk. Dat is toch ook het gedisabled staan van dma? (hoe kun je dat trouwens zien in XP? :oops: )

    Misschien is het dan toch iets hardwarematigs?
  • Hm. Zowel in winXP als in win98 (andere schijf) staat dma bij beide schijven aan. Maar toch blokkeert het hele systeem (ook in XP ja) als ik een dikke schijfoperatie doe (defrag). Dus winamp haakt dan ook als een idioot. Dit was eerst niet zo, ondanks het feit dat ik een niet-optimale IDE-layout heb (2 hdd's op 1 kabel en 2 cdrom's op 1 andere kabel, maar dat paste beter in mijn kast. Maar dat ging dus heel lang goed.
  • waarschijnlijk kun je op zoek gaan naar een nieuwe HD…
    Dat was in ieder geval bij mij met deze melding..

    Ik vermoed dat je over een tijdje wel meer meldingen krijgt, ook tijdens het opstarten :(
  • Ik had een zelfde soort probleem met mijn 120 GB maxtor.
    In kernel 2.6.6 zat een probleem dat dit veroorzaakte. Kernel 2.6.7 geeft geen problemen meer.
    Uit het changelog van kernel 2.6.7:
    many Maxtor disks incorrectly claim CACHE FLUSH EXT command support, fix it by checking both CACHE FLUSH EXT command and LBA48 support (thanks to Eric D. Mudama for help in fixing this).
    Maar wat voor kernel draai je?
  • Ik draai momenteel 2.6.6, ik zal morgen eens een 2.6.7 bakken en kijken hoe dat gaat.
    Misschien krijg ik die meldingen dan niet meer…

    Maar! dan rijzen de volgende vragen:

    1. Hoe kan het dan die meldingen er eerst steeds niet kwamen?
    2. Hoe kan het dan dat nu ook ineens in Windows er problemen zijn met het simultaan afwerken
    van schijfhandelingen over hetzelfde ide-kanaal ? Het geluid stottert bij kopieren van files of defraggen! Dat is toch niet normaal voor een XP1800/512MB systeem ?
  • [quote:6582507fbd="musicom76"]1. Hoe kan het dan die meldingen er eerst steeds niet kwamen?
    2. Hoe kan het dan dat nu ook ineens in Windows er problemen zijn met het simultaan afwerken van schijfhandelingen over hetzelfde ide-kanaal ? [/quote:6582507fbd] Wellicht is zoals Bint al aangaf er iets mis met je harde schijf. Heb je 'm al getest met diagnostic Powermax
  • Tja… de full scan erover gehaald. Niks aan de hand volgens het programma. Er zijn verder ook nog geen bad clusters ofzo hoor. Alleen die onhandigheid in linux en die problemen in windows met simultane schijfbewerkingen. Ook het geheugen heb ik gescand. Niks aan de hand…
  • [quote:2de3d22c2a="musicom76"]Tja… de full scan erover gehaald. Niks aan de hand volgens het programma. Er zijn verder ook nog geen bad clusters ofzo hoor. [/quote:2de3d22c2a] Dus heb je met Powermax test 1 t/m test 4 gedaan?

    Ik heb hier nog wel een oude pc een Pentium 166 Mhz, die ik alleen nog maar voor testen gebruik. Daarin zitten onder andere 2 harddisk een cd-speler en een SyQuest removable 135 MB harddisk. Die SyQuest removable 135 MB harddisk geeft vergelijkbare foutmeldingen, maar dan tijdens het opstarten. De output van dmesg | grep hdd
    [code:1:2de3d22c2a]
    ide1: BM-DMA at 0xe008-0xe00f, BIOS settings: hdc:DMA, hdd:pio
    hdd: SyQuest EZ135A, ATA DISK drive
    hdd: attached ide-disk driver.
    hdd: task_no_data_intr: status=0x53 { DriveReady SeekComplete Index Error }
    hdd: task_no_data_intr: error=0x04 { DriveStatusError }
    hdd: 262144 sectors (134 MB) w/64KiB Cache, CHS=512/16/32, BUG
    hdd:hdd: dma_intr: status=0x53 { DriveReady SeekComplete Index Error }
    hdd: dma_intr: error=0x04 { DriveStatusError }
    hdd: dma_intr: status=0x53 { DriveReady SeekComplete Index Error }
    hdd: dma_intr: error=0x04 { DriveStatusError }
    hdd: dma_intr: status=0x53 { DriveReady SeekComplete Index Error }
    hdd: dma_intr: error=0x04 { DriveStatusError }
    hdd: dma_intr: status=0x53 { DriveReady SeekComplete Index Error }
    hdd: dma_intr: error=0x04 { DriveStatusError }
    hdd: DMA disabled
    hdd1
    [/code:1:2de3d22c2a]

    Bij het afsluiten van Slackware 9.1 geeft deze geen foutmeldingen.


    Je zou die Maxtor harde schijf ook nog kunnen testen met de [b:2de3d22c2a] Generic [/b:2de3d22c2a] test van SeaTools. die dus ook andere harde schijven dan Seagate kan testen. Zelfs de Quik Test keurt die SyQuest EZ135A af.
  • Ja, de maxtor testprog gaf bij alle testen aan dat het in orde was. Bedankt, die seatools ga ik proberen.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.