Vraag & Antwoord

OS Linux

Problemen met m'n mailserver

42 antwoorden
  • Je hebt met vi/VIM zitten spelen, en het is je niet gelukt om deze af te sluiten, en je hebt m waarschijnlijk gekilled of weggeklikt ofzo. Gooi het bestand waarover geklaagd word (/tmp/vi.ccbTRM) maar gewoon weg als er niets van waarde instaat. Het is een soort van autosave functie (mag ik dat zo noemen?) in VIM.
  • Op een slackware bak kreeg je vroeger in zo'n geval mail van Elvis ^-^ ........ dat is feitelijk de vi versie van Slackware.
  • Oke, het is inmiddels verholpen....bedankt ! Nu viel mij iets anders op toen ik de logfiles bekeek. Ik ben er zeker van dat ik de relay opties en dergelijke heb uitgezet, maar toch zie ik veel pogingen / verbindingen met mijn servertje plaatsvinden. Echt wel vreemd aangezien mijn mailservertje nog maar net online is.... Een stukje fan de logfile : [quote:da7c81183e] Deze log heb ik aangepast en ingekort verderop geplaatst om het overzicht te verbeteren [/quote:da7c81183e] Dit is maar een klein stukje uit de logfile. Zelf heb ik in deze periode geloog ik 2 test mailtjes naar een andere gebruiker op het systeem gestuurd. Toch zie ik allerhande vreemde servers die pogen een verbinding met mijn server te maken. Is dit normaal, en handeld hij het zo goed af ? Of moet ik nog meer restricties toepassen ?. Volgens mij staat relay al uit...
  • Hoi, bovenstaande logfile is een beetje lang (vervuilend misschien) en ik wil hem wel weghalen indien het storend is. Toch wil ik jullie nog even naar dit stukje laten kijken. In een zeer kort tijdsbestek zie je dat weer 2 computers gebruik proberen te maken van m'n mailserver. De computer is net opgestart en ze staan alweer in de logfile. [quote:b380ff7f26] Jun 25 10:17:35 deskpro postfix/postfix-script: starting the Postfix mail system Jun 25 10:17:35 deskpro postfix/master[309]: daemon started Jun 25 10:17:36 deskpro postfix/qmgr[313]: BBE79D85F: from=<>, size=3523, nrcpt=1 (queue active) Jun 25 10:17:36 deskpro postfix/qmgr[313]: ABC1AD884: from=<>, size=6503, nrcpt=1 (queue active) Jun 25 10:17:37 deskpro postfix/smtp[323]: connect to mail-my-info.net[69.6.66.13]: Connection refused (port 25) Jun 25 10:17:37 deskpro postfix/smtp[323]: ABC1AD884: to=<Susie@mail-my-info.net>, relay=none, delay=136063, status=deferred (connect to mail-my-info.net[69.6.66.13]: Connection refused) Jun 25 10:18:43 deskpro in.qpopper[397]: (v4.0.4) POP login by user "deskpro" at (192.168.1.33) 192.168.1.33 [pop_log.c:244] Jun 25 10:20:46 deskpro postfix/smtp[322]: connect to inetbharat.com[64.202.167.192]: Connection timed out (port 25) Jun 25 10:20:46 deskpro postfix/smtp[322]: BBE79D85F: to=<lnjeyfpz@inetbharat.com>, relay=none, delay=165439, status=deferred (connect to inetbharat.com[64.202.167.192]: Connection timed out)[/quote:b380ff7f26] Deskpro is een gebruiker op mijn systeem, maar die overige connections'komen van 2 onbekende systemen. Zijn dat spammers ? Slagen zij er in om mail via mij te verspreiden ? Er staat namelijk wel 'queue active'...dus het lijkt er op dat postfix mailtjes accepteerd ! Vervolgens wordt er een verbinding gemaakt met 'inetbharat.com' (onbekende server voor mij) of 'mail-my-info.net (ook onbekend). Dat de connection dan time-out geeft of no relay is een melding van hun server en niet de mijne toch ? Dus dan staat relay bij mij toch open ?
  • Je server staat waarschijnlijk niet open voor relaying - al worden er wel pogingen gedaan. Als jou sever een mailtje terug probeert te bouncen als "No such user" ofzo, lukt dit niet omdat de spammers operen met fake reply adressen enzo. Test je mail server eens op: http://www.abuse.net/relay.html
  • Ah dat is een geruststelling...no relay :D Toch vreemd dat ze gelijk na een boot al weer in staan... En hoe zouden ze mijn domein zo snel hebben gevonden ? Het is nog maar net online..., zeer vreemd dus.
  • lijkt me een kwestie van gewoon hele IPranges bestoken met relaypogingen. Kost weinig, en je hoeft er maar 1 te vinden die niet dichtzit om gelijk een paar duizend/miljoen mails erdoor te jagen... Toen ik nog een mailserver draaide (niet eens op eigen domein maar op dyndns-sub) gebeurde dit ook aan de lopende band...
  • Hmm, toch vreemd...de relay testen geeft steeds de melding : "Reject RCPT from <de-afzender-abuse.net> Recipient address rejected : Relay access denied; Maar die andere 2 doen zoals in het laatste logfile stukje is te zien steeds een poging om te connecten naar een andere server, het lijkt wel alsof ze vanuit mijn eigen box komen...er staat ook iets van een queue. Als het een externe poging was, dan zou hier toch ook 'Relay access denied' moeten staan ?
  • Het is inderdaad afkomstig van je eigen PC. Het zijn de eerder genoemde bounces... de mailserver probeert steeds weer opnieuw een berichtje terug te sturen naar de spammer - en dit gaat mis omdat de mailserver bijvoorbeeld niet bestaat, of een timeout geeft. Dit probeert hij vaak enkele dagen vol te houden, en als het dan echt niet lukt, lever hij het mailtje af bij root of portmaster bijvoorbeeld. Vaak zijn ze terug te vinden in /var/spool/mqueue/ J.
  • Oh, ja zo... logisch. Maar daar kun je dus ook niet zo veel aan doen, want er is dus dan waarschijnlijk een mailtje gestuurd naar 'een-random-gegenereerde-naam@mijndomein.nl' en de mailserver probeerd de afzender te vertellen dat het mail adres dus niet bestaat... Dit is op zich wel vervelend, maar je kunt het niet uit zetten, want wanneer iemand mail stuurt naar mijn domein, maar b.v. een tikfout maakt, dan komt hij daar nooit achter. Oké, nu is het duidelijk. :)
  • Het zou uit te zetten moeten zijn, dit soort berichten generen namelijk een heleboel verkeer. Maar geloof me, ik krijg per dag ook zoveel connect attempts. Er zit zelfs een adres bij die het al 900x geprobeerd heeft ondertussen. stelletje sukkels
  • Je kunt het wel uit zetten, maar wanneer iemand dan een mailtje naar een van de gebruikers stuurt op mijn systeem en een tikfout in het emailadres maakt, dan komt het mailtje dus niet aan en dan wordt de afzender ook niet op de hoogte gesteld van het feit dar er iets is misgegaan... Dus,....klote spammers ! Maar wat mij nog het meest verbaasd is dat ze binnen enkele uren nadat mijn domein online is gegaan er dus al 2 hardnekkige spammers waren. Hoe kunnen zij dit zo snel weten ? Nog nergens kan mijn nieuwe emailadres zijn opgedoken, want ik heb het nog maar net. Zouden de Registars soms lijsten hebben die door de spammers worden gescand of zo...
  • [quote:dd7680c411]Je kunt het wel uit zetten, maar wanneer iemand dan een mailtje naar een van de gebruikers stuurt op mijn systeem en een tikfout in het emailadres maakt, dan komt het mailtje dus niet aan en dan wordt de afzender ook niet op de hoogte gesteld van het feit dar er iets is misgegaan... [/quote:dd7680c411] Je zou aliases kunnen aanmaken voor de meest te verwachten type-/schrijffouten. voornaamachternaam > voornaam.achternaam > initiaal.achternaam etc. Kan je eea mee afvangen... (of je laat het allemaal naar een catch-all user sturen die je zo soms eens doorloopt...)
  • Ja...en catch-all lijkt wel handig..., maar dan krijg je alle spam daar dus ook op binnen. Ik zal binennkort maar eens kijken wat de mogelijkheden zijn van een catch-all i.c.m. spamfilter.
  • [url=http://www.spamassassin.org/]SpamAssassin[/url] samen met [url=http://www.mailscanner.info/]Mailscanner[/url] houd hier zo'n 50+ spam emails per uur tegen. Het vreet wel wat geheugen, en voor elke email worden RBL's geraadpleegd, wat weer wat verkeer kost.
  • [quote:af58f04bcb="Tekkie"][url=http://www.spamassassin.org/]SpamAssassin[/url] samen met [url=http://www.mailscanner.info/]Mailscanner[/url] houd hier zo'n 50+ spam emails per uur tegen. Het vreet wel wat geheugen, en voor elke email worden RBL's geraadpleegd, wat weer wat verkeer kost.[/quote:af58f04bcb] Wat voor server draai jij dan ? 50+ mails per uur is nogal wat ! Hoeveel gebruikers heeft die server wel niet dan... De mijne is alleen voor prive gebruik met familie en vrienden. Het draait op een p120 met 32mb ram...dus niet zo'n zware server.
  • [quote:bafebb0e68="bvvelde"] Zouden de Registars soms lijsten hebben die door de spammers worden gescand of zo...[/quote:bafebb0e68] De WHOIS records.
  • Nu ben ik weer tegen een probleem aangelopen... Aangezien het nog steeds met de postfix server te maken heeft zet ik hem hier maar achteraan... De postfix mailserver werkt opzich goed en ontvangt alle mail, maar nu ik even controleerde of bepaalde verzonden mailtjes wel waren aangekomen kwam ik er achter dat uitgaande mailtjes gericht aan een ander domein niet aankomen. Na verloop van tijd krijg ik dit mailtje : [code:1:8ec15bee07] This is the Postfix program at host mijndomein.nl. I'm sorry to have to inform you that the message returned below could not be delivered to one or more destinations. For further assistance, please send mail to <postmaster> If you do so, please include this problem report. You can delete your own text from the message returned below. The Postfix program <gebruiker@anderdomein.nl>: Name service error for anderdomein.nl: Host found but no data record of requested type Reporting-MTA: dns; mijndomein.nl Arrival-Date: Sun, 27 Jun 2004 19:20:12 +0200 (CEST) Final-Recipient: rfc822; gebruiker@anderdomein.nl Action: failed Status: 5.0.0 Diagnostic-Code: X-Postfix; Name service error for anderdomein.nl: Host found but no data record of requested type [/code:1:8ec15bee07] Wat zou hier misgaan ? Heeft het misschien te maken met het feit dat ik geen dns draai, dus geen mx record heb aangemaakt ?
  • [quote:f4cda60e70] <gebruiker@anderdomein.nl>: Name service error for anderdomein.nl: Host found but no data record of requested type [/quote:f4cda60e70] ja? :roll:
  • Hoi, sinds kort heb ik een mailerver draien m.b.v. postfix. Nou ben ik echter al een hele tijd aan het klooien om er ook een printserver van te maken en hierbij zal wel wat mis zijn gegaan, want ik krijg nu vor mijn users elke dag wel 12x mailtjes met de volgende inhoud : [code:1:41c61a7a4e]On Wed Jun 23 20:48:10 2004, the user root was editing a file named /tmp/vi.ccbTRM on the machine machine-naam, when it was saved for recovery. You can recover most, if not all, of the changes to this file using the -r option to vi: vi -r /tmp/vi.ccbTRM [/code:1:41c61a7a4e] Als ik dat doe dan kom ik in de vi editor (waar ik geen ervaring mee heb) en daar zie ik dan enkele tekens staan. Wat is hier mis gegaan en hoe kan ik het herstellen ?

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.