Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

[SuSE 9.1] nvidia module verdwenen

Anoniem
None
16 antwoorden
  • Toen ik vandaag xawtv wilde opstarten, die gisteren nog wel werkte, gaf deze een foutmelding.
    [code:1:f5288ce05e]
    jolo@linux:~> xawtv
    This is xawtv-3.91, running on Linux/i686 (2.6.5-7.95-smp)
    X Error of failed request: BadMatch (invalid parameter attributes)
    Major opcode of failed request: 129 (GLX)
    Minor opcode of failed request: 5 (X_GLXMakeCurrent)
    Serial number of failed request: 529
    Current serial number in output stream: 529
    jolo@linux:~>[/code:1:f5288ce05e]
    Volgens /etc/X11/XFree86.0.log bleek de nvidia driver niet meer geladen te worden
    [code:1:f5288ce05e]
    (II) LoadModule: "nvidia"
    (II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
    (II) Module nv: vendor="The XFree86 Project"
    compiled for 4.3.99.902, module version = 1.0.1
    Module class: XFree86 Video Driver
    ABI class: XFree86 Video Driver, version 0.7
    [/code:1:f5288ce05e]
    Gisteren werd de nvidia module nog wel geladen volgens /etc/X11/XFree86.0.log.old
    [code:1:f5288ce05e]
    (II) LoadModule: "nvidia"
    (II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
    (II) Module nvidia: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.5336
    Module class: XFree86 Video Driver
    [/code:1:f5288ce05e]
    Wat bleek in de map /lib/modules/2.6.5-7.95-smp/kernel/drivers/video is de nvidia module verdwenen.
    [code:1:f5288ce05e]
    jolo@linux:/lib/modules/2.6.5-7.95-smp/kernel/drivers/video> ls
    aty cyber2000fb.ko i810 neofb.ko riva sstfb.ko tridentfb.ko vgastate.ko
    console hgafb.ko kyro pm2fb.ko sis tdfxfb.ko vga16fb.ko [/code:1:f5288ce05e]
    Vanaf gisteren vond ik in de output van dmesg | grep hda
    [code:1:f5288ce05e]
    jolo@linux:~> dmesg | grep hda
    Kernel command line: root=/dev/hda6 vga=0x317 desktop resume=/dev/hda5 splash=silent noapic
    ide0: BM-DMA at 0xd800-0xd807, BIOS settings: hda:DMA, hdb:DMA
    hda: WDC WD800BB-00CAA1, ATA DISK drive
    hda: max request size: 128KiB
    hda: 156301488 sectors (80026 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(100)
    hda: cache flushes not supported
    hda: hda1 hda2 hda3 < hda5 hda6 hda7 hda8 hda9 hda10 hda11 hda12 hda13 hda14 >
    hda2: <bsd: hda15 hda16 >
    ReiserFS: hda6: found reiserfs format "3.6" with standard journal
    ReiserFS: hda6: using ordered data mode
    ReiserFS: hda6: journal params: device hda6, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
    ReiserFS: hda6: checking transaction log (hda6)
    reiserfs: disabling flush barriers on hda6
    ReiserFS: hda6: Using r5 hash to sort names
    Adding 514040k swap on /dev/hda5. Priority:42 extents:1
    hda: drive_cmd: status=0x51 { DriveReady SeekComplete Error }
    hda: drive_cmd: error=0x04 { DriveStatusError }
    [/code:1:f5288ce05e]
    Die [b:f5288ce05e] DriveReady SeekComplete Error [/b:f5288ce05e] klinkt niet echt goed, maar zou daardoor slechts 1 nvidia module door kunnen verdwijnen? Want zover ik weet ben ik geen data kwijt.
  • Als precies die datablokken weg zij n (of de inode die naar de data verwijst) zou dat idd wel kunnen. Meestal takelt een schijf na zijn eerste fouten snel verder af, dus ik zou iig alles backuppen en de schijf goed testen (daar kun je progseltjes voor downloaden op de site van de fabrikant van de schijf).
  • Ik heb de WDC harddisk inmiddels getest met de diagnostics van de fabrikant. Zowel de Quik- en de Extended test, die ongeveer 55 minuten duurde melde: No errors detected for this drive. De Build Date : 03-okt-02. En heeft 2 jaar garantie. Dus tot 3 oktober 2004.

    Ik heb ook de dmesg | grep hda output gecontroleerd in Slackware 10 met kernel 2.6.7. Die geeft echter geen foutmeldingen.

    Wat wel merkwaardig is dat die nvidia module verdween tijdens die mislukte poging om Kink te compileren/installeren. Daarvoor had ik via yast qt-devel en kdebase3-devel geïnstalleerd. Op een andere pc verdween ook de nvidia module, tijdens een mislukte poging Kink te compileren/installeren in SuSE 9.1. (toeval?) Ook die harddisk werd goed gekeurd door de diagnostics van de fabrikant.

    Ik heb op beide pc's de nvidia drivers opnieuw geïnstalleerd. Dat ging zonder foutmeldingen. Ik heb overigens wel een back-up van mijn data. Alleen staat daar zoals bij vele anderen op dit forum, de meest recente data er niet bij.
  • Dat lijkt me geen toeval. Compile je kink als root?
  • configure heb ik uitgevoerd als user. Alleen die libinklevel die geen configure heeft, probeerde ik make behalve als user, ook als superuser. Maar bij compileren wordt er toch niet buiten de home map van de user geschreven. Wellicht was die nvidia module verwijderd door yast.
  • [quote:b01378af60="jolo"]Wellicht was die nvidia module verwijderd door yast.[/quote:b01378af60] Ik heb dit even gecontroleerd. En inderdaad als ik in een verse SuSE 9.1 installatie, de nvidia divers installeer, en dan via yast de packages qt-devel, kdebase-devel en kdebase3-extra installeer, waarbij als afhankelijkheden 19 andere devel packages worden geïnstalleerd, wordt inderdaad de nvidia module verwijderd.
  • Je zal maar SuSE gebruiken :-?
  • [quote:3ff9683081="jolo"][quote:3ff9683081="jolo"]Wellicht was die nvidia module verwijderd door yast.[/quote:3ff9683081] Ik heb dit even gecontroleerd. En inderdaad als ik in een verse SuSE 9.1 installatie, de nvidia divers installeer, en dan via yast de packages qt-devel, kdebase-devel en kdebase3-extra installeer, waarbij als afhankelijkheden 19 andere devel packages worden geïnstalleerd, wordt inderdaad de nvidia module verwijderd.[/quote:3ff9683081]

    Bij die 19 zat dan ook wellicht de "kernel-source" ?

    idd. dan moet je net als na elke kernel upgrade "fetch_nvidia" draaien of via YOU de nvidia driver opnieuw installeren.

    Helaas hebben de sufkoppen bij SuSE nog niet door dat wanneer je iets met de kernel gedaan hebt die "Update" weer vrijgegeven moet worden :(
  • [quote:28caa144a5="wstolk"]Bij die 19 zat dan ook wellicht de "kernel-source" ? [/quote:28caa144a5] Nee, geen kernel-source. Alleen devel packages met devel in de naam, zoals XFree86-Mesa-devel. Yast installeert als afhankelijkheden alleen packages die nog niet zijn geïnstalleerd.
  • [quote:c4d0f9d4c6="wstolk"]
    idd. dan moet je net als na elke kernel upgrade "fetch_nvidia" draaien of via YOU de nvidia driver opnieuw installeren.

    Helaas hebben de sufkoppen bij SuSE nog niet door dat wanneer je iets met de kernel gedaan hebt die "Update" weer vrijgegeven moet worden :([/quote:c4d0f9d4c6]

    Die 'sufkoppen' bij SuSE zijn helemaal niet zo dom… Veel Linuxgebruikers en ontwikkelaars zien Linux als alternatief voor MS-Win. SuSE is geen uitzondering. Dat betekend dat je je als ontwikkeltoko richt op 'Jan Modaal' en er dan vanuit _mag_ gaan dat de gebruiker nooit (hooguit zelden) een kernel vervangt! Jolo zit al niet meer in de 'Jan Modaal' groep, maar eerder in 'gevorderde', mss wel 'expert'. En juist die groepen zijn voor een 'klik-en-klaar' distro als SuSE geen 'main target'. SuSE richt zich op een stabiel werkend systeem met het principe: 'never change a stable kernel' ;) Distro's als Debian en Slackware zijn veel meer gericht op de laatste stand in kernel-ontwikkeling en daarom is het vervangen van een werkende kernel in zo'n distro veel beter geregeld. Ik denk dat Fedora en Mandrake een zelfde denkwijze toepassen.

    Groet, M.V. Wesstein
  • Sorry hoor maar als je via YOU een kernel update aangeboden krijg en er vervolgens achter kom dat je nvidia driver het niet meer doet is het voor "Jan Modaal" niet te zien waardoor dat komt.
    Zouden ze in hun update script checken of je de nvidia (of en ATI) driver gebruikte dan konden ze die weer vrijgeven in het lijstje zodat "Jan Modaal" ook zou zien dat hij die weer moet installeren.
    Eigenlijk zou het niet meer dan normaal zijn als ze dat dan oo automatisch voor je regelde. Juist omdat, zoals jij beweert, SuSE gericht is op deze groep van gebruikers en niet meer voor de gevorderde gebruiker als jolo is.
  • Hoe is het vervangen van een kernel onder Slackware dan geregeld?
  • Als een kernel patch uitvoert via yast krijg je de mededeling dat de nvidia module opnieuw via yast geinstalleerd moet worden Als je dat doet dan werkt alles weer zoals voor de kernel update.
  • [quote:54e98f69de="Berend-kb"]Als een kernel patch uitvoert via yast krijg je de mededeling dat de nvidia module opnieuw via yast geinstalleerd moet worden Als je dat doet dan werkt alles weer zoals voor de kernel update.[/quote:54e98f69de]

    Wellicht dat ik er meestal te snel overheen lees maar het was me nog niet opgevallen . (maar over het algemeen neem ik de nvidia driver direct mee)
  • [quote:3851cd3cf0="jolo"][quote:3851cd3cf0="wstolk"]Bij die 19 zat dan ook wellicht de "kernel-source" ? [/quote:3851cd3cf0] Nee, geen kernel-source. Alleen devel packages met devel in de naam, zoals XFree86-Mesa-devel. Yast installeert als afhankelijkheden alleen packages die nog niet zijn geïnstalleerd.[/quote:3851cd3cf0]

    Wellicht dat het komt omdat je de standaard Mesa (en wellicht anderen) video driver erop gegooid hebt ??

    SuSE is met name als je al een update gedaan hebt niet echt meer consequent en betrouwbaar.
    vb. ik heb ncurses-devel nodig maar al een update van ncurses gedaan. nu wil yast dat ik de oude terug zet voordat ik de devel package erop kan zetten.
    Een Jan Modaal gebruiker snapt daar dus niets van. Beter zou het dan ook zijn als Yast tevens even in de update directorie kijk of er een update voor het pakket is en dan die installeren ipv. de oude ncurses-devel zoals in mijn geval :D

    Maar ik vrees dat je net als ik veel meededelingen niet eens meer lees waardoor je tegen dit soort "onverwachte" zaken aanloop ;)
  • [quote:8bdae2d246="wstolk"]Wellicht dat het komt omdat je de standaard Mesa (en wellicht anderen) video driver erop gegooid hebt ??[/quote:8bdae2d246]
    XFree86-Mesa-devel is nodig voor qt3-devel. Ik heb dus het volgende getest. De XFree86-Mesa-devel verwijderd via [code:1:8bdae2d246] rpm -e –nodeps XFree86-Mesa-devel [/code:1:8bdae2d246] Op dat moment is de nvidia module nog aanwezig. Maar installeer ik die XFree86-Mesa-devel opnieuw via [code:1:8bdae2d246] rpm -Uvh XFree86-Mesa-devel-4.3.99.902-40 [/code:1:8bdae2d246] dan wordt de nvidia module verwijderd. In /etc/X11/XF86Config blijft in Section "Device" [code:1:8bdae2d246] Driver "nvidia" [/code:1:8bdae2d246] ongewijzigd. Overigens in de SuSE Support Database is niets te vinden met het zoek woord: mesa

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.