Vraag & Antwoord

OS Linux

Frequent updaten.

Anoniem
danieldk
62 antwoorden
  • Oké, bedankt…voortaan doe ik dus check install :).
    Alleen jammer van wat ik er nu al op heb staan…

    Leesvoer voor in het weekend, misschien print ik het wel even, dan kan ik het buiten leze, als het mooi weer is 8) .
  • [quote:723f4e4f62="Bamboe"]
    De meeste distributies hebben een SysV stijl voor hun init scripts, die langs de ene kant wel veelzijdig maar langs de andere kant soms onnodig ingewikkeld zijn. Slackware gebruikt de BSD stijl, die eenvoudiger is.
    [/quote:723f4e4f62]

    Laat ik de mythe nog een keer de wereld uithelpen ;), Slack init scripts zijn niet BSD-style. BSD gebruikt een centrale rc.conf file om zaken in/uit te schakelen, bovendien gebruiken bijna alle moderne BSD's RCng, wat net als SysV een init script heeft per service/taak, maar wel via rc.conf ingesteld wordt ipv. symlinks.
  • Wat je kunt doen voor de software die je er al eerder hebt opgezet is ze gewoon nog een keer met dezelfde opties compilen en met checkinstall te installeren. Je zet ze dan als het ware over de oude bestanden heen en zo zijn ze later toch eenvoudig te verwijderen.
    Checkinstall vind je in de /extra dir van Slackware trouwens.
  • [quote:cbbc166313="Marcel de Reus"]Wat je kunt doen voor de software die je er al eerder hebt opgezet is ze gewoon nog een keer met dezelfde opties compilen en met checkinstall te installeren. Je zet ze dan als het ware over de oude bestanden heen en zo zijn ze later toch eenvoudig te verwijderen.
    Checkinstall vind je in de /extra dir van Slackware trouwens.[/quote:cbbc166313]
    Oke, bedankt.
    Dat scheelt mij weer heel veel gedoe :)
  • [quote:f1c9ddcac2="danieldk"]

    Nice :). Het beste wat je kunt doen is:

    * Minimale installatie.
    * Na de installatie adminmenu upgraden (is een optie in adminmenu), en "y" antwoorden op het einde, zodat de safe update archive wordt gebruikt.
    * apt-get update && apt-get dist-upgrade
    * Alles installeren wat je maar wilt, met apt-get, synaptic, of aptitude (what you prefer)
    * Genieten ;)[/quote:f1c9ddcac2]

    Nja, ik heb de iso's nu binnen maar ik ga mij er zo direct nog niet mee kunnen bezighouden. Mijne pc staat op univ momenteel (in afwachting dat daar nieuwe pc's worden bijgekocht), want ik ben daar bezig met het voorbereiden van een doctoraat (ben sinds een paar weken afgestudeerd als licenciaat/master informatica zoals je wel weet :) ). Ik kan me dus daar moeilijk gaan bezighouden met libranet, want ik word verondersteld daar te werken en dan moet m'n pc het uiteraard ook gewoon blijven doen liefst. Misschien dat ik nog wel een machientje kan fixen om mij er hier thuis mee bezig te houden, maar ik heb hier ook geen cd writer thuis dus ik ga toch moeten wachten tot ik maandag terug op school ben om daar de iso's te branden.
  • Goed, de installatie is prima gegaan, buiten dat ik nogal veel op enter moest rammen heb ik niet veel aan te merken op de installer ;). Ik voel mij wel terug een ontzettende beginner want met dat malle apt geraak ik toch nog niet overweg. Ik heb, zoals je aanradde, xadminmenu geupdate, dan apt-get update && apt-get dist-upgrade gedaan, maar toch blijf ik zitten met oude software. (kde blijft bv. hangen op versie 3.1.2)
    Mozilla firefox wil niet installeren wegens dependencyproblemen, die verwacht gtk 2.4 e.d. terwijl gtk 2.2 geinstalleerd staat, en het magische apt-get upgradet dat blijkbaar toch niet.
    Moet ik toch nog knoeien in m'n sources.list en /etc/apt/preferences ofzo?
    (ben even te lui nu om het uit te zoeken, ik ga slapen en we zien morgen wel verder)
  • Ik ben wat verder ondertussen, mozilla firefox is toch gelukt m.b.v. "apt-get -t testing install mozilla-firefox". Maar blijkbaar is het libranet archief dat gebruikt wordt niet up to date. Als ik bv. gewoon "apt-get dist-upgrade" uitvoer, geeft hij geen upgrades aan, maar "apt-get -t testing dist-upgrade" upgrade zowat alles.
    Kan het zijn dat het libranet update archief enkel beschikbaar is voor betalende gebruikers?
  • Nee, wat dat betreft is Libranet wat meer slack-like; in de stabiele versies wordt niet gelijk de nieuwste zut gemikt. Als je toch nieuwere versies wilt is dat natuurlijk geen probleem (zoals je al ontdekt had), "apt-get -t unstable mozilla-firefox". Natuurlijk kan het ook uit testing, maar mijn systeem is geloof ik al bijna helamaal testing omdat ik hier de neiging heb de nieuwste gimp, inkscape, etc. binnen te halen ;).

    Maar binnenkort verschijnt Libranet 3.0, dan zal KDE 3.2 wel officieel stabiel verklaard worden volgens Libranet-standaarden ;).
  • Overigens doe ik zelf nooit een "apt-get -t testing dist-upgrade", omdat ik in principe bij de safe archive blijf, maar sommige packages gewoon uit unstable haal. Bij mijn weten worden de geinstalleerde unstable packages gewoon automatisch bijgewerkt met een gewone dist-upgrade.
  • Dus als ik het goed begrijp bevat het libranet "safe update archief" over het algemeen oudere software dan debian testing. Nu dacht ik ook dat testing eigenlijk zo goed als stable is tegenwoordig, gezien het feit dat sarge binnen ongeveer een maand stable verklaard zal worden. Waarom zou ik dan nog het libranet archief gebruiken? Je zei dat er veel non-free software inzit, maar volgens Roeland zit die ook in de non-free tree van debian. En tja, veel closed source programma's kan je gewoon van hun website (www.sun.com, www.opera.com) plukken en in /opt mikken, heb je geen apt-get voor nodig :). (zo doe ik dat toch meestal)
  • [quote:4c3924616f="Bamboe"]Dus als ik het goed begrijp bevat het libranet "safe update archief" over het algemeen oudere software dan debian testing. Nu dacht ik ook dat testing eigenlijk zo goed als stable is tegenwoordig, gezien het feit dat sarge binnen ongeveer een maand stable verklaard zal worden. Waarom zou ik dan nog het libranet archief gebruiken?[/quote:4c3924616f]

    Dat is inderdaad de huidige situatie. Maar vergeet niet dat testing al veel problemen heeft gehad. Nu is dat niet zo, omdat er bijna een nieuwe release naderd. Maar daarna zal sarge als stable weer snel verouderen voor desktopgebruik (net als woody), en testing weer veel experimenteler worden. Dan is de safe archive weer een goede combinatie van up-to-date en stabiel, net als het een half jaar geleden was.

    [quote:4c3924616f]Je zei dat er veel non-free software inzit, maar volgens Roeland zit die ook in de non-free tree van debian.[/quote:4c3924616f]

    Probeer maar sun jdk of opera uit non-free te halen, ik wens je veel plezier ;).

    [quote:4c3924616f]
    En tja, veel closed source programma's kan je gewoon van hun website (www.sun.com, www.opera.com) plukken en in /opt mikken, heb je geen apt-get voor nodig :). (zo doe ik dat toch meestal)[/quote:4c3924616f]

    True. Ik geef zelf de voorkeur zulk soort zaken via de package manager te doen. Dat is een kwestie van smaak. Overigens is er nog een "maar", veel java gebruikende programma's in de Debian repositories zijn wel van een JRE of JDK afhankelijk (qua package dependency), natuurlijk kun je de boel gewoon forcen of kaffe installeren. Maar ik vind het persoonlijk veel gemakkelijker dat voor zulke programma's hier automatisch Sun JRE of JDK uit de Libranet archieven geinstalleerd wordt.
  • Dus opera is bij libra net wel via de source-list beschikbaar ?
    Hoe zit het dan met mplayer ?
  • [code:1:3ec3bf4930]
    $ apt-cache search mplayer
    […]
    mplayer-fonts - Fonts needed for OSD in mplayer
    mplayer-mozilla - Embedded video player for mozilla
    mplayer-skins - Skins for mplayer gui
    mplayer - The Ultimate Movie Player
    [/code:1:3ec3bf4930]

    Yep, zit erin. "apt-cache policy" bevestid dat dit uit het Libranet archief komt.
  • Goed, laten we dit onderwerp herdopen tot het grote Libranet en Debian onderwerp. Ik heb ondertussen al flink wat software die ik nodig heb geapt-get, maar toch blijf ik met het enge gevoel zitten dat er veel outdated is (ook in sid dus). En waar ik ook niet aanuit kan is dat, wanneer ik een pakket upgrade naar de versie in -testing (met apt-get -t testing upgrade blabla), hij vaak de helft van het systeem update waardoor ik de indruk heb dat ik momenteel al eerder met sarge/sid bezig zit dan met libranet.
    Zo had ik licq geinstalleerd (vanuit het libranet archief denk ik), en dat was versie 1.2.4, flink verouderd ondertussen. Dus ik doe een apt-get -t testing upgrade licq, wat de helft van m'n systeem update (o.a. xfree86) en dan met een hele zooi vragen afkomt betreffende de configuratie (ik moest bv. m'n xfree opnieuw instellen86, dat ding vroeg weer welke videokaart en keyboardlayout ik had terwijl de libranet installer dat eerder al automatisch geregeld had). Enfin, upgrade gelukt en licq 1.2.7 draaiende. Vervolgens constateer ik dat de firefox die ik had binnengehaald uit -testing versie 0.8 is, dus ik doe "apt-get -t unstable upgrade mozilla-firefox", weer sleurt ie een paar 100 mb updates van vanalles en nog wat binnen (o.a. wééral xfree86, en nog altijd versie 4.3.0) en valt me lastig met configuratievragen, maar m'n firefox blijft hangen op versie 0.8.

    En wat mplayer betreft, het is leuk dat het in het libranet archief zit, maar versie 0.90pre5 is ondertussen ook al weer prehistorisch (het automatisch installeren van codecs lukt al niet meer omdat de url in het update script het niet meer doet) en in de debian archieven heb ik het nog niet kunnen terugvinden.

    Enfin, erg wild ben ik er nog niet van, maar misschien dat het op termijn wel een betere keuze is. Enfin, ik ben in ieder geval +/- verplicht het een iets langere testperiode te gunnen dan de andere distro's die ik geprobeerd heb, want ik heb de slackware installatie er afgegooid voordat ik libranet installeerde dus ik kan toch niet zo makkelijk meer terug nu. We zien dus wel wat de toekomst brengt :)
  • [quote:b872fccb33]Ik zou geen nadelen weten aan het gebruik van swaret mits je wel het een en ander goed geconfigureerd hebt (swaret.conf).[/quote:b872fccb33]
    Ik houd mijn Slackware (9.1) bij met swaret, heb daar tot op heden nog geen nadelige gevolgen van ondervonden. De geluiden in deze draad geven mij het gevoel dat het toch een listige tool is/kan zijn. Wat moet je cq zou je moeten instellen in de swaret.conf om te voorkomen dat het je systeem onderuit haalt? Ik heb de default-instellingen zoals zij in de documentatie staan aangegeven doorgevoerd, en daarmee werkt het.

    Kan iemand "goed" (als in: … een en ander goed geconfigureerd hebt …) definiëren?

    Greetz, dJezzer 8)
  • Okay daar gaan we dan ik gebruik Slackware 10.0. Aangezien ik swaret alleen gebruik voor security updates. Wil ik dat hij niet update naar current dus:

    VERSION=10.0

    Verder wil ik absoluut niet dat swaret zich met depencies gaat bemoeien dus:

    DEPENDENCY=0

    Verder staat de rest in de standaard config wel okay. Tot op heden heb ik met de configuratie nooit problemen ondervonden.
  • Bamboe: ik heb daar geen last van, ik ben nog niet zo'n ster in APT (ook pas recent overgestapt), maar volgens mij upgraded "apt-get -t unstable upgrade blaat" de hele zut, daarom doe ik ook altijd gewoon "apt-get -t unstable [b:01abc99957]install[/b:01abc99957] blaat" als er een oudere versie geinstalleerd is van blaat wordt deze wel geupdated. Ik draai nog behoorlijk veel uit het Libranet archief, terwijl ik toch flink heb zitten "-t unstable"-en. Overigens heb ik gewoon de nieuwste firefox (uit unstable). Heb nooit honderden MB's binnen moeten halen, zelfs niet tientallen (behalve bijv. KDE, want dat is tientallen megabytes ;)).
  • Over MPlayer: dat wist ik niet. Ik heb even op het Libranet forum nagezocht, en door deze regel toe te voegen aan /etc/apt/sources.list kun je o.a. de nieuwste mplayer binnenkrijgen (dit werkt overigens ook op Debian):

    [code:1:6825859cd3]
    deb ftp://ftp.nerim.net/debian-marillat/ unstable main
    [/code:1:6825859cd3]

    Zie ook: http://forum.libranet.com/viewtopic.php?t=1420
  • Handig is ook de volgende link om repositories te zoeken:

    http://www1.apt-get.org/search.php
  • Maar mag je probleemloos siftware uit het libranet archief halen met debian dan ?

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.