Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Een losse .deb installeren op een debian pc

m3ssi4h
4 antwoorden
  • Hallo,

    Ik zit hier bij iemand die een debian computer heeft draaien.
    Hij wil graag een bepaald pakketje installeren, maar dan wel de laatste versie.
    Op de officiele project site staat namelijk een veel nieuwere versie dan de versie die debian zelf aanbied.
    Hij is vanwege bepaalde functionaliteit de meest recente versie nodig.

    Nu ken ik debian niet echt goed, maar volgens mij kun je een los .deb pakketje met dpkg installeren.
    Moeten wij nog ergens op letten ?
    Eerst een 'test-install' proberen of zoiets ?, want ik wil liever geen problemen met dependencies en zo, want het zou heel goed kunnen dat deze nieuwere versie namelijk andere pakketjes nodig is ?
  • Ik weet net zo weinig van debian als jij. Maar de onderstaande commando's ken ik wel:

    dpkg -i blah.deb installeerd een package

    dpkg -r blah.deb verwijderd een package

    dpkg -c blah.deb toont bestanden uit een package

    dpkg -l toont informatie over de functionaliteit die door een package geboden wordt

    Normaal kan het installeren van pakketjes niet echt kwaad mits het niet om dingen zoals PAM of complete Desktop Env. gaat. Dus gewoon proberen zou ik zo zeggen.
  • Oké, ik heb het dus gewoon geprobeerd en het blijkt dus idd niet te werken.
    Allemaal dependencies die niet kloppen.
    Er zijn allemaal nieuwere versies nodig dan die in de woody tak zitten.
    Jammer, maar helaas want een oudere versie is geen optie.
    Misschien moet hij maar upgraden, maar dat wil hij liever niet omdat dit zijn server is.
    Hij update wel regelmatig, maar een upgrade zit hij dus niet op te wachten.
  • je kan een extra regel in je sources.list bijvoegen (bv testing of unstable)
    apt-get update draaien
    je losse .deb (proberen) te installeren,
    dan kom je weer uit op je dependencies problemen
    maar die los je dan (voor zover mogelijk) op met
    apt-get -f install (let op: ZONDER pakketnaam erachter)
    als alles goed gaat is je pakket, met bijbehorende dependencies, geinstalleerd.
    nadien je extra regel terug uitcommenten (#)
    en opnieuw apt-get update draaien.

    apt-get update dient enkel om de versies van de pakketjes op te halen,
    daar installeer / verander je niets mee aan je systeem.
    apt-get upgrade brengt je systeem dan wel weer naar de nieuwste stand van zaken.

    meer info (eventueel over een "mixed" systeem):
    http://www.debian.org/doc/manuals/apt-howto/index.en.html

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.