Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

[FC2] Audio in ut2004: root wel geluid - user niet

m3ssi4h
8 antwoorden
  • Hoi

    Ik heb de afgelopen jaren verscheidene pogingen gedaan om Linux te installeren, in de meeste gevallen zonder succes door moeilijk te installeren drivers. Maar sinds vorige week gaat ie uitstekend, ik heb vrijwel alles aan de praat. Ik loop nu nog tegen een klein probleem op.

    Het probleem is dat de audio nog niet helemaal top werkt. Bijvoorbeeld onder UT2004 krijg ik als root gewoon goed geluid, maar als ik onder m'n eigen naam inlog hoor ik helemaal niks. Foutmelding: open /dev/[sound/]dsp: Device or resource busy

    XMMS geeft in alle gevallen wel goed geluid, Gaim wil na verloop van tijd ook nog wel eens weigeren om geluid te geven. De KDE geluiden voor het sluiten van schermen e.d. hoor ik weer wel.

    Waarschijnlijk zal het iets met de rechten te maken hebben. Ik heb al hier en op google gezocht. Ik kwam een topic tegen met bijna hetzelfde probleem maar die heeft geen oplossing gehad. Ik heb al het een en ander aan rechten gewijzigd, dat mocht niet baten.

    Fedora core 2 met kernel 2.6.5-1.358
    't gaat om het on-board geluid van de A7N8X deluxe
    Ik heb een ghost image van gister, dus ik mag het helemaal in de soep laten lopen ;)
  • Voer eens uit als gebruiker:

    [code:1:3d4a4ed3c9]killall artsd[/code:1:3d4a4ed3c9]

    Artsd is de sound daemon in KDE, lees er maar wat meer over op google, maar die verhindert sommige programma's (zoals ut2004) naar de sound device te schrijven (artsd houdt hem bezet). Je kan artsd zo instellen dat hij na enkele seconden inactiviteit de /dev/dsp vrijgeeft. Dat doe je in kcontrol…

    -Roeland
  • Roeland waarom zit in KDE die sounddaemon artsd als extra tussenlaag. Waarom gewoon niet rechtstreeks via ALSA. Even in de console –> alsamixer –> settings saven klaar.
  • [quote:08db71aa24="m3ssi4h"]Roeland waarom zit in KDE die sounddaemon artsd als extra tussenlaag. Waarom gewoon niet rechtstreeks via ALSA. Even in de console –> alsamixer –> settings saven klaar.[/quote:08db71aa24]

    Ik ben zelf geen voorstander van artsd (esd heeft mijn voorkeur, maar daar sta ik misschien alleen in - de laatste tijd gebruik ik helemaal geen sounddaemons meer). Het probleem bij veel geluidsconfiguraties is dat het onmogelijk is om meerdere programma's tegelijk toegang te geven tot de geluidsdevice. Sinds een dag of twee heb ik een andere geluidskaart, die kan van meerdere devices tegelijk gebruik maken, maar mijn vorige geluidskaart kon dat niet. (Of het is een vernieuwde ALSA, maar ik heb me niet in de changelogs verdiept. Mijn OSS configuratie op de oude geluidskaart kon ook meerdere devices, later niet meer gelukt.)

    Artsd is vrij geavanceerd, dus het zal voordelen hebben.

    Ik gebruik geen s.d. meer…

    -Roeland
  • Dat was mij ook al opgegeven.

    Onder windows kon ik moeiteloos meerdere geluidsbronnen laten spelen.
    Het is mij onder linux nog niet gelukt, maar het moet wel kunnen.
    Momenteel maak ik gebruik van alsa.
    Wat ben je er voor nodig om ook in linux meerdere geluidsbronen te laten afspelen ?
  • Nou als je deze postings hebt gelezen: een sounddaemon he…

    -Roeland
  • Ik heb nu geluid in UT. Hoe? killall artsd hielp niet, ik heb toen bij kcontrol bij geluidsstysteem. Het schuifje van 'Automatische onderbreekstand' naar 1 seconde gezet. En nu geeft ie geluid :)

    Die ene keer dat ik als root geluid had was een toevalstreffer.

    Bedankt, ik begrijjp nu redelijk wat dat artsd inhoud.
  • [quote:6058cfb06c="rhkok"]Nou als je deze postings hebt gelezen: een sounddaemon he…

    -Roeland[/quote:6058cfb06c]
    Is alsa geen sounddaemon dan ?
    Nu zal ik het eerst eens proberen zoals ruudfeen het heeft opgelost, maar dat werkt natuurlijk alleen onder Kde, maar ik gebruik regelmatig andere wm's.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.