Vraag & Antwoord

OS Linux

Oldskool Linux Report

31 antwoorden
  • Maker : Ronald van Zuijlen a.k.a. GoRoW Onderwerp : Old Skool Linux Report Startdatum : 8 augustus 2004 Zie ook : http://forum.computertotaal.nl/phpBB/viewtopic.php?t=125899 Op woensdag 4 augustus 2004 werd er door Roeland Kok een topic aangemaakt op het forum van computertotaal.nl. Hierin had hij in mooie spreektaal een aansporende tekst gezet voor mensen die net zijn begonnen of willen gaan beginnen met Linux. Het was een uitdaging voor mensen die graag meer wilde opsteken van Linux. De tekst van Roeland sprak mij zo aan dat ik besloot het te gaan proberen. De uitdaging was om, zonder overal vragen te gaan stellen, Slackware aan de gang te krijgen. Dit dan ook zonder gebruik te maken van de X-server met zijn grafische opties. In dit topic wil ik graag mijn report kwijt over mijn vorderingen. Dit kan handig zijn voor andere beginners denk ik. Bovendien vind ik het voor mezelf leuk om later nog eens terug te lezen wat mij zoal bezig heeft gehouden. Op 8 augustus 2004 ben ik mijn nieuwe Linux avontuur begonnen. Met alleen een handje vol kennis over Fedora, nvidia drivers, fstab en quake 3 onder linux begon mijn avontuur met de eerste installatie van Slackware 10. Op deze bewuste avond startte ik om 22:00 uur. De eerste installatie verliep vlekkenloos, dacht ik. Na het fdisk'en is de setup gestart, de goede hdd gekozen en geformatteerd. Vervolgens heb ik via de optie 'menu' handmatig alle packages gekozen die ik wilde hebben. Het X-systeem heb ik achterwege gelaten, net als GNOME en KDE. Alles verliep goed. Aan het eind van de installatie kreeg ik alleen een moeilijke keuze. De bootloader genaamd Lilo moest geinstalleerd worden en daarbij kreeg ik drie opties te zien wat betreft de plek waar Lilo dan wel geinstalleerd moest worden: 1. Root 2. Floppy 3. MBR (Master Boot Record) Aangezien een floppy mij niet aansprak moest ik kiezen tussen 'Root' en 'MBR'. In de setup staat er bij de keuze van MBR tussen haakjes iets achter van 'May cause problems'. Ik ben van mezelf al niet een persoon die risico wil lopen, dus koos ik voor 'Root'. Vol vreugde werd disc 2 van Slack aan het einde uitgespuugd en kreeg ik de melding dat ik kon rebooten dmv de bekende toetsencombinatie Ctrl Alt Del. Na deze reboot gebeurde er helaas iets voor mij erg onverwachts. In mijn scherm komt doodleuk te staan: [code:1:ca596dd588] grub>_ [/code:1:ca596dd588] Geheel wachtend op mijn input stond de cursur daar vrolijk te knipperen. Mijn eerste reacite: "Huh? Maar..? Ik..eeh..heb toch Lilo geinstalleerd?". Na veel moeilijke gezichten en wat geklaag op het irc chan van nedlinux kreeg ik twee, nee sorry drie tips van m3ssi4h: [code:1:ca596dd588] 00:33.11 GoRoW dit is echt grappig, ik herstart..krijg ik: 00:33.15 GoRoW grub>_ 00:33.21 m3ssi4h he 00:33.25 GoRoW nix zeggen! 00:33.33 GoRoW moet zelf uitvinden =] 00:33.40 m3ssi4h 1 tip 00:33.49 m3ssi4h slackware werkt met lilo 00:33.53 m3ssi4h ;) 00:34.35 m3ssi4h tip 2 je had waarschijnlijk lilo in je MBR moeten installeren 00:34.45 m3ssi4h meer zeg ik niet okay [/code:1:ca596dd588] Even later nog een tip: [code:1:ca596dd588] 00:38.02 m3ssi4h wat trouwens erg handig is om eerst je MBR te wissen 00:38.05 m3ssi4h met 00:38.08 m3ssi4h hmmmm 00:38.17 m3ssi4h een windows cd-rom 00:38.19 m3ssi4h .... 00:38.24 m3ssi4h helaas 00:38.50 m3ssi4h maar er zijn meer mogelijkheden 00:38.51 GoRoW met een windows cdrom? door gewoon te formatten ofzo? 00:38.58 m3ssi4h fixmbr 00:39.03 GoRoW mbr = master boot record right? 00:39.08 m3ssi4h ja 00:39.16 m3ssi4h heb je een xp cd rom 00:39.21 GoRoW wel 10 :P 00:39.31 m3ssi4h mooi stop hem er ff in 00:39.47 m3ssi4h ff booten met een xp cdrom 00:40.24 GoRoW f@ck, niet 10 00:40.25 GoRoW 0] 00:40.26 GoRoW 0 00:40.32 m3ssi4h lol 00:40.35 GoRoW had er 2, beide uitgeleend 00:40.41 GoRoW heb wel een iso (schaam) 00:40.46 GoRoW brand em wel ff 00:40.53 m3ssi4h okay 00:41.51 m3ssi4h je hoeft xp niet te installeren hoor je hebt alleen de recovery console nodig 00:42.18 m3ssi4h en daar moet je het commando FIXMBR ingegeven 00:44.42 m3ssi4h http://portal.suse.com/sdb/en/2002/09/fhassel_deinstall_grub.html 00:44.45 GoRoW ok zal eens ff kijken [/code:1:ca596dd588] Na deze toch wel zeer handige 3 tips was het nog steeds erg moeilijk. Zet even wat dingen op een rij zo. Ik kan op meerdere manier te werk gaan om mijn MBR leeg te gooien. O.a. via cdrom van winxp, bootflop win98, cdrom van win2k. Mijn problemen: 1. Winxp cd bootte niet 2. Niet in bezit van win98 bootflop 3. Geen werkende floppy drive in pc 4. Geen floppy drive in laptop 5. Win2k cd uitgeleend (hmm..moet ik dat wel zeggen hier?) Je begrijpt, het werd er niet makkelijker op. Nog een helder idee: pc van pa aanzetten en daar proberen een bootflop te maken via de files van http://www.bootdisk.com. Na 5 floppy's had ik niet het idee dat het ging lukken op die pc, helaas. Hmm..en nu? m3ssi4h op #nedlinux gaf nog een aanwijzing: [code:1:ca596dd588] 01:22.26 m3ssi4h laatste mogelijkheid is lilo over grub heen proberen te installeren 01:24.17 GoRoW mja...je bedoeld gewoon slack install doen en in MBR donderen 01:24.23 GoRoW *bedoelt 01:24.27 m3ssi4h ja 01:24.40 GoRoW ja dat ga ik maar proberen, met risico, maar goed :P 01:24.43 phoranix_ netjes GoRoW : bedoeld>bedoelt [/code:1:ca596dd588] Ok, nogmaals Slack installeren. Gewoon doen, niet zeuren :P. Na het op exact dezelfde manier installeren met als enige verschil om Lilo in de MBR te zetten, kreeg ik een foutmelding die klonk als: 'Lilo kan niet geinstalleerd worden, check na de installatie de documentatie maar zodat je het handmatig kunt oplossen.'. Helaas, ook na rebooten kreeg ik weer dat tergende grub voor mijn neus. Helaas niet gelukt dus. Nog 1 wanhopig idee had ik. Ik wist dat ik nog een bootable cd van windows 98 had liggen. Eigenlijk zonder verwachtingen bootte ik die cdrom en ja hoor 'Hope was restored'. Keuzemenu kwam naar voren met de vraag hoe ik had willen opstarten. Na de keus 'Deze computer starten met cdrom ondersteuning' kon ik mijn MBR leeggooien. Het commando 'fdisk /mbr' gaf niet echt een output. Er werd een regel overgeslagen en er werd weer een prompt geopend. Ik dacht dat het wel goed zat en knalde er meteen nog een install van Slack overheen. Helaas wederom met dezelfde Lilo foutmelding... Na dit gehele avontuur was ik het eigenlijk al zat. Maar na het doorlezen van het verhaal van Roeland dat nog open stond in mijn browser wilde ik het nog 1 keer proberen door bij de installatie van Lilo geen 'Root' of 'MBR' te kiezen, maar gewoon voor een floppy kiezen. Het was inmiddels 3 uur 's nachts, maar toch. Ik typ dit trouwens nu om 4 uur 's nachts, precies de tijd dat ik net heb gezien dat het gelukt is =). Via de flop wordt mijn server nu netjes opgestart met een mooie tux linksboven in mijn scherm. Nouw, das een goeie start..maar wel een zware =). 6 uur mee bezig geweest.. =) Toch ben ik tevreden.. Meer nieuws volgt =) GoRoW @ 9 augustus om 04:03:28 uur..OUT.
  • Als ik 1 tip mag geven: Je bent trouwens wel wat op het verkeerde been gezet, je had Slack ook probleemloos met Grub kunnen starten. Ik ben geen GRUB expert, maar zo even uit mn hoofd: [code:1:b33f077d32] root (hd0,0) # Maak 1e partitie op hd0 root kernel /boot/vmlinuz-ide-2.4.26 root=/dev/hda1 ro # kies kernel en geef aan de kernel door wat de root paritie is boot #start de kernel [/code:1:b33f077d32] Na het starten van Slack had je gewoon "liloconfig" opnieuw kunnen draaien.
  • Mijn complimenten voor de manier waarop je de instap doet. Way to go.... Goed verslag ook...
  • Yep, volgens mij komt die GoRoW er wel :^).
  • [quote:ba0900d72a="danieldk"]Als ik 1 tip mag geven: Je bent trouwens wel wat op het verkeerde been gezet, je had Slack ook probleemloos met Grub kunnen starten. Ik ben geen GRUB expert, maar zo even uit mn hoofd: [code:1:ba0900d72a] root (hd0,0) # Maak 1e partitie op hd0 root kernel /boot/vmlinuz-ide-2.4.26 root=/dev/hda1 ro # kies kernel en geef aan de kernel door wat de root paritie is boot #start de kernel [/code:1:ba0900d72a] Na het starten van Slack had je gewoon "liloconfig" opnieuw kunnen draaien.[/quote:ba0900d72a] Het probleem was dat grub nog afkomstig was van een Fedora 2 install en dus verwijderd moest worden (als we het doen dan doen we het goed, anders leert hij niets). Daar zijn verschillende methoden voor zoals bijvoorbeeld hier beschreven: http://portal.suse.com/sdb/en/2002/09/fhassel_deinstall_grub.html Het tweede probleem is natuurlijk als lilo zich niet laat installeren dan kun ook geen liloconfig doen. Verder wel leuk om die IRC berichten nog eens te lezen. En inderdaad GoRoW die komt er wel :D Echt top! BTW jullie geloven het misschien niet maar ik ben gisteren met Gnome bezig. En zal ik je eens wat verklappen ik vond het wel leuk. Zo leren we allemaal wat :wink:
  • Ja, dus? Als die GRUB door Fedora geinstalleerd is kun je het toch net zo goed gebruiken om je Slack te booten. Daarna kun je op gemak LILO configureren, of als dat niet werkt een bootdisk maken.
  • Heej wat cool dit. Gaaf dat je het eens op deze manier probeert! Vooral doorgaan, ik denk dat het je veel voldoening geeft als alles uiteindelijk werkt. En je zult weer een stukje meer weten over het hoe en waarom van bepaalde Linux zaken. Succes! -Roeland
  • Njaah, dit is niet oldskool hé GoroW, want dan had je niet op IRC moeten gaan rondsnollen en al zeker niet op dit forum ;) Maar toch, om wat tips te geven hoe je je lilo toch in orde kunt krijgen: In het geval dat je lilo gewoon op de superblock van een partitie installeert (zoals je eerst deed) werkt dat enkel als er geen bootloader meer in de MBR staat, en als de partitie waarop je lilo installeert ook op active (= bootable) staat. Je kan dat instellen in fdisk. Lilo op de MBR installeren heeft bij mij nog nooit problemen opgeleverd, ik begrijp dan ook de waarschuwing niet die slackware aangeeft bij de installatie ("possibly unsafe"). Ook lilo over grub installeren lukt bij mij altijd prima. Mijn advies is dus: boot in slackware met je bootflop of van de slackware cd. (als je het openingsscerm van de slackware bootcd leest, staat daarop uitgelegd hoe je van je cd toch rechtstreeks naar een linux installatie op harde schijf kunt booten: [code:1:329af6a7d2] In a pinch, you can boot your system from here with a command like: For example, if the Linux system were on /dev/hda1. boot: bare.i root=/dev/hda1 noinitrd ro This prompt is just for entering extra parameters. If you don't need to enter any parameters, hit ENTER to boot the default kernel "bare.i" or press [F2] for a listing of more kernel choices. [/code:1:329af6a7d2] Vanuit slackware kan je dan liloconfig selecteren en terug MBR selecteren. Waarschijnlijk gaat dat weer mis, maar dan is er in elk geval een configuratiefile voor lilo aangemaakt (/etc/lilo.conf) maar die om één of andere reden toch niet werkt. Wat je dan doet, is eens het commando "lilo" uitvoeren (als root) in een terminal. Dat zal een foutmelding geven, maar uit die foutmelding kan je wel achterhalen wat er mis is en je /etc/lilo.conf aanpassen. Wat bij mij al wel eens een reden is waarom lilo faalt, is dat liloconfig een windows partitie ziet en die toevoegt in het lilo menu, maar als er iets scheelt aan die windows partitie wil lilo niet en dan kan je gewoon de betreffende sectie uit lilo.conf verwijderen (en opnieuw lilo uitvoeren). M.a.w. ga zelf eens met lilo prutsen en lees indien nodig wat documentatie over lilo, je lost waarschijnlijk je probleem snel op die manier en je leert flink wat bij.
  • Ik weet het, tis niet oldskool =), maar toch..vond het al een hele stap van mezelf om totaal afstand te doen van X bij een linux install. Iig, op het moment boot ik de boel dus met een floppy. Als ik nu boot zonder flop krijg ik de melding: 'Geen besturingssyteem geinstalleerd.' Verder niets, kan ook verder niets. Ik weet niet wat het precies inhoud, maar het is me duidelijk dat er nog iets mis is in de MBR. Zal eens wat suggesties proberen. Verder ben ik vanochtend begonnen met het configureren van de boel. Bij de eerste boot in slackware werd het duidelijk dat ik geen toegang tot het internet had. Door middel van ifconfig en dhcpcd, mijn fedora boek en wat tips in het nedlinux irc chan is het me nu gelukt. Internet draait, zo ook apache met php al. [edit] Als ik als root 'lilo' invoer, krijg ik deze melding: [code:1:2223cc9dda] Warning: boot record relocation beyond BPB is necessary: /dev/fd0 Warning: The boot sector and map file are on different discs Added Linux * [/code:1:2223cc9dda] Hmm..zal eens rebooten. [/edit]
  • O ja ook nog een handige tip is dat sommige BIOS software het schrijven naar een MBR tegenhoud in verband met virussen. Daarom is het ook altijd wel handig om ff je BIOS instellingen te checken.
  • Tja, je hebt natuurlijk gekozen voor floppy in liloconfig, vandaar die warning vermoed ik. Ergens bovenaan in /etc/lilo.conf staat: [code:1:47b254fa65] boot=/dev/blabla [/code:1:47b254fa65] Als daar /dev/fd0 staat, installeert hij lilo op floppy. (wat bij u wschl het geval was) Staat er /dev/hda, dan wordt het de MBR van hda Staat er /dev/hda3, dan wordt het de superblock van hda3. Dus pas dat even aan en voer lilo opnieuw uit.
  • Zoals je mss al in de gaten hebt had het allemaal veel simpeler gekunt, maar de vraag is of dat er eigenlijk wel wat toe doet? Nee, je hebt nu gewoon lekker lopen prutsen en het werkend gekregen en dat was de bedoeling. Bovendien raak je zo lekker snel gewend aan de Slack install. Heel gaaf dat je zo'n rapport tikt, echt een puik stukje! Complimenten :)
  • Zo, heb vandaag wat minder uren kunnen besteden dan gisteren, maar ben wel flink opgeschoten =]. Vanochtend (na het ongelofelijk abrupt wakker worden van de begrafenisondernemer van de overkant die 1 of andere debiel had ingehuurd om de slootkant aan zijn kant van de sloot met een ongelofelijk luidruchtige machine even kort te wieken terwijl mijn raam open stond..zucht) een aantal uren besteed aan het configureren van apache met php. Dat ging allemaal best snel. Mijn internet deed het in eerste instantie niet, dat was mijn grootste probleem eigenlijk. Eerst heb ik heel veel geprobeerd met ifconfig, wat ook wel aardig lukte. Ik kon mijn ip instellen, evenals mijn subnetmask. Echter kreeg ik nog steeds geen respons van mijn router. Ik kon de router wel pingen, maar had geen internet. Hmm, dacht ik, misschien moet ik eens proberen of ik em geen ip toegewezen kan laten krijgen door de router. DHCP dus. Ik ben op zoek gegaan in mijn fedora boek, evenals internet. In mijn fedora boek kwam ik de term dhclient tegen. Na het draaien van dhclient had ik in ene internet. Toen ik in mijn resolve.conf keek was dat ook door dhclient aangepast. Goed, internet via DHCP werkte dus. Toch is het niet handig, aangezien ik een apache server wil draaien en mijn router precies moet weten waar hij het verkeer van poortje 80 (internet) naar toe moet sturen. Het is dan dus niet gewenst om een telkens veranderend ipadres te hebben. Op #nedlinux kreeg ik een tip van robert: [code:1:b0598aea32] 10:57.54 robert je moet ene ip, netmask en gateway instellen 10:59.11 gorow__ ja..dat snap ik, maar waar 10:59.27 gorow__ heb resolv.conf al gehad, voor dns 10:59.29 robert /etc.rc/d.rc.inet1 zei ik net al 10:59.34 Cybertinus weer geen inet :S 10:59.42 robert en anders doe je het met netconfig 11:01.34 gorow__ met netconfig lukt het niet, die draaitie ook in slack install, heb ik allemaal goed ingevuld maar op 1 of andere manier wordt hem geen internet gevoerd door router als ik static heb [/code:1:b0598aea32] Ik wist dat netconfig bij de slack install werd gebruikt, maar toch kreeg ik na installeren geen verbinding met het internet. Hmm, toch maar eens proberen. In de netconfig procedure kwam ik er achter dat ik in de install van slackware niet heb gekozen voor het instellen van nameservers, iets wat dus wel moest gebeuren. Na het invullen van het ipadres van mijn router, het afsluiten van netconfig en een reboot, kreeg ik netjes verbinding met het internet. Jeeej! [code:1:b0598aea32] 11:02.45 #nedlinux gorow_ valt #nedlinux binnen. 11:02.53 gorow_ hmm...internet 11:04.10 gorow_ YES 11:04.17 gorow_ http://gorow.kicks-ass.net 11:06.11 Cybertinus idd 11:06.12 Cybertinus het werkt 11:06.40 gorow_ stoer! 11:06.56 gorow_ slack is echt handig..al is het zonder X 11:07.08 gorow_ nou eens ff op zoek naar mun httpd.conf [/code:1:b0598aea32] Na deze grote stap voorwaarts ging het gelukkig wat sneller. Ik heb al vaker apache i.c.m. php en mysql geinstalleerd onder windows, dus wist dat ik meteen in httpd.conf en php.ini moest zijn. Echter had ik niet verwacht dat het zoooo snel zou gaan. Na het veranderen van mijn DirectoryIndex in httpd.conf (wat aangeeft welke files apache als eerste moet zoeken als er een directory word geopend via http)in dit: [code:1:b0598aea32] DirectoryIndex index.php index.html index.htm [/code:1:b0598aea32] en het instellen van mijn php.ini, heb ik wel een kwartier lang in mijn browser zitten refreshen, in de hoop dat mijn veranderde index.php (echo "Hallo Slack";) op beeld zou komen. Ik had er alleen met mijn stomme kop niet aan gedacht om apache even te restarten, zodat de nieuwe instellingen ook geladen zouden worden. Zie dit: [code:1:b0598aea32] 11:13.57 gorow_ hhmm..heb directoryindex aangepast voor php en index.php getikt, maar hij geeft nog steeds die apache pagina weer 11:14.15 GoRoW onee hell 11:39.14 GoRoW lol...moest apache gewoon ff restarten =0] [/code:1:b0598aea32] Kwartier zei ik heh? :S Goed, na deze enerverende ochtend ben ik 's middags naar Utrecht gegaan om bij de Slegte eens te kijken voor 'Linux in a Nutshell'. Helaas hadden ze hem daar niet meer liggen. Ik was wel vastbesloten dat ik het boek wilde hebben, dus ben ik naar de Broese gegaan en heb het boek daar gekocht. 's Avonds na een drukke dag weer aan de gang gegaan. Dit keer met iets voor mijn persoonlijke doel: een media server. Doel: al mijn muziek op mijn server kunnen gooien, er weer af kunnen halen, op mijn server in de console af kunnen spelen. Eerste stap: een ftp server. Na wat bladeren in wat man pages van verschillende ftpservers de keuze gemaakt voor iets wat WEL respons gaf in de terminal: proftpd. Deze was heel makkelijk up te krijgen met een simpel commando na het instellen van /etc/proftpd.conf. [code:1:b0598aea32] proftpd -n [/code:1:b0598aea32] De ftpserver loopt op dit moment in mijn tweede shell =). Moet alleen nog even uit gaan vinden hoe ik hem laat opstarten bij booten, maar dat is iets voor morgen =). Welterusten voor nu. GoRoW OUT.
  • Wie zei dat Slackware geen beginners distro was :D Het blijft leuk dit verslag. Dit moet de andere beginners toch ook goed doen. Ga zo door GoRoW :D
  • Leuk verhaal dit. Ga zo door.
  • Leuk verhaal, je maakt goede vorderingen! Misschien is het leuk om als uiteindelijk draait het hele zaakje als een soort 'dagboek' naar een website (bijvoorbeeld linux-box.nl) te sturen, die het kunnen plaatsen. Dit soort verhalen is precies waar dergelijke websites op zitten te wachten... (hehe ik kan dit geen shameless plug noemen, omdat Linux-box.nl niet meer onder mijn beheer is sinds gisteren ;)) Maar wat belangrijker is: je leert enorm veel op deze manier. Dat is heel wat waard, toch? -Roeland
  • Kijk dit ziet er heel goed uit :) Spealing of Broese, ik wacht nu al anderhalf jaar op C in 24 uur. Hij staat nog steeds op 'in bestelling' :P Tip voor je mediaserver: kijk eens naar shfs en esd. Shfs laat je mappen remote en secure mounten, zo kun je je muziek gewoon net als lokaal met cp kopieren van de ene naar de andere PC. Met esd kun je muziek die op jouw PC staat remote afspelen op de server. Succes!
  • [quote:f923d361be] Spealing of Broese, ik wacht nu al anderhalf jaar op C in 24 uur. [/quote:f923d361be] even offtopic: Marcel, ik heb dat boek thuis liggen op mijn stapel 'verkoop'. Als je geinteresseerd bent mag je hem overnemen ;)
  • [quote:791448dac1="rhkok"]Misschien is het leuk om als uiteindelijk draait het hele zaakje als een soort 'dagboek' naar een website (bijvoorbeeld linux-box.nl) te sturen, die het kunnen plaatsen. Dit soort verhalen is precies waar dergelijke websites op zitten te wachten... [/quote:791448dac1] Dat vind ik een leuk plan. Dat motiveert me zelf ook weer wat meer =). [quote:791448dac1="rhkok"]Maar wat belangrijker is: je leert enorm veel op deze manier. Dat is heel wat waard, toch?[/quote:791448dac1] Jah dat is waar ik het voor doe. Wellicht ga ik mijn server na het installeren van al die bende niet eens intensief gebruiken, omdat ik bijvoorbeeld maar 1 speakerset heb en niet telkens wil ompluggen (al is het idee van muziek in console afspelen nog zo leuk). Het feit dat ik er van leer is de drijvende kracht achter de uren die ik maak.
  • 10 augustus 2004, pas om 18:00 uur moet ik opdagen op mijn werk. Tijd zat dus, om even wat te knutselen. Gisteren de ftpserver aan de gang gekregen, nu maar eens even goed testen. Op mijn desktop pc heb ik maar eens geprobeerd om met gFTP te connecten met mijn server. Ik kreeg een respons van de server, maar kreeg echter geen anonymouse acces. Dat klopte, want dat heb ik gisteren afgesteld in proftpd.conf. Als ik de usergegevens van de user 'gorow' gebruikte om in te loggen ging het goed. Ik kreeg de inhoud te zien van de homedirectory van deze user. Nou das mooi! Er stonden al drie directory's in de home dir: 'divx', 'music' en 'dvd'. Ik met mijn goede voornemens snel naar mijn eigen mp3tjes browsen en het nummer genaamd 'Electric Six - Danger, high voltage' dubbelklikken. Helaas: 'Permission Denied'. Huh? Geen toegang tot mijn home directory? Nogal vreemd. Na deze ontdekking heb ik geprobeerd een filmpje in de 2 andere directories te kopieren, ook zonder succes helaas. Wat tot mijn verbazing wel lukte was om een bestand naar /home/gorow zelf te kopieren. Gelukkig wist ik dat je rechten van directories kunt veranderen d.m.v. chmod. Door hier gebruik van te maken : [code:1:57c69e6db7] chmod 777 /home/gorow/divx chmod 777 /home/gorow/music chmod 777 /home/gorow/dvd [/code:1:57c69e6db7] kon ik wel bestanden naar de mapjes kopieren via de ftp . Gelukkig, dat probleem opgelost. Ok, nu heb ik muziek op mijn server, nu moet ik het alleen nog even af kunnen spelen. Ik had gehoord van twee programma's : amp en mpg123, beiden zaten bij de install van slack. [code:1:57c69e6db7] amp Electrix Six - Danger, high voltage mpg123 Electrix Six - Danger, high voltage [/code:1:57c69e6db7] Beide commando's gaven een positieve output. Ik kreeg een melding dat hij aan het spelen was, zelfs een tellertje met hoeveel minuten nog. Hmm..vreemd..want ik hoorde niets namelijk :S. Goed..misschien is mijn soundcard nog niet geconfigureerd? Google dan maar. Na wat gestruin op het internet kwam ik iets tegen over oss (wat tot mijn verbazing stond voor Old Sound System). In de console maar wat gezocht met locate. Wat files doorgelezen maar eigenlijk zonder concreet resultaat. Ik wist dat Fedora gebruik maakt van Alsa, dus alsa ook maar eens met locatie opzoeken. Ik kreeg een waslijst van meer dan 100 resultaten, niet echt overzichtelijk. Meteen opgezocht hoe ik dit iets overzichtelijker kon vinden. Via locate --help kwam ik er achter dat je ook een limiet kan stellen aan de resultaten: [code:1:57c69e6db7] locate -n 30 alsa [/code:1:57c69e6db7] Dit commanda gaf me dus 30 resultaten. Om de andere resultaten door te nemen verhoogde ik telkens het getal met 20. Allerlei files geopend met vi, maar het meeste waren scripts waar ik geen wijs uit kon worden. Na het nadenken heb ik het boekje van mijn moederboard opgezocht om te achterhalen wat voor een soundcard ik eigenlijk aan boord heb. De onboard chipset van mijn Asus moederboard blijkt van VIA te zijn, de benodigde drivers zijn genaamd 'AD1980 Soundmax Audio Driver'. Na wat zoeken op het internet kwam ik een artikel tegen waarin stond dat VIA drivers bij Alsa zouden zitten, en dat je het kunt configureren d.m.v. alsaconfig. Echter kreeg ik een negatieve output op dat commando. Na wat verder zoeken kwam ik een artikel tegen waarin stond dat het geen alsaconfig was, maar alsaconf. Bij dit commando kreeg ik een blauw scherm (maar wel een gewenst blauw scherm ;) ) voor mijn neus met de alsaconfiguratie. Alsa scande mijn computer naar soundcards en vond er 2: de VIA en de legacy. Na de procedure doorlopen te hebben met veel spanning mijn mp3blaster opgestart: [code:1:57c69e6db7] 16:28:20 * GoRoW loves linux =] 16:28:38 <GoRoW> net geluid aan de gang...superspannend het moment dat ik mp3blaster opstartte en limp bizkit op zocht 16:28:43 <GoRoW> WOOHOO ontlading! 16:29:03 * GoRoW plugt speakerset om [/code:1:57c69e6db7] Op het moment dat ik Limp Bizkit hoorde kreeg ik spontaan een grijns op mijn gezicht =]. Na nog wat meer configureren van mp3blaster heb ik nu door hoe ik playlists kan maken (en opslaan) en is de UI (ja een user interface in console kan ook!) me duidelijk. Toch weer vooruitgang in een uur of 3. GoRoW @ 10 augustus om 11:48:25..OUT!

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.