Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

SuSE 9.1 + KDE3.3

nougabolle
31 antwoorden
  • Min of meer bij toeval zag ik dat de ftp-mirrors van SuSE inmiddels KDE 3.3 beschikbaar hebben (al vanaf 11 aug :D )
    En hoewel het heel simpel is om daar gebruik van te maken ( voeg bij installatie medium een ftp source toe bijv naar:
    ftp://ftp.gwdg.de/pub/suse/i386/supplementary/KDE/update_for_9.1/yast-source
    en geef vervolgens aan in YAST software-installatie dat je de diverse selectie's wilt upgraden (rechtse muisknop en dan upgraden indien er een nieuwere versie beschikbaar is) Hierna [u:35a7b2b377]NIET[/u:35a7b2b377] uitloggen maar
    [code:1:35a7b2b377]
    ctrl+alt+backspace
    [/code:1:35a7b2b377]
    zodat kde niets meer aan configuratie terug kan schrijven en daarna is rebooten het makkelijkst ivm libraries welke geladen dienen te worden.
    Verder valt het wel op dat wanneer je dat alleen maar doet je toch eea. mist.
    Oorzaak hiervan is dat er weer pakketten gesplits zijn, waardoor je bijv. nietmeer in konqueror kunt inkloppen
    [code:1:35a7b2b377]
    devices:/
    [/code:1:35a7b2b377]
    omdat dus kio_devices dus uit de gewone kdebase gehaalt is en nu in kdebase3-extra zit.

    Ook zitten er wat niet belangrijke slordigheidjes is (zo is in je "startmenu" weer terug "lock session" en "start new session" en is het uitlog scherm niet vertaald :) MAX ??? :-? )

    Maar KDE3.3 is verder wel de moeite waard want het is dus beduidend sneller weer dan 3.2 en eigenlijk ook veel mooier weer :D
  • Hie die Walter,

    Houd er rekening mee dat dit RC2 is :)

    Waarom lock session en start new session onvertaald zijn bij je weet ik niet.
    Mogelijk zijn de kde-i18n-nl-pakketten te vroeg uit cvs gehaald door suse.

    Andere mogelijkheid is dat ze Engels zijn omdat ze botsen met de suse-patch die je van het 'oude' kde-menu van suse 9.1 kent.
  • [quote:9b3e1b551e="maximilaan"]Hie die Walter,

    Houd er rekening mee dat dit RC2 is :)

    [/quote:9b3e1b551e]

    Maar het ziet er wel al heel goed uit en dit is dus wel al door suse vrij gegeven en normaal zijn ze niet de snelste met dit soort grappen

    [quote:9b3e1b551e]
    Waarom lock session en start new session onvertaald zijn bij je weet ik niet.
    Mogelijk zijn de kde-i18n-nl-pakketten te vroeg uit cvs gehaald door suse.

    Andere mogelijkheid is dat ze Engels zijn omdat ze botsen met de suse-patch die je van het 'oude' kde-menu van suse 9.1 kent.[/quote:9b3e1b551e]

    Sterker nog het i18-nl pakket is helemaal niet geupdate d8t ik.
    kde3-i18n-nl-3.2.3-3
    dat is dus nog dezelfdde als in 3.2 imho

    Wat me overigens ook nog opvalt is dat de kde upgrade voor suse 9.0 bijv. in Kontact een plugin voor kpilot heeft en voor 9.1 kan ik die dus niet vinden :(
    ik zal vlg week eens kijken waar dat hem in zit :-?
  • [quote:9c242d473e="wstolk"]
    Maar het ziet er wel al heel goed uit
    [/quote:9c242d473e]
    Klopt, vroeger was dit ook de officiele uitgave geweest. Tegenwoordig heeft KDE een extra buffer ingebouwd door een RC uit te brengen. Als die RC volgens de packagers en testers goed is, dan wordtie simpelweg omgedoopt naar KDE 3.3. Zitten er toch nog ernstige fouten in, dan komt er nog een RC.

    [quote:9c242d473e]
    en dit is dus wel al door suse vrij gegeven en normaal zijn ze niet de snelste met dit soort grappen
    [/quote:9c242d473e]
    Nou, heb al vaker meegemaakt dat kde-versies een tijd voor de officiele aankondiging al op de ftp-servers te vinden waren :)
    Kan best zijn dat maandag a.s. de officiele aankondiging van kde komt.


    [quote:9c242d473e]
    Sterker nog het i18-nl pakket is helemaal niet geupdate d8t ik.
    kde3-i18n-nl-3.2.3-3
    dat is dus nog dezelfdde als in 3.2 imho
    [/quote:9c242d473e]
    Yeps, dat lijkt me de laatste van kde 3.2.3
    Maar dat betekent dat er meer Engelse tekst door je interface moet waaien.
    Er zitten iets van 10.000 nieuwe programmateksten in deze nieuwe versie..
    1/7 is dan dus nieuw

    [quote:9c242d473e]
    Wat me overigens ook nog opvalt is dat de kde upgrade voor suse 9.0 bijv. in Kontact een plugin voor kpilot heeft en voor 9.1 kan ik die dus niet vinden :(
    ik zal vlg week eens kijken waar dat hem in zit :-?[/quote:9c242d473e]
    mogelijk een apart pakketje?
    zou het verschil uitmaken of je kde voor 9.0 of 9.1 pakt?

    Ander goed nieuws is dat Novell de motor blijkt achter het kdekiosk-project.
    Eerdere geluiden van Ximian wekten de indruk dat de Novell Linux Desktop, die dit najaar eraan komt, op Ximian Gnome gericht zou zijn.
    Dat blijkt dus niet het geval, Novell is druk bezig om kdekiosk af te krijgen, omdat die naadloos aansluit op hun eigen software..

    kdekiosk lijkt me ook ideaal voor bij jou op het werk. Met kdekiosk kun je instellen wat een gebruiker wel of niet met kde kan. Je kunt heel veel functionaliteit in kde uitschakelen, totaan menuopties toe.
    Als je wilt kan ik je de po-broncode sturen, door die door te lezen krijg je een idee wat er zoal mogelijk is.


    Max
  • dus kdekiosk is een soort Policie-editor voor KDE :-?

    En dan te bedenken dat ik van de poledit voor windows al geen moer snapte :D

    Maar gelukkig zijn mijn gebruikers niet zo inventief dat ze gaan leggen klooien in kde want een achtergrondje veranderen is zo'n beetje de meest cruciale handeling die ik ze heb zien doen :D

    Overigens lijkt het of deze KDE versie ff op gang moet komen of iig. dat er achter de schermen een hoop instellingen opnieuw gemaakt moeten worden want als je een progsel voor het eerst opstart of van een functie voor het eerst gebruik maakt zie je dat het beduidend trager is dan later en dat er soms gewoon dingen het niet doen om vervolgens bij een tweede keer gebruik ervan te maken wel weer blijken te functioneren.

    bijv. nadat ik kde3.3 voor de eerste keer opstartte (volledige reboot gedaan ivm. librarie's) duurde het erg lang. de tweede keer was gewoon heel erg snel.
    Een programma opstarten gaf altijd een stuiterend icoon en een programmavak in je menubalk.
    Dat gebuurde eigenlijk pas nadat ik het eerst uitgezet hat en later weer aan.
    Maar tot dusver bevalt deze kde versie me heel goed alleen eens kijken waarom kpilot niet in contact zit.

    Overigens was er tijdens de installatie een dep- probleem voor
    kde3libs, deze heeft libjasper-1.701 nodig.
    SuSE heeft libjasper1-700 en ImageMagic is daar oa. van afhankelijk.
    een update van libjasper geeft dus als resultaat dat Yast zeurt over depencie's en (rpm -u libjasper werkt dus wel gewoon goed zonder problemen) dat Imagemagic niet meer zou werken.
    Doordat er nog wat pakketjes misten heb ik perabuis libjasper weer gedowngraded en alles blijkt dus wel gewoon te blijven werken :-?

    Nu ga ik nog even testen wat er gebeurd als ik libjasper wel weer upgrade.
    En misschien dat dan het kmenu weer helemaal NL is :D

    Overigens is dat in SuSE 9.0 ook hetzelfde >>KDE-menu>> afmelden, Lock Session, Start new Session :D
    Maar daar heb ik geen librarie probleem gezien.
  • [quote:247b552612]
    dus kdekiosk is een soort Policie-editor voor KDE

    En dan te bedenken dat ik van de poledit voor windows al geen moer snapte [/quote:247b552612]
    kiosk zit volgens mij wat helderder in elkaar dan poledit.
    Maar kiosk is een erg krachtig programma, ik heb nog niet gedurfd er mijn vingers aan te branden ;)

    Wat de snelheid van kde betreft, gooi eventeel /tmp/kde-wstolk even weg, en start daarna kde op.
    Mogelijk is ksycoca bij de start druk doende om de oude situatie te vervangen door de nieuwe, wat idd nogal wat tijd kan vergen.

    Max
  • [quote:447555e2e0="maximilaan"][quote:447555e2e0]
    dus kdekiosk is een soort Policie-editor voor KDE

    En dan te bedenken dat ik van de poledit voor windows al geen moer snapte [/quote:447555e2e0]
    kiosk zit volgens mij wat helderder in elkaar dan poledit.
    Maar kiosk is een erg krachtig programma, ik heb nog niet gedurfd er mijn vingers aan te branden ;)

    Wat de snelheid van kde betreft, gooi eventeel /tmp/kde-wstolk even weg, en start daarna kde op.
    Mogelijk is ksycoca bij de start druk doende om de oude situatie te vervangen door de nieuwe, wat idd nogal wat tijd kan vergen.

    Max[/quote:447555e2e0]

    Het is alleen met de eerste keer opstarten dat het heel erg lang duurt
    verder gaat het heel snel alleen dus jammer dat het i18 bestand nog niet klaar was :lol:

    Maar ik kan er mee leven hoewel er idd. in divers progsels ineens engelse zaken tevoorschijn komen 8)
  • Ha, ik denk dat ik eens moet kijken of deze wel thuis op mijn systeeem staan
    [code:1:83e2c51cca]
    /opt/kde3/lib/kde3/libkontact_kpilotplugin.la
    /opt/kde3/lib/kde3/libkontact_kpilotplugin.so
    [/code:1:83e2c51cca]

    [code:1:83e2c51cca]
    /home/walter> rpm -q –whatprovides libkontact_kpilotplugin.so
    kdepim3-kpilot-3.3.0-3
    [/code:1:83e2c51cca]

    en die heb ik d8 ik gewoon geinstalleerd staan, maar ik zal vanavond eens ff checken.

    Overigens ook KDE3.3 op SuSE 9.0 heeft ook de missertjes nog in de vertaling zitten hoor :D
    Duidelijk "Beta" dus ;) maar er is wel mee te leven
  • Ik draai beta2, en die is stabieler dan KDE 3.2.1 :D

    Overigens moet ik nog uitzoeken wat er echt nieuw is.
  • Echt wereldschokkend zijn de veranderingen van kde 3.3 op zich niet.
    De verbetering moet je vooral zoeken in de snelheid
    obuustheid van de desktop, en in nieuwe functionaliteit in de aanvullende programma's die met de desktop worden meegeleverd.

    Max
  • [quote:d510aea926="wstolk"]Ha, ik denk dat ik eens moet kijken of deze wel thuis op mijn systeeem staan
    [code:1:d510aea926]
    /opt/kde3/lib/kde3/libkontact_kpilotplugin.la
    /opt/kde3/lib/kde3/libkontact_kpilotplugin.so
    [/code:1:d510aea926]

    [code:1:d510aea926]
    /home/walter> rpm -q –whatprovides libkontact_kpilotplugin.so
    kdepim3-kpilot-3.3.0-3
    [/code:1:d510aea926]
    [/quote:d510aea926]

    Nou mooi niet dat kdepim3-kpilot deze library heeft he :(

    foutje van SuSE vrees ik :(
    En zo zijn er dus meer zaken die net iets verschillen tussen de Upgrade voor SuSE 9.0 en 9.1 :(
    9.0 is dus gewoon uitgebreider :-?

    Ik ga eens kijken of ik die kde pakketjes kan gebruiken hoewel die dus wel voor kernel 2.4 zijn en SuSE 9.1 dus kernel 2.6 heeft :o

    [edit]
    oei ;( SuSE 9.1 :: kdepim3-kpilot Version: 3.2.3-2
    SuSE 9.0 :: kdepim3-kpilot Version: 3.3.0-3

    Of er verschil is …… D8 het wel :(

    Dus maar even wachten tot de updat voor 9.1 helemaal klaar is denk ik :x
  • Indien men altijd de laatste versie van KDE wil dan raad ik aan om RED-Carpet te installeren. Je krijgt dan automatisch bericht om te updaten. Zo bezit ik reeds 14 dagen KDE 3 specifiek voor Suse Dagen eerder voordat het officieel uitkomt. Het werkt zonder enig probleem.
  • [quote:06090be16a="Berend-kb"]Indien men altijd de laatste versie van KDE wil dan raad ik aan om RED-Carpet te installeren. Je krijgt dan automatisch bericht om te updaten. Zo bezit ik reeds 14 dagen KDE 3 specifiek voor Suse Dagen eerder voordat het officieel uitkomt. Het werkt zonder enig probleem.[/quote:06090be16a]

    Ach het ging me niet zozeer om KDE 3.3 of de nieuwste KDE maar de KDE op de SuSE cd is gewoon verouderd en dus update ik dan direct uit de suppl. dir. op 1 vd. mirrors.

    Overigens staan er alweer nieuwe pakketjes klaar :D
    [code:1:06090be16a]
    ftp://ftp.gwdg.de/pub/linux/suse/ftp.suse.com/suse/i386/supplementary/KDE/update_for_9.1/INDEX

    Last updated: Tue Aug 17 08:12:16 MEST 2004

    [/code:1:06090be16a]

    dus snel ff op mijn server zetten en vanavond mijn bak ff updaten zodat hopelijk die irri verschillen eruit zijn 8)
  • En idd. met de update welke vandaag geplaatst is zijn er diverse "vertaal" missertjes verdwenen, en zit ineens Kpilot ook in kontact :D :lol: 8)

    Ik ben er dus heel erg blij mee, enne Max, Waar blijft de meededeling dat kde-3.3 klaar is ???

    Want ik moet bekennen dat het al erg stabiel was maar nu de missrtjes uit de SuSE pakketjes zijn zal het toch niet gebeuren dat iedereen al kde 3.3 aanbied terwijl kde.org verzuimt om het wereldkundig te maken :D ??
  • [quote:69fc11b572="wstolk"]dat iedereen al kde 3.3 aanbied terwijl kde.org verzuimt om het wereldkundig te maken [/quote:69fc11b572] En is een aankondiging van KDE Developer's Corner ook gped?
  • ik denk dat woensdag 18 augustus idd de aankondiging gaat komen.
    Het cvs is inmiddels weer vrijgegeven voor nieuwe commits, en de aankondiging is ter vertaling aangeboden aan de verschillende teams.

    Of kde 3.3 vanaf morgen uit is weten we morgen pas echt :)

    Verder kunnen we beter iets later kde aankondigen en goede pakketten aanleveren, dan dat we kde te vroeg aankondigen en de pakketten niet of slechts gedeeltelijk beschikbaar zijn. Immers, SuSE is niet de enige pakketbouwer waarmee we rekening houden ;)

    Max
  • [quote:eda5a5f0f1="jolo"][quote:eda5a5f0f1="wstolk"]dat iedereen al kde 3.3 aanbied terwijl kde.org verzuimt om het wereldkundig te maken [/quote:eda5a5f0f1] En is een aankondiging van KDE Developer's Corner ook gped?[/quote:eda5a5f0f1]

    Ik maakte ook maar een geintje :D

    Het is eigenlijk stomtoeval dat ik ineens ipv. een update van KDE 3.2 een update in de vorm van KDE 3.3 binnenhaalde :D anders had ik het nieteens in de gaten gehad ;)
  • wstolk, Ik heb zojuist nog even gekeken op www.kde.org maar nog geen nieuw info. Wel is inmiddels kde3-i18n-nl-3.3.0-3.noarch.rpm beschikbaar. Maar die heb je natuurlijk allang geïnstalleerd. Ik heb deze nieuwe KDE 3.3 ook nog geprobeerd te installeren. Als je dat op de gebruikelijke manier doet, begint SuSE te klagen over dependencies
    [code:1:c44f6c3ed8]
    linux:/mnt/sda9/athlon/suse/kde3.3 # rpm -Uvh *.rpm
    error: Failed dependencies:
    libjasper-1.701.so.1 is needed by kdelibs3-3.3.0-3
    arts = 1.2.1 is needed by (installed) arts-devel-1.2.1-31
    kdebase3 = 3.2.1 is needed by (installed) kdebase3-devel-3.2.1-63
    kdelibs3 = 3.2.1 is needed by (installed) kdelibs3-devel-3.2.1-41
    qt3 = 3.3.1 is needed by (installed) qt3-non-mt-3.3.1-36
    qt3 = 3.3.1 is needed by (installed) qt3-devel-3.3.1-33
    linux:/mnt/sda9/athlon/suse/kde3.3 # [/code:1:c44f6c3ed8]
    Bij mij in SuSE 9.1
    [code:1:c44f6c3ed8]
    rpm -qa | grep libjasper
    libjasper-1.700.5-58

    rpm -qa | grep arts
    arts-devel-1.2.1-31
    arts-1.2.1-31

    rpm -qa | grep kdebase3-3.2
    kdebase3-3.2.1-63

    rpm -qa | grep kdelibs
    kdelibs3-3.2.1-41
    kdelibs3-devel-3.2.1-41
    kdelibs3-devel-doc-3.2.1-41

    rpm -qa | grep qt3-3.3.1
    qt3-3.3.1-33
    [/code:1:c44f6c3ed8]
  • verwijder even de -devel-pakketjes voordat je de upgrade doet..


    Voor wie wil profiteren van de nieuwigheden van bijv. kdepim, maar niet een volledige upgrade wil, kde 3.3 en kde 3.2.3 zijn compatible met elkaar, je kunt dus kdepim 3.3 draaien onder kde 3.2

    Max
  • [quote:6957a5a03b="maximilaan"]verwijder even de -devel-pakketjes voordat je de upgrade doet.. [/quote:6957a5a03b] Bedankt voor de suggestie. Daarna bleken ook nog een aantal andere pakketten moeten worden verwijderd.
    [code:1:6957a5a03b]
    linux:/home/jolo/Downloads/kde3.3 # rpm -Uvh *.rpm
    Preparing… ########################################### [100%]
    file /opt/kde3/share/mimelnk/audio/x-ms-wma.desktop from install of kdelibs3-3.3.0-3 conflicts with file from package kaffeine-0.4.1-82
    file /opt/kde3/share/config/khotnewstuffrc from install of kdelibs3-3.3.0-3 conflicts with file from package kdepim3-3.2.1-35
    file /opt/kde3/bin/ghns from install of kdelibs3-3.3.0-3 conflicts with file from package kdepim3-organizer-3.2.1-35
    file /opt/kde3/bin/khotnewstuff from install of kdelibs3-3.3.0-3 conflicts with file from package kdepim3-organizer-3.2.1-35
    file /opt/kde3/lib/libknewstuff.la from install of kdelibs3-3.3.0-3 conflicts with file from package kdepim3-organizer-3.2.1-35
    file /opt/kde3/lib/libknewstuff.so.1.0.0 from install of kdelibs3-3.3.0-3 conflicts with file from package kdepim3-organizer-3.2.1-35
    file /opt/kde3/bin/kdepasswd from install of kdebase3-3.3.0-3 conflicts with file from package kdeutils3-3.2.1-61
    file /opt/kde3/share/applications/kde/kdepasswd.desktop from install of kdebase3-3.3.0-3 conflicts with file from package kdeutils3-3.2.1-61
    file /opt/kde3/share/apps/kdm/pics/users/BeachBall.png from install of kdebase3-kdm-3.3.0-3 conflicts with file from package kdeutils3-3.2.1-61
    file /opt/kde3/share/apps/kdm/pics/users/Butterfly.png from install of kdebase3-kdm-3.3.0-3 conflicts with file from package kdeutils3-3.2.1-61
    file /opt/kde3/share/apps/kdm/pics/users/Flower.png from install of kdebase3-kdm-3.3.0-3 conflicts with file from package kdeutils3-3.2.1-61
    linux:/home/jolo/Downloads/kde3.3 # [/code:1:6957a5a03b] Deze pakketten heb ik net zoals de devel-pakketten verwijderd via yast2. En libjasper-1.701 heb ik gedownload vanaf Nederlandse SuSE ftp,

    Ik kon uiteindelijk KDE 3.3 (Alleen de base pakketten) installeren via [code:1:6957a5a03b] rpm -Uvh *.rpm [/code:1:6957a5a03b] zonder foutmeldingen. SuSEconfig en een reboot. Deze upgrade naar KDE 3.3 ging wel moeizaam. Maar dat ben ik wel gewent met SuSE.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.